]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- package python csvn bindings
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
b4d1f957 2# - fix java build with java-gcj-compat and s/java-sun/jdk/
1930bef0 3# - remove net_client_only and add db bcond (then without apache and
4# without db => net_client_only - spec will be more simpler, I think)
d46e45ba 5# - finish ruby
1930bef0 6#
bab73684 7# Conditional build:
65c1d4bd 8%bcond_with net_client_only # build only net client
3fc01170 9%bcond_without neon # use serf instead of neon
65c1d4bd
JB
10%bcond_without python # build without python bindings (broken)
11%bcond_without perl # build without perl bindings
73ab938a 12%bcond_without ruby # build without ruby bindings
65c1d4bd
JB
13%bcond_without apache # build without apache support (webdav, etc)
14%bcond_without javahl # build without javahl support (Java high-level bindings)
15%bcond_without tests # don't perform "make check"
7b27380f 16#
bc126282 17%ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
c2f5643d 18%undefine with_javahl
bc126282
AG
19%endif
20#
b56474ff 21%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 22%define apxs /usr/sbin/apxs
1f630180
ER
23%define pdir SVN
24%define pnam _Core
12ae68c1 25#
04129f48 26%if %{with neon}
a510fada 27%define webdavlib neon
04129f48
AG
28%else
29%define webdavlib serf
a510fada
AM
30%endif
31#
67cb9518 32Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
33Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
34Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 35Name: subversion
1429fa1c
AM
36Version: 1.6.0
37Release: 0.1
6f88d80e 38License: Apache/BSD-like
93b78127 39Group: Development/Version Control
1429fa1c 40Source0: http://subversion.tigris.org/downloads/%{name}-%{version}-rc3.tar.bz2
82c1228d 41# Source0-md5: 58473cb07611fd7567b6ce99461009e1
93b78127 42Source1: %{name}-dav_svn.conf
65318afa 43Source2: %{name}-authz_svn.conf
b56474ff
AM
44Source3: %{name}-svnserve.init
45Source4: %{name}-svnserve.sysconfig
a510fada
AM
46# current subversion tarball has correct *.swg files
47# but after regeneration these are broken again, so
48# we still need this script
f313e9a9 49Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 50Patch0: %{name}-home_etc.patch
d46e45ba 51Patch1: %{name}-DESTDIR.patch
00664663 52Patch2: %{name}-ruby-datadir-path.patch
d2bf70bf 53URL: http://subversion.tigris.org/
4945947e
AM
54%if %{with net_client_only}
55%global apache_modules_api 0
56%else
f2a757d6 57%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 58BuildRequires: automake
3817faf5 59BuildRequires: db-devel >= 4.1.25
e8d9186f 60BuildRequires: rpmbuild(macros) >= 1.268
0905b458 61%if %{with perl}
522a69b4 62BuildRequires: perl-devel >= 1:5.8.0
63BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 64BuildRequires: swig-perl >= 1.3.24
536b3fd3 65%endif
b4d1f957 66%{?with_javahl:BuildRequires: java-sun}
0905b458 67%endif
16429189 68BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 69BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 70BuildRequires: autoconf >= 2.59
79d8c53c 71BuildRequires: bison
12ae68c1 72BuildRequires: cyrus-sasl-devel
93b78127 73BuildRequires: expat-devel
86ea8fde 74BuildRequires: gettext-devel
1429fa1c
AM
75BuildRequires: gnome-keyring-devel
76BuildRequires: kde4-kdelibs-devel
f4e6a380 77BuildRequires: libtool >= 1.4-9
a562165a
JB
78BuildRequires: sed >= 4.0
79BuildRequires: texinfo
80BuildRequires: which
81%if %{with neon}
bd3c99a8 82BuildRequires: neon-devel >= 0.26.0
a562165a
JB
83%else
84BuildRequires: serf-devel
e3ad24ea 85%endif
53855fbf 86BuildRequires: python >= 2.2
ed6210a2 87BuildRequires: python-modules >= 2.2
f313e9a9 88%if %{with python}
137fcafd 89BuildRequires: python-ctypesgen
f313e9a9 90BuildRequires: python-devel >= 2.2
15f9818d 91BuildRequires: swig-python >= 1.3.24
0905b458 92%endif
a562165a
JB
93%if %{with ruby}
94BuildRequires: ruby-devel
95BuildRequires: swig-ruby >= 1.3.24
96%endif
027f8ebe 97Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
98BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
f4070f5f 100%define _libexecdir %{_libdir}/svn
1af5e34d
ER
101%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
102%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
103
104%description
105The goal of the Subversion project is to build a version control
106system that is a compelling replacement for CVS in the open source
107community.
108
109Our goals are:
110- All current CVS features.
111- Directories, renames, and file meta-data are versioned.
112- Symbolic links, etc, are supported
113- Commits are truly atomic.
114- Branching and tagging are cheap (constant time) operations
115- Repeated merges are handled gracefully
116- Support for plug-in client side diff programs
117- Natively client/server
118- Client/server protocol sends diffs in both directions
119- Costs are proportional to change size, not project size
120- Internationalization
121- Progressive multi-lingual support
122
aa59005f 123%description -l pl.UTF-8
93b78127
AM
124Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
125zamiennika dla CVS.
126
127Cele projektu to:
aa59005f 128- Wszystkie aktualne możliwości CVS.
24406120
JB
129- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
130- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
131- Commity są w pełni atomowe.
132- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
133- Dobra obsługa powtarzanego łączenia (merge).
134- Obsługa wtyczek diff po stronie klienta.
93b78127 135- Natywny klient/serwer.
aa59005f 136- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
137- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
138- Internacjonalizacja.
aa59005f 139- Postępujące wsparcie dla wielu języków.
93b78127 140
aa59005f
JR
141%description -l pt_BR.UTF-8
142O objetivo do projeto Subversion é construir um sistema de controle de
143versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 144System) na comunidade opensource, fornecendo grandes melhorias.
145
f4e6a380
AM
146%package libs
147Summary: Subversion libraries and modules
abe3c421 148Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 149Group: Libraries
04129f48 150%{?with_neon:Requires: neon >= 0.26.0}
53855fbf 151Obsoletes: libsubversion0
f4e6a380
AM
152
153%description libs
154Subversion libraries and modules.
155
aa59005f
JR
156%description libs -l pl.UTF-8
157Biblioteka subversion oraz ładowalne moduły.
f4e6a380 158
93b78127
AM
159%package devel
160Summary: Header files and develpment documentation for subversion
abe3c421
ER
161Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
162Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 163Group: Development/Libraries
9cb7e099 164Requires: %{name}-libs = %{version}-%{release}
c5b1d686 165Requires: apr-util-devel >= 1:1.0.0
04129f48 166%{?with_neon:Requires: neon-devel >= 0.26.0}
12cf252c 167Obsoletes: libsubversion0-devel
93b78127
AM
168
169%description devel
170Header files and develpment documentation for subversion.
171
aa59005f
JR
172%description devel -l pl.UTF-8
173Pliki nagłówkowe i dokumetacja do subversion.
93b78127 174
aa59005f
JR
175%description devel -l pt_BR.UTF-8
176Este pacote provê os arquivos necessários para desenvolvedores
92066deb 177interagirem com o Subversion.
178
93b78127
AM
179%package static
180Summary: Static subversion library
abe3c421
ER
181Summary(pl.UTF-8): Biblioteka statyczna subversion
182Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
183Group: Development/Libraries
184Requires: %{name}-devel = %{version}
12cf252c 185Obsoletes: libsubversion0-static-devel
93b78127
AM
186
187%description static
188Static subversion library.
189
aa59005f 190%description static -l pl.UTF-8
93b78127
AM
191Biblioteka statyczna subversion.
192
aa59005f
JR
193%description static -l pt_BR.UTF-8
194Este pacote provê um cliente estático do subversion.
92066deb 195
b56474ff
AM
196%package svnserve
197Summary: Subversion svnserve
abe3c421 198Summary(pl.UTF-8): Subversion svnserve
b56474ff 199Group: Networking/Daemons
3817faf5 200Requires(post,preun): /sbin/chkconfig
93f1d402 201Requires(postun): /usr/sbin/groupdel
202Requires(postun): /usr/sbin/userdel
203Requires(pre): /bin/id
204Requires(pre): /usr/bin/getgid
205Requires(pre): /usr/lib/rpm/user_group.sh
206Requires(pre): /usr/sbin/groupadd
207Requires(pre): /usr/sbin/useradd
208Requires(pre): /usr/sbin/usermod
9cb7e099 209Requires: %{name} = %{version}-%{release}
7b27380f 210Requires: rc-scripts
a1bac09d
211Provides: group(svn)
212Provides: user(svn)
b56474ff
AM
213
214%description svnserve
215Subversion svnserve server.
216
aa59005f 217%description svnserve -l pl.UTF-8
b56474ff
AM
218Serwer subversion svnserve.
219
4bbdbbf8
AM
220%package tools
221Summary: Subversion tools and scripts
abe3c421
ER
222Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
223Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 224Group: Applications
4bbdbbf8 225%pyrequires_eq python
7b27380f 226Requires: %{name} = %{version}-%{release}
1271c9bd 227Requires: python-rcsparse >= 0.1-0.20031026.0
4bbdbbf8
AM
228Requires: python-subversion = %{version}
229
230%description tools
231Subversion tools and scripts.
232
aa59005f
JR
233%description tools -l pl.UTF-8
234Narzędzia oraz skrypty dla subversion.
4bbdbbf8 235
fe5bb6bb 236%package -n bash-completion-subversion
237Summary: bash completion for subversion
abe3c421 238Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 239Group: Applications/Shells
e30588c4 240Requires: %{name} = %{version}-%{release}
53855fbf 241Requires: bash-completion
e30588c4 242Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 243
244%description -n bash-completion-subversion
245Bash completion for subversion.
246
aa59005f
JR
247%description -n bash-completion-subversion -l pl.UTF-8
248Dopełnienia basha dla subversion.
fe5bb6bb 249
1cc7453a 250%package -n java-subversion
65c1d4bd
JB
251Summary: Subversion Java bindings
252Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 253Group: Development/Languages/Java
254Requires: %{name}-libs = %{version}-%{release}
255
256%description -n java-subversion
257This is a set of Java classes which provide the functionality of
258subversion-libs, the Subversion libraries. It is useful if you want
259to, for example, write a Java class that manipulates a Subversion
260repository or working copy. See the 'subversion' package for more
261information.
262
65c1d4bd
JB
263%description -n java-subversion -l pl.UTF-8
264Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
265subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
d46e45ba
AM
266pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
267roboczą. Więcej informacji w pakiecie subversion.
65c1d4bd 268
fa3ff1b2 269%package -n python-subversion
65c1d4bd
JB
270Summary: Subversion Python bindings
271Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
272Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 273Group: Development/Languages/Python
f4e6a380 274%pyrequires_eq python
9cb7e099 275Requires: %{name}-libs = %{version}-%{release}
53855fbf 276Obsoletes: subversion-python
f4e6a380 277
fa3ff1b2 278%description -n python-subversion
65c1d4bd 279Subversion Python bindings.
f4e6a380 280
aa59005f 281%description -n python-subversion -l pl.UTF-8
65c1d4bd 282Dowiązania do Subversion dla Pythona.
f4e6a380 283
aa59005f 284%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 285Módulos Python para acessar os recursos do Subversion.
92066deb 286
137fcafd
AM
287%package -n python-csvn
288Summary: CTypes Subversion Python bindings
289Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
290Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
291Group: Development/Languages/Python
292%pyrequires_eq python
293Requires: %{name}-libs = %{version}-%{release}
294
295%description -n python-csvn
296Subversion CTypes Python bindings.
297
298%description -n python-csvn -l pl.UTF-8
299Dowiązania do Subversion dla Pythona używające CTypes.
300
301%description -n python-csvn -l pt_BR.UTF-8
302Módulos Python para acessar os recursos do Subversion.
303
b56474ff 304%package -n perl-subversion
65c1d4bd
JB
305Summary: Subversion Perl bindings
306Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
307Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 308Group: Development/Languages/Perl
9cb7e099 309Requires: %{name}-libs = %{version}-%{release}
53855fbf 310Obsoletes: subversion-perl
b56474ff
AM
311
312%description -n perl-subversion
65c1d4bd 313Subversion Perl bindings.
b56474ff 314
aa59005f 315%description -n perl-subversion -l pl.UTF-8
65c1d4bd 316Dowiązania do Subversion dla Perla.
b56474ff 317
aa59005f 318%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 319Módulos Perl para acessar os recursos do Subversion.
b56474ff 320
d46e45ba
AM
321%package -n ruby-subversion
322Summary: Subversion Ruby bindings
d2bf70bf 323Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
d46e45ba
AM
324Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
325Group: Development/Languages
326Requires: %{name}-libs = %{version}-%{release}
327Obsoletes: subversion-ruby
328
329%description -n ruby-subversion
330Subversion Ruby bindings.
331
332%description -n ruby-subversion -l pl.UTF-8
d2bf70bf 333Dowiązania do Subversion dla języka Ruby.
d46e45ba
AM
334
335%description -n ruby-subversion -l pt_BR.UTF-8
336Módulos Ruby para acessar os recursos do Subversion.
337
93b78127
AM
338%package -n apache-mod_dav_svn
339Summary: Apache module: Subversion Server
abe3c421 340Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 341Group: Networking/Daemons
7b27380f 342Requires: %{name} = %{version}-%{release}
53855fbf 343Requires: apache(modules-api) = %apache_modules_api
7887b1ac 344Requires: apache-mod_dav
93b78127
AM
345
346%description -n apache-mod_dav_svn
347Apache module: Subversion Server.
348
aa59005f
JR
349%description -n apache-mod_dav_svn -l pl.UTF-8
350Moduł apache: Serwer Subversion.
93b78127 351
65318afa
AF
352%package -n apache-mod_authz_svn
353Summary: Apache module: Subversion Server - path-based authorization
abe3c421 354Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 355Group: Networking/Daemons
53855fbf 356Requires: apache(modules-api) = %apache_modules_api
9cb7e099 357Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
358
359%description -n apache-mod_authz_svn
360Apache module: Subversion Server - path-based authorization.
361
aa59005f
JR
362%description -n apache-mod_authz_svn -l pl.UTF-8
363Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 364
1429fa1c
AM
365%package -n gnome-keyring-subversion
366Summary: Subversion module for Gnome Keyring
367Summary(pl.UTF-8): Moduł subversion dla zarządcy kluczy Gnome
368Group: X11/Applications
369
370%description -n gnome-keyring-subversion
371Subversion module for Gnome Keyring.
372
373%description -n gnome-keyring-subversion -l pl.UTF-8
374Moduł subversion dla zarządcy kluczy Gnome.
375
376%package -n kde4-kwallet-subversion
377Summary: Subversion module for KDE Wallet
378Summary(pl.UTF-8): Moduł subversion dla Portfela KDE
379Group: X11/Applications
380
381%description -n kde4-kwallet-subversion
382Subversion module for KDE Wallet.
383
384%description -n kde4-kwallet-subversion -l pl.UTF-8
385Moduł subversion dla Portfela KDE.
386
93b78127 387%prep
1429fa1c 388%setup -q -n %{name}-%{version}-rc3
e30588c4 389rm -rf apr apr-util neon
ed6210a2 390%patch0 -p0
d4bccc60 391%patch1 -p1
00664663 392%patch2 -p0
a510fada
AM
393
394sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
395
396# serf.m4 macro is broken and ignores --without serf
244bdb04 397%{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
027f8ebe 398
93b78127 399%build
93f1d402 400rm subversion/bindings/swig/proxy/*.swg
24406120 401cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 402cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 403chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 404
93b78127 405%configure \
5dfeafd7 406 --with-editor=vi \
12ae68c1 407 --with-zlib=%{_libdir} \
536b3fd3
AM
408%if %{with net_client_only}
409 --without-apache \
410 --without-swig \
411 --without-apxs \
412 --without-berkeley-db \
413%else
fa6fa2cf 414 --disable-runtime-module-search \
86ee97d3 415 --disable-mod-activation \
0905b458 416%if %{with apache}
536b3fd3 417 --with-apxs=%{_sbindir}/apxs \
0905b458 418%else
419 --without-apache \
420 --without-apxs \
536b3fd3 421 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
0905b458 422%endif
73ab938a 423%if !%{with python} && !%{with perl} && !%{with ruby}
0905b458 424 --without-swig \
425%endif
137fcafd 426 %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
1cc7453a 427 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 428%endif
1cc7453a 429 --with-jdk="%{java_home}" \
04129f48 430%if %{with neon}
e3ad24ea 431 --without-serf \
e30588c4 432 --with-neon=%{_prefix} \
78f330c4 433 --disable-neon-version-check \
04129f48
AG
434%else
435 --with-serf=%{_prefix} \
436 --without-neon \
e3ad24ea 437%endif
16429189 438 --with-apr=%{_bindir}/apr-1-config \
1429fa1c
AM
439 --with-apr-util=%{_bindir}/apu-1-config \
440 --with-kwallet \
441 --with-gnome-keyring
536b3fd3 442
1f630180 443%{__make} -j1
536b3fd3 444
cf353d53 445%if !%{with net_client_only}
b56474ff 446# python
0905b458 447%if %{with python}
137fcafd
AM
448# ctypes bindings
449%{__make} ctypes-python
450# swig bindings
86a4919e 451%{__make} swig-py \
65318afa
AF
452 swig_pydir=%{py_sitedir}/libsvn \
453 swig_pydir_extra=%{py_sitedir}/svn
0905b458 454%endif
b56474ff 455# perl
0905b458 456%if %{with perl}
390bb8f4 457%{__make} -j1 swig-pl-lib
bf539998
AM
458odir=$(pwd)
459cd subversion/bindings/swig/perl/native
460%{__perl} Makefile.PL INSTALLDIRS=vendor
b445847c 461%{__make} -j1
bf539998 462cd $odir
536b3fd3 463%endif
1cc7453a 464%if %{with javahl}
b445847c 465%{__make} -j1 javahl \
1cc7453a 466 javahl_javadir="%{_javadir}"
467%endif
d46e45ba
AM
468# ruby
469%if %{with ruby}
470%{__make} swig-rb
471%endif
12ae68c1
AM
472%endif
473
474%if %{with tests}
475%{__make} check
d46e45ba 476%if %{with python}
137fcafd 477%{__make} check-ctypes-python
d46e45ba
AM
478%{__make} check-swig-py
479%endif
480%if %{with perl}
481%{__make} check-swig-pl
482%endif
483%if %{with ruby}
484%{__make} check-swig-rb
485%endif
0905b458 486%endif
93b78127
AM
487
488%install
489rm -rf $RPM_BUILD_ROOT
1326bb99 490install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 491 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 492 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 493 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 494
1f630180 495%{__make} install -j1 \
1cc7453a 496%if %{with javahl}
497 install-javahl \
498 javahl_javadir="%{_javadir}" \
499%endif
d46e45ba
AM
500%if !%{with net_client_only}
501%if %{with python}
0905b458 502 install-swig-py \
137fcafd 503 install-ctypes-python \
d46e45ba
AM
504%endif
505%if %{with ruby}
506 install-swig-rb install-swig-rb-doc \
507%endif
0905b458 508%endif
f2a757d6 509 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 510 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
511 swig_pydir=%{py_sitedir}/libsvn \
512 swig_pydir_extra=%{py_sitedir}/svn
93b78127 513
cf353d53 514%if !%{with net_client_only} && %{with perl}
bf539998
AM
515%{__make} install-swig-pl-lib \
516 DESTDIR=$RPM_BUILD_ROOT
b445847c 517%{__make} -C subversion/bindings/swig/perl/native install \
bf539998
AM
518 DESTDIR=$RPM_BUILD_ROOT \
519 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
520 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
bf539998
AM
521%endif
522
0905b458 523%if %{with apache}
1af5e34d
ER
524install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
525install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
526install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
527install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 528%endif
93b78127 529
cf353d53 530%if !%{with net_client_only}
1326bb99 531install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 532%if %{with python}
f4e6a380
AM
533%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
534%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
535find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
536install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 537%endif
0905b458 538%endif
f4e6a380 539
1326bb99
JK
540install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
541install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 542
205a3ddc
AM
543%find_lang %{name}
544
1429fa1c
AM
545rm $RPM_BUILD_ROOT%{_libdir}/libsvn{javahl,_swig}*.{la,a}
546rm $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
a6ecf312 547
e23909be
JB
548%clean
549rm -rf $RPM_BUILD_ROOT
550
a1bac09d
551%pre svnserve
552%groupadd -g 86 svn
553%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
554
d2bf70bf
JB
555%post libs -p /sbin/ldconfig
556%postun libs -p /sbin/ldconfig
557
558%post devel -p /sbin/postshell
6f99c3bd 559-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 560
d2bf70bf 561%postun devel -p /sbin/postshell
6f99c3bd 562-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 563
d2bf70bf
JB
564%post -n perl-subversion -p /sbin/ldconfig
565%postun -n perl-subversion -p /sbin/ldconfig
566
567%post -n python-subversion -p /sbin/ldconfig
568%postun -n python-subversion -p /sbin/ldconfig
f4e6a380 569
b56474ff 570%post svnserve
e8d9186f
ER
571/sbin/chkconfig --add svnserve
572%service svnserve restart "svnserve daemon"
573
b56474ff
AM
574%preun svnserve
575if [ "$1" = "0" ]; then
e8d9186f
ER
576 %service svnserve stop
577 /sbin/chkconfig --del svnserve
b56474ff
AM
578fi
579
a1bac09d
580%postun svnserve
581if [ "$1" = "0" ]; then
582 %userremove svn
583 %groupremove svn
584fi
585
93b78127 586%post -n apache-mod_dav_svn
e8d9186f 587%service -q httpd restart
93b78127
AM
588
589%preun -n apache-mod_dav_svn
590if [ "$1" = "0" ]; then
e8d9186f 591 %service -q httpd restart
93b78127
AM
592fi
593
93b78127
AM
594%files
595%defattr(644,root,root,755)
983a49f6 596%doc BUGS CHANGES COPYING INSTALL README
d37298dc 597%doc doc/*/*.html
4bbdbbf8
AM
598%doc tools/hook-scripts/*.{pl,py,example}
599%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 600%doc tools/xslt/*
b445847c
JB
601%attr(755,root,root) %{_bindir}/svn
602%attr(755,root,root) %{_bindir}/svnadmin
603%attr(755,root,root) %{_bindir}/svndumpfilter
604%attr(755,root,root) %{_bindir}/svnlook
605%attr(755,root,root) %{_bindir}/svnsync
606%attr(755,root,root) %{_bindir}/svnversion
607%{_mandir}/man1/svn.1*
608%{_mandir}/man1/svnadmin.1*
609%{_mandir}/man1/svndumpfilter.1*
610%{_mandir}/man1/svnlook.1*
611%{_mandir}/man1/svnsync.1*
612%{_mandir}/man1/svnversion.1*
f4e6a380 613
205a3ddc 614%files libs -f %{name}.lang
f4e6a380 615%defattr(644,root,root,755)
b445847c
JB
616%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
617%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
618%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
619%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
620%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
621%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
622%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
623%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
624%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
625%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
626%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
627%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
628%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
629%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
630%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
631%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
632%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
633%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
a510fada
AM
634%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
635%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
b445847c
JB
636%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
637%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
638%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
639%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
640%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
641%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
642%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
643%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
93b78127
AM
644
645%files devel
646%defattr(644,root,root,755)
b445847c
JB
647%attr(755,root,root) %{_libdir}/libsvn_client-1.so
648%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
649%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
650%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
651%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
652%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
653%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
654%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
655%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
a510fada 656%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
b445847c
JB
657%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
658%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
659%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
660%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
661%{_libdir}/libsvn_client-1.la
662%{_libdir}/libsvn_delta-1.la
663%{_libdir}/libsvn_diff-1.la
664%{_libdir}/libsvn_fs-1.la
665%{_libdir}/libsvn_fs_base-1.la
666%{_libdir}/libsvn_fs_fs-1.la
667%{_libdir}/libsvn_fs_util-1.la
668%{_libdir}/libsvn_ra-1.la
669%{_libdir}/libsvn_ra_local-1.la
a510fada 670%{_libdir}/libsvn_ra_%{webdavlib}-1.la
b445847c
JB
671%{_libdir}/libsvn_ra_svn-1.la
672%{_libdir}/libsvn_repos-1.la
673%{_libdir}/libsvn_subr-1.la
674%{_libdir}/libsvn_wc-1.la
675%{_includedir}/%{name}-1
1326bb99 676%{_examplesdir}/%{name}-%{version}
93b78127
AM
677
678%files static
679%defattr(644,root,root,755)
b445847c
JB
680%{_libdir}/libsvn_client-1.a
681%{_libdir}/libsvn_delta-1.a
682%{_libdir}/libsvn_diff-1.a
683%{_libdir}/libsvn_fs-1.a
684%{_libdir}/libsvn_fs_base-1.a
685%{_libdir}/libsvn_fs_fs-1.a
686%{_libdir}/libsvn_fs_util-1.a
687%{_libdir}/libsvn_ra-1.a
688%{_libdir}/libsvn_ra_local-1.a
a510fada 689%{_libdir}/libsvn_ra_%{webdavlib}-1.a
b445847c
JB
690%{_libdir}/libsvn_ra_svn-1.a
691%{_libdir}/libsvn_repos-1.a
692%{_libdir}/libsvn_subr-1.a
693%{_libdir}/libsvn_wc-1.a
93b78127 694
1429fa1c
AM
695%files -n gnome-keyring-subversion
696%defattr(644,root,root,755)
697%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
698%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
699
700%files -n kde4-kwallet-subversion
701%defattr(644,root,root,755)
702%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
703%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
704
cf353d53 705%if !%{with net_client_only}
b56474ff
AM
706%files svnserve
707%defattr(644,root,root,755)
708%attr(755,root,root) %{_bindir}/svnserve
b445847c
JB
709%{_mandir}/man5/svnserve.conf.5*
710%{_mandir}/man8/svnserve.8*
a1bac09d
711%dir %attr(750,svn,svn) /home/services/subversion
712%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 713%if %{with apache}
b56474ff 714%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 715%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 716%endif
b56474ff 717
4bbdbbf8
AM
718%files tools
719%defattr(644,root,root,755)
1326bb99 720%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 721
722%files -n bash-completion-subversion
101e74de 723%defattr(644,root,root,755)
1326bb99 724/etc/bash_completion.d/%{name}
536b3fd3 725
1cc7453a 726%if %{with javahl}
727%files -n java-subversion
728%defattr(644,root,root,755)
b445847c
JB
729%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
730%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
731%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
1cc7453a 732%{_javadir}/svn-javahl.jar
733%endif
734
0905b458 735%if %{with python}
fa3ff1b2 736%files -n python-subversion
f4e6a380 737%defattr(644,root,root,755)
4bbdbbf8 738%doc tools/backup/*.py tools/examples/*.py
b445847c
JB
739%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
740%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
741%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
65318afa 742%dir %{py_sitedir}/libsvn
65318afa 743%{py_sitedir}/libsvn/*.py[co]
b445847c
JB
744%dir %{py_sitedir}/svn
745%{py_sitedir}/svn/*.py[co]
65318afa 746%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 747%{_examplesdir}/python-%{name}-%{version}
137fcafd
AM
748
749%files -n python-csvn
750%defattr(644,root,root,755)
751%doc subversion/bindings/ctypes-python/{README,TODO}
752%doc subversion/bindings/ctypes-python/examples/*.py
753%dir %{py_sitescriptdir}/csvn
754%{py_sitescriptdir}/csvn/*.py[co]
755%dir %{py_sitescriptdir}/csvn/core
756%{py_sitescriptdir}/csvn/core/*.py[co]
757%dir %{py_sitescriptdir}/csvn/ext
758%{py_sitescriptdir}/csvn/ext/*.py[co]
759%{py_sitescriptdir}/*.egg-info
0905b458 760%endif
f4e6a380 761
0905b458 762%if %{with perl}
b56474ff
AM
763%files -n perl-subversion
764%defattr(644,root,root,755)
b445847c
JB
765%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
766%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
767%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
b56474ff
AM
768%{perl_vendorarch}/SVN
769%dir %{perl_vendorarch}/auto/SVN
770%dir %{perl_vendorarch}/auto/SVN/*
771%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
772%{perl_vendorarch}/auto/SVN/*/*.bs
773%{_mandir}/man3/*.3pm*
0905b458 774%endif
b56474ff 775
d46e45ba
AM
776%if %{with ruby}
777%files -n ruby-subversion
778%defattr(644,root,root,755)
b445847c
JB
779%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
780%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
781%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
1429fa1c
AM
782%dir %{_libdir}/ruby/site_ruby/[0-9].[0-9]
783%dir %{_libdir}/ruby/site_ruby/*/svn
784%{_libdir}/ruby/site_ruby/*/svn/*.rb
785%dir %{_libdir}/ruby/site_ruby/*/*-*
786%dir %{_libdir}/ruby/site_ruby/*/*-*/svn/ext
787%attr(755,root,root) %{_libdir}/ruby/site_ruby/*/*-*/svn/ext/*.so
ab6adef9 788%{_datadir}/ri/*.*/system/OptionParser
00664663 789%{_datadir}/ri/*.*/system/Svn
790%{_datadir}/ri/*.*/system/Time
791%{_datadir}/ri/*.*/system/Uconv
792%{_datadir}/ri/*.*/system/*.rid
793%{_datadir}/ri/*.*/system/Kernel/*
d46e45ba
AM
794%endif
795
0905b458 796%if %{with apache}
93b78127
AM
797%files -n apache-mod_dav_svn
798%defattr(644,root,root,755)
1af5e34d
ER
799%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
800%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
801
802%files -n apache-mod_authz_svn
803%defattr(644,root,root,755)
804%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
805%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
806%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 807%endif
7b27380f
ER
808
809%endif # net_client_only
This page took 2.245016 seconds and 4 git commands to generate.