]> git.pld-linux.org Git - packages/soprano.git/blame - soprano.spec
- allow virtuoso backend to build, it's required to build kde4-nepomuk-core
[packages/soprano.git] / soprano.spec
CommitLineData
dbea7b1e
ER
1# Conditional build:
2%bcond_without serializer # with raptor serializer. need to figure out proper BR
28d38ada 3%bcond_with sesame2 # with sesame2backend
e8d4b674 4%bcond_without virtuoso # with virtuosobackend
c7018ab4 5
81ed0294 6%define qtbrver 4.7.3
e8d4b674 7%define snap svn1042011
855ec3f8 8
8667f3ab
JB
9Summary: Soprano - Qt wrapper API to librdf
10Summary(pl.UTF-8): Soprano - wrapper Qt do librdf
195f432c 11Name: soprano
e75bcc64 12Version: 2.9.4
f6f5f54c 13Release: 7
5b9e452e 14License: GPL v2
195f432c 15Group: X11/Applications
25b958ac 16Source0: http://downloads.sourceforge.net/soprano/%{name}-%{version}.tar.bz2
e75bcc64 17# Source0-md5: 91413e5783efeee0beb747ea4c5c9ef0
e8d4b674 18#Source0: %{name}-%{version}-%{snap}.tar.gz
5a8ef18c 19URL: http://sourceforge.net/projects/soprano
855ec3f8 20BuildRequires: QtCore-devel >= %{qtbrver}
21BuildRequires: QtDBus-devel >= %{qtbrver}
2ba17820 22BuildRequires: QtGui-devel >= %{qtbrver}
855ec3f8 23BuildRequires: QtNetwork-devel >= %{qtbrver}
2b1fcc2c 24BuildRequires: clucene-core-devel >= 0.9.16a-2
214d4c81 25BuildRequires: cmake >= 2.8.0
ba131f66 26BuildRequires: doxygen
84df784d 27%{?with_sesame2:BuildRequires: libgcj-devel}
e432317c 28%{?with_serializer:BuildRequires: libraptor2-devel >= 2.0.0}
25b958ac 29BuildRequires: pkgconfig
855ec3f8 30BuildRequires: qt4-build >= %{qtbrver}
31BuildRequires: qt4-qmake >= %{qtbrver}
dbea7b1e 32BuildRequires: rasqal-devel
81ed0294 33BuildRequires: redland-devel >= 1.0.14
d2faa209 34BuildRequires: rpmbuild(macros) >= 1.600
2ba17820 35BuildRequires: xorg-lib-libX11-devel
36BuildRequires: xorg-lib-libXext-devel
e8d4b674 37%if %{with virtuoso}
38BuildRequires: libiodbc-devel
39Requires: virtuoso >= 6.1.0
40%endif
195f432c 41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
8667f3ab
JB
44Soprano (formally known as QRDF) is a library which provides a Qt
45wrapper API to different RDF storage solutions. It features named
46graphs (contexts) and has a modular plug-in structure which allows to
47use different RDF storage implementations.
195f432c 48
8667f3ab 49%description -l pl.UTF-8
2ba17820 50Soprano (wcześniej znane jako QRDF) to biblioteka udostępniająca API
51wrappera Qt do różnych rozwiązań przechowywania danych RDF. Obsługuje
52nazwane grafy (konteksty) i ma strukturę modularnych wtyczek, co
53pozwala na używanie różnych implementacji przechowywania danych RDF.
195f432c 54
55%package devel
56Summary: Header files for soprano
57Summary(pl.UTF-8): Pliki nagłówkowe dla soprano
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60
61%description devel
62Header files for soprano.
63
64%description devel -l pl.UTF-8
65Pliki nagłówkowe dla soprano.
66
67%prep
a4a085c3 68%setup -q
435be701 69# Sesame2 backend doesn't really use the new JNI-1.6 feature -> GetObjectRefType.
84df784d 70#sed -i 's:JNI_VERSION_1_6:JNI_VERSION_1_4:g' CMakeLists.txt
435be701 71# cleanup.
84df784d 72#sed -i 's:${JAVA_INCLUDE_PATH2}::' backends/sesame2/CMakeLists.txt
195f432c 73
74%build
75install -d build
76cd build
84df784d 77# add this to get verbose output
78# -DCMAKE_VERBOSE_MAKEFILE=1
195f432c 79%cmake \
84df784d 80 -DJAVA_INCLUDE_PATH=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
81 -DJAVA_INCLUDE_PATH2=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
78ba8e2d 82%if "%{pld_release}" == "ti"
214d4c81 83 -DJAVA_JVM_LIBRARY=%{_libdir}/gcj-%{cc_version}-11/libjvm.so \
78ba8e2d 84%else
81ed0294 85 -DJAVA_JVM_LIBRARY=$(ls -1 %{_libdir}/gcj-%{cc_version}-*/libjvm.so | head -n 1) \
78ba8e2d 86%endif
84df784d 87 ../
195f432c 88
89%{__make}
90
91%install
92rm -rf $RPM_BUILD_ROOT
8667f3ab
JB
93
94%{__make} -C build install \
195f432c 95 DESTDIR=$RPM_BUILD_ROOT
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post -p /sbin/ldconfig
101%postun -p /sbin/ldconfig
102
103%files
104%defattr(644,root,root,755)
2fc92623
RT
105%attr(755,root,root) %{_bindir}/sopranocmd
106%attr(755,root,root) %{_bindir}/sopranod
3dd5cf66 107%attr(755,root,root) %{_bindir}/onto2vocabularyclass
0b2cd574 108%attr(755,root,root) %{_libdir}/libsoprano.so.*.*.*
2fc92623 109%attr(755,root,root) %ghost %{_libdir}/libsoprano.so.4
5b9e452e 110%attr(755,root,root) %{_libdir}/libsopranoclient.so.*.*.*
2fc92623 111%attr(755,root,root) %ghost %{_libdir}/libsopranoclient.so.1
5b9e452e 112%attr(755,root,root) %{_libdir}/libsopranoserver.so.*.*.*
2fc92623 113%attr(755,root,root) %ghost %{_libdir}/libsopranoserver.so.1
3d311b00
RT
114%attr(755,root,root) %{_libdir}/libsopranoindex.so.*.*.*
115%attr(755,root,root) %ghost %{_libdir}/libsopranoindex.so.1
5b9e452e 116%dir %{_libdir}/soprano
0b2cd574 117%attr(755,root,root) %{_libdir}/soprano/libsoprano_redlandbackend.so
2fc92623
RT
118%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadparser.so
119%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadserializer.so
120%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorparser.so
c4571e50 121%{?with_sesame2:%attr(755,root,root) %{_libdir}/soprano/libsoprano_sesame2backend.so}
122%{?with_serializer:%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorserializer.so}
e8d4b674 123%{?with_virtuoso:%attr(755,root,root) %{_libdir}/soprano/libsoprano_virtuosobackend.so}
5b9e452e 124%{_datadir}/soprano
2fc92623
RT
125%{_datadir}/dbus-1/interfaces/org.soprano.Model.xml
126%{_datadir}/dbus-1/interfaces/org.soprano.NodeIterator.xml
127%{_datadir}/dbus-1/interfaces/org.soprano.QueryResultIterator.xml
128%{_datadir}/dbus-1/interfaces/org.soprano.Server.xml
129%{_datadir}/dbus-1/interfaces/org.soprano.StatementIterator.xml
130
195f432c 131%files devel
132%defattr(644,root,root,755)
0b2cd574 133%attr(755,root,root) %{_libdir}/libsoprano.so
2fc92623
RT
134%attr(755,root,root) %{_libdir}/libsopranoserver.so
135%attr(755,root,root) %{_libdir}/libsopranoclient.so
3d311b00 136%attr(755,root,root) %{_libdir}/libsopranoindex.so
195f432c 137%dir %{_includedir}/soprano
138%{_includedir}/soprano/*.h
2fc92623 139%{_includedir}/Soprano
5b9e452e 140%{_pkgconfigdir}/soprano.pc
0835c44e
AM
141%{_pkgconfigdir}/sopranoserver.pc
142%{_pkgconfigdir}/sopranoclient.pc
143%{_pkgconfigdir}/sopranoindex.pc
This page took 0.206011 seconds and 4 git commands to generate.