]> git.pld-linux.org Git - packages/sdcc.git/blame - sdcc.spec
- BR: texlive-tex-xkeyval (required by tex/latex/xkeyval/xkeyval.sty from texinfo...
[packages/sdcc.git] / sdcc.spec
CommitLineData
ad45c647 1#
2# Conditional build:
3%bcond_without doc # don't rebuild documentation
4
396dd56d 5Summary: C compiler for Intel 8051 and Zilog Z80
6e9646c0 6Summary(pl.UTF-8): Kompilator C dla Intel 8051 i Zilog Z80
2766fe68 7Name: sdcc
079010b6
JB
8Version: 3.6.0
9Release: 1
ea490d2d 10License: GPL v2+ (tools), GPL v2+ with linking exception (runtime)
79712cbc 11Group: Development/Languages
edea8164 12Source0: http://downloads.sourceforge.net/sdcc/%{name}-src-%{version}.tar.bz2
079010b6 13# Source0-md5: 4c4cf17d8d2b2d37af66c5b7511f62d8
2766fe68 14URL: http://sdcc.sourceforge.net/
79712cbc 15BuildRequires: bison
100f1d12 16BuildRequires: boost-devel
79712cbc 17BuildRequires: flex
2804323a 18BuildRequires: gc-devel
21a15d8c 19BuildRequires: gputils
79712cbc 20BuildRequires: libstdc++-devel
079010b6 21BuildRequires: python >= 1:2.4
ea490d2d 22BuildRequires: sed >= 4.0
ad45c647 23%if %{with doc}
24BuildRequires: latex2html
64937913 25BuildRequires: lyx >= 1.4.4
ecf69603 26BuildRequires: texlive-fonts-cmsuper
27BuildRequires: texlive-fonts-type1-urw
28BuildRequires: texlive-format-pdflatex
29BuildRequires: texlive-latex-ams
30BuildRequires: texlive-makeindex
31BuildRequires: texlive-tex-babel
491b2b3c 32BuildRequires: texlive-tex-xkeyval
100f1d12 33BuildRequires: texlive-xetex
ad45c647 34%endif
80a5a011 35Obsoletes: ucsim
d62c156f 36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2766fe68 37
100f1d12 38%define _noautostrip .*%{_datadir}/%{name}/.*
21a15d8c 39
2766fe68 40%description
ea490d2d
JB
41SDCC is retargettable, optimizing ANSI-C compiler. The current version
42targets the Intel 8051 and recently the Zilog Z80 based MCUs. SDCC can
43be retargeted for other 8 bit MCUs or PICs and some day soon will be.
44Supported data types are short (8 bits, 1 byte), char (8 bits, 1
45byte), int (16 bits, 2 bytes), long (32 bit, 4 bytes) and float (4
46byte IEEE). SDCC also comes with the source level debugger SDCDB.
79712cbc 47
2d52e5b2 48%description -l pl.UTF-8
ea490d2d
JB
49SDCC jest optymalizującym kompilatorem ANSI C dla wielu platform.
50Aktualna wersja obsługuje procesory Intel 8051 oraz Zilog Z80. SDCC
51może być łatwo zmodyfikowany by obsługiwać inne 8-bitowe jednostki.
52Obsługiwane typy danych to short (8 bitów, 1 bajt), char (8 bitów, 1
53bajt), int (16 bitów, 2 bajty), long (32 bity, 4 bajty) oraz float (4
54bajty IEEE). SDCC dostarcza również debugger oparty na emulatorze
55ucsim.
56
57%package -n emacs-sdcdb
58Summary: SDCDB debugger support for Emacs
59Summary(pl.UTF-8): Obsługa debuggera SDCDB dla Emacsa
60Group: Development/Tools
61Requires: %{name} = %{version}-%{release}
62Requires: emacs
63
64%description -n emacs-sdcdb
65SDCDB debugger support for Emacs.
66
67%description -n emacs-sdcdb -l pl.UTF-8
68Obsługa debuggera SDCDB dla Emacsa.
2766fe68
MP
69
70%prep
edea8164 71%setup -q
2766fe68 72
ea490d2d 73%{__sed} -i -e '1s,/usr/bin/env python,/usr/bin/python,' support/scripts/as2gbmap.py
9bd8989f 74
ea490d2d 75%build
9bd8989f 76%configure \
76352eee 77 PDFOPT=/bin/cp \
ad45c647 78 %{__enable_disable doc} \
2804323a 79 --enable-libgc \
80 --enable-ucsim \
81 --enable-xa \
82 --enable-serio \
83 --enable-statistic
9bd8989f 84
ecf69603 85%{__make} -j1
2766fe68 86
ea490d2d 87%{__make} -C device/lib -j1 model-mcs51-stack-auto model-mcs51-xstack-auto
386e1cdb 88
2766fe68
MP
89%install
90rm -rf $RPM_BUILD_ROOT
f81fe682 91install -d $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
80a5a011 92
93%{__make} install \
94 "DESTDIR=$RPM_BUILD_ROOT" \
95 "docdir=%{_docdir}/%{name}-%{version}" \
96 "STRIP=/bin/true"
2766fe68 97
f81fe682 98%{__mv} $RPM_BUILD_ROOT%{_bindir}/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
25ff8dc3 99
079010b6
JB
100%{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
101
2766fe68
MP
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%files
79712cbc 106%defattr(644,root,root,755)
25ff8dc3 107%doc %{_docdir}/%{name}-%{version}
ea490d2d
JB
108%attr(755,root,root) %{_bindir}/as2gbmap
109%attr(755,root,root) %{_bindir}/makebin
110%attr(755,root,root) %{_bindir}/packihx
111%attr(755,root,root) %{_bindir}/s51
ea490d2d
JB
112%attr(755,root,root) %{_bindir}/sdar
113%attr(755,root,root) %{_bindir}/sdas*
114%attr(755,root,root) %{_bindir}/sdcc
115%attr(755,root,root) %{_bindir}/sdcclib
116%attr(755,root,root) %{_bindir}/sdcdb
117%attr(755,root,root) %{_bindir}/sdcpp
118%attr(755,root,root) %{_bindir}/sdld*
119%attr(755,root,root) %{_bindir}/sdnm
120%attr(755,root,root) %{_bindir}/sdobjcopy
121%attr(755,root,root) %{_bindir}/sdranlib
122%attr(755,root,root) %{_bindir}/shc08
ea490d2d 123%attr(755,root,root) %{_bindir}/sstm8
ea490d2d 124%attr(755,root,root) %{_bindir}/sz80
25ff8dc3 125%{_datadir}/%{name}
ea490d2d
JB
126
127%files -n emacs-sdcdb
128%defattr(644,root,root,755)
f81fe682
JR
129%{_datadir}/emacs/site-lisp/sdcdb.el
130%{_datadir}/emacs/site-lisp/sdcdbsrc.el
This page took 0.342872 seconds and 4 git commands to generate.