]> git.pld-linux.org Git - packages/sdcc.git/blame - sdcc.spec
- release 2 (by relup.sh)
[packages/sdcc.git] / sdcc.spec
CommitLineData
ad45c647 1#
2# Conditional build:
3%bcond_without doc # don't rebuild documentation
4
396dd56d 5Summary: C compiler for Intel 8051 and Zilog Z80
6e9646c0 6Summary(pl.UTF-8): Kompilator C dla Intel 8051 i Zilog Z80
2766fe68 7Name: sdcc
f313c56f 8Version: 3.5.0
5833841d 9Release: 2
ea490d2d 10License: GPL v2+ (tools), GPL v2+ with linking exception (runtime)
79712cbc 11Group: Development/Languages
edea8164 12Source0: http://downloads.sourceforge.net/sdcc/%{name}-src-%{version}.tar.bz2
f313c56f 13# Source0-md5: e0a1df72747c481cdedbbd328b0fceae
2766fe68 14URL: http://sdcc.sourceforge.net/
79712cbc 15BuildRequires: bison
100f1d12 16BuildRequires: boost-devel
79712cbc 17BuildRequires: flex
2804323a 18BuildRequires: gc-devel
21a15d8c 19BuildRequires: gputils
79712cbc 20BuildRequires: libstdc++-devel
ea490d2d 21BuildRequires: sed >= 4.0
ad45c647 22%if %{with doc}
23BuildRequires: latex2html
64937913 24BuildRequires: lyx >= 1.4.4
ecf69603 25BuildRequires: texlive-fonts-cmsuper
26BuildRequires: texlive-fonts-type1-urw
27BuildRequires: texlive-format-pdflatex
28BuildRequires: texlive-latex-ams
29BuildRequires: texlive-makeindex
30BuildRequires: texlive-tex-babel
100f1d12 31BuildRequires: texlive-xetex
ad45c647 32%endif
80a5a011 33Obsoletes: ucsim
d62c156f 34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2766fe68 35
100f1d12 36%define _noautostrip .*%{_datadir}/%{name}/.*
21a15d8c 37
2766fe68 38%description
ea490d2d
JB
39SDCC is retargettable, optimizing ANSI-C compiler. The current version
40targets the Intel 8051 and recently the Zilog Z80 based MCUs. SDCC can
41be retargeted for other 8 bit MCUs or PICs and some day soon will be.
42Supported data types are short (8 bits, 1 byte), char (8 bits, 1
43byte), int (16 bits, 2 bytes), long (32 bit, 4 bytes) and float (4
44byte IEEE). SDCC also comes with the source level debugger SDCDB.
79712cbc 45
2d52e5b2 46%description -l pl.UTF-8
ea490d2d
JB
47SDCC jest optymalizującym kompilatorem ANSI C dla wielu platform.
48Aktualna wersja obsługuje procesory Intel 8051 oraz Zilog Z80. SDCC
49może być łatwo zmodyfikowany by obsługiwać inne 8-bitowe jednostki.
50Obsługiwane typy danych to short (8 bitów, 1 bajt), char (8 bitów, 1
51bajt), int (16 bitów, 2 bajty), long (32 bity, 4 bajty) oraz float (4
52bajty IEEE). SDCC dostarcza również debugger oparty na emulatorze
53ucsim.
54
55%package -n emacs-sdcdb
56Summary: SDCDB debugger support for Emacs
57Summary(pl.UTF-8): Obsługa debuggera SDCDB dla Emacsa
58Group: Development/Tools
59Requires: %{name} = %{version}-%{release}
60Requires: emacs
61
62%description -n emacs-sdcdb
63SDCDB debugger support for Emacs.
64
65%description -n emacs-sdcdb -l pl.UTF-8
66Obsługa debuggera SDCDB dla Emacsa.
2766fe68
MP
67
68%prep
edea8164 69%setup -q
2766fe68 70
ea490d2d 71%{__sed} -i -e '1s,/usr/bin/env python,/usr/bin/python,' support/scripts/as2gbmap.py
9bd8989f 72
ea490d2d 73%build
9bd8989f 74%configure \
76352eee 75 PDFOPT=/bin/cp \
ad45c647 76 %{__enable_disable doc} \
2804323a 77 --enable-libgc \
78 --enable-ucsim \
79 --enable-xa \
80 --enable-serio \
81 --enable-statistic
9bd8989f 82
ecf69603 83%{__make} -j1
2766fe68 84
ea490d2d 85%{__make} -C device/lib -j1 model-mcs51-stack-auto model-mcs51-xstack-auto
386e1cdb 86
2766fe68
MP
87%install
88rm -rf $RPM_BUILD_ROOT
f81fe682 89install -d $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
80a5a011 90
91%{__make} install \
92 "DESTDIR=$RPM_BUILD_ROOT" \
93 "docdir=%{_docdir}/%{name}-%{version}" \
94 "STRIP=/bin/true"
2766fe68 95
f81fe682 96%{__mv} $RPM_BUILD_ROOT%{_bindir}/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
25ff8dc3 97
2766fe68
MP
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%files
79712cbc 102%defattr(644,root,root,755)
25ff8dc3 103%doc %{_docdir}/%{name}-%{version}
ea490d2d
JB
104%attr(755,root,root) %{_bindir}/as2gbmap
105%attr(755,root,root) %{_bindir}/makebin
106%attr(755,root,root) %{_bindir}/packihx
107%attr(755,root,root) %{_bindir}/s51
ea490d2d
JB
108%attr(755,root,root) %{_bindir}/sdar
109%attr(755,root,root) %{_bindir}/sdas*
110%attr(755,root,root) %{_bindir}/sdcc
111%attr(755,root,root) %{_bindir}/sdcclib
112%attr(755,root,root) %{_bindir}/sdcdb
113%attr(755,root,root) %{_bindir}/sdcpp
114%attr(755,root,root) %{_bindir}/sdld*
115%attr(755,root,root) %{_bindir}/sdnm
116%attr(755,root,root) %{_bindir}/sdobjcopy
117%attr(755,root,root) %{_bindir}/sdranlib
118%attr(755,root,root) %{_bindir}/shc08
ea490d2d 119%attr(755,root,root) %{_bindir}/sstm8
ea490d2d 120%attr(755,root,root) %{_bindir}/sz80
25ff8dc3 121%{_datadir}/%{name}
ea490d2d
JB
122
123%files -n emacs-sdcdb
124%defattr(644,root,root,755)
f81fe682
JR
125%{_datadir}/emacs/site-lisp/sdcdb.el
126%{_datadir}/emacs/site-lisp/sdcdbsrc.el
This page took 0.127893 seconds and 4 git commands to generate.