]> git.pld-linux.org Git - packages/phpMyAdmin.git/blame - phpMyAdmin.spec
- added S: webserver(indexfile)
[packages/phpMyAdmin.git] / phpMyAdmin.spec
CommitLineData
fdda4e42
ER
1# TODO
2# - add codepress (http://codepress.org/index.php) patch
d8c0193b 3Summary: phpMyAdmin - web-based MySQL administration
7f70cea7 4Summary(pl.UTF-8): phpMyAdmin - administracja bazami MySQL przez WWW
78a895aa 5Name: phpMyAdmin
ebddf688 6Version: 2.11.6
7bb50a64 7Release: 3
c6adf9fe 8License: GPL v2
78a895aa 9Group: Applications/Databases/Interfaces
fb6eaade 10Source0: http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
ebddf688 11# Source0-md5: 0477a97e80e12c97fef671365db910a5
aac07012 12Source1: %{name}.conf
59d81573 13Source2: %{name}-lighttpd.conf
d0c3620a 14Patch0: %{name}-config.patch
50091634 15URL: http://www.phpmyadmin.net/
72d7283c 16BuildRequires: rpmbuild(macros) >= 1.268
f935b243 17Requires(triggerpostun): sed >= 4.0
3eb57405 18Requires: php(ctype)
2d3dc34c 19Requires: php(mbstring)
7bb50a64 20Requires: php(mcrypt)
71be8e00
ER
21Requires: php(mysql)
22Requires: php(pcre)
f935b243 23Requires: webapps
9c9eb38c 24Requires: webserver(access)
bef21c33 25Requires: webserver(alias)
71be8e00 26Requires: webserver(php)
7bb50a64 27Suggests: webserver(indexfile)
89cacb94 28BuildArch: noarch
78a895aa
PG
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
7e9b99de 31%define _appdir %{_datadir}/%{name}
f935b243
ER
32%define _webapps /etc/webapps
33%define _webapp %{name}
34%define _sysconfdir %{_webapps}/%{_webapp}
78a895aa
PG
35
36%description
37phpMyAdmin can administer a whole MySQL-server (needs a super-user)
38but also a single database. To accomplish the latter you'll need a
39properly set up MySQL-user who can read/write only the desired
40database. It's up to you to look up the appropiate part in the MySQL
41manual. Currently phpMyAdmin can:
1d23e58d 42- create and drop databases
43- create, copy, drop and alter tables
44- delete, edit and add fields
45- execute any SQL-statement, even batch-queries
46- manage keys on fields
47- load text files into tables
48- create (*) and read dumps of tables
49- export (*) and import data to CSV values
50- administer multiple servers and single databases
ffe964b1
TP
51- check referencial integrity
52- create complex queries automatically connecting required tables
53- create PDF graphics of your database layout
54- communicate in more than 50 different languages
78a895aa 55
27fed873
JR
56%description -l pl.UTF-8
57phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
58uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
59Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
60baz, którymi chcemy administrować (więcej informacji w odpowiedniej
61podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
62- tworzyć i usuwać bazy
63- wykonywać create, copy, drop oraz alter na tabelach
64- dodawać, usuwać i modyfikować pola
65- wykonywać dowolne zapytania SQL
66- zarządzać kluczami na rekordach
67- wczytywać tekst z plików do tabel
68- obsługiwać ponad 20 języków
69- zarządzać wieloma serwerami i pojedynczymi bazami danych
70- eksportować i importować dane do wartości CSV
71- tworzyć i czytać zrzuty tabel
78a895aa 72
78a895aa 73%prep
fb6eaade 74%setup -q -n %{name}-%{version}-all-languages
8677f286 75%patch0 -p1
78a895aa
PG
76
77%install
78rm -rf $RPM_BUILD_ROOT
8677f286 79install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/{js,lang,libraries/{auth,dbg,dbi,engines,export,tcpdf/font,import,transformations}}}
f935b243
ER
80
81install *.php *.html *.css $RPM_BUILD_ROOT%{_appdir}
82install lang/*.php $RPM_BUILD_ROOT%{_appdir}/lang
ffe964b1 83cp -rf pmd $RPM_BUILD_ROOT%{_appdir}
f935b243 84cp -rf themes $RPM_BUILD_ROOT%{_appdir}
786331fa 85install js/* $RPM_BUILD_ROOT%{_appdir}/js
52f3e0d7 86install libraries/*.php $RPM_BUILD_ROOT%{_appdir}/libraries
f935b243 87install libraries/auth/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/auth
f935b243
ER
88install libraries/dbg/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbg
89install libraries/dbi/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbi
eedbae07 90install libraries/engines/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/engines
91install libraries/export/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/export
ffe964b1 92install libraries/import/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/import
f4f5ac2a 93install libraries/tcpdf/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf
94install libraries/tcpdf/font/*.{php,z} $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf/font
f935b243 95install libraries/transformations/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/transformations
78a895aa 96
52f3e0d7 97install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
f935b243 98ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
aac07012 99
f935b243
ER
100install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
101install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
c3491de8 102install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
aac07012 103
ffe964b1
TP
104cp -f libraries/tcpdf/README{,-tcpdf}
105cp -f libraries/import/README{,-import}
106cp -f libraries/transformations/README{,-transformations}
107
78a895aa 108%clean
95798666 109rm -rf $RPM_BUILD_ROOT
78a895aa 110
879dcd55 111%triggerin -- apache1 < 1.3.37-3, apache1-base
f935b243 112%webapp_register apache %{_webapp}
aac07012 113
879dcd55 114%triggerun -- apache1 < 1.3.37-3, apache1-base
f935b243
ER
115%webapp_unregister apache %{_webapp}
116
243b3916 117%triggerin -- apache < 2.2.0, apache-base
f935b243
ER
118%webapp_register httpd %{_webapp}
119
243b3916 120%triggerun -- apache < 2.2.0, apache-base
f935b243 121%webapp_unregister httpd %{_webapp}
aac07012 122
59d81573
PG
123%triggerin -- lighttpd
124%webapp_register lighttpd %{_webapp}
125
126%triggerun -- lighttpd
127%webapp_unregister lighttpd %{_webapp}
128
7bb50a64 129%post
130if [ "$1" = 1 ]; then
131%banner -e %{name} <<EOF
132To access phpMyAdmin type in a web browser following url:
133http://localhost/myadmin/index.php
134If you have installed webserver(indexfile) you can use shorter version:
135http://localhost/myadmin
136EOF
137fi
138
78a895aa
PG
139%files
140%defattr(644,root,root,755)
ffe964b1 141%doc Documentation.* CREDITS ChangeLog INSTALL README TODO translators.html scripts libraries/tcpdf/README-tcpdf libraries/import/README-import libraries/transformations/README-transformations libraries/transformations/TEMPLATE* libraries/transformations/*.sh lang/*.sh
f935b243
ER
142%dir %attr(750,root,http) %{_sysconfdir}
143%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
144%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
59d81573 145%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
f935b243
ER
146%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
147%dir %{_appdir}
786331fa 148%{_appdir}/js
f935b243
ER
149%{_appdir}/lang
150%{_appdir}/libraries
ffe964b1 151%{_appdir}/pmd
786331fa 152%{_appdir}/themes
f935b243
ER
153%{_appdir}/*.css
154%{_appdir}/*.html
155%{_appdir}/*.php
This page took 0.052568 seconds and 4 git commands to generate.