]> git.pld-linux.org Git - packages/perl-Math-Vec.git/blame - perl-Math-Vec.spec
- updated to 1.01
[packages/perl-Math-Vec.git] / perl-Math-Vec.spec
CommitLineData
bbcf5ee0 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Math
7%define pnam Vec
8Summary: Math::Vec - Object-Oriented Vector Math Methods in Perl
8d156cf6 9Summary(pl.UTF-8): Math::Vec - zorientowane obiektowo metody do wektorów w Perlu
bbcf5ee0 10Name: perl-Math-Vec
f8f1c7dc 11Version: 1.01
bbcf5ee0 12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
8d156cf6 16Source0: http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
f8f1c7dc 17# Source0-md5: 3d881e6f8074257d54125190719859eb
8d156cf6 18URL: http://search.cpan.org/dist/Math-Vec/
bbcf5ee0 19BuildRequires: perl-Module-Build
20BuildRequires: perl-devel >= 1:5.8.0
21BuildRequires: rpm-perlprov >= 4.1-13
22BuildArch: noarch
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26This module was adapted from Math::Vector, written by Wayne M.
27Syvinski.
28
29It uses most of the same algorithms, and currently preserves the same
30names as the original functions, though some aliases have been added
31to make the interface more natural (at least to the way I think.)
32
33The "object" for the object oriented calling style is a blessed array
34reference which contains a vector of the form [x,y,z]. Methods will
35typically return a list.
36
8d156cf6
JB
37%description -l pl.UTF-8
38Ten moduł został zaadaptowany z Math::Vector napisanego przez Wayne'a
39M. Syvinskiego.
40
41Używa w większości tych samych algorytmów i aktualnie zachowuje te
42same nazwy jak funkcje oryginalne, ale dodano trochę aliasów, aby
43uczynić interfejs bardziej naturalnym (przynajmniej zdaniem autora).
44
45"Obiekt" dla zorientowanego obiektowo stylu wywołań jest
46pobłogosławioną referencją do tablicy zawierającą wektor w postaci
47[x,y,z]. Metody zwykle zwracają listę.
48
bbcf5ee0 49%prep
50%setup -q -n %{pdir}-%{pnam}-%{version}
51
52%build
53%{__perl} Makefile.PL \
54 INSTALLDIRS=vendor \
55 destdir=$RPM_BUILD_ROOT
56./Build
57
58%{?with_tests:./Build test}
59
60%install
61rm -rf $RPM_BUILD_ROOT
62
63./Build install
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(644,root,root,755)
70%doc README
71%{perl_vendorlib}/Math/Vec.pm
72%{_mandir}/man3/*
This page took 0.116047 seconds and 4 git commands to generate.