]> git.pld-linux.org Git - packages/mbedtls.git/blame - mbedtls.spec
- updated to 2.16.6 (fixes CVE-2020-10932)
[packages/mbedtls.git] / mbedtls.spec
CommitLineData
875e57b3
JB
1#
2# Conditional build:
3%bcond_with zlib # zlib compression support (may reduce security, see CRIME)
4#
a3f8074d
JB
5Summary: Light-weight cryptographic and SSL/TLS library
6Summary(pl.UTF-8): Lekka biblioteka kryptograficzna oraz SSL/TLS
7Name: mbedtls
af4afdcf 8Version: 2.16.6
bf36c92e 9Release: 1
a3f8074d
JB
10License: GPL v2+
11Group: Libraries
12Source0: https://tls.mbed.org/code/releases/%{name}-%{version}-gpl.tgz
af4afdcf 13# Source0-md5: 4ba3d1a090159486394ba6e46f95bf6c
a3f8074d
JB
14URL: https://tls.mbed.org/
15BuildRequires: cmake >= 2.6
16BuildRequires: doxygen
17BuildRequires: rpmbuild(macros) >= 1.605
875e57b3 18%{?with_zlib:BuildRequires: zlib-devel}
a3f8074d
JB
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22mbedTLS is a light-weight open source cryptographic and SSL/TLS
23library written in C. mbedTLS makes it easy for developers to include
24cryptographic and SSL/TLS capabilities in their (embedded)
25applications with as little hassle as possible.
26
27%description -l pl.UTF-8
28mbedTLS to lekka, mająca otwarte źródła biblioteka kryptograficzna
29oraz SSL/TLS napisana w C. mbedTLS ułatwia programistom dołączanie
30funkcji kryptograficznych i SSL/TLS do swoich (wbudowanych) aplikacji
31przy jak najmniejszym narzucie.
32
33%package devel
34Summary: Development files for mbedTLS
35Summary(pl.UTF-8): Pliki programistyczne biblioteki mbedTLS
36Group: Development/Libraries
37Requires: %{name} = %{version}-%{release}
a3f8074d
JB
38
39%description devel
40This package contains the header files for developing applications
41that use mbedTLS.
42
43%description devel -l pl.UTF-8
44Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
45wykorzystujących bibliotekę mbedTLS.
46
47%package static
48Summary: Static mbedTLS library
49Summary(pl.UTF-8): Statyczna biblioteka mbedTLS
50Group: Development/Libraries
51Requires: %{name}-devel = %{version}-%{release}
52
53%description static
54Static mbedTLS library.
55
56%description static -l pl.UTF-8
57Statyczna biblioteka mbedTLS.
58
875e57b3
JB
59%package apidocs
60Summary: API documentation for mbedTLS library
61Summary(pl.UTF-8): Dokumentacja API biblioteki mbedTLS
62Group: Documentation
63
64%description apidocs
65API documentation for mbedTLS library.
66
67%description apidocs -l pl.UTF-8
68Dokumentacja API biblioteki mbedTLS.
69
a3f8074d
JB
70%prep
71%setup -q
72
73%build
74install -d build
75cd build
76%cmake .. \
77 -DLIB_INSTALL_DIR:PATH=%{_libdir} \
875e57b3
JB
78 %{?with_zlib:-DENABLE_ZLIB_SUPPORT=ON} \
79 -DUSE_SHARED_MBEDTLS_LIBRARY=ON
a3f8074d
JB
80
81%{__make}
82%{__make} apidoc
83
84%if %{with tests}
85# Tests are not stable on 64-bit
86ctest --output-on-failure
87%endif
88
89%install
90rm -rf $RPM_BUILD_ROOT
91
92%{__make} -C build install \
93 DESTDIR=$RPM_BUILD_ROOT
94
95install -d $RPM_BUILD_ROOT%{_libdir}
96mv $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT%{_libdir}/%{name}
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post -p /sbin/ldconfig
102%postun -p /sbin/ldconfig
103
104%files
105%defattr(644,root,root,755)
95cbb035 106%doc ChangeLog LICENSE README.md
64c8d752 107%attr(755,root,root) %{_libdir}/libmbedcrypto.so.*.*.*
628fc698 108%attr(755,root,root) %ghost %{_libdir}/libmbedcrypto.so.3
a3f8074d 109%attr(755,root,root) %{_libdir}/libmbedtls.so.*.*.*
628fc698 110%attr(755,root,root) %ghost %{_libdir}/libmbedtls.so.12
64c8d752
JB
111%attr(755,root,root) %{_libdir}/libmbedx509.so.*.*.*
112%attr(755,root,root) %ghost %{_libdir}/libmbedx509.so.0
a3f8074d
JB
113%dir %{_libdir}/%{name}
114%attr(755,root,root) %{_libdir}/%{name}/aescrypt2
115%attr(755,root,root) %{_libdir}/%{name}/benchmark
116%attr(755,root,root) %{_libdir}/%{name}/cert_app
117%attr(755,root,root) %{_libdir}/%{name}/cert_req
118%attr(755,root,root) %{_libdir}/%{name}/cert_write
119%attr(755,root,root) %{_libdir}/%{name}/crl_app
120%attr(755,root,root) %{_libdir}/%{name}/crypt_and_hash
121%attr(755,root,root) %{_libdir}/%{name}/dh_client
122%attr(755,root,root) %{_libdir}/%{name}/dh_genprime
123%attr(755,root,root) %{_libdir}/%{name}/dh_server
64c8d752
JB
124%attr(755,root,root) %{_libdir}/%{name}/dtls_client
125%attr(755,root,root) %{_libdir}/%{name}/dtls_server
a3f8074d
JB
126%attr(755,root,root) %{_libdir}/%{name}/gen_entropy
127%attr(755,root,root) %{_libdir}/%{name}/gen_key
128%attr(755,root,root) %{_libdir}/%{name}/gen_random_ctr_drbg
129%attr(755,root,root) %{_libdir}/%{name}/gen_random_havege
130%attr(755,root,root) %{_libdir}/%{name}/generic_sum
131%attr(755,root,root) %{_libdir}/%{name}/hello
132%attr(755,root,root) %{_libdir}/%{name}/key_app
bf36c92e 133%attr(755,root,root) %{_libdir}/%{name}/mini_client
a3f8074d 134%attr(755,root,root) %{_libdir}/%{name}/mpi_demo
a3f8074d
JB
135%attr(755,root,root) %{_libdir}/%{name}/pem2der
136%attr(755,root,root) %{_libdir}/%{name}/pk_decrypt
137%attr(755,root,root) %{_libdir}/%{name}/pk_encrypt
138%attr(755,root,root) %{_libdir}/%{name}/pk_sign
139%attr(755,root,root) %{_libdir}/%{name}/pk_verify
628fc698 140%attr(755,root,root) %{_libdir}/%{name}/query_compile_time_config
a3f8074d
JB
141%attr(755,root,root) %{_libdir}/%{name}/req_app
142%attr(755,root,root) %{_libdir}/%{name}/rsa_decrypt
143%attr(755,root,root) %{_libdir}/%{name}/rsa_encrypt
144%attr(755,root,root) %{_libdir}/%{name}/rsa_genkey
145%attr(755,root,root) %{_libdir}/%{name}/rsa_sign
146%attr(755,root,root) %{_libdir}/%{name}/rsa_verify
147%attr(755,root,root) %{_libdir}/%{name}/selftest
a3f8074d
JB
148%attr(755,root,root) %{_libdir}/%{name}/ssl_client1
149%attr(755,root,root) %{_libdir}/%{name}/ssl_client2
150%attr(755,root,root) %{_libdir}/%{name}/ssl_fork_server
151%attr(755,root,root) %{_libdir}/%{name}/ssl_mail_client
152%attr(755,root,root) %{_libdir}/%{name}/ssl_pthread_server
153%attr(755,root,root) %{_libdir}/%{name}/ssl_server
a3f8074d 154%attr(755,root,root) %{_libdir}/%{name}/strerror
64c8d752 155%attr(755,root,root) %{_libdir}/%{name}/udp_proxy
a3f8074d
JB
156
157%files devel
158%defattr(644,root,root,755)
64c8d752 159%attr(755,root,root) %{_libdir}/libmbedcrypto.so
a3f8074d 160%attr(755,root,root) %{_libdir}/libmbedtls.so
64c8d752
JB
161%attr(755,root,root) %{_libdir}/libmbedx509.so
162%{_includedir}/mbedtls
a3f8074d
JB
163
164%files static
165%defattr(644,root,root,755)
95cbb035 166%{_libdir}/libmbedcrypto.a
a3f8074d 167%{_libdir}/libmbedtls.a
64c8d752 168%{_libdir}/libmbedx509.a
875e57b3
JB
169
170%files apidocs
171%defattr(644,root,root,755)
172%doc apidoc/*
This page took 0.122805 seconds and 4 git commands to generate.