]> git.pld-linux.org Git - packages/libfilezilla.git/blame - libfilezilla.spec
- up to 0.13.0
[packages/libfilezilla.git] / libfilezilla.spec
CommitLineData
fdec25bb
WF
1#
2# Conditional build:
98d72535
JB
3%bcond_without apidocs # doxygen API documentation
4%bcond_without static_libs # static library
5%bcond_without tests # "make check"
fdec25bb 6#
98d72535
JB
7Summary: Library for high-performing platform-independent programs
8Summary(pl.UTF-8): Biblioteka do wydajnych programów niezależnych od platformy
fdec25bb 9Name: libfilezilla
d7e96a85 10Version: 0.13.0
5479badf 11Release: 1
fdec25bb
WF
12License: GPL v2
13Group: Libraries
defa0a72 14Source0: http://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
d7e96a85 15# Source0-md5: bdb48a81e0cdef196fc336bf306cd6d5
fdec25bb 16URL: http://lib.filezilla-project.org/
98d72535
JB
17%{?with_tests:BuildRequires: cppunit-devel >= 1.10.2}
18%{?with_apidocs:BuildRequires: doxygen}
19%if %{with tests} && %(locale -a | grep -q '^C\.UTF-8$'; echo $?)
20BuildRequires: glibc-localedb-all
21%endif
02115c6c
WF
22BuildRequires: autoconf >= 2.50
23BuildRequires: automake
24BuildRequires: libtool >= 2:2
25BuildRequires: pkgconfig >= 1:0.7
98d72535
JB
26# -std=c++14
27BuildRequires: libstdc++-devel >= 6:5
fdec25bb
WF
28BuildRequires: rpmbuild(macros) >= 1.583
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32libfilezilla is a free, open source C++ library, offering some basic
33functionality to build high-performing, platform-independent programs.
34Some of the highlights include:
35
36- A typesafe, multi-threaded event system that's very simple to use
37 yet extremely efficient
38- Timers for periodic events
39- A datetime class that not only tracks timestamp but also their
40 accuracy, which simplifies dealing with timestamps originating from
41 different sources
42- Simple process handling for spawning child processes with redirected
43 I/O
44
98d72535
JB
45%description -l pl.UTF-8
46libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
47oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
48programów niezależnych od platformy. Uwzględnione funkcje obejmują:
49- bezpieczny pod względem typów, wielowątkowy system zdarzeń -
50 bardzo prosty w użyciu, a jednocześnie bardzo wydajny
51- zegary do zdarzeń regularnych
52- klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
53 dokładność, co upraszcza obsługę znaczników czasu pochodzących z
54 różnych źródeł
55- prostą obsługę procesów do tworzenia procesów potomnych z
56 przekierowanym wejściem/wyjściem
fdec25bb
WF
57
58%package devel
98d72535
JB
59Summary: Header files for libfilezilla library
60Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libfilezilla
fdec25bb
WF
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
98d72535 63Requires: libstdc++-devel >= 6:5
fdec25bb
WF
64
65%description devel
98d72535 66Header files for libfilezilla library.
fdec25bb
WF
67
68%description devel -l pl.UTF-8
98d72535 69Pliki nagłówkowe biblioteki libfilezilla.
fdec25bb
WF
70
71%package static
98d72535
JB
72Summary: Static libfilezilla library
73Summary(pl.UTF-8): Statyczna biblioteka libfilezilla
fdec25bb
WF
74Group: Development/Libraries
75Requires: %{name}-devel = %{version}-%{release}
76
77%description static
98d72535 78Static libfilezilla library.
fdec25bb
WF
79
80%description static -l pl.UTF-8
98d72535 81Statyczna biblioteka libfilezilla.
fdec25bb
WF
82
83%package apidocs
84Summary: %{name} API documentation
85Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
86Group: Documentation
87
88%description apidocs
89API documentation for %{name} library.
90
91%description apidocs -l pl.UTF-8
92Dokumentacja API biblioteki %{name}.
93
94%prep
95%setup -q
96
97%build
02115c6c
WF
98%{__libtoolize}
99%{__aclocal} -I m4
100%{__autoconf}
101%{__autoheader}
102%{__automake}
fdec25bb
WF
103%configure \
104 %{!?with_static_libs:--disable-static}
105%{__make}
106
98d72535
JB
107%if %{with tests}
108# wide char conversion test fails with plain C locale
109LC_ALL=C.UTF-8 \
110%{__make} check
111%endif
112
113%if %{with apidocs}
114%{__make} -C doc html
115%endif
116
fdec25bb
WF
117%install
118rm -rf $RPM_BUILD_ROOT
119
120%{__make} install \
121 DESTDIR=$RPM_BUILD_ROOT
122
123%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%post -p /sbin/ldconfig
129%postun -p /sbin/ldconfig
130
131%files
132%defattr(644,root,root,755)
98d72535
JB
133%doc AUTHORS ChangeLog NEWS README
134%attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
135%attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.0
fdec25bb
WF
136
137%files devel
138%defattr(644,root,root,755)
98d72535
JB
139%attr(755,root,root) %{_libdir}/libfilezilla.so
140%{_includedir}/libfilezilla
141%{_pkgconfigdir}/libfilezilla.pc
fdec25bb
WF
142
143%if %{with static_libs}
144%files static
145%defattr(644,root,root,755)
98d72535 146%{_libdir}/libfilezilla.a
fdec25bb
WF
147%endif
148
98d72535 149%if %{with apidocs}
fdec25bb
WF
150%files apidocs
151%defattr(644,root,root,755)
98d72535 152%doc doc/doxygen-doc/html/*
fdec25bb 153%endif
This page took 1.128855 seconds and 4 git commands to generate.