]> git.pld-linux.org Git - packages/libfilezilla.git/blame - libfilezilla.spec
- added random_bytes.patch
[packages/libfilezilla.git] / libfilezilla.spec
CommitLineData
fdec25bb
WF
1#
2# Conditional build:
98d72535
JB
3%bcond_without apidocs # doxygen API documentation
4%bcond_without static_libs # static library
5%bcond_without tests # "make check"
fdec25bb 6#
98d72535
JB
7Summary: Library for high-performing platform-independent programs
8Summary(pl.UTF-8): Biblioteka do wydajnych programów niezależnych od platformy
fdec25bb 9Name: libfilezilla
02115c6c 10Version: 0.9.2
61a72c2d 11Release: 2
fdec25bb
WF
12License: GPL v2
13Group: Libraries
defa0a72 14Source0: http://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
02115c6c
WF
15# Source0-md5: d52a0e7229efb3c9fafc8a2b649d665d
16Patch0: cppunit-pkgconfig.patch
61a72c2d 17Patch1: random_bytes.patch
fdec25bb 18URL: http://lib.filezilla-project.org/
98d72535
JB
19%{?with_tests:BuildRequires: cppunit-devel >= 1.10.2}
20%{?with_apidocs:BuildRequires: doxygen}
21%if %{with tests} && %(locale -a | grep -q '^C\.UTF-8$'; echo $?)
22BuildRequires: glibc-localedb-all
23%endif
02115c6c
WF
24BuildRequires: autoconf >= 2.50
25BuildRequires: automake
26BuildRequires: libtool >= 2:2
27BuildRequires: pkgconfig >= 1:0.7
98d72535
JB
28# -std=c++14
29BuildRequires: libstdc++-devel >= 6:5
fdec25bb
WF
30BuildRequires: rpmbuild(macros) >= 1.583
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34libfilezilla is a free, open source C++ library, offering some basic
35functionality to build high-performing, platform-independent programs.
36Some of the highlights include:
37
38- A typesafe, multi-threaded event system that's very simple to use
39 yet extremely efficient
40- Timers for periodic events
41- A datetime class that not only tracks timestamp but also their
42 accuracy, which simplifies dealing with timestamps originating from
43 different sources
44- Simple process handling for spawning child processes with redirected
45 I/O
46
98d72535
JB
47%description -l pl.UTF-8
48libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
49oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
50programów niezależnych od platformy. Uwzględnione funkcje obejmują:
51- bezpieczny pod względem typów, wielowątkowy system zdarzeń -
52 bardzo prosty w użyciu, a jednocześnie bardzo wydajny
53- zegary do zdarzeń regularnych
54- klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
55 dokładność, co upraszcza obsługę znaczników czasu pochodzących z
56 różnych źródeł
57- prostą obsługę procesów do tworzenia procesów potomnych z
58 przekierowanym wejściem/wyjściem
fdec25bb
WF
59
60%package devel
98d72535
JB
61Summary: Header files for libfilezilla library
62Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libfilezilla
fdec25bb
WF
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
98d72535 65Requires: libstdc++-devel >= 6:5
fdec25bb
WF
66
67%description devel
98d72535 68Header files for libfilezilla library.
fdec25bb
WF
69
70%description devel -l pl.UTF-8
98d72535 71Pliki nagłówkowe biblioteki libfilezilla.
fdec25bb
WF
72
73%package static
98d72535
JB
74Summary: Static libfilezilla library
75Summary(pl.UTF-8): Statyczna biblioteka libfilezilla
fdec25bb
WF
76Group: Development/Libraries
77Requires: %{name}-devel = %{version}-%{release}
78
79%description static
98d72535 80Static libfilezilla library.
fdec25bb
WF
81
82%description static -l pl.UTF-8
98d72535 83Statyczna biblioteka libfilezilla.
fdec25bb
WF
84
85%package apidocs
86Summary: %{name} API documentation
87Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
88Group: Documentation
89
90%description apidocs
91API documentation for %{name} library.
92
93%description apidocs -l pl.UTF-8
94Dokumentacja API biblioteki %{name}.
95
96%prep
97%setup -q
02115c6c 98%patch0 -p1
61a72c2d 99%patch1 -p1
fdec25bb
WF
100
101%build
02115c6c
WF
102%{__libtoolize}
103%{__aclocal} -I m4
104%{__autoconf}
105%{__autoheader}
106%{__automake}
fdec25bb
WF
107%configure \
108 %{!?with_static_libs:--disable-static}
109%{__make}
110
98d72535
JB
111%if %{with tests}
112# wide char conversion test fails with plain C locale
113LC_ALL=C.UTF-8 \
114%{__make} check
115%endif
116
117%if %{with apidocs}
118%{__make} -C doc html
119%endif
120
fdec25bb
WF
121%install
122rm -rf $RPM_BUILD_ROOT
123
124%{__make} install \
125 DESTDIR=$RPM_BUILD_ROOT
126
127%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132%post -p /sbin/ldconfig
133%postun -p /sbin/ldconfig
134
135%files
136%defattr(644,root,root,755)
98d72535
JB
137%doc AUTHORS ChangeLog NEWS README
138%attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
139%attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.0
fdec25bb
WF
140
141%files devel
142%defattr(644,root,root,755)
98d72535
JB
143%attr(755,root,root) %{_libdir}/libfilezilla.so
144%{_includedir}/libfilezilla
145%{_pkgconfigdir}/libfilezilla.pc
fdec25bb
WF
146
147%if %{with static_libs}
148%files static
149%defattr(644,root,root,755)
98d72535 150%{_libdir}/libfilezilla.a
fdec25bb
WF
151%endif
152
98d72535 153%if %{with apidocs}
fdec25bb
WF
154%files apidocs
155%defattr(644,root,root,755)
98d72535 156%doc doc/doxygen-doc/html/*
fdec25bb 157%endif
This page took 0.164033 seconds and 4 git commands to generate.