]> git.pld-linux.org Git - packages/libfilezilla.git/blame - libfilezilla.spec
- release 2, fix locales in a similar way it is done in FileZilla.spec
[packages/libfilezilla.git] / libfilezilla.spec
CommitLineData
fdec25bb
WF
1#
2# Conditional build:
98d72535
JB
3%bcond_without apidocs # doxygen API documentation
4%bcond_without static_libs # static library
5%bcond_without tests # "make check"
fdec25bb 6#
98d72535
JB
7Summary: Library for high-performing platform-independent programs
8Summary(pl.UTF-8): Biblioteka do wydajnych programów niezależnych od platformy
fdec25bb 9Name: libfilezilla
db09d1b5 10Version: 0.17.1
1676018f 11Release: 2
fdec25bb
WF
12License: GPL v2
13Group: Libraries
35f64aba 14Source0: https://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
db09d1b5 15# Source0-md5: 7cecda7c08f141223076487490374cb5
35f64aba 16URL: https://lib.filezilla-project.org/
9f68b570 17%{?with_tests:BuildRequires: cppunit-devel >= 1.13.0}
98d72535 18%{?with_apidocs:BuildRequires: doxygen}
9021009f 19%if %{with tests} && %(locale -a | grep -q '^C\.utf8$'; echo $?)
98d72535
JB
20BuildRequires: glibc-localedb-all
21%endif
02115c6c
WF
22BuildRequires: autoconf >= 2.50
23BuildRequires: automake
db09d1b5 24BuildRequires: gnutls-devel >= 3.5.7
02115c6c 25BuildRequires: libtool >= 2:2
9f68b570 26BuildRequires: nettle-devel >= 3.1
02115c6c 27BuildRequires: pkgconfig >= 1:0.7
98d72535
JB
28# -std=c++14
29BuildRequires: libstdc++-devel >= 6:5
fdec25bb
WF
30BuildRequires: rpmbuild(macros) >= 1.583
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34libfilezilla is a free, open source C++ library, offering some basic
35functionality to build high-performing, platform-independent programs.
36Some of the highlights include:
37
38- A typesafe, multi-threaded event system that's very simple to use
39 yet extremely efficient
40- Timers for periodic events
41- A datetime class that not only tracks timestamp but also their
42 accuracy, which simplifies dealing with timestamps originating from
43 different sources
44- Simple process handling for spawning child processes with redirected
45 I/O
46
98d72535
JB
47%description -l pl.UTF-8
48libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
49oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
50programów niezależnych od platformy. Uwzględnione funkcje obejmują:
51- bezpieczny pod względem typów, wielowątkowy system zdarzeń -
52 bardzo prosty w użyciu, a jednocześnie bardzo wydajny
53- zegary do zdarzeń regularnych
54- klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
55 dokładność, co upraszcza obsługę znaczników czasu pochodzących z
56 różnych źródeł
57- prostą obsługę procesów do tworzenia procesów potomnych z
58 przekierowanym wejściem/wyjściem
fdec25bb
WF
59
60%package devel
98d72535
JB
61Summary: Header files for libfilezilla library
62Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libfilezilla
fdec25bb
WF
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
98d72535 65Requires: libstdc++-devel >= 6:5
fdec25bb
WF
66
67%description devel
98d72535 68Header files for libfilezilla library.
fdec25bb
WF
69
70%description devel -l pl.UTF-8
98d72535 71Pliki nagłówkowe biblioteki libfilezilla.
fdec25bb
WF
72
73%package static
98d72535
JB
74Summary: Static libfilezilla library
75Summary(pl.UTF-8): Statyczna biblioteka libfilezilla
fdec25bb
WF
76Group: Development/Libraries
77Requires: %{name}-devel = %{version}-%{release}
78
79%description static
98d72535 80Static libfilezilla library.
fdec25bb
WF
81
82%description static -l pl.UTF-8
98d72535 83Statyczna biblioteka libfilezilla.
fdec25bb
WF
84
85%package apidocs
86Summary: %{name} API documentation
87Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
88Group: Documentation
89
90%description apidocs
91API documentation for %{name} library.
92
93%description apidocs -l pl.UTF-8
94Dokumentacja API biblioteki %{name}.
95
96%prep
97%setup -q
98
1676018f
AG
99cd locales
100%{__mv} bg{_BG,}.po
101%{__mv} ca{_ES,}@valencia.po
102%{__mv} cs{_CZ,}.po
103%{__mv} fa{_IR,}.po
104%{__mv} fi{_FI,}.po
105%{__mv} gl{_ES,}.po
106%{__mv} he{_IL,}.po
107%{__mv} hu{_HU,}.po
108%{__mv} id{_ID,}.po
109%{__mv} ja{_JP,}.po
110%{__mv} ko{_KR,}.po
111%{__mv} lo{_LA,}.po
112%{__mv} lt{_LT,}.po
113%{__mv} lv{_LV,}.po
114%{__mv} mk{_MK,}.po
115%{__mv} nb{_NO,}.po
116%{__mv} nn{_NO,}.po
117%{__mv} pl{_PL,}.po
118%{__mv} pt{_PT,}.po
119%{__mv} ro{_RO,}.po
120%{__mv} sk{_SK,}.po
121%{__mv} sl{_SI,}.po
122%{__mv} th{_TH,}.po
123%{__mv} uk{_UA,}.po
124%{__mv} vi{_VN,}.po
125
fdec25bb 126%build
02115c6c
WF
127%{__libtoolize}
128%{__aclocal} -I m4
129%{__autoconf}
130%{__autoheader}
131%{__automake}
fdec25bb
WF
132%configure \
133 %{!?with_static_libs:--disable-static}
134%{__make}
135
98d72535
JB
136%if %{with tests}
137# wide char conversion test fails with plain C locale
138LC_ALL=C.UTF-8 \
139%{__make} check
140%endif
141
142%if %{with apidocs}
143%{__make} -C doc html
144%endif
145
fdec25bb
WF
146%install
147rm -rf $RPM_BUILD_ROOT
148
149%{__make} install \
150 DESTDIR=$RPM_BUILD_ROOT
151
152%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
153
1676018f
AG
154# not supported by glibc (as of 2.25)
155%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/co
156
db09d1b5
AG
157%find_lang %{name}
158
fdec25bb
WF
159%clean
160rm -rf $RPM_BUILD_ROOT
161
162%post -p /sbin/ldconfig
163%postun -p /sbin/ldconfig
164
db09d1b5 165%files -f %{name}.lang
fdec25bb 166%defattr(644,root,root,755)
98d72535
JB
167%doc AUTHORS ChangeLog NEWS README
168%attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
169%attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.0
fdec25bb
WF
170
171%files devel
172%defattr(644,root,root,755)
98d72535
JB
173%attr(755,root,root) %{_libdir}/libfilezilla.so
174%{_includedir}/libfilezilla
175%{_pkgconfigdir}/libfilezilla.pc
fdec25bb
WF
176
177%if %{with static_libs}
178%files static
179%defattr(644,root,root,755)
98d72535 180%{_libdir}/libfilezilla.a
fdec25bb
WF
181%endif
182
98d72535 183%if %{with apidocs}
fdec25bb
WF
184%files apidocs
185%defattr(644,root,root,755)
98d72535 186%doc doc/doxygen-doc/html/*
fdec25bb 187%endif
This page took 0.101434 seconds and 4 git commands to generate.