]> git.pld-linux.org Git - packages/libfilezilla.git/blame - libfilezilla.spec
- updated dependencies
[packages/libfilezilla.git] / libfilezilla.spec
CommitLineData
fdec25bb
WF
1#
2# Conditional build:
98d72535
JB
3%bcond_without apidocs # doxygen API documentation
4%bcond_without static_libs # static library
5%bcond_without tests # "make check"
fdec25bb 6#
98d72535
JB
7Summary: Library for high-performing platform-independent programs
8Summary(pl.UTF-8): Biblioteka do wydajnych programów niezależnych od platformy
fdec25bb 9Name: libfilezilla
db09d1b5 10Version: 0.17.1
1676018f 11Release: 2
fdec25bb
WF
12License: GPL v2
13Group: Libraries
35f64aba 14Source0: https://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
db09d1b5 15# Source0-md5: 7cecda7c08f141223076487490374cb5
35f64aba 16URL: https://lib.filezilla-project.org/
9f68b570 17%{?with_tests:BuildRequires: cppunit-devel >= 1.13.0}
98d72535 18%{?with_apidocs:BuildRequires: doxygen}
9021009f 19%if %{with tests} && %(locale -a | grep -q '^C\.utf8$'; echo $?)
98d72535
JB
20BuildRequires: glibc-localedb-all
21%endif
02115c6c
WF
22BuildRequires: autoconf >= 2.50
23BuildRequires: automake
02f4ce22 24BuildRequires: gettext-tools >= 0.11.0
db09d1b5 25BuildRequires: gnutls-devel >= 3.5.7
02115c6c 26BuildRequires: libtool >= 2:2
9f68b570 27BuildRequires: nettle-devel >= 3.1
02115c6c 28BuildRequires: pkgconfig >= 1:0.7
02f4ce22
JB
29# -std=c++17
30BuildRequires: libstdc++-devel >= 6:7
fdec25bb
WF
31BuildRequires: rpmbuild(macros) >= 1.583
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35libfilezilla is a free, open source C++ library, offering some basic
36functionality to build high-performing, platform-independent programs.
37Some of the highlights include:
38
39- A typesafe, multi-threaded event system that's very simple to use
40 yet extremely efficient
41- Timers for periodic events
42- A datetime class that not only tracks timestamp but also their
43 accuracy, which simplifies dealing with timestamps originating from
44 different sources
45- Simple process handling for spawning child processes with redirected
46 I/O
47
98d72535
JB
48%description -l pl.UTF-8
49libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
50oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
51programów niezależnych od platformy. Uwzględnione funkcje obejmują:
52- bezpieczny pod względem typów, wielowątkowy system zdarzeń -
53 bardzo prosty w użyciu, a jednocześnie bardzo wydajny
54- zegary do zdarzeń regularnych
55- klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
56 dokładność, co upraszcza obsługę znaczników czasu pochodzących z
57 różnych źródeł
58- prostą obsługę procesów do tworzenia procesów potomnych z
59 przekierowanym wejściem/wyjściem
fdec25bb
WF
60
61%package devel
98d72535
JB
62Summary: Header files for libfilezilla library
63Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libfilezilla
fdec25bb
WF
64Group: Development/Libraries
65Requires: %{name} = %{version}-%{release}
02f4ce22 66Requires: libstdc++-devel >= 6:7
fdec25bb
WF
67
68%description devel
98d72535 69Header files for libfilezilla library.
fdec25bb
WF
70
71%description devel -l pl.UTF-8
98d72535 72Pliki nagłówkowe biblioteki libfilezilla.
fdec25bb
WF
73
74%package static
98d72535
JB
75Summary: Static libfilezilla library
76Summary(pl.UTF-8): Statyczna biblioteka libfilezilla
fdec25bb
WF
77Group: Development/Libraries
78Requires: %{name}-devel = %{version}-%{release}
79
80%description static
98d72535 81Static libfilezilla library.
fdec25bb
WF
82
83%description static -l pl.UTF-8
98d72535 84Statyczna biblioteka libfilezilla.
fdec25bb
WF
85
86%package apidocs
87Summary: %{name} API documentation
88Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
89Group: Documentation
90
91%description apidocs
92API documentation for %{name} library.
93
94%description apidocs -l pl.UTF-8
95Dokumentacja API biblioteki %{name}.
96
97%prep
98%setup -q
99
1676018f
AG
100cd locales
101%{__mv} bg{_BG,}.po
102%{__mv} ca{_ES,}@valencia.po
103%{__mv} cs{_CZ,}.po
104%{__mv} fa{_IR,}.po
105%{__mv} fi{_FI,}.po
106%{__mv} gl{_ES,}.po
107%{__mv} he{_IL,}.po
108%{__mv} hu{_HU,}.po
109%{__mv} id{_ID,}.po
110%{__mv} ja{_JP,}.po
111%{__mv} ko{_KR,}.po
112%{__mv} lo{_LA,}.po
113%{__mv} lt{_LT,}.po
114%{__mv} lv{_LV,}.po
115%{__mv} mk{_MK,}.po
116%{__mv} nb{_NO,}.po
117%{__mv} nn{_NO,}.po
118%{__mv} pl{_PL,}.po
119%{__mv} pt{_PT,}.po
120%{__mv} ro{_RO,}.po
121%{__mv} sk{_SK,}.po
122%{__mv} sl{_SI,}.po
123%{__mv} th{_TH,}.po
124%{__mv} uk{_UA,}.po
125%{__mv} vi{_VN,}.po
126
fdec25bb 127%build
02115c6c
WF
128%{__libtoolize}
129%{__aclocal} -I m4
130%{__autoconf}
131%{__autoheader}
132%{__automake}
fdec25bb
WF
133%configure \
134 %{!?with_static_libs:--disable-static}
135%{__make}
136
98d72535
JB
137%if %{with tests}
138# wide char conversion test fails with plain C locale
139LC_ALL=C.UTF-8 \
140%{__make} check
141%endif
142
143%if %{with apidocs}
144%{__make} -C doc html
145%endif
146
fdec25bb
WF
147%install
148rm -rf $RPM_BUILD_ROOT
149
150%{__make} install \
151 DESTDIR=$RPM_BUILD_ROOT
152
153%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
154
1676018f
AG
155# not supported by glibc (as of 2.25)
156%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/co
157
db09d1b5
AG
158%find_lang %{name}
159
fdec25bb
WF
160%clean
161rm -rf $RPM_BUILD_ROOT
162
163%post -p /sbin/ldconfig
164%postun -p /sbin/ldconfig
165
db09d1b5 166%files -f %{name}.lang
fdec25bb 167%defattr(644,root,root,755)
98d72535
JB
168%doc AUTHORS ChangeLog NEWS README
169%attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
170%attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.0
fdec25bb
WF
171
172%files devel
173%defattr(644,root,root,755)
98d72535
JB
174%attr(755,root,root) %{_libdir}/libfilezilla.so
175%{_includedir}/libfilezilla
176%{_pkgconfigdir}/libfilezilla.pc
fdec25bb
WF
177
178%if %{with static_libs}
179%files static
180%defattr(644,root,root,755)
98d72535 181%{_libdir}/libfilezilla.a
fdec25bb
WF
182%endif
183
98d72535 184%if %{with apidocs}
fdec25bb
WF
185%files apidocs
186%defattr(644,root,root,755)
98d72535 187%doc doc/doxygen-doc/html/*
fdec25bb 188%endif
This page took 0.060447 seconds and 4 git commands to generate.