]> git.pld-linux.org Git - packages/lcms.git/blame - lcms.spec
- undos configure.ac
[packages/lcms.git] / lcms.spec
CommitLineData
86fd4aa9
JB
1#
2# Conditional build:
3%bcond_without python # don't build python bindings
4#
914017f0 5Summary: Little CMS - a library to transform between colour profiles
ba784bd7 6Summary(pl.UTF-8): Little CMS - biblioteka do konwersji między profilami kolorów
914017f0 7Name: lcms
3d8ffedb 8Version: 1.18
a855e4c9 9Release: 2
896f7926 10License: MIT
914017f0 11Group: Libraries
3d8ffedb
JB
12# corrupted
13#Source0: http://dl.sourceforge.net/lcms/%{name}-%{version}.tar.gz
14Source0: http://www.littlecms.com/%{name}-%{version}.tar.gz
15# Source0-md5: 9f908e2dc48f76db77ac35a382e394c7
14847a72 16Patch0: %{name}-python.patch
914017f0 17URL: http://www.littlecms.com/
429231dc 18BuildRequires: autoconf >= 2.57
63b969c4 19BuildRequires: automake >= 1:1.7.2
a855e4c9 20BuildRequires: dos2unix
38ffa639 21BuildRequires: libjpeg-devel
429231dc 22BuildRequires: libstdc++-devel
38ffa639 23BuildRequires: libtiff-devel
429231dc 24BuildRequires: libtool >= 1:1.4.2-9
4af9957c 25BuildRequires: sed >= 4.0
64ad2df3 26%if %{with python}
14847a72
JB
27BuildRequires: python-devel >= 2.2
28BuildRequires: swig-python >= 1.3.30
64ad2df3 29%endif
38ffa639 30BuildRequires: zlib-devel
914017f0
JB
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33# There is no pretty description in source archive... use these.
34
35%description
36lcms does not allow to write profiles, and profile manipulation is not
37its goal. Instead, lcms focus on implement fast transforms between
38profiles.
39
b3bff7a9
JR
40%description -l pl.UTF-8
41lcms nie pozwala na tworzenie profili i obróbka profili nie jest celem
42tej biblioteki. Natomiast lcms skupia się na implementacji szybkiej
43konwersji między profilami.
914017f0
JB
44
45%package devel
46Summary: Little CMS - header files and developer's documentation
ba784bd7 47Summary(pl.UTF-8): Little CMS - pliki nagłówkowe i dokumentacja
914017f0 48Group: Development/Libraries
d4a273c7 49Requires: %{name} = %{version}-%{release}
914017f0
JB
50
51%description devel
52Header files needed to compile programs with liblcms and some
53documentation useful for programmers.
54
b3bff7a9
JR
55%description devel -l pl.UTF-8
56Pliki nagłówkowe potrzebne do konsolidacji z liblcms oraz dokumentacja
57dla programistów.
914017f0
JB
58
59%package static
60Summary: Little CMS - static library
ba784bd7 61Summary(pl.UTF-8): Little CMS - biblioteka statyczna
914017f0 62Group: Development/Libraries
d4a273c7 63Requires: %{name}-devel = %{version}-%{release}
914017f0
JB
64
65%description static
66Static version of liblcms.
67
b3bff7a9 68%description static -l pl.UTF-8
914017f0
JB
69Statyczna biblioteka liblcms.
70
38ffa639
JB
71%package progs
72Summary: Example and demonstration programs for Little CMS
ba784bd7 73Summary(pl.UTF-8): Programy przykładowe i demonstracyjne do Little CMS
38ffa639 74Group: Applications/Graphics
d4a273c7 75Requires: %{name} = %{version}-%{release}
38ffa639
JB
76
77%description progs
78Example and demonstration programs for Little CMS.
79
b3bff7a9
JR
80%description progs -l pl.UTF-8
81Programy przykładowe i demonstracyjne do Little CMS.
38ffa639 82
429231dc
JB
83%package -n python-lcms
84Summary: Little CMS module for Python
ba784bd7 85Summary(pl.UTF-8): Moduł Little CMS dla Pythona
429231dc 86Group: Libraries/Python
d4a273c7 87Requires: %{name} = %{version}-%{release}
429231dc
JB
88%pyrequires_eq python
89
90%description -n python-lcms
91Little CMS module for Python.
92
b3bff7a9
JR
93%description -n python-lcms -l pl.UTF-8
94Moduł Little CMS dla Pythona.
429231dc 95
914017f0
JB
96%prep
97%setup -q
a855e4c9 98dos2unix configure.ac
14847a72 99%patch0 -p1
914017f0
JB
100
101%build
14847a72
JB
102# rebuild using newer swig (needed for g++ 4/python 2.5)
103cd python
104rm -f lcms.py lcms_wrap.cxx
105swig -python -c++ -I../include lcms.i
106cd ..
5ec09a5a 107%{__libtoolize}
108%{__aclocal}
109%{__autoconf}
110%{__automake}
429231dc 111%configure \
64ad2df3 112 --with%{!?with_python:out}-python
5ec09a5a 113
429231dc 114%{__make}
914017f0
JB
115
116%install
117rm -rf $RPM_BUILD_ROOT
118
5ec09a5a 119%{__make} install \
120 DESTDIR=$RPM_BUILD_ROOT
914017f0 121
38ffa639
JB
122install samples/{icctrans,wtpt} tifficc/tifficc $RPM_BUILD_ROOT%{_bindir}
123
429231dc
JB
124rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
125
914017f0
JB
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post -p /sbin/ldconfig
130%postun -p /sbin/ldconfig
131
132%files
133%defattr(644,root,root,755)
896f7926 134%doc AUTHORS COPYING NEWS README.1ST
14847a72 135%attr(755,root,root) %{_libdir}/liblcms.so.*.*.*
f723569a 136%attr(755,root,root) %ghost %{_libdir}/liblcms.so.1
914017f0
JB
137
138%files devel
139%defattr(644,root,root,755)
44e323b4 140%doc doc/*
14847a72
JB
141%attr(755,root,root) %{_libdir}/liblcms.so
142%{_libdir}/liblcms.la
429231dc 143%{_includedir}/*.h
14847a72 144%{_pkgconfigdir}/lcms.pc
914017f0
JB
145
146%files static
147%defattr(644,root,root,755)
14847a72 148%{_libdir}/liblcms.a
38ffa639
JB
149
150%files progs
151%defattr(644,root,root,755)
152%attr(755,root,root) %{_bindir}/*
02971f77 153%{_mandir}/man1/*.1*
429231dc 154
64ad2df3 155%if %{with python}
429231dc
JB
156%files -n python-lcms
157%defattr(644,root,root,755)
158%attr(755,root,root) %{py_sitedir}/_lcms.so
159%{py_sitedir}/lcms.py
64ad2df3 160%endif
This page took 0.091064 seconds and 4 git commands to generate.