]> git.pld-linux.org Git - packages/kismet.git/blame - kismet.spec
- up to 2021-05-R1
[packages/kismet.git] / kismet.spec
CommitLineData
bd19fd3a
ER
1# TODO
2# - Anybody knows, why it will not build, when kernel-headers are installed?
7d77e3fc 3#
496b93f1 4%define tarver %(echo %{version} | tr _ -)
ce8d2811 5Summary: Wireless network sniffer
3197fdd7 6Summary(pl.UTF-8): Sniffer sieci bezprzewodowych
ce8d2811 7Name: kismet
d7f9660c
JR
8Version: 2021_05_R1
9Release: 0.1
ce8d2811
AM
10License: GPL
11Group: Networking/Utilities
4c554cef 12Source0: http://www.kismetwireless.net/code/%{name}-%{tarver}.tar.xz
d7f9660c 13# Source0-md5: df4cc90d5183b7fd45846a33bf598339
74f46803 14Patch0: config.patch
ce8d2811 15URL: http://www.kismetwireless.net/
58c65496
JB
16BuildRequires: autoconf
17BuildRequires: automake
412db6e5 18BuildRequires: bluez-libs-devel
7d77e3fc 19BuildRequires: gmp-devel
412db6e5 20BuildRequires: libcap-devel
399fadea 21BuildRequires: libnl-devel
387a2d36 22BuildRequires: libpcap-devel >= 2:0.9.4-1
d7f9660c 23BuildRequires: libwebsockets-devel >= 3.1.0
6870d034 24BuildRequires: libstdc++-devel
92c7dc22 25BuildRequires: ncurses-ext-devel
412db6e5 26BuildRequires: openssl-devel
27BuildRequires: pcre-devel
9cf4f36b 28BuildRequires: pkgconfig
496b93f1 29BuildRequires: sed >= 4.0
9128618d 30Suggests: %{name}-server
58c65496
JB
31# it uses internal structures - so strict deps
32%requires_eq libpcap
472ae821 33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
ce8d2811 34
d7f9660c 35%define plugins plugin-alertsyslog plugin-dashboard
89d87381 36
ce8d2811
AM
37%description
38Kismet is a 802.11b wireless network sniffer. It is capable of
39sniffing using almost any wireless card supported in Linux, including
40Prism2 based cards supported by the Wlan-NG project (Linksys, Dlink,
41Rangelan, etc), cards which support standard packet capture via
42libpcap (Cisco), and limited support for cards without RF Monitor
43support.
44
280f6f5a 45%description -l pl.UTF-8
ce8d2811 46Kismet to sniffer bezprzewodowych sieci 802.11b. Jest zdolny do
280f6f5a
JR
47sniffowania używając prawie dowolnych bezprzewodowych kart sieciowych
48w Linuksie włączając w to karty Prism2 wspierane przez projekt Wlan-NG
49(Linksys, Dlink, Rangelan, etc), kart które umożliwiają
50przechwytywanie pakietów poprzez libpcap (Cisco), oraz ograniczone
51wsparcie dla kart bez obsługi Monitora RF.
ce8d2811 52
9128618d
ER
53%package server
54Summary: Server for Kismet
55Group: Networking/Daemons
56Requires(postun): /usr/sbin/groupdel
57Requires(pre): /usr/sbin/groupadd
58Provides: group(kismet)
59
60%description server
61This package contains kismet_server which you can access with kismet
62protocol compatible clients.
63
ce8d2811 64%prep
496b93f1 65%setup -q -n %{name}-%{tarver}
74f46803 66%patch0 -p1
ce8d2811 67
496b93f1
ER
68# make lib64 aware, include exec bits on install
69%{__sed} -i -e 's!\$(prefix)/lib/!%_libdir/!g' plugin-*/Makefile
70%{__sed} -i -e '/install/ s!-m644!-m755!' plugin-*/Makefile
71
72# make %doc friendly
73for a in plugin-*/README; do
74 mv $a README.${a%/README}
75done
a824f1d9 76
69914467
JB
77%build
78cp -f /usr/share/automake/config.* .
2be18a10
SZ
79%{__aclocal}
80%{__autoconf}
496b93f1 81%configure
2be18a10 82
d7f9660c
JR
83# -j1 due to OOM
84%{__make} -j1
ce8d2811 85
89d87381 86for plugin in %plugins; do
496b93f1
ER
87 %{__make} -C $plugin \
88 KIS_SRC_DIR=$PWD
89d87381 89done
90
ce8d2811
AM
91%install
92rm -rf $RPM_BUILD_ROOT
1c58060a 93install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir},/var/log/%{name}}
496b93f1
ER
94for dir in . %plugins; do
95 %{__make} -C $dir install \
96 DESTDIR="$RPM_BUILD_ROOT" \
97 KIS_SRC_DIR=$PWD \
98 INSTUSR=%(id -un) \
99 INSTGRP=%(id -gn) \
d7f9660c 100 SUIDGROUP=%(id -gn) \
496b93f1 101 MANGRP=%(id -gn)
89d87381 102done
103
ce8d2811
AM
104%clean
105rm -rf $RPM_BUILD_ROOT
106
9128618d
ER
107%pre server
108%groupadd -P %{name}-server -g 180 kismet
109
110%preun server
111if [ "$1" = "0" ]; then
112 %groupremove kismet
113fi
114
ce8d2811
AM
115%files
116%defattr(644,root,root,755)
d7f9660c 117%doc CHANGELOG README.md README.plugin-alertsyslog README.plugin-dashboard
496b93f1 118%attr(755,root,root) %{_bindir}/kismet
ce8d2811 119%{_datadir}/%{name}
9128618d
ER
120
121%files server
122%defattr(644,root,root,755)
496b93f1 123%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet.conf
9128618d 124%attr(755,root,root) %{_bindir}/kismet_server
496b93f1 125%dir %{_libdir}/kismet
d7f9660c
JR
126#%attr(755,root,root) %{_libdir}/kismet/alertsyslog.so
127#%attr(755,root,root) %{_libdir}/kismet/spectool_net.so
9128618d 128%dir %attr(770,root,kismet) /var/log/%{name}
This page took 1.201969 seconds and 4 git commands to generate.