]> git.pld-linux.org Git - packages/kismet.git/blame - kismet.spec
- btscan plugin installed with proper perms, so bluez-libs dep added automaticaly
[packages/kismet.git] / kismet.spec
CommitLineData
bd19fd3a
ER
1# TODO
2# - Anybody knows, why it will not build, when kernel-headers are installed?
3# - maybe subpkg server and add initscript to it?
7d77e3fc 4#
496b93f1 5%define tarver %(echo %{version} | tr _ -)
ce8d2811 6Summary: Wireless network sniffer
3197fdd7 7Summary(pl.UTF-8): Sniffer sieci bezprzewodowych
ce8d2811 8Name: kismet
496b93f1
ER
9Version: 2010_07_R1
10Release: 0.1
ce8d2811
AM
11License: GPL
12Group: Networking/Utilities
496b93f1
ER
13Source0: http://www.kismetwireless.net/code/%{name}-%{tarver}.tar.gz
14# Source0-md5: 85e59186eb529889118b5635f35cf57d
ce8d2811 15URL: http://www.kismetwireless.net/
58c65496
JB
16BuildRequires: autoconf
17BuildRequires: automake
412db6e5 18BuildRequires: bluez-libs-devel
7d77e3fc 19BuildRequires: gmp-devel
412db6e5 20BuildRequires: libcap-devel
399fadea 21BuildRequires: libnl-devel
387a2d36 22BuildRequires: libpcap-devel >= 2:0.9.4-1
6870d034 23BuildRequires: libstdc++-devel
92c7dc22 24BuildRequires: ncurses-ext-devel
412db6e5 25BuildRequires: openssl-devel
26BuildRequires: pcre-devel
9cf4f36b 27BuildRequires: pkgconfig
496b93f1 28BuildRequires: sed >= 4.0
58c65496
JB
29# it uses internal structures - so strict deps
30%requires_eq libpcap
472ae821 31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
ce8d2811 32
496b93f1 33%define plugins plugin-autowep plugin-btscan plugin-ptw plugin-spectools
89d87381 34
ce8d2811
AM
35%description
36Kismet is a 802.11b wireless network sniffer. It is capable of
37sniffing using almost any wireless card supported in Linux, including
38Prism2 based cards supported by the Wlan-NG project (Linksys, Dlink,
39Rangelan, etc), cards which support standard packet capture via
40libpcap (Cisco), and limited support for cards without RF Monitor
41support.
42
280f6f5a 43%description -l pl.UTF-8
ce8d2811 44Kismet to sniffer bezprzewodowych sieci 802.11b. Jest zdolny do
280f6f5a
JR
45sniffowania używając prawie dowolnych bezprzewodowych kart sieciowych
46w Linuksie włączając w to karty Prism2 wspierane przez projekt Wlan-NG
47(Linksys, Dlink, Rangelan, etc), kart które umożliwiają
48przechwytywanie pakietów poprzez libpcap (Cisco), oraz ograniczone
49wsparcie dla kart bez obsługi Monitora RF.
ce8d2811
AM
50
51%prep
496b93f1 52%setup -q -n %{name}-%{tarver}
ce8d2811 53
496b93f1
ER
54# make lib64 aware, include exec bits on install
55%{__sed} -i -e 's!\$(prefix)/lib/!%_libdir/!g' plugin-*/Makefile
56%{__sed} -i -e '/install/ s!-m644!-m755!' plugin-*/Makefile
57
58# make %doc friendly
59for a in plugin-*/README; do
60 mv $a README.${a%/README}
61done
a824f1d9 62
69914467
JB
63%build
64cp -f /usr/share/automake/config.* .
2be18a10
SZ
65%{__aclocal}
66%{__autoconf}
496b93f1 67%configure
2be18a10 68
c0067f80 69%{__make} \
70 CLIENTLIBS="-ldl -lncurses -lpanel -ltinfo" # hack to add -ltinfo
ce8d2811 71
89d87381 72for plugin in %plugins; do
496b93f1
ER
73 %{__make} -C $plugin \
74 KIS_SRC_DIR=$PWD
89d87381 75done
76
ce8d2811
AM
77%install
78rm -rf $RPM_BUILD_ROOT
ce8d2811 79install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
496b93f1
ER
80for dir in . %plugins; do
81 %{__make} -C $dir install \
82 DESTDIR="$RPM_BUILD_ROOT" \
83 KIS_SRC_DIR=$PWD \
84 INSTUSR=%(id -un) \
85 INSTGRP=%(id -gn) \
86 MANGRP=%(id -gn)
89d87381 87done
88
ce8d2811
AM
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%files
93%defattr(644,root,root,755)
496b93f1
ER
94%doc docs/* CHANGELOG README README.plugin-*
95%attr(755,root,root) %{_bindir}/kismet
96%attr(755,root,root) %{_bindir}/kismet_client
97%attr(755,root,root) %{_bindir}/kismet_drone
98%attr(755,root,root) %{_bindir}/kismet_server
ce8d2811 99%{_datadir}/%{name}
496b93f1
ER
100%{_mandir}/man1/kismet.1*
101%{_mandir}/man1/kismet_drone.1*
102%{_mandir}/man5/kismet.conf.5*
103%{_mandir}/man5/kismet_drone.conf.5*
104%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet.conf
105%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kismet_drone.conf
106%dir %{_libdir}/kismet
107%dir %{_libdir}/kismet_client
108%attr(755,root,root) %{_libdir}/kismet/aircrack-kismet.so
109%attr(755,root,root) %{_libdir}/kismet/autowep-kismet.so
110%attr(755,root,root) %{_libdir}/kismet/btscan.so
111%attr(755,root,root) %{_libdir}/kismet/spectool_net.so
112%attr(755,root,root) %{_libdir}/kismet_client/btscan_ui.so
113%attr(755,root,root) %{_libdir}/kismet_client/spectools_ui.so
This page took 0.089081 seconds and 4 git commands to generate.