]> git.pld-linux.org Git - packages/gtkmm3.git/blame - gtkmm3.spec
- updated to 3.24.3
[packages/gtkmm3.git] / gtkmm3.spec
CommitLineData
33bee831
AF
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
222a6ef9 4
928477ea 5%define atkmm_ver 2.24.2
7c2001a4
JB
6%define glibmm_ver 2.54.0
7%define gtk3_ver 3.24.0
928477ea 8%define pangomm_ver 2.38.2
33bee831
AF
9Summary: A C++ interface for the GTK+ (a GUI library for X)
10Summary(pl.UTF-8): Wrapper C++ dla GTK+
11Name: gtkmm3
c6e33ff3 12Version: 3.24.3
70058bc0 13Release: 1
33bee831
AF
14License: LGPL v2+
15Group: X11/Libraries
c6e33ff3
JB
16Source0: https://download.gnome.org/sources/gtkmm/3.24/gtkmm-%{version}.tar.xz
17# Source0-md5: 9a9a00bcd634e3eca0b101809f2eae02
7c1d0224 18URL: https://www.gtkmm.org/
928477ea 19BuildRequires: atkmm-devel >= %{atkmm_ver}
33bee831 20BuildRequires: autoconf >= 2.59
31a8d119 21BuildRequires: automake >= 1:1.11
70058bc0 22BuildRequires: cairomm-devel >= 1.12.0
c6e33ff3 23BuildRequires: doxygen >= 1:1.8.9
ef8910d5 24BuildRequires: gdk-pixbuf2-devel >= 2.36.0
e34bbb24 25BuildRequires: glibmm-devel >= %{glibmm_ver}
a4ed03e8 26BuildRequires: gtk+3-devel >= %{gtk3_ver}
70058bc0 27BuildRequires: libepoxy-devel >= 1.2
33bee831 28BuildRequires: libsigc++-devel
4f3647ae 29BuildRequires: libstdc++-devel >= 6:4.7
e3273d66 30BuildRequires: libtool >= 2:2.0
928477ea
JB
31BuildRequires: mm-common >= 0.9.10
32BuildRequires: pangomm-devel >= %{pangomm_ver}
33bee831
AF
33BuildRequires: perl-base >= 1:5.6.0
34BuildRequires: pkgconfig
c6e33ff3 35BuildRequires: rpmbuild(macros) >= 1.752
e3273d66
JB
36BuildRequires: tar >= 1:1.22
37BuildRequires: xz
928477ea 38Requires: atkmm >= %{atkmm_ver}
70058bc0 39Requires: cairomm >= 1.12.0
ef8910d5 40Requires: gdk-pixbuf2 >= 2.36.0
e34bbb24 41Requires: glibmm >= %{glibmm_ver}
a4ed03e8 42Requires: gtk+3 >= %{gtk3_ver}
928477ea 43Requires: pangomm >= %{pangomm_ver}
33bee831
AF
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
47This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
48library. The interface provides a convenient interface for C++
49programmers to create GUIs with GTK+'s flexible object-oriented
50framework. Features include type safe callbacks, widgets that are
51extensible using inheritance and over 110 classes that can be freely
52combined to quickly create complex user interfaces.
53
54%description -l pl.UTF-8
55gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
56służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
57także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
58
59%package devel
60Summary: gtkmm and gdkmm header files
61Summary(pl.UTF-8): Pliki nagłówkowe gtkmm i gdkmm
62Group: X11/Development/Libraries
63Requires: %{name} = %{version}-%{release}
928477ea 64Requires: atkmm-devel >= %{atkmm_ver}
70058bc0 65Requires: cairomm-devel >= 1.12.0
ef8910d5 66Requires: gdk-pixbuf2-devel >= 2.36.0
e34bbb24 67Requires: glibmm-devel >= %{glibmm_ver}
a4ed03e8 68Requires: gtk+3-devel >= %{gtk3_ver}
70058bc0 69Requires: libstdc++-devel >= 6:4.6
928477ea 70Requires: pangomm-devel >= %{pangomm_ver}
33bee831
AF
71
72%description devel
73Header files for gtkmm library.
74
75%description devel -l pl.UTF-8
76Pliki nagłówkowe biblioteki gtkmm.
77
78%package static
79Summary: gtkmm and gdkmm static libraries
80Summary(pl.UTF-8): Biblioteki statyczne gtkmm i gdkmm
81Group: X11/Development/Libraries
82Requires: %{name}-devel = %{version}-%{release}
83
84%description static
85gtkmm and gdkmm static libraries.
86
87%description static -l pl.UTF-8
88Biblioteki statyczne gtkmm i gdkmm.
89
90%package apidocs
91Summary: Reference documentation for gtkmm and gdkmm
92Summary(pl.UTF-8): Szczegółowa dokumentacja gtkmm i gdkmm
93Group: Documentation
94Requires: devhelp
c6e33ff3 95%{?noarchpackage}
33bee831
AF
96
97%description apidocs
98Reference documentation for gtkmm and gdkmm.
99
100%description apidocs -l pl.UTF-8
101Szczegółowa dokumentacja gtkmm i gdkmm.
102
103%prep
104%setup -q -n gtkmm-%{version}
105
c6e33ff3
JB
106# missing in release tarball, not needed for Linux
107mkdir win32_installer
108touch win32_installer/filelist.am \
109 win32_installer/gtkmm-installer.nsi.in
110
33bee831 111%build
c6e33ff3 112mm-common-prepare --copy --force
33bee831
AF
113%{__libtoolize}
114%{__aclocal} -I build
115%{__autoconf}
116%{__autoheader}
117%{__automake}
118%configure \
c6e33ff3 119 --enable-maintainer-mode \
ef8910d5 120 --disable-silent-rules \
33bee831
AF
121 %{?with_static_libs:--enable-static}
122
123%{__make}
124
125%install
126rm -rf $RPM_BUILD_ROOT
127
128%{__make} install \
129 DESTDIR=$RPM_BUILD_ROOT
130
131%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
132
133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%post -p /sbin/ldconfig
137%postun -p /sbin/ldconfig
138
139%files
140%defattr(644,root,root,755)
3f8d9ad2 141%doc AUTHORS ChangeLog NEWS README
33bee831
AF
142%attr(755,root,root) %{_libdir}/libgdkmm-3.0.so.*.*.*
143%attr(755,root,root) %ghost %{_libdir}/libgdkmm-3.0.so.1
144%attr(755,root,root) %{_libdir}/libgtkmm-3.0.so.*.*.*
145%attr(755,root,root) %ghost %{_libdir}/libgtkmm-3.0.so.1
146
147%files devel
148%defattr(644,root,root,755)
149%attr(755,root,root) %{_libdir}/libgdkmm-3.0.so
150%attr(755,root,root) %{_libdir}/libgtkmm-3.0.so
151%{_libdir}/gdkmm-3.0
152%{_libdir}/gtkmm-3.0
153%{_includedir}/gdkmm-3.0
154%{_includedir}/gtkmm-3.0
155%{_pkgconfigdir}/gdkmm-3.0.pc
156%{_pkgconfigdir}/gtkmm-3.0.pc
157
158%if %{with static_libs}
159%files static
160%defattr(644,root,root,755)
161%{_libdir}/libgdkmm-3.0.a
162%{_libdir}/libgtkmm-3.0.a
163%endif
164
165%files apidocs
166%defattr(644,root,root,755)
167%{_docdir}/gtkmm-3.0
168%{_datadir}/devhelp/books/gtkmm-3.0
This page took 0.090243 seconds and 4 git commands to generate.