]> git.pld-linux.org Git - packages/grub2.git/blame - grub2.spec
- rel 0.9
[packages/grub2.git] / grub2.spec
CommitLineData
f97cafb4 1# TODO
dc6928bc 2# - reap out which in probe scripts and drop R: which
f97cafb4 3# - subpackages? e.g. modules and utils
bcd6a47e 4# - check where is that locale path: /boot/grub/locale and fix it or change it
8fcee4aa
ER
5# - grubemu notes
6# --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7# - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8# - put grub-emu to subpackage if it is fixed
f97cafb4 9#
90feddde 10# Conditional build:
1536aaf2 11%bcond_with grubemu # build grub-emu debugging utility
b06c130d 12%bcond_without efiemu # build efiemu runtimes
1536aaf2
JK
13%bcond_without pc # do not build for PC BIOS platform
14%bcond_without efi # do not build for EFI platform
b06c130d
ER
15
16%if "%{cc_version}" < "3.4"
17# cc does not support:
18# cc1: sorry, unimplemented: code model `large' not supported yet
19%undefine with_efiemu
20%endif
21
feaacba3
JB
22%ifnarch %{ix86} %{x8664}
23%undefine with_pc
24%endif
25%ifnarch %{ix86} %{x8664} ia64
26%undefine with_efi
27%endif
28
2d8da575
AM
29%ifnarch %{x8664}
30# non-x86_64 arch doesn't support this
31%undefine with_efiemu
32%endif
33
1536aaf2 34# the 'most natural' platform should go last
feaacba3 35%ifarch %{ix86} %{x8664} ia64
1536aaf2 36%define platforms %{?with_efi:efi} %{?with_pc:pc}
feaacba3
JB
37%endif
38%ifarch ppc ppc64 sparc64
39%define platforms ieee1275
40%endif
41%ifarch mips
42%define platforms arc
43%endif
44%ifarch mipsel
45%define platforms loongson
46%endif
1536aaf2 47
afe8504a 48Summary: GRand Unified Bootloader
c8155f7f 49Summary(de.UTF-8): GRUB2 - ein Bootloader für x86 und ppc
f97cafb4 50Summary(hu.UTF-8): GRUB2 - rendszerbetöltő x86 és ppc gépekhez
c8155f7f
ER
51Summary(pl.UTF-8): GRUB2 - bootloader dla x86 i ppc
52Summary(pt_BR.UTF-8): Gerenciador de inicialização GRUB2
afe8504a 53Name: grub2
7615a862 54Version: 2.00
216f53b7 55Release: 0.9
2e4bec6f 56License: GPL v2
afe8504a 57Group: Base
f951fcbe 58Source0: http://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
7615a862 59# Source0-md5: a1043102fbc7bcedbf53e7ee3d17ab91
22909ca1
ER
60Source1: update-grub
61Source2: update-grub.8
b46589aa 62Source3: grub.sysconfig
e2964b87 63Source4: grub-custom.cfg
b46589aa 64Patch1: pld-sysconfdir.patch
872700b0 65Patch2: grub-garbage.patch
c9273ffc
JK
66Patch3: grub-lvmdevice.patch
67Patch4: pld-mkconfigdir.patch
68Patch5: grub-mkconfig-diagnostics.patch
69Patch6: ppc.patch
70Patch7: %{name}-awk.patch
71Patch8: posix.patch
72Patch9: %{name}-gets.patch
26996aed 73Patch10: %{name}-fonts_path.patch
55de8afc 74Patch11: %{name}-tftp_fix.patch
50fb4025
JR
75Patch12: add-vlan-tag-support.patch
76Patch13: just-say-linux.patch
77Patch14: add-GRUB-DISABLE-SUBMENU-option.patch
78Patch15: add-X-option-to-printf-functions.patch
79Patch16: dhcp-client-id-and-uuid-options-added.patch
80Patch17: fix-http-crash.patch
81Patch18: Issue-separate-DNS-queries-for-ipv4-and-ipv6.patch
82Patch19: search-for-specific-config-file-for-netboot.patch
b78e362f 83Patch20: ignore-kernel-symlinks.patch
806364c8 84Patch21: choose-preferred-initrd.patch
feaacba3 85URL: http://www.gnu.org/software/grub/
27550907
ER
86BuildRequires: autoconf >= 2.53
87BuildRequires: automake >= 1:1.11.1-1
8b781299 88BuildRequires: bison
06df59fd 89BuildRequires: device-mapper-devel
feaacba3 90BuildRequires: flex >= 2.5.35
26996aed 91BuildRequires: fonts-TTF-DejaVu
feaacba3 92BuildRequires: freetype-devel >= 2
12fd19f5 93BuildRequires: gawk
63e45785 94BuildRequires: gettext-devel
feaacba3 95BuildRequires: glibc-static
1349ebb8 96BuildRequires: help2man
42985b0d 97BuildRequires: libfuse-devel
afe8504a 98BuildRequires: libtool
feaacba3
JB
99BuildRequires: ncurses-devel
100BuildRequires: rpm >= 4.4.9-56
101BuildRequires: rpmbuild(macros) >= 1.213
102BuildRequires: sed >= 4.0
103BuildRequires: tar >= 1:1.22
81a7e0ba 104BuildRequires: texinfo
feaacba3
JB
105BuildRequires: xz
106BuildRequires: xz-devel
c668211a
ER
107%ifarch %{x8664}
108BuildRequires: /usr/lib/libc.so
8905dae4
ER
109%if "%{pld_release}" == "ac"
110BuildRequires: libgcc32
111%else
797addca 112BuildRequires: gcc-multilib
c668211a 113%endif
dee0d6f5 114%endif
feaacba3 115Requires: %{name}-platform = %{version}-%{release}
dc6928bc 116Requires: which
feaacba3
JB
117%ifarch %{ix86} %{x8664}
118Suggests: %{name}-platform-pc
119%endif
190cc685 120Suggests: cdrkit-mkisofs
97ee543c 121Suggests: os-prober
afe8504a 122Provides: bootloader
fc835b5e 123Conflicts: grub
feaacba3 124ExclusiveArch: %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
afe8504a
SP
125BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127%define _sbindir /sbin
4a00f3b7 128%define _bindir %{_sbindir}
1536aaf2 129%define _libdir /lib
e6fbd304 130%define _datadir %{_libdir}
26e757db 131%define _libexecdir %{_libdir}/grub
1536aaf2 132%define _grubdir /boot/grub
da9b7cf9 133%define _localedir /usr/share/locale
9d44d75e 134
0e2cbb94
JK
135# part of grub code is not relocable (these are not Linux libs)
136# stack protector also breaks non-Linux binaries
b78e362f 137%define filterout_c -fPIC
5967241e 138%undefine _ssp_cflags
0e2cbb94 139
afe8504a
SP
140%description
141GRUB is a GPLed bootloader intended to unify bootloading across x86
142operating systems. In addition to loading the Linux and *BSD kernels,
143it implements the Multiboot standard, which allows for flexible
144loading of multiple boot images (needed for modular kernels such as
145the GNU Hurd).
146
211df1ed
ER
147GRUB 2 is derived from PUPA which was a research project to
148investigate the next generation of GRUB. GRUB 2 has been rewritten
149from scratch to clean up everything for modularity and portability.
150
151GRUB 2 targets at the following goals:
152- Scripting support, such as conditionals, loops, variables and
153 functions.
154- Graphical interface.
155- Dynamic loading of modules in order to extend itself at the run time
156 rather than at the build time.
157- Portability for various architectures.
158- Internationalization. This includes support for non-ASCII character
159 code, message catalogs like gettext, fonts, graphics console, and so
160 on.
161- Real memory management, to make GNU GRUB more extensible.
162- Modular, hierarchical, object-oriented framework for file systems,
163 files, devices, drives, terminals, commands, partition tables and OS
164 loaders.
165- Cross-platform installation which allows for installing GRUB from a
166 different architecture.
167- Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
168- Fix design mistakes in GRUB Legacy, which could not be solved for
169 backward-compatibility, such as the way of numbering partitions.
170
6b0aefbf 171%description -l de.UTF-8
afe8504a
SP
172GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
173Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
6b0aefbf 174läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
afe8504a
SP
175
176GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
6b0aefbf
JR
177und wird unter der GPL vertrieben. Aufgrund seiner höheren
178Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
afe8504a
SP
179traditionellen Boot-Loader LILO.
180
f97cafb4
ZU
181%description -l hu.UTF-8
182GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
183betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
184teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
185GNU Hurd).
186
187GRUB2 céljai a következők:
188- szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
189 függvények.
190- grafikus felület
191- modulok dinamikus betöltése futási időben
192- hordozhatóság több architektúrára
193- többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
194 mint gettext, betűtípusok, grafikus konzolon, és így tovább
195- valós memória kezelés, amellyel még bővíthetőbbé tehetjük
196- moduláris, hierarchikus, objektum-orientált keretrendszer
197 fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
198 terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
199
6b0aefbf
JR
200%description -l es.UTF-8
201Éste es GRUB - Grand Unified Boot Loader - un administrador de
202inicialización capaz de entrar en la mayoría de los sistemas
afe8504a 203operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
6b0aefbf 204también en la mayoría de los sistemas operacionales comerciales para
afe8504a
SP
205PC.
206
207El administrador GRUB puede ser una buena alternativa a LILO, para
6b0aefbf
JR
208usuarios conmás experiencia y que deseen obtener más recursos de su
209cargador de inicialización (boot loader).
afe8504a 210
6b0aefbf 211%description -l pl.UTF-8
feaacba3 212GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
6b0aefbf 213procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
feaacba3 214Linuksa i *BSD: posiada również implementację standardu Multiboot,
6b0aefbf
JR
215który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
216(czego wymagają modułowe jądra, takie jak GNU Hurd).
afe8504a 217
6b0aefbf
JR
218%description -l pt_BR.UTF-8
219Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
afe8504a
SP
220capaz de entrar na maioria dos sistemas operacionais livres - Linux,
221FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
222operacionais comerciais para PC.
223
6b0aefbf
JR
224O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
225avançados e que querem mais recursos de seu boot loader.
afe8504a 226
565fe2e3
ER
227%package -n bash-completion-%{name}
228Summary: bash-completion for GRUB
feaacba3 229Summary(pl.UTF-8): Bashowe uzupełnianie nazw dla GRUB-a
565fe2e3
ER
230Group: Applications/Shells
231Requires: bash-completion
232
233%description -n bash-completion-%{name}
234This package provides bash-completion for GRUB.
235
236%description -n bash-completion-%{name} -l pl.UTF-8
feaacba3 237Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
565fe2e3 238
6d8475a4 239%package platform-pc
62081337 240Summary: PC BIOS platform support for GRUB
feaacba3 241Summary(pl.UTF-8): Obsługa platformy PC BIOS dla GRUB-a
62081337 242Group: Base
6d8475a4 243Provides: %{name}-platform = %{version}-%{release}
1536aaf2 244
6d8475a4 245%description platform-pc
62081337 246PC BIOS platform support for GRUB.
1536aaf2 247
feaacba3
JB
248%description platform-pc -l pl.UTF-8
249Obsługa platformy PC BIOS dla GRUB-a.
250
6d8475a4 251%package platform-efi
1536aaf2 252Summary: (U)EFI platform support for GRUB
feaacba3 253Summary(pl.UTF-8): Obsługa platformy (U)EFI dla GRUB-a
1536aaf2 254Group: Base
6e81e1fe 255Suggests: efibootmgr
6d8475a4 256Provides: %{name}-platform = %{version}-%{release}
1536aaf2 257
6d8475a4 258%description platform-efi
1536aaf2
JK
259(U)EFI platform support for GRUB.
260
feaacba3
JB
261%description platform-efi -l pl.UTF-8
262Obsługa platformy (U)EFI dla GRUB-a.
263
7615a862
JK
264%package mkfont
265Summary: GRUB font files converter
feaacba3 266Summary(pl.UTF-8): Konwerter plików fontów GRUB-a
7615a862
JK
267Group: Base
268
269%description mkfont
270Converts common font file formats into PF2.
271
feaacba3
JB
272%description mkfont -l pl.UTF-8
273Program do konwersji popularnych formatów plików fontów do PF2.
274
8ac8605d
JK
275%package theme-starfield
276Summary: starfield theme for GRUB
feaacba3 277Summary(pl.UTF-8): Motyw starfield dla GRUB-a
8ac8605d
JK
278Group: Base
279
280%description theme-starfield
281starfield theme for GRUB.
282
feaacba3
JB
283%description theme-starfield -l pl.UTF-8
284Motyw starfield dla GRUB-a.
285
afe8504a 286%prep
f951fcbe 287%setup -q -n grub-%{version}
b46589aa 288%patch1 -p1
872700b0 289%patch2 -p1
f951fcbe 290%patch3 -p1
aec70abd 291%patch4 -p1
f7ae30d0 292%patch5 -p1
e2964b87 293%patch6 -p1
449dde54 294%patch7 -p1
61d105fa 295%patch8 -p1
4c7bb96e 296%patch9 -p1
26996aed 297%patch10 -p1
55de8afc 298%patch11 -p1
50fb4025
JR
299%patch12 -p1
300%patch13 -p1
301%patch14 -p1
302%patch15 -p1
303%patch16 -p1
304%patch17 -p1
305%patch18 -p1
306%patch19 -p1
b78e362f 307%patch20 -p1
806364c8 308%patch21 -p1
afe8504a 309
71c933c0 310%if "%{cc_version}" < "3.4"
dea0c850
ER
311grep -rl -- -Wno-missing-field-initializers . | xargs %{__sed} -i -e 's,-Wno-missing-field-initializers,,'
312%{__sed} -i -e '/video_mod_CFLAGS/s/$/ -Wno-error/' conf/common.rmk
71c933c0
ER
313%endif
314
afe8504a 315%build
928eb9c1
AM
316# if gold is used then grub doesn't even boot
317install -d our-ld
318ln -s /usr/bin/ld.bfd our-ld/ld
319export PATH=$(pwd)/our-ld:$PATH
320
3ff87e8a 321cp -f /usr/share/automake/config.sub .
afe8504a 322%{__libtoolize}
e9d73181 323%{__aclocal} -I m4
afe8504a 324%{__autoheader}
b1a4846d 325echo timestamp > stamp-h.in
afe8504a 326%{__autoconf}
80936b4a 327%{__automake}
53c50f89 328export CFLAGS="%{rpmcflags} -Os %{?debug:-g}"
12fd19f5 329
1536aaf2 330for platform in %{platforms} ; do
fc490c3e
JK
331 install -d build-${platform}
332 cd build-${platform}
0e2cbb94
JK
333
334 if [ "$platform" != "efi" ] ; then
feaacba3 335 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
0e2cbb94
JK
336 else
337 platform_opts=""
338 fi
339
1536aaf2
JK
340 ln -s ../configure .
341 # mawk stalls at ./genmoddep.awk, so force gawk
342 AWK=gawk \
343 %configure \
344 --with-platform=${platform} \
345 --disable-werror \
346 %if %{with grubemu}
347 --enable-grub-emu-usb \
348 --enable-grub-emu-sdl \
349 --enable-grub-emu-pci \
350 %endif
0e2cbb94 351 $platform_opts \
1536aaf2
JK
352 TARGET_LDFLAGS=-static
353
354 %{__make}
355 cd ..
356done
0fb8b1a5 357
afe8504a
SP
358%install
359rm -rf $RPM_BUILD_ROOT
afe8504a 360
1536aaf2 361for platform in %{platforms} ; do
fc490c3e 362 cd build-${platform}
1536aaf2
JK
363 %{__make} install \
364 pkgdatadir=%{_libexecdir} \
365 pkglibdir=%{_libexecdir} \
366 DESTDIR=$RPM_BUILD_ROOT
367 cd ..
368done
afe8504a 369
7615a862
JK
370# not in Th (?)
371%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
372%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
373
f951fcbe
AM
374%find_lang grub
375
bcd6a47e
ER
376# this must be after 'make install'
377install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
378
1536aaf2
JK
379install -d $RPM_BUILD_ROOT%{_grubdir}
380cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
381
7b6caae9 382# grub.d/41_custom
1536aaf2 383cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
7b6caae9
ER
384%{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
385
22909ca1 386install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
7b6caae9
ER
387cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
388
389install -d $RPM_BUILD_ROOT/etc/sysconfig
390cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
391
392# rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
47069130 393rm -f $RPM_BUILD_ROOT%{_infodir}/dir
e2964b87 394
feaacba3
JB
395# platform specific, unnecessarily always installed
396%ifnarch %{ix86} %{x8664}
397%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
398%endif
399%ifnarch sparc64
400%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
401%endif
402
cbd79801 403# core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
1536aaf2
JK
404touch $RPM_BUILD_ROOT%{_grubdir}/core.img
405touch $RPM_BUILD_ROOT%{_grubdir}/device.map
cbd79801 406
8b5c394b
ER
407# needs to be exactly 1KiB
408# but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
1536aaf2 409dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
8b5c394b 410
afe8504a
SP
411%clean
412rm -rf $RPM_BUILD_ROOT
413
5028d8c9 414%post -p %{_sbindir}/postshell
fc58858a 415-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 416
5028d8c9 417%postun -p %{_sbindir}/postshell
fc58858a 418-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 419
287a39cc 420%triggerpostun -- %{name} < 2.00-0.1
a7bef3b9 421# Note this trigger on version upgrade
287a39cc
JK
422# needed only for upgrade from old grub2 packages
423# which contained modules in /boot/grub
92904505
ER
424# don't do anything on --downgrade
425if [ $1 -le 1 ]; then
426 exit 0
427fi
428echo "Grub was upgraded, trying to setup it to boot sector"
429/sbin/grub-install '(hd0)' || :
430
7b6caae9
ER
431%triggerpostun -- %{name} < 1.99-7.3
432# migrate /etc/grub.d/custom.cfg.rpmsave -> /boot/grub/custom.cfg
433if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
1536aaf2
JK
434 cp -f %{_grubdir}/custom.cfg{,.rpmnew}
435 mv -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
7b6caae9
ER
436fi
437
f951fcbe 438%files -f grub.lang
afe8504a 439%defattr(644,root,root,755)
2e4bec6f 440%doc AUTHORS ChangeLog NEWS README THANKS TODO
aec70abd 441%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
71c933c0 442%attr(755,root,root) %{_sbindir}/grub-editenv
3ea0c40e 443%attr(755,root,root) %{_sbindir}/grub-fstest
e9d73181 444%attr(755,root,root) %{_sbindir}/grub-kbdcomp
fc835b5e 445%attr(755,root,root) %{_sbindir}/grub-install
e9d73181 446%attr(755,root,root) %{_sbindir}/grub-menulst2cfg
fc835b5e 447%attr(755,root,root) %{_sbindir}/grub-mkconfig
e9d73181
AM
448%attr(755,root,root) %{_sbindir}/grub-mklayout
449%attr(755,root,root) %{_sbindir}/grub-mknetdir
71c933c0
ER
450%attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
451%attr(755,root,root) %{_sbindir}/grub-mkrelpath
452%attr(755,root,root) %{_sbindir}/grub-mkrescue
7615a862
JK
453%attr(755,root,root) %{_sbindir}/grub-mkstandalone
454%attr(755,root,root) %{_sbindir}/grub-mount
455%attr(755,root,root) %{_sbindir}/grub-ofpathname
71c933c0
ER
456%attr(755,root,root) %{_sbindir}/grub-reboot
457%attr(755,root,root) %{_sbindir}/grub-script-check
458%attr(755,root,root) %{_sbindir}/grub-set-default
22909ca1 459%attr(755,root,root) %{_sbindir}/update-grub
76be4c4a 460%ifarch %{ix86} %{x8664}
feaacba3
JB
461%attr(755,root,root) %{_sbindir}/grub-bios-setup
462%{_mandir}/man8/grub-bios-setup.8*
463%endif
464%ifarch %{ix86} %{x8664}
76be4c4a 465%attr(755,root,root) %{_sbindir}/grub-mkimage
fc835b5e 466%{_mandir}/man1/grub-mkimage.1*
76be4c4a
AM
467%else
468%attr(755,root,root) %{_sbindir}/grub-probe
76be4c4a 469%{_mandir}/man8/grub-probe.8*
76be4c4a 470%endif
feaacba3
JB
471%ifarch sparc64
472%attr(755,root,root) %{_sbindir}/grub-sparc64-setup
473%{_mandir}/man8/grub-sparc64-setup.8*
474%endif
71c933c0 475%{_mandir}/man1/grub-editenv.1*
3ea0c40e 476%{_mandir}/man1/grub-fstest.1*
7615a862 477%{_mandir}/man1/grub-kbdcomp.1*
e9d73181 478%{_mandir}/man1/grub-menulst2cfg.1*
e9d73181 479%{_mandir}/man1/grub-mklayout.1*
71c933c0 480%{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
03b9d04b 481%{_mandir}/man1/grub-mkrelpath.1*
71c933c0 482%{_mandir}/man1/grub-mkrescue.1*
7615a862
JK
483%{_mandir}/man1/grub-mkstandalone.1*
484%{_mandir}/man1/grub-mount.1*
71c933c0
ER
485%{_mandir}/man1/grub-script-check.1*
486%{_mandir}/man8/grub-install.8*
fc835b5e 487%{_mandir}/man8/grub-mkconfig.8*
e9d73181 488%{_mandir}/man8/grub-mknetdir.8*
7615a862 489%{_mandir}/man8/grub-ofpathname.8*
71c933c0
ER
490%{_mandir}/man8/grub-reboot.8*
491%{_mandir}/man8/grub-set-default.8*
22909ca1 492%{_mandir}/man8/update-grub.8*
797addca 493%if %{with grubemu}
8fcee4aa
ER
494%attr(755,root,root) %{_sbindir}/grub-emu
495%{_mandir}/man8/grub-emu.8*
797addca 496%endif
e6fbd304 497%{_libexecdir}/grub-mkconfig_lib
aec70abd 498
1536aaf2 499%dir %{_grubdir}
26e757db 500%dir %{_libexecdir}
bcd6a47e 501# XXX: check this locale dir location and if it is neccesaary to exist on /boot
565fe2e3 502
bcd6a47e 503%dir %{_libexecdir}/locale
1536aaf2
JK
504%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
505%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
aec70abd 506
cbd79801 507# generated by grub at runtime
1536aaf2
JK
508%ghost %{_grubdir}/device.map
509%ghost %{_grubdir}/core.img
510%ghost %{_grubdir}/grubenv
cbd79801 511
e2964b87
ER
512%dir /lib/grub.d
513%doc /lib/grub.d/README
514%attr(755,root,root) /lib/grub.d/00_header
515%attr(755,root,root) /lib/grub.d/10_linux
e9d73181 516%attr(755,root,root) /lib/grub.d/20_linux_xen
e2964b87 517%attr(755,root,root) /lib/grub.d/30_os-prober
e9d73181 518%attr(755,root,root) /lib/grub.d/41_custom
e2964b87 519
1e58ef6c 520%ifarch %{ix86} %{x8664}
1ffaf1f6 521%attr(755,root,root) %{_sbindir}/grub-probe
fc835b5e 522%{_mandir}/man8/grub-probe.8*
4a00f3b7 523%endif
aec70abd 524
f4604ef8 525%{_infodir}/grub*.info*
565fe2e3 526
8ac8605d
JK
527%dir %{_datadir}/grub/themes
528
1536aaf2 529%if %{with pc}
6d8475a4 530%files platform-pc
1536aaf2
JK
531%defattr(644,root,root,755)
532%dir %{_libexecdir}/*-pc
533%{_libexecdir}/*-pc/modinfo.sh
534%{_libexecdir}/*-pc/*.exec
535%{_libexecdir}/*-pc/*.image
536%{_libexecdir}/*-pc/*.lst
537%{_libexecdir}/*-pc/*.mod
538%{_libexecdir}/*-pc/*.module
539%{_libexecdir}/*-pc/lzma_decompress.img
540%{_libexecdir}/*-pc/config.h
541%{_libexecdir}/*-pc/gdb_grub
542%{_libexecdir}/*-pc/gmodule.pl
543%if %{with efiemu}
1536aaf2
JK
544%{_libexecdir}/*-pc/efiemu*.o
545%endif
1536aaf2
JK
546%{_libexecdir}/*-pc/kernel.img
547%ifarch %{ix86} %{x8664} sparc sparc64
548%{_libexecdir}/*-pc/boot.img
549%{_libexecdir}/*-pc/cdboot.img
550%{_libexecdir}/*-pc/diskboot.img
551%{_libexecdir}/*-pc/lnxboot.img
552%{_libexecdir}/*-pc/pxeboot.img
553%endif
554%endif
555
556%if %{with efi}
6d8475a4 557%files platform-efi
1536aaf2
JK
558%defattr(644,root,root,755)
559%dir %{_libexecdir}/*-efi
560%{_libexecdir}/*-efi/modinfo.sh
561%{_libexecdir}/*-efi/*.exec
562%{_libexecdir}/*-efi/*.lst
563%{_libexecdir}/*-efi/*.mod
564%{_libexecdir}/*-efi/*.module
565%{_libexecdir}/*-efi/config.h
566%{_libexecdir}/*-efi/gdb_grub
567%{_libexecdir}/*-efi/gmodule.pl
1536aaf2
JK
568%{_libexecdir}/*-efi/kernel.img
569%endif
570
7615a862
JK
571%files mkfont
572%defattr(644,root,root,755)
7615a862 573%attr(755,root,root) %{_sbindir}/grub-mkfont
feaacba3 574%{_mandir}/man1/grub-mkfont.1*
7615a862 575
8ac8605d
JK
576%files theme-starfield
577%defattr(644,root,root,755)
578%{_datadir}/grub/themes/starfield
579
565fe2e3
ER
580%files -n bash-completion-%{name}
581%defattr(644,root,root,755)
582/etc/bash_completion.d/grub
This page took 0.145679 seconds and 4 git commands to generate.