]> git.pld-linux.org Git - packages/grub2.git/blame - grub2.spec
Upgrade trigger is needed only for old grub2
[packages/grub2.git] / grub2.spec
CommitLineData
f97cafb4 1# TODO
dc6928bc 2# - reap out which in probe scripts and drop R: which
f97cafb4 3# - subpackages? e.g. modules and utils
bcd6a47e 4# - check where is that locale path: /boot/grub/locale and fix it or change it
8fcee4aa
ER
5# - grubemu notes
6# --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7# - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8# - put grub-emu to subpackage if it is fixed
659f8cfc 9# - warning: Installed (but unpackaged) file(s) found:
1536aaf2
JK
10# /sbin/grub-sparc64-setup
11# /usr/share/man/man8/grub-sparc64-setup.8.gz
12
659f8cfc
ER
13# /boot/grub/config.h
14# /etc/bash_completion.d/grub
7615a862
JK
15# /sbin/grub-sparc64-setup
16# /boot/grub/gdb_grub
17# /boot/grub/gmodule.pl
18# /sbin/grub-sparc64-setup
f97cafb4 19#
90feddde 20# Conditional build:
1536aaf2 21%bcond_with grubemu # build grub-emu debugging utility
b06c130d 22%bcond_without efiemu # build efiemu runtimes
1536aaf2
JK
23%bcond_without pc # do not build for PC BIOS platform
24%bcond_without efi # do not build for EFI platform
b06c130d
ER
25
26%if "%{cc_version}" < "3.4"
27# cc does not support:
28# cc1: sorry, unimplemented: code model `large' not supported yet
29%undefine with_efiemu
30%endif
31
2d8da575
AM
32%ifnarch %{x8664}
33# non-x86_64 arch doesn't support this
34%undefine with_efiemu
35%endif
36
1536aaf2
JK
37# the 'most natural' platform should go last
38%define platforms %{?with_efi:efi} %{?with_pc:pc}
39
afe8504a 40Summary: GRand Unified Bootloader
c8155f7f 41Summary(de.UTF-8): GRUB2 - ein Bootloader für x86 und ppc
f97cafb4 42Summary(hu.UTF-8): GRUB2 - rendszerbetöltő x86 és ppc gépekhez
c8155f7f
ER
43Summary(pl.UTF-8): GRUB2 - bootloader dla x86 i ppc
44Summary(pt_BR.UTF-8): Gerenciador de inicialização GRUB2
afe8504a 45Name: grub2
7615a862 46Version: 2.00
e2506058 47Release: 0.3
2e4bec6f 48License: GPL v2
afe8504a 49Group: Base
f951fcbe 50Source0: http://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
7615a862 51# Source0-md5: a1043102fbc7bcedbf53e7ee3d17ab91
22909ca1
ER
52Source1: update-grub
53Source2: update-grub.8
b46589aa 54Source3: grub.sysconfig
e2964b87 55Source4: grub-custom.cfg
695ab3a5 56URL: http://www.gnu.org/software/grub/
5028d8c9 57Patch0: pld-initrd.patch
b46589aa 58Patch1: pld-sysconfdir.patch
872700b0 59Patch2: grub-garbage.patch
c9273ffc
JK
60Patch3: grub-lvmdevice.patch
61Patch4: pld-mkconfigdir.patch
62Patch5: grub-mkconfig-diagnostics.patch
63Patch6: ppc.patch
64Patch7: %{name}-awk.patch
65Patch8: posix.patch
66Patch9: %{name}-gets.patch
26996aed 67Patch10: %{name}-fonts_path.patch
55de8afc 68Patch11: %{name}-tftp_fix.patch
27550907
ER
69BuildRequires: autoconf >= 2.53
70BuildRequires: automake >= 1:1.11.1-1
8b781299 71BuildRequires: bison
06df59fd 72BuildRequires: device-mapper-devel
26996aed 73BuildRequires: fonts-TTF-DejaVu
013b927c 74BuildRequires: freetype-devel
12fd19f5 75BuildRequires: gawk
63e45785 76BuildRequires: gettext-devel
1349ebb8 77BuildRequires: help2man
42985b0d 78BuildRequires: libfuse-devel
afe8504a 79BuildRequires: libtool
81a7e0ba 80BuildRequires: texinfo
c668211a
ER
81%ifarch %{x8664}
82BuildRequires: /usr/lib/libc.so
8905dae4
ER
83%if "%{pld_release}" == "ac"
84BuildRequires: libgcc32
85%else
797addca 86BuildRequires: gcc-multilib
c668211a 87%endif
dee0d6f5 88%endif
6b675158 89BuildRequires: glibc-static
565fe2e3 90BuildRequires: ncurses-devel
8905dae4 91BuildRequires: rpm >= 4.4.9-56
403e7b01 92BuildRequires: rpmbuild(macros) >= 1.213
565fe2e3 93BuildRequires: sed >= 4.0
dc6928bc 94Requires: which
190cc685 95Suggests: cdrkit-mkisofs
97ee543c 96Suggests: os-prober
afe8504a 97Provides: bootloader
fc835b5e 98Conflicts: grub
6d8475a4 99Requires: %{name}-platform = %{version}-%{release}
616e4468 100Suggests: %{name}-platform-pc
58a823d7 101ExclusiveArch: %{ix86} %{x8664} ppc sparc64
afe8504a
SP
102BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104%define _sbindir /sbin
4a00f3b7 105%define _bindir %{_sbindir}
1536aaf2 106%define _libdir /lib
e6fbd304 107%define _datadir %{_libdir}
26e757db 108%define _libexecdir %{_libdir}/grub
1536aaf2 109%define _grubdir /boot/grub
da9b7cf9 110%define _localedir /usr/share/locale
9d44d75e 111
0e2cbb94
JK
112# part of grub code is not relocable (these are not Linux libs)
113# stack protector also breaks non-Linux binaries
5967241e
PS
114%define filterout_c -fPIC
115%undefine _ssp_cflags
0e2cbb94 116
afe8504a
SP
117%description
118GRUB is a GPLed bootloader intended to unify bootloading across x86
119operating systems. In addition to loading the Linux and *BSD kernels,
120it implements the Multiboot standard, which allows for flexible
121loading of multiple boot images (needed for modular kernels such as
122the GNU Hurd).
123
211df1ed
ER
124GRUB 2 is derived from PUPA which was a research project to
125investigate the next generation of GRUB. GRUB 2 has been rewritten
126from scratch to clean up everything for modularity and portability.
127
128GRUB 2 targets at the following goals:
129- Scripting support, such as conditionals, loops, variables and
130 functions.
131- Graphical interface.
132- Dynamic loading of modules in order to extend itself at the run time
133 rather than at the build time.
134- Portability for various architectures.
135- Internationalization. This includes support for non-ASCII character
136 code, message catalogs like gettext, fonts, graphics console, and so
137 on.
138- Real memory management, to make GNU GRUB more extensible.
139- Modular, hierarchical, object-oriented framework for file systems,
140 files, devices, drives, terminals, commands, partition tables and OS
141 loaders.
142- Cross-platform installation which allows for installing GRUB from a
143 different architecture.
144- Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
145- Fix design mistakes in GRUB Legacy, which could not be solved for
146 backward-compatibility, such as the way of numbering partitions.
147
6b0aefbf 148%description -l de.UTF-8
afe8504a
SP
149GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
150Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
6b0aefbf 151läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
afe8504a
SP
152
153GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
6b0aefbf
JR
154und wird unter der GPL vertrieben. Aufgrund seiner höheren
155Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
afe8504a
SP
156traditionellen Boot-Loader LILO.
157
f97cafb4
ZU
158%description -l hu.UTF-8
159GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
160betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
161teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
162GNU Hurd).
163
164GRUB2 céljai a következők:
165- szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
166 függvények.
167- grafikus felület
168- modulok dinamikus betöltése futási időben
169- hordozhatóság több architektúrára
170- többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
171 mint gettext, betűtípusok, grafikus konzolon, és így tovább
172- valós memória kezelés, amellyel még bővíthetőbbé tehetjük
173- moduláris, hierarchikus, objektum-orientált keretrendszer
174 fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
175 terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
176
6b0aefbf
JR
177%description -l es.UTF-8
178Éste es GRUB - Grand Unified Boot Loader - un administrador de
179inicialización capaz de entrar en la mayoría de los sistemas
afe8504a 180operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
6b0aefbf 181también en la mayoría de los sistemas operacionales comerciales para
afe8504a
SP
182PC.
183
184El administrador GRUB puede ser una buena alternativa a LILO, para
6b0aefbf
JR
185usuarios conmás experiencia y que deseen obtener más recursos de su
186cargador de inicialización (boot loader).
afe8504a 187
6b0aefbf
JR
188%description -l pl.UTF-8
189GRUB jest bootloaderem na licencji GNU, mającym na celu unifikację
190procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
191Linuksa i *BSD: posiada również implementacje standardu Multiboot,
192który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
193(czego wymagają modułowe jądra, takie jak GNU Hurd).
afe8504a 194
6b0aefbf
JR
195%description -l pt_BR.UTF-8
196Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
afe8504a
SP
197capaz de entrar na maioria dos sistemas operacionais livres - Linux,
198FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
199operacionais comerciais para PC.
200
6b0aefbf
JR
201O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
202avançados e que querem mais recursos de seu boot loader.
afe8504a 203
565fe2e3
ER
204%package -n bash-completion-%{name}
205Summary: bash-completion for GRUB
206Summary(pl.UTF-8): bashowe uzupełnianie nazw dla GRUB
207Group: Applications/Shells
208Requires: bash-completion
209
210%description -n bash-completion-%{name}
211This package provides bash-completion for GRUB.
212
213%description -n bash-completion-%{name} -l pl.UTF-8
214Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB.
215
6d8475a4 216%package platform-pc
62081337
ER
217Summary: PC BIOS platform support for GRUB
218Group: Base
6d8475a4 219Provides: %{name}-platform = %{version}-%{release}
1536aaf2 220
6d8475a4 221%description platform-pc
62081337 222PC BIOS platform support for GRUB.
1536aaf2 223
6d8475a4 224%package platform-efi
1536aaf2
JK
225Summary: (U)EFI platform support for GRUB
226Group: Base
6d8475a4 227Provides: %{name}-platform = %{version}-%{release}
1536aaf2 228
6d8475a4 229%description platform-efi
1536aaf2
JK
230(U)EFI platform support for GRUB.
231
7615a862
JK
232%package mkfont
233Summary: GRUB font files converter
234Group: Base
235
236%description mkfont
237Converts common font file formats into PF2.
238
8ac8605d
JK
239%package theme-starfield
240Summary: starfield theme for GRUB
241Group: Base
242
243%description theme-starfield
244starfield theme for GRUB.
245
afe8504a 246%prep
f951fcbe 247%setup -q -n grub-%{version}
5028d8c9 248%patch0 -p1
b46589aa 249%patch1 -p1
872700b0 250%patch2 -p1
f951fcbe 251%patch3 -p1
aec70abd 252%patch4 -p1
f7ae30d0 253%patch5 -p1
e2964b87 254%patch6 -p1
449dde54 255%patch7 -p1
61d105fa 256%patch8 -p1
4c7bb96e 257%patch9 -p1
26996aed 258%patch10 -p1
55de8afc 259%patch11 -p1
afe8504a 260
71c933c0 261%if "%{cc_version}" < "3.4"
dea0c850
ER
262grep -rl -- -Wno-missing-field-initializers . | xargs %{__sed} -i -e 's,-Wno-missing-field-initializers,,'
263%{__sed} -i -e '/video_mod_CFLAGS/s/$/ -Wno-error/' conf/common.rmk
71c933c0
ER
264%endif
265
afe8504a 266%build
928eb9c1
AM
267# if gold is used then grub doesn't even boot
268install -d our-ld
269ln -s /usr/bin/ld.bfd our-ld/ld
270export PATH=$(pwd)/our-ld:$PATH
271
3ff87e8a 272cp -f /usr/share/automake/config.sub .
afe8504a 273%{__libtoolize}
e9d73181 274%{__aclocal} -I m4
afe8504a 275%{__autoheader}
b1a4846d 276echo timestamp > stamp-h.in
afe8504a 277%{__autoconf}
53c50f89 278export CFLAGS="%{rpmcflags} -Os %{?debug:-g}"
12fd19f5 279
1536aaf2 280for platform in %{platforms} ; do
fc490c3e
JK
281 install -d build-${platform}
282 cd build-${platform}
0e2cbb94
JK
283
284 if [ "$platform" != "efi" ] ; then
285 platform_opts="--%{!?with_efiemu:dis}%{?with_efiemu:en}able-efiemu"
286 else
287 platform_opts=""
288 fi
289
1536aaf2
JK
290 ln -s ../configure .
291 # mawk stalls at ./genmoddep.awk, so force gawk
292 AWK=gawk \
293 %configure \
294 --with-platform=${platform} \
295 --disable-werror \
296 %if %{with grubemu}
297 --enable-grub-emu-usb \
298 --enable-grub-emu-sdl \
299 --enable-grub-emu-pci \
300 %endif
0e2cbb94 301 $platform_opts \
1536aaf2
JK
302 TARGET_LDFLAGS=-static
303
304 %{__make}
305 cd ..
306done
0fb8b1a5 307
afe8504a
SP
308%install
309rm -rf $RPM_BUILD_ROOT
afe8504a 310
1536aaf2 311for platform in %{platforms} ; do
fc490c3e 312 cd build-${platform}
1536aaf2
JK
313 %{__make} install \
314 pkgdatadir=%{_libexecdir} \
315 pkglibdir=%{_libexecdir} \
316 DESTDIR=$RPM_BUILD_ROOT
317 cd ..
318done
afe8504a 319
7615a862
JK
320# not in Th (?)
321%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
322%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
323
f951fcbe
AM
324%find_lang grub
325
bcd6a47e
ER
326# this must be after 'make install'
327install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
328
1536aaf2
JK
329install -d $RPM_BUILD_ROOT%{_grubdir}
330cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
331
7b6caae9 332# grub.d/41_custom
1536aaf2 333cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
7b6caae9
ER
334%{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
335
22909ca1 336install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
7b6caae9
ER
337cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
338
339install -d $RPM_BUILD_ROOT/etc/sysconfig
340cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
341
342# rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
47069130 343rm -f $RPM_BUILD_ROOT%{_infodir}/dir
e2964b87 344
cbd79801 345# core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
1536aaf2
JK
346touch $RPM_BUILD_ROOT%{_grubdir}/core.img
347touch $RPM_BUILD_ROOT%{_grubdir}/device.map
cbd79801 348
8b5c394b
ER
349# needs to be exactly 1KiB
350# but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
1536aaf2 351dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
8b5c394b 352
afe8504a
SP
353%clean
354rm -rf $RPM_BUILD_ROOT
355
5028d8c9 356%post -p %{_sbindir}/postshell
fc58858a 357-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 358
5028d8c9 359%postun -p %{_sbindir}/postshell
fc58858a 360-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 361
287a39cc 362%triggerpostun -- %{name} < 2.00-0.1
a7bef3b9 363# Note this trigger on version upgrade
287a39cc
JK
364# needed only for upgrade from old grub2 packages
365# which contained modules in /boot/grub
92904505
ER
366# don't do anything on --downgrade
367if [ $1 -le 1 ]; then
368 exit 0
369fi
370echo "Grub was upgraded, trying to setup it to boot sector"
371/sbin/grub-install '(hd0)' || :
372
7b6caae9
ER
373%triggerpostun -- %{name} < 1.99-7.3
374# migrate /etc/grub.d/custom.cfg.rpmsave -> /boot/grub/custom.cfg
375if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
1536aaf2
JK
376 cp -f %{_grubdir}/custom.cfg{,.rpmnew}
377 mv -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
7b6caae9
ER
378fi
379
f951fcbe 380%files -f grub.lang
afe8504a 381%defattr(644,root,root,755)
2e4bec6f 382%doc AUTHORS ChangeLog NEWS README THANKS TODO
aec70abd 383%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
7615a862 384%attr(755,root,root) %{_sbindir}/grub-bios-setup
71c933c0 385%attr(755,root,root) %{_sbindir}/grub-editenv
3ea0c40e 386%attr(755,root,root) %{_sbindir}/grub-fstest
e9d73181 387%attr(755,root,root) %{_sbindir}/grub-kbdcomp
fc835b5e 388%attr(755,root,root) %{_sbindir}/grub-install
e9d73181 389%attr(755,root,root) %{_sbindir}/grub-menulst2cfg
fc835b5e 390%attr(755,root,root) %{_sbindir}/grub-mkconfig
e9d73181
AM
391%attr(755,root,root) %{_sbindir}/grub-mklayout
392%attr(755,root,root) %{_sbindir}/grub-mknetdir
71c933c0
ER
393%attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
394%attr(755,root,root) %{_sbindir}/grub-mkrelpath
395%attr(755,root,root) %{_sbindir}/grub-mkrescue
7615a862
JK
396%attr(755,root,root) %{_sbindir}/grub-mkstandalone
397%attr(755,root,root) %{_sbindir}/grub-mount
398%attr(755,root,root) %{_sbindir}/grub-ofpathname
71c933c0
ER
399%attr(755,root,root) %{_sbindir}/grub-reboot
400%attr(755,root,root) %{_sbindir}/grub-script-check
401%attr(755,root,root) %{_sbindir}/grub-set-default
22909ca1 402%attr(755,root,root) %{_sbindir}/update-grub
76be4c4a
AM
403%ifarch %{ix86} %{x8664}
404%attr(755,root,root) %{_sbindir}/grub-mkimage
fc835b5e 405%{_mandir}/man1/grub-mkimage.1*
76be4c4a
AM
406%else
407%attr(755,root,root) %{_sbindir}/grub-probe
76be4c4a 408%{_mandir}/man8/grub-probe.8*
76be4c4a 409%endif
71c933c0 410%{_mandir}/man1/grub-editenv.1*
3ea0c40e 411%{_mandir}/man1/grub-fstest.1*
7615a862 412%{_mandir}/man1/grub-kbdcomp.1*
e9d73181 413%{_mandir}/man1/grub-menulst2cfg.1*
e9d73181 414%{_mandir}/man1/grub-mklayout.1*
71c933c0 415%{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
03b9d04b 416%{_mandir}/man1/grub-mkrelpath.1*
71c933c0 417%{_mandir}/man1/grub-mkrescue.1*
7615a862
JK
418%{_mandir}/man1/grub-mkstandalone.1*
419%{_mandir}/man1/grub-mount.1*
71c933c0 420%{_mandir}/man1/grub-script-check.1*
7615a862 421%{_mandir}/man8/grub-bios-setup.8*
71c933c0 422%{_mandir}/man8/grub-install.8*
fc835b5e 423%{_mandir}/man8/grub-mkconfig.8*
e9d73181 424%{_mandir}/man8/grub-mknetdir.8*
7615a862 425%{_mandir}/man8/grub-ofpathname.8*
71c933c0
ER
426%{_mandir}/man8/grub-reboot.8*
427%{_mandir}/man8/grub-set-default.8*
22909ca1 428%{_mandir}/man8/update-grub.8*
797addca 429%if %{with grubemu}
8fcee4aa
ER
430%attr(755,root,root) %{_sbindir}/grub-emu
431%{_mandir}/man8/grub-emu.8*
797addca 432%endif
e6fbd304 433%{_libexecdir}/grub-mkconfig_lib
aec70abd 434
1536aaf2 435%dir %{_grubdir}
26e757db 436%dir %{_libexecdir}
bcd6a47e 437# XXX: check this locale dir location and if it is neccesaary to exist on /boot
565fe2e3 438
bcd6a47e 439%dir %{_libexecdir}/locale
1536aaf2
JK
440%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
441%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
aec70abd 442
cbd79801 443# generated by grub at runtime
1536aaf2
JK
444%ghost %{_grubdir}/device.map
445%ghost %{_grubdir}/core.img
446%ghost %{_grubdir}/grubenv
cbd79801 447
e2964b87
ER
448%dir /lib/grub.d
449%doc /lib/grub.d/README
450%attr(755,root,root) /lib/grub.d/00_header
451%attr(755,root,root) /lib/grub.d/10_linux
e9d73181 452%attr(755,root,root) /lib/grub.d/20_linux_xen
e2964b87 453%attr(755,root,root) /lib/grub.d/30_os-prober
e9d73181 454%attr(755,root,root) /lib/grub.d/41_custom
e2964b87 455
1e58ef6c 456%ifarch %{ix86} %{x8664}
1ffaf1f6 457%attr(755,root,root) %{_sbindir}/grub-probe
fc835b5e 458%{_mandir}/man8/grub-probe.8*
4a00f3b7 459%endif
aec70abd 460
f4604ef8 461%{_infodir}/grub*.info*
565fe2e3 462
8ac8605d
JK
463%dir %{_datadir}/grub/themes
464
1536aaf2 465%if %{with pc}
6d8475a4 466%files platform-pc
1536aaf2
JK
467%defattr(644,root,root,755)
468%dir %{_libexecdir}/*-pc
469%{_libexecdir}/*-pc/modinfo.sh
470%{_libexecdir}/*-pc/*.exec
471%{_libexecdir}/*-pc/*.image
472%{_libexecdir}/*-pc/*.lst
473%{_libexecdir}/*-pc/*.mod
474%{_libexecdir}/*-pc/*.module
475%{_libexecdir}/*-pc/lzma_decompress.img
476%{_libexecdir}/*-pc/config.h
477%{_libexecdir}/*-pc/gdb_grub
478%{_libexecdir}/*-pc/gmodule.pl
479%if %{with efiemu}
480%ifarch %{x8664}
481%{_libexecdir}/*-pc/efiemu*.o
482%endif
483%endif
484%{_libexecdir}/*-pc/kernel.img
485%ifarch %{ix86} %{x8664} sparc sparc64
486%{_libexecdir}/*-pc/boot.img
487%{_libexecdir}/*-pc/cdboot.img
488%{_libexecdir}/*-pc/diskboot.img
489%{_libexecdir}/*-pc/lnxboot.img
490%{_libexecdir}/*-pc/pxeboot.img
491%endif
492%endif
493
494%if %{with efi}
6d8475a4 495%files platform-efi
1536aaf2
JK
496%defattr(644,root,root,755)
497%dir %{_libexecdir}/*-efi
498%{_libexecdir}/*-efi/modinfo.sh
499%{_libexecdir}/*-efi/*.exec
500%{_libexecdir}/*-efi/*.lst
501%{_libexecdir}/*-efi/*.mod
502%{_libexecdir}/*-efi/*.module
503%{_libexecdir}/*-efi/config.h
504%{_libexecdir}/*-efi/gdb_grub
505%{_libexecdir}/*-efi/gmodule.pl
1536aaf2
JK
506%{_libexecdir}/*-efi/kernel.img
507%endif
508
7615a862
JK
509%files mkfont
510%defattr(644,root,root,755)
511%{_mandir}/man1/grub-mkfont.1*
512%attr(755,root,root) %{_sbindir}/grub-mkfont
513
8ac8605d
JK
514%files theme-starfield
515%defattr(644,root,root,755)
516%{_datadir}/grub/themes/starfield
517
565fe2e3
ER
518%files -n bash-completion-%{name}
519%defattr(644,root,root,755)
520/etc/bash_completion.d/grub
This page took 0.211435 seconds and 4 git commands to generate.