]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- outdated in 0.8.1
[packages/qemu.git] / qemu.spec
CommitLineData
6aef4654 1#
0b920c52
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
c33439fc
ER
4# - kqemu could be distributable if somebody bothers to contact qemu
5# author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
0b920c52 6#
6aef4654 7# Conditional build:
8%bcond_with kqemu # with QEMU accelerator module
161ffd93 9%bcond_with cflags_passing # with passing rpmcflags to Makefiles
a6d3659e 10%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
27439af0 11%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
8bb1261c
KK
12%bcond_without dist_kernel # without distribution kernel
13%bcond_without kernel # don't build kernel modules
14%bcond_without smp # don't build SMP module
15%bcond_without userspace # don't build userspace utilities
6aef4654 16#
39b50bf0
ER
17%if %{without kqemu}
18%undefine with_kernel
19%endif
20#
21%define _kqemu_version 1.3.0pre7
c33439fc 22%define _rel 0.2
cd19124e 23Summary: QEMU CPU Emulator
5a2da1d0 24Summary(pl): QEMU - emulator procesora
cd19124e 25Name: qemu
c33439fc 26Version: 0.8.1
8bb1261c 27Release: %{_rel}%{?with_kqemu:k}
5a2da1d0
JB
28License: GPL
29Group: Applications/Emulators
867764ba 30#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
cd19124e 31Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
c33439fc
ER
32# Source0-md5: 67d924324a5ab79d017bd97a1e767285
33Source1: http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
39b50bf0 34# NoSource1-md5: 3b77edbada790f924456aa4675edd0be
6aef4654 35NoSource: 1
8bd2aee2 36Patch0: %{name}-nostatic.patch
c33439fc 37Patch1: %{name}-cc.patch
867764ba 38Patch2: %{name}-longjmp.patch
d8d8cede 39Patch3: %{name}-dot.patch
c33439fc 40
0b920c52
41Patch5: %{name}-gcc4_x86.patch
42Patch6: %{name}-gcc4_ppc.patch
3b2d6429 43Patch7: %{name}-parallel.patch
a6d3659e 44Patch8: %{name}-nosdlgui.patch
ac6e5743 45Patch9: %{name}-ifup.patch
3fe0282d 46Patch10: %{name}-gcc33.patch
c33439fc 47
cd19124e 48URL: http://fabrice.bellard.free.fr/qemu/
867764ba 49BuildRequires: SDL-devel >= 1.2.1
b0b3ca8d 50BuildRequires: alsa-lib-devel
21c5c008 51%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
8bb1261c 52%if %{with kqemu} && %{with dist_kernel}
8799423b 53BuildRequires: kernel-module-build >= 3:2.6.7
4b0669f5 54%endif
8bb1261c
KK
55BuildRequires: rpmbuild(macros) >= 1.217
56BuildRequires: sed >= 4.0
57Requires: SDL >= 1.2.1
2ef13cb9 58# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
39b50bf0 59ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
cd19124e 60BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
867764ba
JB
62# some SPARC boot image in ELF format
63%define _noautostrip .*%{_datadir}/qemu/proll.elf
64
cd19124e 65%description
66QEMU is a FAST! processor emulator. By using dynamic translation it
67achieves a reasonnable speed while being easy to port on new host
68CPUs. QEMU has two operating modes:
69
70- User mode emulation. In this mode, QEMU can launch Linux processes
71 compiled for one CPU on another CPU. Linux system calls are converted
72 because of endianness and 32/64 bit mismatches. Wine (Windows
73 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
74
75- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
76 including a processor and various peripherials. It can also be used to
77 provide virtual hosting of several virtual PC on a single server.
cd19124e 78
5a2da1d0
JB
79%description -l pl
80