]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- qemu-gcc33.patch - small workaround to gcc33
[packages/qemu.git] / qemu.spec
CommitLineData
6aef4654 1#
0b920c52
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
6aef4654 5# Conditional build:
6%bcond_with kqemu # with QEMU accelerator module
161ffd93 7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
a6d3659e 8%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
8bb1261c
KK
9%bcond_without dist_kernel # without distribution kernel
10%bcond_without kernel # don't build kernel modules
11%bcond_without smp # don't build SMP module
12%bcond_without userspace # don't build userspace utilities
b4eae133 13
14%define _kqemu_version 0.7.2
6aef4654 15#
cd19124e 16Summary: QEMU CPU Emulator
5a2da1d0 17Summary(pl): QEMU - emulator procesora
cd19124e 18Name: qemu
b4eae133 19Version: 0.8.0
20%define _rel 1
8bb1261c 21Release: %{_rel}%{?with_kqemu:k}
5a2da1d0
JB
22License: GPL
23Group: Applications/Emulators
867764ba 24#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
cd19124e 25Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
b4eae133 26# Source0-md5: eb175b26583280706fe7e4d8910d320d
6aef4654 27%if %{with kqemu}
b4eae133 28Source1: http://fabrice.bellard.free.fr/qemu/kqemu-%{_kqemu_version}.tar.gz
57d8430f 29# NoSource1-md5: 02cfdecda90458d6393781496ec6b48b
6aef4654 30NoSource: 1
31%endif
8bd2aee2 32Patch0: %{name}-nostatic.patch
f1ae848c 33Patch1: %{name}-DESTDIR.patch
867764ba 34Patch2: %{name}-longjmp.patch
d8d8cede 35Patch3: %{name}-dot.patch
d5906b49 36Patch4: %{name}-initrd_load_addr.patch
0b920c52
37Patch5: %{name}-gcc4_x86.patch
38Patch6: %{name}-gcc4_ppc.patch
3b2d6429 39Patch7: %{name}-parallel.patch
a6d3659e 40Patch8: %{name}-nosdlgui.patch
ac6e5743 41Patch9: %{name}-ifup.patch
3fe0282d 42Patch10: %{name}-gcc33.patch
cd19124e 43URL: http://fabrice.bellard.free.fr/qemu/
867764ba 44BuildRequires: SDL-devel >= 1.2.1
8bb1261c
KK
45%if %{with kqemu} && %{with dist_kernel}
46BuildRequires: kernel-module-build >= 2.6.7
4b0669f5 47%endif
8bb1261c
KK
48BuildRequires: rpmbuild(macros) >= 1.217
49BuildRequires: sed >= 4.0
50Requires: SDL >= 1.2.1
1815bf07 51ExclusiveArch: %{ix86} %{x8664} ppc
2ef13cb9 52# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
cd19124e 53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
867764ba
JB
55# some SPARC boot image in ELF format
56%define _noautostrip .*%{_datadir}/qemu/proll.elf
57
8bb1261c
KK
58%if !%{with kqemu}
59%undefine with_kernel
60%endif
61
cd19124e 62%description
63QEMU is a FAST! processor emulator. By using dynamic translation it
64achieves a reasonnable speed while being easy to port on new host
65CPUs. QEMU has two operating modes:
66
67- User mode emulation. In this mode, QEMU can launch Linux processes
68 compiled for one CPU on another CPU. Linux system calls are converted
69 because of endianness and 32/64 bit mismatches. Wine (Windows
70 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
71
72- Full system emulation. In this mode, QEMU emulates a full system,
c012f329 73 including a processor and various peripherials.
74 It can also be used to provide virtual hosting of several
75 virtual PC on a single server.
cd19124e 76
5a2da1d0
JB
77%description -l pl
78