]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- patch to override qemu-ifup path
[packages/qemu.git] / qemu.spec
CommitLineData
6aef4654 1#
0b920c52
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
6aef4654 5# Conditional build:
6%bcond_with kqemu # with QEMU accelerator module
161ffd93 7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
a6d3659e 8%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
8bb1261c
KK
9%bcond_without dist_kernel # without distribution kernel
10%bcond_without kernel # don't build kernel modules
11%bcond_without smp # don't build SMP module
12%bcond_without userspace # don't build userspace utilities
6aef4654 13#
cd19124e 14Summary: QEMU CPU Emulator
5a2da1d0 15Summary(pl): QEMU - emulator procesora
cd19124e 16Name: qemu
8bf91894 17Version: 0.7.1
8bb1261c
KK
18%define _rel 1
19Release: %{_rel}%{?with_kqemu:k}
5a2da1d0
JB
20License: GPL
21Group: Applications/Emulators
867764ba 22#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
cd19124e 23Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
8bf91894 24# Source0-md5: b0c80d2c082049a5b8ccbc7f55fe165b
6aef4654 25%if %{with kqemu}
8bb1261c 26Source1: http://fabrice.bellard.free.fr/qemu/kqemu-%{version}-1.tar.gz
080a0c6f 27# NoSource1-md5: 012498dac620eb8c212bf5f622414dd0
6aef4654 28NoSource: 1
29%endif
8bd2aee2 30Patch0: %{name}-nostatic.patch
f1ae848c 31Patch1: %{name}-DESTDIR.patch
867764ba 32Patch2: %{name}-longjmp.patch
d8d8cede 33Patch3: %{name}-dot.patch
d5906b49 34Patch4: %{name}-initrd_load_addr.patch
0b920c52
35Patch5: %{name}-gcc4_x86.patch
36Patch6: %{name}-gcc4_ppc.patch
3b2d6429 37Patch7: %{name}-parallel.patch
a6d3659e 38Patch8: %{name}-nosdlgui.patch
cd19124e 39URL: http://fabrice.bellard.free.fr/qemu/
867764ba 40BuildRequires: SDL-devel >= 1.2.1
8bb1261c
KK
41%if %{with kqemu} && %{with dist_kernel}
42BuildRequires: kernel-module-build >= 2.6.7
4b0669f5 43%endif
8bb1261c
KK
44BuildRequires: rpmbuild(macros) >= 1.217
45BuildRequires: sed >= 4.0
46Requires: SDL >= 1.2.1
1815bf07 47ExclusiveArch: %{ix86} %{x8664} ppc
2ef13cb9 48# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
cd19124e 49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
867764ba
JB
51# some SPARC boot image in ELF format
52%define _noautostrip .*%{_datadir}/qemu/proll.elf
53
8bb1261c
KK
54%if !%{with kqemu}
55%undefine with_kernel
56%endif
57
cd19124e 58%description
59QEMU is a FAST! processor emulator. By using dynamic translation it
60achieves a reasonnable speed while being easy to port on new host
61CPUs. QEMU has two operating modes:
62
63- User mode emulation. In this mode, QEMU can launch Linux processes
64 compiled for one CPU on another CPU. Linux system calls are converted
65 because of endianness and 32/64 bit mismatches. Wine (Windows
66 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
67
68- Full system emulation. In this mode, QEMU emulates a full system,
c012f329 69 including a processor and various peripherials.
70 It can also be used to provide virtual hosting of several
71 virtual PC on a single server.
cd19124e 72
5a2da1d0
JB
73%description -l pl
74