]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- update kqemu to 1.3.0pre7
[packages/qemu.git] / qemu.spec
CommitLineData
6aef4654 1#
0b920c52
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
6aef4654 5# Conditional build:
6%bcond_with kqemu # with QEMU accelerator module
161ffd93 7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
a6d3659e 8%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
27439af0 9%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
8bb1261c
KK
10%bcond_without dist_kernel # without distribution kernel
11%bcond_without kernel # don't build kernel modules
12%bcond_without smp # don't build SMP module
13%bcond_without userspace # don't build userspace utilities
6aef4654 14#
39b50bf0
ER
15%if %{without kqemu}
16%undefine with_kernel
17%endif
18#
19%define _kqemu_version 1.3.0pre7
20%define _rel 1.2
cd19124e 21Summary: QEMU CPU Emulator
5a2da1d0 22Summary(pl): QEMU - emulator procesora
cd19124e 23Name: qemu
b4eae133 24Version: 0.8.0
8bb1261c 25Release: %{_rel}%{?with_kqemu:k}
5a2da1d0
JB
26License: GPL
27Group: Applications/Emulators
867764ba 28#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
cd19124e 29Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
b4eae133 30# Source0-md5: eb175b26583280706fe7e4d8910d320d
39b50bf0
ER
31Source1: http://fabrice.bellard.free.fr/qemu/kqemu-%{_kqemu_version}.tar.gz
32# NoSource1-md5: 3b77edbada790f924456aa4675edd0be
6aef4654 33NoSource: 1
8bd2aee2 34Patch0: %{name}-nostatic.patch
f1ae848c 35Patch1: %{name}-DESTDIR.patch
867764ba 36Patch2: %{name}-longjmp.patch
d8d8cede 37Patch3: %{name}-dot.patch
d5906b49 38Patch4: %{name}-initrd_load_addr.patch
0b920c52
39Patch5: %{name}-gcc4_x86.patch
40Patch6: %{name}-gcc4_ppc.patch
3b2d6429 41Patch7: %{name}-parallel.patch
a6d3659e 42Patch8: %{name}-nosdlgui.patch
ac6e5743 43Patch9: %{name}-ifup.patch
3fe0282d 44Patch10: %{name}-gcc33.patch
2ab5858a 45Patch11: %{name}-slirp_throttle.patch
cd19124e 46URL: http://fabrice.bellard.free.fr/qemu/
867764ba 47BuildRequires: SDL-devel >= 1.2.1
b0b3ca8d 48BuildRequires: alsa-lib-devel
21c5c008 49%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
8bb1261c 50%if %{with kqemu} && %{with dist_kernel}
8799423b 51BuildRequires: kernel-module-build >= 3:2.6.7
4b0669f5 52%endif
8bb1261c
KK
53BuildRequires: rpmbuild(macros) >= 1.217
54BuildRequires: sed >= 4.0
55Requires: SDL >= 1.2.1
2ef13cb9 56# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
39b50bf0 57ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
cd19124e 58BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
867764ba
JB
60# some SPARC boot image in ELF format
61%define _noautostrip .*%{_datadir}/qemu/proll.elf
62
cd19124e 63%description
64QEMU is a FAST! processor emulator. By using dynamic translation it
65achieves a reasonnable speed while being easy to port on new host
66CPUs. QEMU has two operating modes:
67
68- User mode emulation. In this mode, QEMU can launch Linux processes
69 compiled for one CPU on another CPU. Linux system calls are converted
70 because of endianness and 32/64 bit mismatches. Wine (Windows
71 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
72
73- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
74 including a processor and various peripherials. It can also be used to
75 provide virtual hosting of several virtual PC on a single server.
cd19124e 76
5a2da1d0
JB
77%description -l pl
78