]> git.pld-linux.org Git - packages/mlt.git/commitdiff
- rel 4; tiny fixes from debian auto/th/mlt-0.9.0-4
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 13 Apr 2014 18:35:29 +0000 (20:35 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 13 Apr 2014 18:35:29 +0000 (20:35 +0200)
02-crash-empty-ladspa-path.diff [new file with mode: 0644]
03-freetype-ftbfs.diff [new file with mode: 0644]
mlt.spec

diff --git a/02-crash-empty-ladspa-path.diff b/02-crash-empty-ladspa-path.diff
new file mode 100644 (file)
index 0000000..1b8f80d
--- /dev/null
@@ -0,0 +1,18 @@
+# Upstream patch to fix crash if LADSPA_PATH is empty.
+# Closes: #726197
+
+diff -Naur mlt-0.9.0.orig/src/modules/jackrack/plugin_mgr.c mlt-0.9.0/src/modules/jackrack/plugin_mgr.c
+--- mlt-0.9.0.orig/src/modules/jackrack/plugin_mgr.c   2013-06-03 05:34:35.000000000 +0200
++++ mlt-0.9.0/src/modules/jackrack/plugin_mgr.c        2013-10-17 14:49:57.147889337 +0200
+@@ -237,10 +237,8 @@
+     ladspa_path = g_strdup ("/usr/local/lib/ladspa:/usr/lib/ladspa:/usr/lib64/ladspa");
+ #endif
+   
+-  dir = strtok (ladspa_path, ":");
+-  do
++  for (dir = strtok (ladspa_path, ":"); dir; dir = strtok (NULL, ":"))
+     plugin_mgr_get_dir_plugins (plugin_mgr, dir);
+-  while ((dir = strtok (NULL, ":")));
+   g_free (ladspa_path);
+ }
diff --git a/03-freetype-ftbfs.diff b/03-freetype-ftbfs.diff
new file mode 100644 (file)
index 0000000..ad051b5
--- /dev/null
@@ -0,0 +1,26 @@
+# Upstream patch to fix FTBFS with newer freetype versions.
+# Closes: #733375
+
+diff -Naur mlt-0.9.0.orig/src/modules/gtk2/Makefile mlt-0.9.0/src/modules/gtk2/Makefile
+--- mlt-0.9.0.orig/src/modules/gtk2/Makefile   2013-06-03 05:34:35.000000000 +0200
++++ mlt-0.9.0/src/modules/gtk2/Makefile        2014-01-03 11:43:13.518109987 +0100
+@@ -37,6 +37,7 @@
+ OBJS += producer_count.o
+ OBJS += filter_dynamictext.o
+ CFLAGS += `pkg-config $(PKGCONFIG_PREFIX) --cflags pangoft2`
++CFLAGS += `pkg-config --cflags-only-I freetype2 | sed 's/ *$$//g'`/freetype
+ LDFLAGS += `pkg-config $(PKGCONFIG_PREFIX) --libs pangoft2`
+ ifeq ($(targetos),Darwin)
+ LDFLAGS += -liconv
+diff -Naur mlt-0.9.0.orig/src/modules/gtk2/producer_pango.c mlt-0.9.0/src/modules/gtk2/producer_pango.c
+--- mlt-0.9.0.orig/src/modules/gtk2/producer_pango.c   2013-06-03 05:34:35.000000000 +0200
++++ mlt-0.9.0/src/modules/gtk2/producer_pango.c        2014-01-03 11:41:10.270113314 +0100
+@@ -25,7 +25,7 @@
+ #include <string.h>
+ #include <gdk-pixbuf/gdk-pixbuf.h>
+ #include <pango/pangoft2.h>
+-#include <freetype/freetype.h>
++#include <freetype.h>
+ #include <iconv.h>
+ #include <pthread.h>
+ #include <ctype.h>
index b9f3c47749530dd5a456339f42eede0134bc16a6..0195b01b7246e5b2774ba54debda2132c0cc5c29 100644 (file)
--- a/mlt.spec
+++ b/mlt.spec
@@ -8,11 +8,13 @@ Summary:      MLT - open source multimedia framework
 Summary(pl.UTF-8):     MLT - szkielet multimedialny o otwartych źródłach
 Name:          mlt
 Version:       0.9.0
-Release:       3
+Release:       4
 License:       GPL
 Group:         X11/Applications/Multimedia
 Source0:       http://downloads.sourceforge.net/mlt/%{name}-%{version}.tar.gz
 # Source0-md5: 1cd2d73f3ffe77a43980e99aaa4ea06c
+Patch0:                02-crash-empty-ladspa-path.diff
+Patch1:                03-freetype-ftbfs.diff
 URL:           http://www.mltframework.org/
 BuildRequires: QtGui-devel
 BuildRequires: QtSvg-devel
@@ -79,6 +81,8 @@ Ten pakiet zawiera pliki nagłówkowe dla MLT.
 
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
 
 # current
 sed -i -e 's#/usr/lib/libvdpau.so#%{_libdir}/libvdpau.so.1#g' ./src/modules/avformat/vdpau.c
This page took 0.284663 seconds and 4 git commands to generate.