]> git.pld-linux.org Git - packages/mlt.git/blob - mlt.spec
- rel 4; tiny fixes from debian
[packages/mlt.git] / mlt.spec
1 #
2 # TODO:
3 #       - bconds
4 #       - more bindings
5 #       - movit library - http://libregraphicsworld.org/blog/entry/introducing-movit-free-library-for-gpu-side-video-processing
6 #
7 Summary:        MLT - open source multimedia framework
8 Summary(pl.UTF-8):      MLT - szkielet multimedialny o otwartych źródłach
9 Name:           mlt
10 Version:        0.9.0
11 Release:        4
12 License:        GPL
13 Group:          X11/Applications/Multimedia
14 Source0:        http://downloads.sourceforge.net/mlt/%{name}-%{version}.tar.gz
15 # Source0-md5:  1cd2d73f3ffe77a43980e99aaa4ea06c
16 Patch0:         02-crash-empty-ladspa-path.diff
17 Patch1:         03-freetype-ftbfs.diff
18 URL:            http://www.mltframework.org/
19 BuildRequires:  QtGui-devel
20 BuildRequires:  QtSvg-devel
21 BuildRequires:  QtXml-devel
22 BuildRequires:  SDL-devel
23 BuildRequires:  ffmpeg-devel
24 BuildRequires:  gtk+2-devel
25 #BuildRequires: ladspa-devel
26 #BuildRequires: lame-libs-devel
27 BuildRequires:  libdv-devel >= 0.102
28 #BuildRequires: libmad-devel
29 BuildRequires:  libquicktime-devel
30 BuildRequires:  libsamplerate-devel
31 BuildRequires:  libvorbis-devel >= 1:1.0.1
32 BuildRequires:  libxml2-devel >= 2.5
33 BuildRequires:  pkgconfig
34 BuildRequires:  python-devel
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  sox-devel
37 BuildRequires:  swig-python
38 BuildRequires:  swfdec-devel
39 BuildRequires:  which
40 Obsoletes:      mlt++ < %{version}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 MLT is an open source multimedia framework, designed and developed for
45 television broadcasting. It provides a toolkit for broadcasters, video
46 editors, media players, transcoders, web streamers and many more types
47 of applications. The functionality of the system is provided via an
48 assortment of ready to use tools, XML authoring components, and an
49 extendible plug-in based API.
50
51 %description -l pl.UTF-8
52 MLT to szkielet multimedialny o otwartych źródłach zaprojektowany i
53 rozwijany do nadawania telewizji. Udostępnia zestaw narzędzi dla
54 nadawców, edytory obrazu, odtwarzacze mediów, transkodery, narzędzia
55 do udostępniania strumieni przez WWW i wiele innych rodzajów
56 aplikacji. Funkcjonalność systemu jest zapewniona poprzez asortyment
57 gotowych do użycia narzędzi, komponentów do tworzenia XML-a i
58 rozszerzalne API oparte na wtyczkach.
59
60 %package -n python-mlt
61 Summary:        MLT Python bindings
62 Summary(pl.UTF-8):      Wiązania MLT dla Pythona
63 Group:          Development/Languages/Python
64 Requires:       %{name} = %{version}-%{release}
65
66 %description -n python-mlt
67 Python bindings for MLT - open source multimedia framework.
68
69 %package devel
70 Summary:        Header files for MLT
71 Summary(pl.UTF-8):      Pliki nagłówkowe dla MLT
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Obsoletes:      mlt++-devel < %{version}
75
76 %description devel
77 This package contains header files for MLT.
78
79 %description devel -l pl.UTF-8
80 Ten pakiet zawiera pliki nagłówkowe dla MLT.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86
87 # current
88 sed -i -e 's#/usr/lib/libvdpau.so#%{_libdir}/libvdpau.so.1#g' ./src/modules/avformat/vdpau.c
89 # in case of future changes
90 sed -i -e 's#/usr/local/lib/libvdpau.so#%{_libdir}/libvdpau.so.2#g' ./src/modules/avformat/vdpau.c
91
92 %build
93 %configure \
94         --enable-gpl \
95         --enable-gpl3 \
96 %ifarch %{x8664}
97         --disable-motion-est \
98 %else
99         --enable-motion-est \
100 %endif
101         --disable-debug \
102 %ifarch i586 i686 %{x8664}
103         --enable-mmx \
104 %else
105         --disable-mmx \
106 %endif
107 %ifarch %{x8664}
108         --enable-sse \
109         --enable-sse2 \
110 %else
111         --disable-sse \
112         --disable-sse2 \
113 %endif
114         --avformat-swscale \
115         --avformat-vdpau \
116         --qimage-includedir=%{_includedir}/qt4 \
117         --qimage-libdir=%{_libdir} \
118         --swig-languages=python
119
120 %{__make} \
121         CC="%{__cc}"
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT%{py_sitedir}
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 install src/swig/python/{*.py,*.so} $RPM_BUILD_ROOT%{py_sitedir}
131
132 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
133 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
134 %py_postclean
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc ChangeLog README
145 %attr(755,root,root) %{_bindir}/*
146 %attr(755,root,root) %ghost %{_libdir}/*.so.?
147 %attr(755,root,root) %{_libdir}/*.so.*.*
148 %dir %{_libdir}/%{name}
149 %attr(755,root,root) %{_libdir}/%{name}/*
150 %{_datadir}/mlt*
151
152 %files -n python-mlt
153 %defattr(644,root,root,755)
154 %{py_sitedir}/*.py[co]
155 %attr(755,root,root) %{py_sitedir}/*.so
156
157 %files devel
158 %defattr(644,root,root,755)
159 %{_pkgconfigdir}/*.pc
160 %{_includedir}/mlt*
161 %{_libdir}/*.so
This page took 0.048124 seconds and 3 git commands to generate.