]> git.pld-linux.org Git - packages/minify.git/blame - minify.spec
fix missing semicolon
[packages/minify.git] / minify.spec
CommitLineData
42993e38
ER
1%define php_min_version 5.2.1
2%include /usr/lib/rpm/macros.php
981a47f4
ER
3Summary: Combines, minifies, and caches JavaScript and CSS files on demand to speed up page loads
4Name: minify
4ca11b01 5Version: 3.0
1751fa7f 6Release: 2.2
981a47f4
ER
7License: New BSD License
8Group: Applications/WWW
4ca11b01 9#Source0: https://github.com/mrclay/minify/archive/%{version}/%{name}-%{version}.tar.gz
0f2f0225 10#Source0: https://github.com/glensc/minify/archive/lessphp-dev3/%{name}-%{version}.tar.gz
1751fa7f
ER
11Source0: https://github.com/mrclay/minify/archive/e271c37/%{name}-%{version}.tar.gz
12# Source0-md5: 4691fc13004fa5863bbfece3f70f6f6a
3e524d3a 13Patch0: paths.patch
42993e38 14Patch1: pear-firephp.patch
f3d01beb 15Patch2: yui-path.patch
93d46ec2 16Patch3: contentfunc-params.patch
ab52a567
ER
17Source1: apache.conf
18Source2: lighttpd.conf
0f2f0225 19URL: https://github.com/mrclay/minify
95c64b7e 20BuildRequires: rpmbuild(macros) >= 1.654
15a438fc 21BuildRequires: unzip
981a47f4
ER
22Requires: php-%{name} = %{version}-%{release}
23Requires: webapps
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%define _webapps /etc/webapps
28%define _webapp %{name}
29%define _sysconfdir %{_webapps}/%{_webapp}
30%define _appdir %{_datadir}/%{_webapp}
31%define cachedir /var/cache/%{name}
32
c6db73a7 33# skip pear deps
95c64b7e 34%define _noautoreq_pear .*Minify/Loader.php FirePHPCore/FirePHP.class.php
c6db73a7 35
981a47f4
ER
36%description
37Minify is a PHP5 app that helps you follow several of Yahoo!'s Rules
38for High Performance Web Sites.
39
40It combines multiple CSS or Javascript files, removes unnecessary
41whitespace and comments, and serves them with gzip encoding and
42optimal client-side cache headers.
43
44%package -n php-%{name}
45Summary: Minify Classes
46Group: Applications/WWW
1a6e11b9 47Requires: php(core) >= %{php_min_version}
eab9097f
ER
48Requires: php(ctype)
49Requires: php(date)
21f19bc8
ER
50Requires: php(mbstring)
51Requires: php(pcre)
eab9097f 52Requires: php(spl)
42993e38 53Requires: php-dirs
656c761a
ER
54Requires: php-yui-css-compressor
55Suggests: lessphp >= 0.4.0
42993e38 56Suggests: php-firephp-FirePHPCore
981a47f4
ER
57
58%description -n php-%{name}
59Minify Classes.
60
61%package builder
62Summary: Minify URI Builder
63Group: Applications/WWW
64Requires: %{name} = %{version}-%{release}
1a6e11b9 65Requires: php(core) >= %{php_min_version}
21f19bc8 66Requires: php(pcre)
981a47f4
ER
67
68%description builder
69Minify URI Builder.
70
71%package unit_tests
72Summary: Unit tests for Minify
73Group: Applications/WWW
74Requires: %{name} = %{version}-%{release}
75
76%description unit_tests
77Unit tests for Minify.
78
79%prep
4ca11b01
ER
80%setup -qc
81mv %{name}-*/* .
42993e38 82%undos -f php
3e524d3a 83%patch0 -p1
42993e38 84%patch1 -p1
f3d01beb 85%patch2 -p1
6d697cfd 86%patch3 -p1
981a47f4 87%undos UPGRADING.txt
981a47f4 88
f3d01beb
ER
89find -type f | xargs chmod a-x
90
5aff6a93 91# not needed for functionality
0f2f0225 92%{__rm} -r lib/MrClay
656c761a 93
f3d01beb
ER
94# cleanup backups after patching
95find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
96
981a47f4
ER
97%install
98rm -rf $RPM_BUILD_ROOT
99install -d $RPM_BUILD_ROOT{%{php_data_dir},%{_sysconfdir},%{_appdir},%{cachedir}}
100
1751fa7f
ER
101cp -a *.php builder $RPM_BUILD_ROOT%{_appdir}
102cp -a lib/* $RPM_BUILD_ROOT%{php_data_dir}
981a47f4
ER
103
104for config in config.php groupsConfig.php; do
105 mv $RPM_BUILD_ROOT{%{_appdir}/$config,%{_sysconfdir}}
106 ln -s %{_sysconfdir}/$config $RPM_BUILD_ROOT%{_appdir}
107done
108
3e524d3a
ER
109cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
110cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
ab52a567 111cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
981a47f4
ER
112
113%triggerin -- apache1 < 1.3.37-3, apache1-base
114%webapp_register apache %{_webapp}
115
116%triggerun -- apache1 < 1.3.37-3, apache1-base
117%webapp_unregister apache %{_webapp}
118
ab52a567 119%triggerin -- apache < 2.2.0, apache-base
981a47f4
ER
120%webapp_register httpd %{_webapp}
121
ab52a567 122%triggerun -- apache < 2.2.0, apache-base
981a47f4
ER
123%webapp_unregister httpd %{_webapp}
124
125%triggerin -- lighttpd
126%webapp_register lighttpd %{_webapp}
127
128%triggerun -- lighttpd
129%webapp_unregister lighttpd %{_webapp}
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%preun
135if [ "$1" = 0 ]; then
136 echo %{cachedir}/* | xargs rm -rf
137fi
138
139%files
140%defattr(644,root,root,755)
141%doc *.txt
142%dir %attr(750,root,http) %{_sysconfdir}
143%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
144%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
145%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
146%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
147%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/groupsConfig.php
148%dir %{_appdir}
149%{_appdir}/*.php
150
151%dir %attr(771,root,http) %{cachedir}
152
153%files builder
154%defattr(644,root,root,755)
155%{_appdir}/builder
156
157%files -n php-%{name}
158%defattr(644,root,root,755)
159%dir %{php_data_dir}/HTTP
160%{php_data_dir}/HTTP/ConditionalGet.php
161%{php_data_dir}/HTTP/Encoder.php
51765038 162%{php_data_dir}/DooDigestAuth.php
981a47f4
ER
163%{php_data_dir}/Minify.php
164%{php_data_dir}/Minify
This page took 0.054839 seconds and 4 git commands to generate.