]> git.pld-linux.org Git - packages/minify.git/blame - minify.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/minify.git] / minify.spec
CommitLineData
42993e38 1%define php_min_version 5.2.1
981a47f4
ER
2Summary: Combines, minifies, and caches JavaScript and CSS files on demand to speed up page loads
3Name: minify
4ca11b01 4Version: 3.0
656c761a 5Release: 2
981a47f4
ER
6License: New BSD License
7Group: Applications/WWW
4ca11b01
ER
8#Source0: https://github.com/mrclay/minify/archive/%{version}/%{name}-%{version}.tar.gz
9Source0: https://github.com/glensc/minify/archive/lessphp-dev3/%{name}-%{version}.tar.gz
10# Source0-md5: a84596d6b4febde3d5f4b00698b7cc70
3e524d3a 11Patch0: paths.patch
42993e38 12Patch1: pear-firephp.patch
f3d01beb 13Patch2: yui-path.patch
93d46ec2 14Patch3: contentfunc-params.patch
ab52a567
ER
15Source1: apache.conf
16Source2: lighttpd.conf
981a47f4 17URL: http://code.google.com/p/minify/
95c64b7e 18BuildRequires: rpmbuild(macros) >= 1.654
15a438fc 19BuildRequires: unzip
981a47f4
ER
20Requires: php-%{name} = %{version}-%{release}
21Requires: webapps
22BuildArch: noarch
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define _webapps /etc/webapps
26%define _webapp %{name}
27%define _sysconfdir %{_webapps}/%{_webapp}
28%define _appdir %{_datadir}/%{_webapp}
29%define cachedir /var/cache/%{name}
30
c6db73a7 31# skip pear deps
95c64b7e 32%define _noautoreq_pear .*Minify/Loader.php FirePHPCore/FirePHP.class.php
c6db73a7 33
981a47f4
ER
34%description
35Minify is a PHP5 app that helps you follow several of Yahoo!'s Rules
36for High Performance Web Sites.
37
38It combines multiple CSS or Javascript files, removes unnecessary
39whitespace and comments, and serves them with gzip encoding and
40optimal client-side cache headers.
41
42%package -n php-%{name}
43Summary: Minify Classes
44Group: Applications/WWW
1a6e11b9 45Requires: php(core) >= %{php_min_version}
eab9097f
ER
46Requires: php(ctype)
47Requires: php(date)
21f19bc8
ER
48Requires: php(mbstring)
49Requires: php(pcre)
eab9097f 50Requires: php(spl)
42993e38 51Requires: php-dirs
656c761a
ER
52Requires: php-yui-css-compressor
53Suggests: lessphp >= 0.4.0
42993e38 54Suggests: php-firephp-FirePHPCore
981a47f4
ER
55
56%description -n php-%{name}
57Minify Classes.
58
59%package builder
60Summary: Minify URI Builder
61Group: Applications/WWW
62Requires: %{name} = %{version}-%{release}
1a6e11b9 63Requires: php(core) >= %{php_min_version}
21f19bc8 64Requires: php(pcre)
981a47f4
ER
65
66%description builder
67Minify URI Builder.
68
69%package unit_tests
70Summary: Unit tests for Minify
71Group: Applications/WWW
72Requires: %{name} = %{version}-%{release}
73
74%description unit_tests
75Unit tests for Minify.
76
77%prep
4ca11b01
ER
78%setup -qc
79mv %{name}-*/* .
42993e38 80%undos -f php
3e524d3a 81%patch0 -p1
42993e38 82%patch1 -p1
f3d01beb 83%patch2 -p1
6d697cfd 84%patch3 -p1
981a47f4 85%undos UPGRADING.txt
981a47f4 86
f3d01beb
ER
87find -type f | xargs chmod a-x
88
5aff6a93
ER
89# not needed for functionality
90%{__rm} min/lib/Minify/YUI/CssCompressor.java
91%{__rm} -r min/lib/MrClay
92
42993e38 93# php-firephp-FirePHPCore
5aff6a93 94%{__rm} min/lib/FirePHP.php
42993e38 95
656c761a
ER
96# php-yui-css-compressor
97%{__rm} min/lib/CSSmin.php
98
f3d01beb
ER
99# cleanup backups after patching
100find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
101
981a47f4
ER
102%install
103rm -rf $RPM_BUILD_ROOT
104install -d $RPM_BUILD_ROOT{%{php_data_dir},%{_sysconfdir},%{_appdir},%{cachedir}}
105
3e524d3a
ER
106cp -a min/*.php min/builder $RPM_BUILD_ROOT%{_appdir}
107cp -a min/lib/* $RPM_BUILD_ROOT%{php_data_dir}
981a47f4
ER
108
109for config in config.php groupsConfig.php; do
110 mv $RPM_BUILD_ROOT{%{_appdir}/$config,%{_sysconfdir}}
111 ln -s %{_sysconfdir}/$config $RPM_BUILD_ROOT%{_appdir}
112done
113
3e524d3a
ER
114cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
115cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
ab52a567 116cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
981a47f4
ER
117
118%triggerin -- apache1 < 1.3.37-3, apache1-base
119%webapp_register apache %{_webapp}
120
121%triggerun -- apache1 < 1.3.37-3, apache1-base
122%webapp_unregister apache %{_webapp}
123
ab52a567 124%triggerin -- apache < 2.2.0, apache-base
981a47f4
ER
125%webapp_register httpd %{_webapp}
126
ab52a567 127%triggerun -- apache < 2.2.0, apache-base
981a47f4
ER
128%webapp_unregister httpd %{_webapp}
129
130%triggerin -- lighttpd
131%webapp_register lighttpd %{_webapp}
132
133%triggerun -- lighttpd
134%webapp_unregister lighttpd %{_webapp}
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%preun
140if [ "$1" = 0 ]; then
141 echo %{cachedir}/* | xargs rm -rf
142fi
143
144%files
145%defattr(644,root,root,755)
146%doc *.txt
147%dir %attr(750,root,http) %{_sysconfdir}
148%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
149%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
150%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
151%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
152%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/groupsConfig.php
153%dir %{_appdir}
154%{_appdir}/*.php
155
156%dir %attr(771,root,http) %{cachedir}
157
158%files builder
159%defattr(644,root,root,755)
160%{_appdir}/builder
161
162%files -n php-%{name}
163%defattr(644,root,root,755)
164%dir %{php_data_dir}/HTTP
165%{php_data_dir}/HTTP/ConditionalGet.php
166%{php_data_dir}/HTTP/Encoder.php
51765038 167%{php_data_dir}/DooDigestAuth.php
981a47f4
ER
168%{php_data_dir}/JSMin.php
169%{php_data_dir}/JSMinPlus.php
170%{php_data_dir}/Minify.php
171%{php_data_dir}/Minify
This page took 0.060104 seconds and 5 git commands to generate.