]> git.pld-linux.org Git - packages/minify.git/blame - minify.spec
use system php-yui-css-compressor package
[packages/minify.git] / minify.spec
CommitLineData
42993e38
ER
1%define php_min_version 5.2.1
2%include /usr/lib/rpm/macros.php
981a47f4
ER
3Summary: Combines, minifies, and caches JavaScript and CSS files on demand to speed up page loads
4Name: minify
4ca11b01 5Version: 3.0
656c761a 6Release: 2
981a47f4
ER
7License: New BSD License
8Group: Applications/WWW
4ca11b01
ER
9#Source0: https://github.com/mrclay/minify/archive/%{version}/%{name}-%{version}.tar.gz
10Source0: https://github.com/glensc/minify/archive/lessphp-dev3/%{name}-%{version}.tar.gz
11# Source0-md5: a84596d6b4febde3d5f4b00698b7cc70
3e524d3a 12Patch0: paths.patch
42993e38 13Patch1: pear-firephp.patch
f3d01beb 14Patch2: yui-path.patch
93d46ec2 15Patch3: contentfunc-params.patch
ab52a567
ER
16Source1: apache.conf
17Source2: lighttpd.conf
981a47f4 18URL: http://code.google.com/p/minify/
95c64b7e 19BuildRequires: rpmbuild(macros) >= 1.654
15a438fc 20BuildRequires: unzip
981a47f4
ER
21Requires: php-%{name} = %{version}-%{release}
22Requires: webapps
23BuildArch: noarch
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%define _webapps /etc/webapps
27%define _webapp %{name}
28%define _sysconfdir %{_webapps}/%{_webapp}
29%define _appdir %{_datadir}/%{_webapp}
30%define cachedir /var/cache/%{name}
31
c6db73a7 32# skip pear deps
95c64b7e 33%define _noautoreq_pear .*Minify/Loader.php FirePHPCore/FirePHP.class.php
c6db73a7 34
981a47f4
ER
35%description
36Minify is a PHP5 app that helps you follow several of Yahoo!'s Rules
37for High Performance Web Sites.
38
39It combines multiple CSS or Javascript files, removes unnecessary
40whitespace and comments, and serves them with gzip encoding and
41optimal client-side cache headers.
42
43%package -n php-%{name}
44Summary: Minify Classes
45Group: Applications/WWW
1a6e11b9 46Requires: php(core) >= %{php_min_version}
eab9097f
ER
47Requires: php(ctype)
48Requires: php(date)
21f19bc8
ER
49Requires: php(mbstring)
50Requires: php(pcre)
eab9097f 51Requires: php(spl)
42993e38 52Requires: php-dirs
656c761a
ER
53Requires: php-yui-css-compressor
54Suggests: lessphp >= 0.4.0
42993e38 55Suggests: php-firephp-FirePHPCore
981a47f4
ER
56
57%description -n php-%{name}
58Minify Classes.
59
60%package builder
61Summary: Minify URI Builder
62Group: Applications/WWW
63Requires: %{name} = %{version}-%{release}
1a6e11b9 64Requires: php(core) >= %{php_min_version}
21f19bc8 65Requires: php(pcre)
981a47f4
ER
66
67%description builder
68Minify URI Builder.
69
70%package unit_tests
71Summary: Unit tests for Minify
72Group: Applications/WWW
73Requires: %{name} = %{version}-%{release}
74
75%description unit_tests
76Unit tests for Minify.
77
78%prep
4ca11b01
ER
79%setup -qc
80mv %{name}-*/* .
42993e38 81%undos -f php
3e524d3a 82%patch0 -p1
42993e38 83%patch1 -p1
f3d01beb 84%patch2 -p1
6d697cfd 85%patch3 -p1
981a47f4 86%undos UPGRADING.txt
981a47f4 87
f3d01beb
ER
88find -type f | xargs chmod a-x
89
5aff6a93
ER
90# not needed for functionality
91%{__rm} min/lib/Minify/YUI/CssCompressor.java
92%{__rm} -r min/lib/MrClay
93
42993e38 94# php-firephp-FirePHPCore
5aff6a93 95%{__rm} min/lib/FirePHP.php
42993e38 96
656c761a
ER
97# php-yui-css-compressor
98%{__rm} min/lib/CSSmin.php
99
f3d01beb
ER
100# cleanup backups after patching
101find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
102
981a47f4
ER
103%install
104rm -rf $RPM_BUILD_ROOT
105install -d $RPM_BUILD_ROOT{%{php_data_dir},%{_sysconfdir},%{_appdir},%{cachedir}}
106
3e524d3a
ER
107cp -a min/*.php min/builder $RPM_BUILD_ROOT%{_appdir}
108cp -a min/lib/* $RPM_BUILD_ROOT%{php_data_dir}
981a47f4
ER
109
110for config in config.php groupsConfig.php; do
111 mv $RPM_BUILD_ROOT{%{_appdir}/$config,%{_sysconfdir}}
112 ln -s %{_sysconfdir}/$config $RPM_BUILD_ROOT%{_appdir}
113done
114
3e524d3a
ER
115cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
116cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
ab52a567 117cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
981a47f4
ER
118
119%triggerin -- apache1 < 1.3.37-3, apache1-base
120%webapp_register apache %{_webapp}
121
122%triggerun -- apache1 < 1.3.37-3, apache1-base
123%webapp_unregister apache %{_webapp}
124
ab52a567 125%triggerin -- apache < 2.2.0, apache-base
981a47f4
ER
126%webapp_register httpd %{_webapp}
127
ab52a567 128%triggerun -- apache < 2.2.0, apache-base
981a47f4
ER
129%webapp_unregister httpd %{_webapp}
130
131%triggerin -- lighttpd
132%webapp_register lighttpd %{_webapp}
133
134%triggerun -- lighttpd
135%webapp_unregister lighttpd %{_webapp}
136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%preun
141if [ "$1" = 0 ]; then
142 echo %{cachedir}/* | xargs rm -rf
143fi
144
145%files
146%defattr(644,root,root,755)
147%doc *.txt
148%dir %attr(750,root,http) %{_sysconfdir}
149%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
150%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
151%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
152%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
153%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/groupsConfig.php
154%dir %{_appdir}
155%{_appdir}/*.php
156
157%dir %attr(771,root,http) %{cachedir}
158
159%files builder
160%defattr(644,root,root,755)
161%{_appdir}/builder
162
163%files -n php-%{name}
164%defattr(644,root,root,755)
165%dir %{php_data_dir}/HTTP
166%{php_data_dir}/HTTP/ConditionalGet.php
167%{php_data_dir}/HTTP/Encoder.php
51765038 168%{php_data_dir}/DooDigestAuth.php
981a47f4
ER
169%{php_data_dir}/JSMin.php
170%{php_data_dir}/JSMinPlus.php
171%{php_data_dir}/Minify.php
172%{php_data_dir}/Minify
This page took 0.051375 seconds and 4 git commands to generate.