]> git.pld-linux.org Git - packages/curl.git/commitdiff
- rel 3; revert additional SSL freeing since it will harm other openssl users; will... auto/th/curl-7.49.1-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 6 Jul 2016 11:44:58 +0000 (13:44 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 6 Jul 2016 11:44:58 +0000 (13:44 +0200)
curl-revert-ssl-freeing.patch [new file with mode: 0644]
curl.spec

diff --git a/curl-revert-ssl-freeing.patch b/curl-revert-ssl-freeing.patch
new file mode 100644 (file)
index 0000000..29cdbb6
--- /dev/null
@@ -0,0 +1,30 @@
+
+This patch reverts:
+
+commit 3caaeffbe8ded4deaeb946d23631b04507bee408
+Author: Jay Satiro <raysatiro@yahoo.com>
+Date:   Fri May 20 16:44:01 2016 -0400
+
+    openssl: cleanup must free compression methods
+    
+    - Free compression methods if OpenSSL 1.0.2 to avoid a memory leak.
+    
+    Bug: https://github.com/curl/curl/issues/817
+    Reported-by: jveazey@users.noreply.github.com
+
+diff --git b/lib/vtls/openssl.c a/lib/vtls/openssl.c
+index 3a4bde5..6e3335e 100644
+--- b/lib/vtls/openssl.c
++++ a/lib/vtls/openssl.c
+@@ -747,11 +747,6 @@ void Curl_ossl_cleanup(void)
+   /* Free all memory allocated by all configuration modules */
+   CONF_modules_free();
+-
+-#if OPENSSL_VERSION_NUMBER >= 0x10002003L && \
+-    OPENSSL_VERSION_NUMBER <= 0x10002FFFL
+-  SSL_COMP_free_compression_methods();
+-#endif
+ }
+ /*
index d34b8d98ae3da57df18d61e8a3ab3d90de28945d..15a843e081d9fb5e3346e4449edd0541a88943f1 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -23,13 +23,14 @@ Summary(ru.UTF-8):  Утилита для получения файлов с се
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
 Version:       7.49.1
-Release:       2
+Release:       3
 License:       MIT-like
 Group:         Applications/Networking
 Source0:       https://curl.haxx.se/download/%{name}-%{version}.tar.lzma
 # Source0-md5: ae5e5e395da413d1fa0864e1d0a3fa57
 Patch0:                %{name}-ac.patch
 Patch1:                %{name}-krb5flags.patch
+Patch2:                curl-revert-ssl-freeing.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
@@ -215,6 +216,7 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %{__rm} m4/lt*.m4 m4/libtool.m4
 
This page took 0.422603 seconds and 4 git commands to generate.