]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- rel 3; revert additional SSL freeing since it will harm other openssl users; will...
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssh             # SSH support
4 %bcond_without  ssl             # SSL support
5 %bcond_with     gnutls          # GnuTLS instead of OpenSSL
6 %bcond_without  kerberos5       # Heimdal Kerberos 5 support
7 %bcond_without  ldap            # LDAP support
8 %bcond_without  http2           # HTTP/2.0 support (nghttp2 based)
9 %bcond_without  metalink        # metalink support
10 %if "%{pld_release}" != "ac"
11 %bcond_without  ares            # c-ares (asynchronous DNS operations) library support
12 %bcond_without  rtmp            # Real Time Media Protocol support
13 %else
14 %bcond_with     ares            # c-ares (asynchronous DNS operations) library support
15 %bcond_with     rtmp            # Real Time Media Protocol support
16 %endif
17
18 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
19 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
20 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
21 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
22 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
23 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
24 Name:           curl
25 Version:        7.49.1
26 Release:        3
27 License:        MIT-like
28 Group:          Applications/Networking
29 Source0:        https://curl.haxx.se/download/%{name}-%{version}.tar.lzma
30 # Source0-md5:  ae5e5e395da413d1fa0864e1d0a3fa57
31 Patch0:         %{name}-ac.patch
32 Patch1:         %{name}-krb5flags.patch
33 Patch2:         curl-revert-ssl-freeing.patch
34 URL:            http://curl.haxx.se/
35 BuildRequires:  autoconf >= 2.57
36 BuildRequires:  automake
37 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
38 %{?with_kerberos5:BuildRequires:        heimdal-devel}
39 BuildRequires:  libidn-devel >= 0.4.1
40 %{?with_metalink:BuildRequires: libmetalink-devel >= 0.1.0}
41 BuildRequires:  libpsl-devel
42 %{?with_rtmp:BuildRequires:     librtmp-devel}
43 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
44 BuildRequires:  libtool
45 BuildRequires:  nettle-devel
46 %{?with_http2:BuildRequires:    nghttp2-devel >= 1.9.0}
47 %{?with_ldap:BuildRequires:     openldap-devel}
48 BuildRequires:  pkgconfig
49 BuildRequires:  rpm >= 4.4.9-56
50 BuildRequires:  rpmbuild(macros) >= 1.527
51 %if %{with ssl}
52 %if %{with gnutls}
53 BuildRequires:  gnutls-devel
54 %else
55 BuildRequires:  openssl-devel >= 1.0.1
56 %endif
57 %endif
58 BuildRequires:  tar >= 1:1.22
59 BuildRequires:  zlib-devel
60 Requires:       %{name}-libs = %{version}-%{release}
61 Requires:       libidn >= 0.4.1
62 Obsoletes:      libcurl2
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 cURL is a tool for getting files with URL syntax, supporting FTP,
67 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
68 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
69 cookies, user+password authentication and a busload of other useful
70 tricks. The main use for curl is when you want to get or send files
71 automatically to or from a site using one of the supported protocols.
72
73 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
74 Dict servers, using any of the supported protocols. cURL is designed
75 to work without user interaction or any kind of interactivity. cURL
76 offers many useful capabilities, like proxy support, user
77 authentication, FTP upload, HTTP post, and file transfer resume.
78
79 %description -l pl.UTF-8
80 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
81 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
82 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
83 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
84 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
85 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
86 pliki z/na serwer używając jednego z dostępnych protokołów.
87 %{?with_ssl:Ten pakiet obsługuje także SSL.}
88
89 %description -l pt_BR.UTF-8
90 Curl é um cliente para baixar/enviar arquivos de/para servidores
91 usando um dos protocolos suportados. É projetado para funcionar sem a
92 interação do usuário.
93
94 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
95 continuar transferências interrompidas, e mais...
96
97 %description -l ru.UTF-8
98 curl - это клиент с множеством поддерживаемых протоколов для получения
99 файлов с серверов, спроектированный для работы как в неинтерактивном
100 режиме, так и с возможностью диалога с пользователем.
101
102 curl поддерживает много полезных возможностей, среди которых поддержка
103 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
104 POST, восстановление прерванной пересылки и многое другое.
105
106 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
107 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
108 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
109
110 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
111 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
112 в╕дновлення перервано╖ пересилки та багато ╕ншого.
113
114 %package libs
115 Summary:        curl library
116 Summary(pl.UTF-8):      Biblioteka curl
117 Group:          Libraries
118 %{?with_ares:Requires:  c-ares >= 1.7.0}
119 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
120 %{?with_http2:Requires: nghttp2 >= 1.9.0}
121 %if %{with ssl} && %{without gnutls}
122 Requires:       openssl >= 1.0.1
123 %endif
124 Suggests:       ca-certificates
125 Conflicts:      ca-certificates < 20080809-4
126
127 %description libs
128 curl library.
129
130 %description libs -l pl.UTF-8
131 Biblioteka curl.
132
133 %package devel
134 Summary:        Header files and development documentation for curl library
135 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
136 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
137 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
138 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
139 Group:          Development/Libraries
140 Requires:       %{name}-libs = %{version}-%{release}
141 %{?with_ares:Requires:  c-ares-devel}
142 %{?with_kerberos5:Requires:     heimdal-devel}
143 Requires:       libidn-devel >= 0.4.1
144 Requires:       libpsl-devel
145 %{?with_rtmp:Requires:  librtmp-devel}
146 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
147 %{?with_http2:Requires: nghttp2-devel >= 1.9.0}
148 %{?with_ldap:Requires:  openldap-devel}
149 %if %{with ssl}
150 %if %{with gnutls}
151 Requires:       gnutls-devel
152 %else
153 Requires:       openssl-devel >= 0.9.7c
154 %endif
155 %endif
156 Requires:       zlib-devel
157 Obsoletes:      libcurl2-devel
158
159 %description devel
160 Header files and development documentation for curl library.
161
162 %description devel -l pl.UTF-8
163 Pliki nagłówkowe i dokumentacja do biblioteki curl.
164
165 %description devel -l pt_BR.UTF-8
166 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
167
168 %description devel -l ru.UTF-8
169 Этот пакет содержит файлы, необходимые для разработки программ с
170 использованием библиотеки curl.
171
172 %description devel -l uk.UTF-8
173 Цей пакет містить файли, необхідні для розробки програм з
174 використанням бібліотеки curl.
175
176 %package static
177 Summary:        Static version of curl library
178 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
179 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
180 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
181 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
182 Group:          Development/Libraries
183 Requires:       %{name}-devel = %{version}-%{release}
184
185 %description static
186 Static version of curl library.
187
188 %description static -l pl.UTF-8
189 Statyczna wersja biblioteki curl.
190
191 %description static -l pt_BR.UTF-8
192 Bibliotecas estáticas para desenvolvimento com o curl.
193
194 %description static -l ru.UTF-8
195 Этот пакет содержит статическую библиотеку для разработки программ с
196 использованием библиотеки curl.
197
198 %description static -l uk.UTF-8
199 Цей пакет містить статичну бібліотеку для розробки програм з
200 використанням бібліотеки curl.
201
202 %package -n zsh-completion-curl
203 Summary:        ZSH completion for curl command
204 Summary(pl.UTF-8):      Dopełnianianie parametrów w ZSH dla polecenia curl
205 Group:          Applications/Shells
206 Requires:       %{name} = %{version}-%{release}
207 Requires:       zsh
208
209 %description -n zsh-completion-curl
210 ZSH completion for curl command.
211
212 %description -n zsh-completion-curl -l pl.UTF-8
213 Dopełnianianie parametrów w ZSH dla polecenia curl.
214
215 %prep
216 %setup -q
217 %patch0 -p1
218 %patch1 -p1
219 %patch2 -p1
220
221 %{__rm} m4/lt*.m4 m4/libtool.m4
222
223 %build
224 %{__libtoolize}
225 %{__aclocal} -I m4
226 %{__autoconf}
227 %{__autoheader}
228 %{__automake}
229 %configure \
230         ac_cv_header_gss_h=no \
231         %{__enable_disable ares} \
232         --enable-ipv6 \
233         %{__enable_disable ldap} \
234         %{__enable_disable ldap ldaps} \
235         --disable-silent-rules \
236 %if %{with ssl}
237         --with-ca-bundle=/etc/certs/ca-certificates.crt \
238 %if %{with gnutls}
239         --with-gnutls --without-ssl \
240 %else
241         --with-ssl=%{_prefix} \
242 %endif
243 %endif
244         %{__with_without kerberos5 gssapi %{_prefix}} \
245         %{__with_without metalink libmetalink} \
246         %{__with_without rtmp librtmp} \
247         %{__with_without http2 nghttp2} \
248         %{__with_without ssh libssh2}
249
250 %{__make}
251
252 %install
253 rm -rf $RPM_BUILD_ROOT
254 %{__make} install \
255         DESTDIR=$RPM_BUILD_ROOT
256
257 %{__make} -C scripts install \
258         DESTDIR=$RPM_BUILD_ROOT
259
260 # no longer in upstream but a lot of apps tries to include it so we create fake one
261 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
262 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
263
264 %clean
265 rm -rf $RPM_BUILD_ROOT
266
267 %post   libs -p /sbin/ldconfig
268 %postun libs -p /sbin/ldconfig
269
270 %files
271 %defattr(644,root,root,755)
272 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
273 %attr(755,root,root) %{_bindir}/curl
274 %{_mandir}/man1/curl.1*
275
276 %files libs
277 %defattr(644,root,root,755)
278 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
279 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
280
281 %files devel
282 %defattr(644,root,root,755)
283 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
284 %attr(755,root,root) %{_bindir}/curl-config
285 %attr(755,root,root) %{_libdir}/libcurl.so
286 %{_libdir}/libcurl.la
287 %{_includedir}/curl
288 %{_pkgconfigdir}/libcurl.pc
289 %{_aclocaldir}/libcurl.m4
290 %{_mandir}/man1/curl-config.1*
291 %{_mandir}/man3/curl_*.3*
292 %{_mandir}/man3/libcurl*.3*
293 %{_mandir}/man3/CURLINFO_*.3*
294 %{_mandir}/man3/CURLOPT_*.3*
295 %{_mandir}/man3/CURLMOPT_*.3*
296
297 %files static
298 %defattr(644,root,root,755)
299 %{_libdir}/libcurl.a
300
301 %files -n zsh-completion-curl
302 %defattr(644,root,root,755)
303 %{_datadir}/zsh/site-functions/_curl
This page took 0.068606 seconds and 3 git commands to generate.