]> git.pld-linux.org Git - packages/FHS.git/blob - FHS.spec
- Added %{_datadir}/{icons,pixmaps}
[packages/FHS.git] / FHS.spec
1 Summary:        Basic FHS 2.3 filesystem layout
2 Summary(de):    Grundlegende Dateisystemstruktur
3 Summary(fr):    Arborescence de base du système de fichiers
4 Summary(pl):    Podstawowy uk³ad katalogów systemu Linux zgodny z FHS 2.3
5 Summary(tr):    Temel dosya sistemi yapýsý
6 Name:           FHS
7 Version:        2.3
8 Release:        15
9 License:        GPL
10 Group:          Base
11 URL:            http://www.pathname.com/fhs/
12 BuildRequires:  rpmbuild(macros) >= 1.213
13 Requires:       setup >= 2.4.6-4
14 Provides:       filesystem
15 Obsoletes:      filesystem
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _locmandir      /usr/local/man
19 # directory for "privilege separation" chroot
20 %define         _privsepdir     /usr/share/empty
21 # directory for *.idl files (for CORBA implementations)
22 %define         _idldir         /usr/share/idl
23
24 %description
25 This package contains the basic directory layout for a Linux system,
26 including the proper permissions for the directories. This layout
27 conforms to the Filesystem Hierarchy Standard (FHS) 2.3.
28
29 %description -l de
30 Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
31 Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
32 Struktur entspricht dem Filesystem Hierarchy Standard (FHS) 2.3.
33
34 %description -l fr
35 Ce package contient l'arborescence type pour système Linux y compris
36 les permissions adéquates pour les répertoires. Cette arborescence est
37 conforme au standard "Filesystem Hierarchy Standard" (FHS) 2.3.
38
39 %description -l pl
40 Pakiet ten zawiera informacje o podstawowej strukturze katalogów
41 systemu i praw dostêpu do nich. Struktura katalogów jest zgodna z FHS
42 2.3.
43
44 %description -l tr
45 Bu paket GNU makro iþleme dilini içerir. Mantýksal olarak
46 ayrýþtýrýlabilen metin dosyalarý yazýmý için yararlýdýr.
47
48 %prep
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT/{bin,boot,initrd,dev,etc,home/{users,services},opt,selinux,srv,sys} \
54         $RPM_BUILD_ROOT%{_sysconfdir}/{X11,certs,opt,security} \
55         $RPM_BUILD_ROOT{/lib/{firmware,modules},/%{_lib}/security} \
56         $RPM_BUILD_ROOT/{mnt,media/{cdrom,floppy},proc,root,sbin,tmp} \
57         $RPM_BUILD_ROOT%{_prefix}/{bin,games,include/security,lib/cgi-bin,sbin,share,src/examples} \
58         $RPM_BUILD_ROOT%{_datadir}/{applications,dict,doc,games,icons,info,misc,pixmaps,tmac} \
59         $RPM_BUILD_ROOT%{_libdir}/games \
60         $RPM_BUILD_ROOT%{_prefix}/local/{bin,etc,games,include,lib,sbin,share/{doc,info},src} \
61         $RPM_BUILD_ROOT/var/{lock/subsys,log,mail,run,spool} \
62         $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/misc,local,opt,tmp} \
63         $RPM_BUILD_ROOT%{_idldir} \
64         $RPM_BUILD_ROOT%{_fontsdir}/{100,75}dpi \
65         $RPM_BUILD_ROOT%{_fontsdir}/OTF \
66         $RPM_BUILD_ROOT%{_fontsdir}/Speedo \
67         $RPM_BUILD_ROOT%{_fontsdir}/Type1/{afm,pfm} \
68         $RPM_BUILD_ROOT%{_fontsdir}/TTF \
69         $RPM_BUILD_ROOT%{_fontsdir}/cyrillic \
70         $RPM_BUILD_ROOT%{_fontsdir}/local \
71         $RPM_BUILD_ROOT%{_fontsdir}/misc \
72         $RPM_BUILD_ROOT%{_privsepdir}
73
74 %ifarch %{x8664} ppc64 s390x sparc64
75 install -d $RPM_BUILD_ROOT{/lib64,%{_prefix}/lib64,%{_prefix}/local/lib64}
76 %endif
77
78 for manp in man{1,2,3,4,5,6,7,8} ; do
79         install -d $RPM_BUILD_ROOT%{_mandir}/${manp}
80         install -d $RPM_BUILD_ROOT%{_locmandir}/${manp}
81         for mloc in bg cs da de el es fi fr gl hr hu id it ja ko nl pl pt \
82                     pt_BR ro ru sk sl sr sv tr uk zh_CN zh_TW ; do
83                 install -d $RPM_BUILD_ROOT%{_mandir}/${mloc}/${manp}
84         done
85 done
86 install -d $RPM_BUILD_ROOT%{_mandir}/man{n,l}
87 install -d $RPM_BUILD_ROOT%{_mandir}/pl/mann
88
89 ln -sf ../man $RPM_BUILD_ROOT/usr/local/share/man
90
91 %clean
92 cd $RPM_BUILD_ROOT
93
94 # %{_rpmfilename} is not expanded, so use
95 # %{name}-%{version}-%{release}.%{buildarch}.rpm
96 RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
97 TMPFILE=%{name}-%{version}.tmp$$
98 find . | sed -e 's|^\.||g' -e 's|^$||g' | sort | grep -v $TMPFILE > $TMPFILE
99
100 # find finds also '.', so use option -B for diff
101 if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | sort | diff -uB $TMPFILE - ; then
102         rm -rf $RPM_BUILD_ROOT
103 else
104         echo -e "\nNot so good, some directories are not included in package\n"
105         exit 1;
106 fi
107
108 %files
109 %defattr(644,root,root,755)
110 %dir /
111 /bin
112 /boot
113 /initrd
114 /dev
115 %dir /etc
116 %dir %{_sysconfdir}/X11
117 %attr(751,root,root) %dir /etc/certs
118 %dir %{_sysconfdir}/opt
119 %attr(751,root,root) %dir /etc/security
120 %dir /home
121 /home/users
122 %attr(751,root,adm) /home/services
123 /lib
124 %attr(775,root,disk) %dir /media
125 %attr(775,root,disk) /media/floppy
126 %attr(775,root,disk) /media/cdrom
127 /mnt
128 /opt
129 %attr(555,root,proc) %verify(not group) /proc
130 %attr(700,root,root) /root
131 %dir /sbin
132 %dir /sys
133 %dir /selinux
134 %attr(751,root,root) /srv
135 %attr(1777,root,root) /tmp
136 %dir %{_prefix}
137 %{_prefix}/bin
138 %{_prefix}/games
139 %{_prefix}/include
140 %{_prefix}/lib
141 %{_prefix}/sbin
142 %dir %{_prefix}/share
143 %{_datadir}/applications
144 %{_datadir}/dict
145 %{_datadir}/doc
146 %{_privsepdir}
147 %{_fontsdir}
148 %{_idldir}
149 %{_datadir}/games
150 %{_datadir}/icons
151 %{_datadir}/info
152 %dir %{_mandir}
153 %dir %{_mandir}/man*
154 %lang(bg) %{_mandir}/bg
155 %lang(cs) %{_mandir}/cs
156 %lang(da) %{_mandir}/da
157 %lang(de) %{_mandir}/de
158 %lang(el) %{_mandir}/el
159 %lang(es) %{_mandir}/es
160 %lang(fi) %{_mandir}/fi
161 %lang(fr) %{_mandir}/fr
162 %lang(gl) %{_mandir}/gl
163 %lang(hr) %{_mandir}/hr
164 %lang(hu) %{_mandir}/hu
165 %lang(id) %{_mandir}/id
166 %lang(it) %{_mandir}/it
167 %lang(ja) %{_mandir}/ja
168 %lang(ko) %{_mandir}/ko
169 %lang(nl) %{_mandir}/nl
170 %lang(pl) %{_mandir}/pl
171 %lang(pt) %{_mandir}/pt
172 %lang(pt_BR) %{_mandir}/pt_BR
173 %lang(ro) %{_mandir}/ro
174 %lang(ru) %{_mandir}/ru
175 %lang(sl) %{_mandir}/sl
176 %lang(sk) %{_mandir}/sk
177 %lang(sr) %{_mandir}/sr
178 %lang(sv) %{_mandir}/sv
179 %lang(tr) %{_mandir}/tr
180 %lang(uk) %{_mandir}/uk
181 %lang(zh_CN) %{_mandir}/zh_CN
182 %lang(zh_TW) %{_mandir}/zh_TW
183 %{_datadir}/misc
184 %{_datadir}/pixmaps
185 %{_datadir}/tmac
186 %dir %{_prefix}/lib/cgi-bin
187 %{_prefix}/src
188 %dir %{_prefix}/local
189 %{_prefix}/local/bin
190 %{_prefix}/local/etc
191 %{_prefix}/local/games
192 %{_prefix}/local/include
193 %{_prefix}/local/lib
194 %{_prefix}/local/sbin
195 %dir %{_prefix}/local/share
196 %{_prefix}/local/share/doc
197 %{_prefix}/local/share/man
198 %{_prefix}/local/share/info
199 %{_locmandir}
200 %{_prefix}/local/src
201 %dir /var
202 /var/cache
203 %dir /var/crash
204 %dir /var/db
205 %dir /var/games
206 %dir /var/lib
207 %dir /var/lib/misc
208 %dir /var/local
209 %attr(1771,root,uucp) %dir /var/lock
210 %attr(700,root,root) %dir /var/lock/subsys
211 %attr(751,root,root) /var/log
212 %attr(2775,root,mail) /var/mail
213 %dir /var/opt
214 %dir /var/run
215 %dir /var/spool
216 %attr(1777,root,root) %dir /var/tmp
217
218 %ifarch ppc64 sparc64 x86_64
219 /lib64
220 %{_prefix}/lib64
221 %{_prefix}/local/lib64
222 %endif
This page took 0.053747 seconds and 4 git commands to generate.