]> git.pld-linux.org Git - packages/FHS.git/blob - FHS.spec
- pl for -debug
[packages/FHS.git] / FHS.spec
1 # NOTE
2 # - don't use %{_*dir} macros for paths defined by FHS
3 # - do not add any dependencies to this pkg, FHS should be the first package being installed
4 # - do not use any other user/group than "root", as then we have to depend on "setup" package.
5 #   But: root %attr+chown in %post means integrity verification (rpm -V) error.
6 #   Maybe use non-root %attr+numeric chown in %post (without setup dependency)? The only disadvantage
7 #   seems to be a warning message on install.
8 Summary:        Basic FHS 3.0 filesystem layout
9 Summary(de.UTF-8):      Grundlegende Dateisystemstruktur
10 Summary(fr.UTF-8):      Arborescence de base du système de fichiers
11 Summary(pl.UTF-8):      Podstawowy układ katalogów systemu Linux zgodny z FHS 3.0
12 Summary(tr.UTF-8):      Temel dosya sistemi yapısı
13 Name:           FHS
14 Version:        3.0
15 Release:        7
16 License:        GPL
17 Group:          Base
18 URL:            http://refspecs.linuxfoundation.org/fhs.shtml
19 # list of languages for localized man pages directories
20 Source0:        locale-dirs
21 BuildRequires:  mktemp
22 BuildRequires:  rpmbuild(macros) >= 1.213
23 Conflicts:      setup < 2.7
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # nothing to put there
27 %define         _enable_debug_packages  0
28
29 %if "%{_lib}" == "lib64"
30 %define         with_lib64      1
31 %endif
32 %if "%{_lib}" == "libx32"
33 %define         with_libx32     1
34 %define         with_lib64      1
35 %else
36 %ifarch %{x8664}
37 # x32 as additional ABI
38 %define         with_libx32     1
39 %endif
40 %endif
41
42 # avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
43 %define         __spec_clean_body       %{nil}
44
45 # doesn't contain any files, but we're not noarch package
46 %define         no_install_post_strip   1
47 %define         no_install_post_chrpath 1
48 %define         no_install_post_compress_modules        1
49
50 # we have to use numeric uids/groups. see comment above
51 %define         gid_uucp        14
52 %define         gid_mail        12
53
54 %description
55 This package contains the basic directory layout for a Linux system,
56 including the proper permissions for the directories. This layout
57 conforms to the Filesystem Hierarchy Standard (FHS) %{version}.
58
59 %description -l de.UTF-8
60 Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
61 Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
62 Struktur entspricht dem Filesystem Hierarchy Standard (FHS) %{version}.
63
64 %description -l fr.UTF-8
65 Ce package contient l'arborescence type pour système Linux y compris
66 les permissions adéquates pour les répertoires. Cette arborescence est
67 conforme au standard "Filesystem Hierarchy Standard" (FHS) %{version}.
68
69 %description -l pl.UTF-8
70 Pakiet ten zawiera informacje o podstawowej strukturze katalogów
71 systemu i praw dostępu do nich. Struktura katalogów jest zgodna z FHS
72 %{version}.
73
74 %package debug
75 Summary:        Debug information directory hierarchy
76 Summary(pl.UTF-8):      Hierarchia katalogów dla informacji diagnostycznych
77 Group:          Development/Debug
78
79 %description debug
80 This package provides directory hierarchy for debug information
81 contained in debuginfo rpm packages.
82
83 %description debug -l pl.UTF-8
84 Ten pakiet dostarcza hierarchię katalogów dla zawarych w pakietach
85 RPM debuginfo informacji pozwalających na śledzenie programów.
86
87 %prep
88 %setup -qcT
89 cp -p %{SOURCE0} .
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 install -d \
95         $RPM_BUILD_ROOT/{bin,boot,dev,etc,home,opt,run,srv,sys} \
96         $RPM_BUILD_ROOT/etc/{X11,opt} \
97         $RPM_BUILD_ROOT/lib/modules \
98         $RPM_BUILD_ROOT/{mnt,media,proc,root/tmp,sbin,tmp} \
99         $RPM_BUILD_ROOT/usr/{bin,games,include,lib,libexec,sbin,share,src} \
100         $RPM_BUILD_ROOT/usr/share/{color/icc,dict,doc,games,info,misc,ppd,tmac,xml} \
101         $RPM_BUILD_ROOT/usr/lib/games \
102         $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,libexec,sbin,share/{color/icc,doc,info,man},src} \
103         $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/{color/icc,misc},local,lock,log,mail,opt,run,spool,tmp,yp}
104
105 %if %{with lib64}
106 install -d $RPM_BUILD_ROOT{/lib64,/usr/lib64/games,/usr/local/lib64}
107 %endif
108 %if %{with libx32}
109 install -d $RPM_BUILD_ROOT{/libx32,/usr/libx32/games,/usr/local/libx32}
110 %endif
111
112 install -d $RPM_BUILD_ROOT/usr/share/man/man{1,2,3,4,5,6,7,8}
113 install -d $RPM_BUILD_ROOT/usr/local/share/man/man{1,2,3,4,5,6,7,8}
114
115 for i in $(seq 0 255); do
116         install -d "$RPM_BUILD_ROOT$(printf '/usr/lib/.build-id/%02x' $i)"
117 done
118
119 > %{name}.lang
120 for mloc in $(cat locale-dirs); do
121         echo "%%lang($mloc) %dir /usr/share/man/${mloc}" >> %{name}.lang
122         for manp in man{1,2,3,4,5,6,7,8}; do
123                 install -d $RPM_BUILD_ROOT/usr/share/man/${mloc}/${manp}
124                 echo "%%lang($mloc) %dir /usr/share/man/${mloc}/${manp}" >> %{name}.lang
125         done
126 done
127
128 %clean
129 cd $RPM_BUILD_ROOT
130
131 check_filesystem_dirs() {
132         RPMFILES="%{_rpmdir}/%{name}-%{version}-%{release}.%{_target_cpu}.rpm %{_rpmdir}/%{name}-debug-%{version}-%{release}.%{_target_cpu}.rpm"
133         TMPFILE=$(mktemp)
134         find | sed -e 's|^\.||g' -e '/^$/d' | LC_ALL=C sort > $TMPFILE
135
136         if rpm -qpl $RPMFILES | grep -v '^/$' | LC_ALL=C sort | diff -u $TMPFILE - ; then
137                 rm -rf $RPM_BUILD_ROOT
138         else
139                 echo -e "\nNot so good, some directories are not included in package\n"
140                 exit 1
141         fi
142         rm -f $TMPFILE
143 }
144 check_filesystem_dirs
145
146 %pretrans -p <lua>
147 st = posix.stat("/usr/local/share/man")
148 if st and st.type == "link" then
149     os.remove("/usr/local/share/man")
150 end
151
152 %post -p <lua>
153 --# XXX: it is 2009, what uucp?! but we use /var/lock/subsys, so change it just to root?
154 posix.chown("/var/mail", 0, %{gid_mail})
155 posix.chown("/var/lock", 0, %{gid_uucp})
156
157 %files -f %{name}.lang
158 %defattr(644,root,root,755)
159 %dir /
160 %dir /bin
161 %dir /boot
162 %dir /dev
163 %dir /etc
164 %dir /etc/X11
165 %dir /etc/opt
166 %dir /home
167 %dir /lib
168 %dir /lib/modules
169 %dir /media
170 %dir /mnt
171 %dir /opt
172 %dir %attr(555,root,root) %verify(not group) /proc
173 %dir %attr(700,root,root) /root
174 %dir %attr(700,root,root) /root/tmp
175 %dir /run
176 %dir /sbin
177 %dir %attr(755,root,root) /srv
178 %dir %attr(555,root,root) /sys
179 %dir %attr(1777,root,root) /tmp
180 %dir /usr
181 %dir /usr/bin
182 %dir /usr/games
183 %dir /usr/include
184 %dir /usr/lib
185 %dir /usr/libexec
186 %dir /usr/lib/games
187 %dir /usr/sbin
188 %dir /usr/share
189 %dir /usr/share/color
190 %dir /usr/share/color/icc
191 %dir /usr/share/dict
192 %dir /usr/share/doc
193 %dir /usr/share/games
194 %dir /usr/share/info
195 %dir /usr/share/man
196 %dir /usr/share/man/man[1-8]
197 %dir /usr/share/misc
198 %dir /usr/share/ppd
199 %dir /usr/share/tmac
200 %dir /usr/share/xml
201 %dir /usr/src
202 %dir /usr/local
203 %dir /usr/local/bin
204 %dir /usr/local/etc
205 %dir /usr/local/games
206 %dir /usr/local/include
207 %dir /usr/local/lib
208 %dir /usr/local/libexec
209 %dir /usr/local/sbin
210 %dir /usr/local/share
211 %dir /usr/local/share/color
212 %dir /usr/local/share/color/icc
213 %dir /usr/local/share/doc
214 %dir /usr/local/share/info
215 %dir /usr/local/share/man
216 %dir /usr/local/share/man/man[1-8]
217 %dir /usr/local/src
218 %dir /var
219 %dir /var/cache
220 %dir /var/crash
221 %dir /var/db
222 %dir /var/games
223 %dir /var/lib
224 %dir /var/lib/color
225 %dir /var/lib/color/icc
226 %dir /var/lib/misc
227 %dir /var/local
228 %dir %attr(1771,root,root) /var/lock
229 %dir %attr(751,root,root) /var/log
230 %dir %attr(2775,root,root) /var/mail
231 %dir /var/opt
232 %dir /var/run
233 %dir /var/spool
234 %dir /var/yp
235 %dir %attr(1777,root,root) /var/tmp
236 %if %{with lib64}
237 %dir /lib64
238 %dir /usr/lib64
239 %dir /usr/lib64/games
240 %dir /usr/local/lib64
241 %endif
242 %if %{with libx32}
243 %dir /libx32
244 %dir /usr/libx32
245 %dir /usr/libx32/games
246 %dir /usr/local/libx32
247 %endif
248
249 %files debug
250 %defattr(644,root,root,755)
251 %dir /usr/lib/.build-id
252 %dir /usr/lib/.build-id/[0-9a-f][0-9a-f]
This page took 0.10738 seconds and 4 git commands to generate.