]> git.pld-linux.org Git - packages/FHS.git/blob - FHS.spec
- more font dirs for modular xorg.
[packages/FHS.git] / FHS.spec
1 Summary:        Basic FHS 2.3 filesystem layout
2 Summary(de):    Grundlegende Dateisystemstruktur
3 Summary(fr):    Arborescence de base du système de fichiers
4 Summary(pl):    Podstawowy uk³ad katalogów systemu Linux zgodny z FHS 2.3
5 Summary(tr):    Temel dosya sistemi yapýsý
6 Name:           FHS
7 Version:        2.3
8 Release:        14
9 License:        GPL
10 Group:          Base
11 URL:            http://www.pathname.com/fhs/
12 BuildRequires:  rpmbuild(macros) >= 1.213
13 Requires:       setup >= 2.4.6-4
14 Provides:       filesystem
15 Obsoletes:      filesystem
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _locmandir      /usr/local/man
19 %define         _xmandir        /usr/X11R6/man
20 # directory for "privilege separation" chroot
21 %define         _privsepdir     /usr/share/empty
22 # directory for *.idl files (for CORBA implementations)
23 %define         _idldir         /usr/share/idl
24
25 %description
26 This package contains the basic directory layout for a Linux system,
27 including the proper permissions for the directories. This layout
28 conforms to the Filesystem Hierarchy Standard (FHS) 2.3.
29
30 %description -l de
31 Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
32 Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
33 Struktur entspricht dem Filesystem Hierarchy Standard (FHS) 2.3.
34
35 %description -l fr
36 Ce package contient l'arborescence type pour système Linux y compris
37 les permissions adéquates pour les répertoires. Cette arborescence est
38 conforme au standard "Filesystem Hierarchy Standard" (FHS) 2.3.
39
40 %description -l pl
41 Pakiet ten zawiera informacje o podstawowej strukturze katalogów
42 systemu i praw dostêpu do nich. Struktura katalogów jest zgodna z FHS
43 2.3.
44
45 %description -l tr
46 Bu paket GNU makro iþleme dilini içerir. Mantýksal olarak
47 ayrýþtýrýlabilen metin dosyalarý yazýmý için yararlýdýr.
48
49 %prep
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 install -d $RPM_BUILD_ROOT/{bin,boot,initrd,dev,etc,home/{users,services},opt,selinux,srv,sys} \
55         $RPM_BUILD_ROOT%{_sysconfdir}/{X11,certs,opt,security} \
56         $RPM_BUILD_ROOT{/lib/{firmware,modules},/%{_lib}/security} \
57         $RPM_BUILD_ROOT/{mnt,media/{cdrom,floppy},proc,root,sbin,tmp} \
58         $RPM_BUILD_ROOT%{_prefix}/{bin,games,include/security,lib/cgi-bin,sbin,share,src/examples} \
59         $RPM_BUILD_ROOT%{_datadir}/{applications,dict,doc,games,info,misc,tmac} \
60         $RPM_BUILD_ROOT%{_libdir}/games \
61         $RPM_BUILD_ROOT%{_prefix}/local/{bin,etc,games,include,lib,sbin,share/{doc,info},src} \
62         $RPM_BUILD_ROOT/var/{lock/subsys,log,mail,run,spool} \
63         $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/misc,local,opt,tmp} \
64         $RPM_BUILD_ROOT%{_idldir} \
65         $RPM_BUILD_ROOT%{_fontsdir}/{100,75}dpi \
66         $RPM_BUILD_ROOT%{_fontsdir}/OTF \
67         $RPM_BUILD_ROOT%{_fontsdir}/Speedo \
68         $RPM_BUILD_ROOT%{_fontsdir}/Type1/{afm,pfm} \
69         $RPM_BUILD_ROOT%{_fontsdir}/TTF \
70         $RPM_BUILD_ROOT%{_fontsdir}/cyrillic \
71         $RPM_BUILD_ROOT%{_fontsdir}/local \
72         $RPM_BUILD_ROOT%{_fontsdir}/misc \
73         $RPM_BUILD_ROOT%{_privsepdir} \
74         $RPM_BUILD_ROOT/usr/X11R6/share
75
76 %ifarch %{x8664} ppc64 s390x sparc64
77 install -d $RPM_BUILD_ROOT{/lib64,%{_prefix}/lib64,%{_prefix}/local/lib64}
78 %endif
79
80 for manp in man{1,2,3,4,5,6,7,8} ; do
81         install -d $RPM_BUILD_ROOT%{_mandir}/${manp}
82         install -d $RPM_BUILD_ROOT%{_locmandir}/${manp}
83         install -d $RPM_BUILD_ROOT%{_xmandir}/${manp}
84         for mloc in bg cs da de el es fi fr gl hr hu id it ja ko nl pl pt \
85                     pt_BR ro ru sk sl sr sv tr uk zh_CN zh_TW ; do
86                 install -d $RPM_BUILD_ROOT%{_mandir}/${mloc}/${manp}
87         done
88         for mloc in it ko pl ; do
89                 install -d $RPM_BUILD_ROOT%{_xmandir}/${mloc}/${manp}
90         done
91 done
92 install -d $RPM_BUILD_ROOT%{_mandir}/man{n,l}
93 install -d $RPM_BUILD_ROOT%{_mandir}/pl/mann
94
95 ln -sf ../man $RPM_BUILD_ROOT/usr/local/share/man
96
97 %clean
98 cd $RPM_BUILD_ROOT
99
100 # %{_rpmfilename} is not expanded, so use
101 # %{name}-%{version}-%{release}.%{buildarch}.rpm
102 RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
103 TMPFILE=%{name}-%{version}.tmp$$
104 find . | sed -e 's|^\.||g' -e 's|^$||g' | sort | grep -v $TMPFILE > $TMPFILE
105
106 # find finds also '.', so use option -B for diff
107 if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | sort | diff -uB $TMPFILE - ; then
108         rm -rf $RPM_BUILD_ROOT
109 else
110         echo -e "\nNot so good, some directories are not included in package\n"
111         exit 1;
112 fi
113
114 %files
115 %defattr(644,root,root,755)
116 %dir /
117 /bin
118 /boot
119 /initrd
120 /dev
121 %dir /etc
122 %dir %{_sysconfdir}/X11
123 %attr(751,root,root) %dir /etc/certs
124 %dir %{_sysconfdir}/opt
125 %attr(751,root,root) %dir /etc/security
126 %dir /home
127 /home/users
128 %attr(751,root,adm) /home/services
129 /lib
130 %attr(775,root,disk) %dir /media
131 %attr(775,root,disk) /media/floppy
132 %attr(775,root,disk) /media/cdrom
133 /mnt
134 /opt
135 %attr(555,root,proc) %verify(not group) /proc
136 %attr(700,root,root) /root
137 %dir /sbin
138 %dir /sys
139 %dir /selinux
140 %attr(751,root,root) /srv
141 %attr(1777,root,root) /tmp
142 %dir %{_prefix}
143 %{_prefix}/bin
144 %{_prefix}/games
145 %{_prefix}/include
146 %{_prefix}/lib
147 %{_prefix}/sbin
148 %dir %{_prefix}/share
149 %{_datadir}/applications
150 %{_datadir}/dict
151 %{_datadir}/doc
152 %{_privsepdir}
153 %{_fontsdir}
154 %{_idldir}
155 %{_datadir}/games
156 %{_datadir}/info
157 %dir %{_mandir}
158 %dir %{_mandir}/man*
159 %lang(bg) %{_mandir}/bg
160 %lang(cs) %{_mandir}/cs
161 %lang(da) %{_mandir}/da
162 %lang(de) %{_mandir}/de
163 %lang(el) %{_mandir}/el
164 %lang(es) %{_mandir}/es
165 %lang(fi) %{_mandir}/fi
166 %lang(fr) %{_mandir}/fr
167 %lang(gl) %{_mandir}/gl
168 %lang(hr) %{_mandir}/hr
169 %lang(hu) %{_mandir}/hu
170 %lang(id) %{_mandir}/id
171 %lang(it) %{_mandir}/it
172 %lang(ja) %{_mandir}/ja
173 %lang(ko) %{_mandir}/ko
174 %lang(nl) %{_mandir}/nl
175 %lang(pl) %{_mandir}/pl
176 %lang(pt) %{_mandir}/pt
177 %lang(pt_BR) %{_mandir}/pt_BR
178 %lang(ro) %{_mandir}/ro
179 %lang(ru) %{_mandir}/ru
180 %lang(sl) %{_mandir}/sl
181 %lang(sk) %{_mandir}/sk
182 %lang(sr) %{_mandir}/sr
183 %lang(sv) %{_mandir}/sv
184 %lang(tr) %{_mandir}/tr
185 %lang(uk) %{_mandir}/uk
186 %lang(zh_CN) %{_mandir}/zh_CN
187 %lang(zh_TW) %{_mandir}/zh_TW
188 %{_datadir}/misc
189 %{_datadir}/tmac
190 %dir %{_prefix}/lib/cgi-bin
191 %{_prefix}/src
192 %dir %{_prefix}/local
193 %{_prefix}/local/bin
194 %{_prefix}/local/etc
195 %{_prefix}/local/games
196 %{_prefix}/local/include
197 %{_prefix}/local/lib
198 %{_prefix}/local/sbin
199 %dir %{_prefix}/local/share
200 %{_prefix}/local/share/doc
201 %{_prefix}/local/share/man
202 %{_prefix}/local/share/info
203 %{_locmandir}
204 %{_prefix}/local/src
205 %dir /usr/X11R6
206 %dir %{_xmandir}
207 %{_xmandir}/man*
208 %lang(it) %{_xmandir}/it
209 %lang(ko) %{_xmandir}/ko
210 %lang(pl) %{_xmandir}/pl
211 %dir /usr/X11R6/share
212
213 %dir /var
214 /var/cache
215 %dir /var/crash
216 %dir /var/db
217 %dir /var/games
218 %dir /var/lib
219 %dir /var/lib/misc
220 %dir /var/local
221 %attr(1771,root,uucp) %dir /var/lock
222 %attr(700,root,root) %dir /var/lock/subsys
223 %attr(751,root,root) /var/log
224 %attr(2775,root,mail) /var/mail
225 %dir /var/opt
226 %dir /var/run
227 %dir /var/spool
228 %attr(1777,root,root) %dir /var/tmp
229
230 %ifarch ppc64 sparc64 x86_64
231 /lib64
232 %{_prefix}/lib64
233 %{_prefix}/local/lib64
234 %endif
This page took 0.057886 seconds and 4 git commands to generate.