]> git.pld-linux.org Git - packages/FHS.git/blob - FHS.spec
drop bogus tr translation
[packages/FHS.git] / FHS.spec
1 # NOTE
2 # - don't use %{_*dir} macros for paths defined by FHS
3 # - do not add any dependencies to this pkg, FHS should be the first package being installed
4 # - do not use any other user/group than "root", as then we have to depend on "setup" package.
5 Summary:        Basic FHS 2.3 filesystem layout
6 Summary(de.UTF-8):      Grundlegende Dateisystemstruktur
7 Summary(fr.UTF-8):      Arborescence de base du système de fichiers
8 Summary(pl.UTF-8):      Podstawowy układ katalogów systemu Linux zgodny z FHS 2.3
9 Summary(tr.UTF-8):      Temel dosya sistemi yapısı
10 Name:           FHS
11 Version:        2.3
12 Release:        37
13 License:        GPL
14 Group:          Base
15 URL:            http://www.pathname.com/fhs/
16 Source0:        locale-dirs
17 BuildRequires:  mktemp
18 BuildRequires:  rpmbuild(macros) >= 1.213
19 Conflicts:      setup < 2.7
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # nothing to put there
23 %define         _enable_debug_packages  0
24
25 %if "%{_lib}" == "lib64"
26 %define         with_lib64      1
27 %else
28 %define         with_lib64      0
29 %endif
30 %if "%{_lib}" == "libx32"
31 %define         with_libx32     1
32 %else
33 %ifarch %{x8664}
34 # x32 as additional ABI
35 %define         with_libx32     1
36 %endif
37 %endif
38
39 # avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
40 %define         __spec_clean_body       %{nil}
41
42 %define         _locmandir      /usr/local/man
43
44 # doesn't contain any files, but we're not noarch package
45 %define         no_install_post_strip   1
46 %define         no_install_post_chrpath 1
47 %define         no_install_post_compress_modules        1
48
49 # we have to use numeric uids/groups. see comment above
50
51 %define         gid_uucp        14
52 %define         gid_mail        12
53
54 %description
55 This package contains the basic directory layout for a Linux system,
56 including the proper permissions for the directories. This layout
57 conforms to the Filesystem Hierarchy Standard (FHS) 2.3.
58
59 %description -l de.UTF-8
60 Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
61 Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
62 Struktur entspricht dem Filesystem Hierarchy Standard (FHS) 2.3.
63
64 %description -l fr.UTF-8
65 Ce package contient l'arborescence type pour système Linux y compris
66 les permissions adéquates pour les répertoires. Cette arborescence est
67 conforme au standard "Filesystem Hierarchy Standard" (FHS) 2.3.
68
69 %description -l pl.UTF-8
70 Pakiet ten zawiera informacje o podstawowej strukturze katalogów
71 systemu i praw dostępu do nich. Struktura katalogów jest zgodna z FHS
72 2.3.
73
74 %prep
75 %setup -qcT
76 cp -a %{SOURCE0} .
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 install -d \
82         $RPM_BUILD_ROOT/{bin,boot,dev,etc,home,opt,srv} \
83         $RPM_BUILD_ROOT/etc/{X11,opt} \
84         $RPM_BUILD_ROOT/lib/modules \
85         $RPM_BUILD_ROOT/{mnt,media,proc,root/tmp,sbin,tmp} \
86         $RPM_BUILD_ROOT/usr/{bin,games,include,lib,sbin,share,src} \
87         $RPM_BUILD_ROOT/usr/share/{dict,doc,games,info,misc,tmac,xml} \
88         $RPM_BUILD_ROOT/usr/lib/games \
89         $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,sbin,share/{doc,info},src} \
90         $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/misc,local,lock,log,mail,opt,run,spool,tmp,yp}
91
92 %if %{with lib64}
93 install -d $RPM_BUILD_ROOT{/lib64,/usr/lib64/games,/usr/local/lib64}
94 %endif
95 %if %{with libx32}
96 install -d $RPM_BUILD_ROOT{/libx32,/usr/libx32/games,/usr/local/libx32}
97 %endif
98
99 install -d $RPM_BUILD_ROOT/usr/share/man/man{1,2,3,4,5,6,7,8}
100 install -d $RPM_BUILD_ROOT%{_locmandir}/man{1,2,3,4,5,6,7,8}
101
102 # "/usr/local/share/man and /usr/local/man must be synonomous" per FHS 2.3
103 ln -sf ../man $RPM_BUILD_ROOT/usr/local/share/man
104
105 > %{name}.lang
106 for mloc in $(cat locale-dirs); do
107         echo "%%lang($mloc) %dir /usr/share/man/${mloc}" >> %{name}.lang
108         for manp in man{1,2,3,4,5,6,7,8}; do
109                 install -d $RPM_BUILD_ROOT/usr/share/man/${mloc}/${manp}
110                 echo "%%lang($mloc) %dir /usr/share/man/${mloc}/${manp}" >> %{name}.lang
111         done
112 done
113
114 %clean
115 cd $RPM_BUILD_ROOT
116
117 check_filesystem_dirs() {
118         RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
119         TMPFILE=$(mktemp)
120         find | sed -e 's|^\.||g' -e 's|^$||g' | LC_ALL=C sort > $TMPFILE
121
122         # find finds also '.', so use option -B for diff
123         if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | LC_ALL=C sort | diff -uB $TMPFILE - ; then
124                 rm -rf $RPM_BUILD_ROOT
125         else
126                 echo -e "\nNot so good, some directories are not included in package\n"
127                 exit 1
128         fi
129         rm -f $TMPFILE
130 }
131 check_filesystem_dirs
132
133 # XXX: it is 2009, what uucp?! but we use /var/lock/subsys, so change it just to root?
134 %post -p <lua>
135 posix.chown("/var/mail", 0, %{gid_mail})
136 posix.chown("/var/lock", 0, %{gid_uucp})
137
138 %files -f %{name}.lang
139 %defattr(644,root,root,755)
140 %dir /
141 %dir /bin
142 %dir /boot
143 %dir /dev
144 %dir /etc
145 %dir /etc/X11
146 %dir /etc/opt
147 %dir /home
148 %dir /lib
149 %dir /lib/modules
150 %dir /media
151 %dir /mnt
152 %dir /opt
153 %dir %attr(555,root,root) %verify(not group) /proc
154 %dir %attr(700,root,root) /root
155 %dir %attr(700,root,root) /root/tmp
156 %dir /sbin
157 %dir %attr(755,root,root) /srv
158 %dir %attr(1777,root,root) /tmp
159 %dir /usr
160 %dir /usr/bin
161 %dir /usr/games
162 %dir /usr/include
163 %dir /usr/lib
164 %dir /usr/lib/games
165 %dir /usr/sbin
166 %dir /usr/share
167 %dir /usr/share/dict
168 %dir /usr/share/doc
169 %dir /usr/share/games
170 %dir /usr/share/info
171 %dir /usr/share/man
172 %dir /usr/share/man/man[1-8]
173 %dir /usr/share/misc
174 %dir /usr/share/tmac
175 %dir /usr/share/xml
176 %dir /usr/src
177 %dir /usr/local
178 %dir /usr/local/bin
179 %dir /usr/local/etc
180 %dir /usr/local/games
181 %dir /usr/local/include
182 %dir /usr/local/lib
183 %dir /usr/local/sbin
184 %dir /usr/local/share
185 %dir /usr/local/share/doc
186 %dir /usr/local/share/info
187 /usr/local/share/man
188 %{_locmandir}
189 %dir /usr/local/src
190 %dir /var
191 %dir /var/cache
192 %dir /var/crash
193 %dir /var/db
194 %dir /var/games
195 %dir /var/lib
196 %dir /var/lib/misc
197 %dir /var/local
198 %dir %attr(1771,root,root) /var/lock
199 %dir %attr(751,root,root) /var/log
200 %dir %attr(2775,root,root) /var/mail
201 %dir /var/opt
202 %dir /var/run
203 %dir /var/spool
204 %dir /var/yp
205 %dir %attr(1777,root,root) /var/tmp
206 %if %{with lib64}
207 %dir /lib64
208 %dir /usr/lib64
209 %dir /usr/lib64/games
210 %dir /usr/local/lib64
211 %endif
212 %if %{with libx32}
213 %dir /libx32
214 %dir /usr/libx32
215 %dir /usr/libx32/games
216 %dir /usr/local/libx32
217 %endif
This page took 0.050493 seconds and 4 git commands to generate.