]> git.pld-linux.org Git - packages/FHS.git/blob - FHS.spec
- lib64 only on supporting archs (so nolonger noarch...); release 15
[packages/FHS.git] / FHS.spec
1 Summary:        Basic FHS 2.2 filesystem layout
2 Summary(de):    Grundlegende Dateisystemstruktur
3 Summary(fr):    Arborescence de base du système de fichiers
4 Summary(pl):    Podstawowy uk³ad katalogów systemu Linux zgodny z FHS 2.2
5 Summary(tr):    Temel dosya sistemi yapýsý
6 Name:           FHS
7 Version:        2.2
8 Release:        15
9 License:        GPL
10 Group:          Base
11 URL:            http://www.pathname.com/fhs/
12 PreReq:         setup
13 Provides:       filesystem
14 Obsoletes:      filesystem
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _locmandir      /usr/local/man
18 %define         _xmandir        /usr/X11R6/man
19 # directory for "privilege separation" chroot
20 %define         _privsepdir     /usr/share/empty
21 # directory for *.idl files (for CORBA implementations)
22 %define         _idldir         /usr/share/idl
23
24 %description
25 This package contains the basic directory layout for a Linux system,
26 including the proper permissions for the directories. This layout
27 conforms to the Filesystem Hierarchy Standard (FHS) 2.2.
28
29 %description -l de
30 Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
31 Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
32 Struktur entspricht dem Filesystem Hierarchy Standard (FHS) 2.2.
33
34 %description -l fr
35 Ce package contient l'arborescence type pour système Linux y compris
36 les permissions adéquates pour les répertoires. Cette arborescence est
37 conforme au standard \"Filesystem Hierarchy Standard\" (FHS) 2.2.
38
39 %description -l pl
40 Pakiet ten zawiera informacje o podstawowej strukturze katalogów
41 systemu i praw dostêpu do nich. Struktura katalogów jest zgodna z FHS
42 2.2.
43
44 %description -l tr
45 Bu paket GNU makro iþleme dilini içerir. Mantýksal olarak
46 ayrýþtýrýlabilen metin dosyalarý yazýmý için yararlýdýr.
47
48 %prep
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT/{bin,boot,dev,etc,home/{users,services},opt,sys} \
54         $RPM_BUILD_ROOT%{_sysconfdir}/{X11,opt,security} \
55         $RPM_BUILD_ROOT/lib/{modules,security} \
56         $RPM_BUILD_ROOT/{mnt/{cdrom,floppy},proc,root,sbin,tmp} \
57         $RPM_BUILD_ROOT%{_prefix}/{bin,games,include/security,lib,sbin,share,src/examples} \
58         $RPM_BUILD_ROOT%{_datadir}/{applications,dict,doc,games,info,misc,tmac} \
59         $RPM_BUILD_ROOT%{_libdir}/games \
60         $RPM_BUILD_ROOT%{_prefix}/local/{bin,games,include,lib,sbin,share/{doc,info},src} \
61         $RPM_BUILD_ROOT/var/{lock/subsys,log,mail,run,spool} \
62         $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/misc,local,opt,tmp} \
63         $RPM_BUILD_ROOT%{_idldir} \
64         $RPM_BUILD_ROOT%{_fontsdir}/Type1/{afm,pfm} \
65         $RPM_BUILD_ROOT%{_fontsdir}/TTF \
66         $RPM_BUILD_ROOT%{_fontsdir}/misc \
67         $RPM_BUILD_ROOT%{_privsepdir} \
68         $RPM_BUILD_ROOT/usr/X11R6/share
69
70 %ifarch ppc64 sparc64 x86_64
71 install -d $RPM_BUILD_ROOT{/lib64,%{_prefix}/lib64,%{_prefix}/local/lib64}
72 %endif
73
74 for manp in man{1,2,3,4,5,6,7,8} ; do
75         install -d $RPM_BUILD_ROOT%{_mandir}/${manp}
76         install -d $RPM_BUILD_ROOT%{_locmandir}/${manp}
77         install -d $RPM_BUILD_ROOT%{_xmandir}/${manp}
78         for mloc in bg cs da de el es fi fr gl hr hu id it ja ko nl pl pt pt_BR ro ru sl sk sv ; do
79                 install -d $RPM_BUILD_ROOT%{_mandir}/${mloc}/${manp}
80         done
81         for mloc in da fi fr hu it ja ko pl sk ; do
82                 install -d $RPM_BUILD_ROOT%{_xmandir}/${mloc}/${manp}
83         done
84 done
85 install -d $RPM_BUILD_ROOT%{_mandir}/man{n,l}
86 install -d $RPM_BUILD_ROOT%{_mandir}/pl/mann
87
88 %clean
89 cd $RPM_BUILD_ROOT
90
91 # %{_rpmfilename} is not expanded, so use
92 # %{name}-%{version}-%{release}.%{buildarch}.rpm
93 RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
94 TMPFILE=%{name}-%{version}.tmp$$
95 find . | sed -e 's|^\.||g' -e 's|^$||g' | sort | grep -v $TMPFILE > $TMPFILE
96
97 # find finds also '.', so use option -B for diff
98 if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | sort | diff -uB $TMPFILE - ; then
99         rm -rf $RPM_BUILD_ROOT
100 else
101         echo -e "\nNot so good, some directories are not included in package\n"
102         exit 1;
103 fi
104
105 %files
106 %defattr(644,root,root,755)
107 %dir /
108 /bin
109 /boot
110 /dev
111 %dir /etc
112 %dir %{_sysconfdir}/X11
113 %dir %{_sysconfdir}/opt
114 %attr(751,root,root) %dir /etc/security
115 %dir /home
116 /home/users
117 %attr(751,root,root) /home/services
118 /lib
119 /mnt
120 /opt
121 %attr(555,root,proc) %verify(not group) /proc
122 %attr(700,root,root) /root
123 %dir /sbin
124 %dir /sys
125 %attr(1777,root,root) /tmp
126 %dir %{_prefix}
127 %{_prefix}/bin
128 %{_prefix}/games
129 %{_prefix}/include
130 %{_prefix}/lib
131 %{_prefix}/sbin
132 %dir %{_prefix}/share
133 %{_datadir}/applications
134 %{_datadir}/dict
135 %{_datadir}/doc
136 %{_privsepdir}
137 %{_fontsdir}
138 %{_idldir}
139 %{_datadir}/games
140 %{_datadir}/info
141 %dir %{_mandir}
142 %dir %{_mandir}/man*
143 %lang(bg) %{_mandir}/bg
144 %lang(cs) %{_mandir}/cs
145 %lang(da) %{_mandir}/da
146 %lang(de) %{_mandir}/de
147 %lang(el) %{_mandir}/el
148 %lang(es) %{_mandir}/es
149 %lang(fi) %{_mandir}/fi
150 %lang(fr) %{_mandir}/fr
151 %lang(gl) %{_mandir}/gl
152 %lang(hr) %{_mandir}/hr
153 %lang(hu) %{_mandir}/hu
154 %lang(id) %{_mandir}/id
155 %lang(it) %{_mandir}/it
156 %lang(ja) %{_mandir}/ja
157 %lang(ko) %{_mandir}/ko
158 %lang(nl) %{_mandir}/nl
159 %lang(pl) %{_mandir}/pl
160 %lang(pt) %{_mandir}/pt
161 %lang(pt_BR) %{_mandir}/pt_BR
162 %lang(ro) %{_mandir}/ro
163 %lang(ru) %{_mandir}/ru
164 %lang(sl) %{_mandir}/sl
165 %lang(sk) %{_mandir}/sk
166 %lang(sv) %{_mandir}/sv
167 %{_datadir}/misc
168 %{_datadir}/tmac
169 %{_prefix}/src
170 %dir %{_prefix}/local
171 %{_prefix}/local/bin
172 %{_prefix}/local/games
173 %{_prefix}/local/include
174 %{_prefix}/local/lib
175 %{_prefix}/local/sbin
176 %dir %{_prefix}/local/share
177 %{_prefix}/local/share/doc
178 %{_prefix}/local/share/info
179 %{_locmandir}
180 %{_prefix}/local/src
181 %dir /usr/X11R6
182 %dir %{_xmandir}
183 %{_xmandir}/man*
184 %lang(da) %{_xmandir}/da
185 %lang(fi) %{_xmandir}/fi
186 %lang(fr) %{_xmandir}/fr
187 %lang(hu) %{_xmandir}/hu
188 %lang(it) %{_xmandir}/it
189 %lang(ja) %{_xmandir}/ja
190 %lang(ko) %{_xmandir}/ko
191 %lang(pl) %{_xmandir}/pl
192 %lang(sk) %{_xmandir}/sk
193 %dir /usr/X11R6/share
194
195 %dir /var
196 /var/cache
197 %dir /var/crash
198 %dir /var/db
199 %dir /var/games
200 %dir /var/lib
201 %dir /var/lib/misc
202 %dir /var/local
203 %attr(1771,root,uucp) %dir /var/lock
204 %attr(700,root,root) %dir /var/lock/subsys
205 %attr(751,root,root) /var/log
206 %attr(2775,root,mail) /var/mail
207 %dir /var/opt
208 %dir /var/run
209 %dir /var/spool
210 %attr(1777,root,root) %dir /var/tmp
211
212 %ifarch ppc64 sparc64 x86_64
213 /lib64
214 %{_prefix}/lib64
215 %{_prefix}/local/lib64
216 %endif
This page took 0.037749 seconds and 4 git commands to generate.