]> git.pld-linux.org Git - packages/FHS.git/blob - FHS.spec
- %files fixed, rel 7
[packages/FHS.git] / FHS.spec
1 Summary:        Basic FHS 2.3 filesystem layout
2 Summary(de):    Grundlegende Dateisystemstruktur
3 Summary(fr):    Arborescence de base du système de fichiers
4 Summary(pl):    Podstawowy uk³ad katalogów systemu Linux zgodny z FHS 2.3
5 Summary(tr):    Temel dosya sistemi yapýsý
6 Name:           FHS
7 Version:        2.3
8 Release:        7
9 License:        GPL
10 Group:          Base
11 URL:            http://www.pathname.com/fhs/
12 PreReq:         setup >= 2.4.6-4
13 Provides:       filesystem
14 Obsoletes:      filesystem
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _locmandir      /usr/local/man
18 %define         _xmandir        /usr/X11R6/man
19 # directory for "privilege separation" chroot
20 %define         _privsepdir     /usr/share/empty
21 # directory for *.idl files (for CORBA implementations)
22 %define         _idldir         /usr/share/idl
23
24 %description
25 This package contains the basic directory layout for a Linux system,
26 including the proper permissions for the directories. This layout
27 conforms to the Filesystem Hierarchy Standard (FHS) 2.3.
28
29 %description -l de
30 Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
31 Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
32 Struktur entspricht dem Filesystem Hierarchy Standard (FHS) 2.3.
33
34 %description -l fr
35 Ce package contient l'arborescence type pour système Linux y compris
36 les permissions adéquates pour les répertoires. Cette arborescence est
37 conforme au standard "Filesystem Hierarchy Standard" (FHS) 2.3.
38
39 %description -l pl
40 Pakiet ten zawiera informacje o podstawowej strukturze katalogów
41 systemu i praw dostêpu do nich. Struktura katalogów jest zgodna z FHS
42 2.3.
43
44 %description -l tr
45 Bu paket GNU makro iþleme dilini içerir. Mantýksal olarak
46 ayrýþtýrýlabilen metin dosyalarý yazýmý için yararlýdýr.
47
48 %prep
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT/{bin,boot,initrd,dev,etc,home/{users,services},opt,selinux,srv,sys} \
54         $RPM_BUILD_ROOT%{_sysconfdir}/{X11,opt,security} \
55         $RPM_BUILD_ROOT{/lib/modules,/%{_lib}/security} \
56         $RPM_BUILD_ROOT/{mnt,media/{cdrom,floppy},proc,root,sbin,tmp} \
57         $RPM_BUILD_ROOT%{_prefix}/{bin,games,include/security,lib,sbin,share,src/examples} \
58         $RPM_BUILD_ROOT%{_datadir}/{applications,dict,doc,games,info,misc,tmac} \
59         $RPM_BUILD_ROOT%{_libdir}/games \
60         $RPM_BUILD_ROOT%{_prefix}/local/{bin,games,include,lib,sbin,share/{doc,info},src} \
61         $RPM_BUILD_ROOT/var/{lock/subsys,log,mail,run,spool} \
62         $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/misc,local,opt,tmp} \
63         $RPM_BUILD_ROOT%{_idldir} \
64         $RPM_BUILD_ROOT%{_fontsdir}/Type1/{afm,pfm} \
65         $RPM_BUILD_ROOT%{_fontsdir}/TTF \
66         $RPM_BUILD_ROOT%{_fontsdir}/misc \
67         $RPM_BUILD_ROOT%{_privsepdir} \
68         $RPM_BUILD_ROOT/usr/X11R6/share
69
70 %ifarch amd64 ppc64 sparc64
71 install -d $RPM_BUILD_ROOT{/lib64,%{_prefix}/lib64,%{_prefix}/local/lib64}
72 %endif
73
74 for manp in man{1,2,3,4,5,6,7,8} ; do
75         install -d $RPM_BUILD_ROOT%{_mandir}/${manp}
76         install -d $RPM_BUILD_ROOT%{_locmandir}/${manp}
77         install -d $RPM_BUILD_ROOT%{_xmandir}/${manp}
78         for mloc in bg cs da de el es fi fr gl hr hu id it ja ko nl pl pt \
79                     pt_BR ro ru sl sk sr sv zh_CN zh_TW ; do
80                 install -d $RPM_BUILD_ROOT%{_mandir}/${mloc}/${manp}
81         done
82         for mloc in it ko pl ; do
83                 install -d $RPM_BUILD_ROOT%{_xmandir}/${mloc}/${manp}
84         done
85 done
86 install -d $RPM_BUILD_ROOT%{_mandir}/man{n,l}
87 install -d $RPM_BUILD_ROOT%{_mandir}/pl/mann
88
89 %clean
90 cd $RPM_BUILD_ROOT
91
92 # %{_rpmfilename} is not expanded, so use
93 # %{name}-%{version}-%{release}.%{buildarch}.rpm
94 RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
95 TMPFILE=%{name}-%{version}.tmp$$
96 find . | sed -e 's|^\.||g' -e 's|^$||g' | sort | grep -v $TMPFILE > $TMPFILE
97
98 # find finds also '.', so use option -B for diff
99 if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | sort | diff -uB $TMPFILE - ; then
100         rm -rf $RPM_BUILD_ROOT
101 else
102         echo -e "\nNot so good, some directories are not included in package\n"
103         exit 1;
104 fi
105
106 %files
107 %defattr(644,root,root,755)
108 %dir /
109 /bin
110 /boot
111 /initrd
112 /dev
113 %dir /etc
114 %dir %{_sysconfdir}/X11
115 %dir %{_sysconfdir}/opt
116 %attr(751,root,root) %dir /etc/security
117 %dir /home
118 /home/users
119 %attr(751,root,adm) /home/services
120 /lib
121 %attr(775,root,disk) %dir /media
122 %attr(775,root,disk) /media/floppy
123 %attr(775,root,disk) /media/cdrom
124 /mnt
125 /opt
126 %attr(555,root,proc) %verify(not group) /proc
127 %attr(700,root,root) /root
128 %dir /sbin
129 %dir /sys
130 %dir /selinux
131 %attr(751,root,root) /srv
132 %attr(1777,root,root) /tmp
133 %dir %{_prefix}
134 %{_prefix}/bin
135 %{_prefix}/games
136 %{_prefix}/include
137 %{_prefix}/lib
138 %{_prefix}/sbin
139 %dir %{_prefix}/share
140 %{_datadir}/applications
141 %{_datadir}/dict
142 %{_datadir}/doc
143 %{_privsepdir}
144 %{_fontsdir}
145 %{_idldir}
146 %{_datadir}/games
147 %{_datadir}/info
148 %dir %{_mandir}
149 %dir %{_mandir}/man*
150 %lang(bg) %{_mandir}/bg
151 %lang(cs) %{_mandir}/cs
152 %lang(da) %{_mandir}/da
153 %lang(de) %{_mandir}/de
154 %lang(el) %{_mandir}/el
155 %lang(es) %{_mandir}/es
156 %lang(fi) %{_mandir}/fi
157 %lang(fr) %{_mandir}/fr
158 %lang(gl) %{_mandir}/gl
159 %lang(hr) %{_mandir}/hr
160 %lang(hu) %{_mandir}/hu
161 %lang(id) %{_mandir}/id
162 %lang(it) %{_mandir}/it
163 %lang(ja) %{_mandir}/ja
164 %lang(ko) %{_mandir}/ko
165 %lang(nl) %{_mandir}/nl
166 %lang(pl) %{_mandir}/pl
167 %lang(pt) %{_mandir}/pt
168 %lang(pt_BR) %{_mandir}/pt_BR
169 %lang(ro) %{_mandir}/ro
170 %lang(ru) %{_mandir}/ru
171 %lang(sl) %{_mandir}/sl
172 %lang(sk) %{_mandir}/sk
173 %lang(sv) %{_mandir}/sv
174 %{_datadir}/misc
175 %{_datadir}/tmac
176 %{_prefix}/src
177 %dir %{_prefix}/local
178 %{_prefix}/local/bin
179 %{_prefix}/local/games
180 %{_prefix}/local/include
181 %{_prefix}/local/lib
182 %{_prefix}/local/sbin
183 %dir %{_prefix}/local/share
184 %{_prefix}/local/share/doc
185 %{_prefix}/local/share/info
186 %{_locmandir}
187 %{_prefix}/local/src
188 %dir /usr/X11R6
189 %dir %{_xmandir}
190 %{_xmandir}/man*
191 %lang(it) %{_xmandir}/it
192 %lang(ko) %{_xmandir}/ko
193 %lang(pl) %{_xmandir}/pl
194 %dir /usr/X11R6/share
195
196 %dir /var
197 /var/cache
198 %dir /var/crash
199 %dir /var/db
200 %dir /var/games
201 %dir /var/lib
202 %dir /var/lib/misc
203 %dir /var/local
204 %attr(1771,root,uucp) %dir /var/lock
205 %attr(700,root,root) %dir /var/lock/subsys
206 %attr(751,root,root) /var/log
207 %attr(2775,root,mail) /var/mail
208 %dir /var/opt
209 %dir /var/run
210 %dir /var/spool
211 %attr(1777,root,root) %dir /var/tmp
212
213 %ifarch ppc64 sparc64 x86_64
214 /lib64
215 %{_prefix}/lib64
216 %{_prefix}/local/lib64
217 %endif
This page took 0.057908 seconds and 4 git commands to generate.