]> git.pld-linux.org Git - packages/FHS.git/blob - FHS.spec
- rel. 2
[packages/FHS.git] / FHS.spec
1 Summary:        Basic FHS 2.2 filesystem layout
2 Summary(de):    Grundlegende Dateisystemstruktur
3 Summary(fr):    Arborescence de base du système de fichiers
4 Summary(pl):    Podstawowy uk³ad katalogów systemu Linux zgodny z FHS 2.2
5 Summary(tr):    Temel dosya sistemi yapýsý
6 Name:           FHS
7 Version:        2.2
8 Release:        2
9 License:        GPL
10 Group:          Base
11 URL:            http://www.pathname.com/fhs/
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13 BuildRequires:  grep
14 BuildRequires:  textutils
15 PreReq:         setup
16 BuildArch:      noarch
17 Provides:       filesystem
18 Obsoletes:      filesystem
19
20 %define         _locmandir      /usr/local/man
21 %define         _xmandir        /usr/X11R6/man
22 %define         _privsepdir     /usr/share/empty
23
24 %description
25 This package contains the basic directory layout for a Linux system,
26 including the proper permissions for the directories. This layout
27 conforms to the Filesystem Hierarchy Standard (FHS) 2.2.
28
29 %description -l de
30 Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
31 Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
32 Struktur entspricht dem Filesystem Hierarchy Standard (FHS) 2.2.
33
34 %description -l fr
35 Ce package contient l'arborescence type pour système Linux y compris
36 les permissions adéquates pour les répertoires. Cette arborescence est
37 conforme au standard \"Filesystem Hierarchy Standard\" (FHS) 2.2.
38
39 %description -l pl
40 Pakiet ten zawiera informacje o podstawowej strukturze katalogów
41 systemu i praw dostêpu do nich. Struktura katalogów jest zgodna z FHS
42 2.2.
43
44 %description -l tr
45 Bu paket GNU makro iþleme dilini içerir. Mantýksal olarak
46 ayrýþtýrýlabilen metin dosyalarý yazýmý için yararlýdýr.
47
48 %prep
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT/{bin,boot,dev,etc,home/{users,services},opt} \
54         $RPM_BUILD_ROOT%{_sysconfdir}/{X11,opt,security} \
55         $RPM_BUILD_ROOT/lib/{modules,security} \
56         $RPM_BUILD_ROOT/{mnt/{cdrom,floppy},proc,root,sbin,tmp} \
57         $RPM_BUILD_ROOT%{_prefix}/{bin,games,include,lib,sbin,share,src/examples} \
58         $RPM_BUILD_ROOT%{_datadir}/{dict,doc,games,info,misc,tmac} \
59         $RPM_BUILD_ROOT%{_libdir}/games \
60         $RPM_BUILD_ROOT%{_prefix}/local/{bin,games,lib,sbin,share/{doc,info},src} \
61         $RPM_BUILD_ROOT/var/{lock/subsys,log,mail,run,spool} \
62         $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/misc,opt,tmp} \
63         $RPM_BUILD_ROOT/usr/X11R6/share/idl \
64         $RPM_BUILD_ROOT%{_fontsdir}/Type1/{afm,pfm} \
65         $RPM_BUILD_ROOT%{_privsepdir}
66
67 for manp in man{1,2,3,4,5,6,7,8} ; do
68         install -d $RPM_BUILD_ROOT%{_mandir}/${manp}
69         install -d $RPM_BUILD_ROOT%{_locmandir}/${manp}
70         install -d $RPM_BUILD_ROOT%{_xmandir}/${manp}
71         for mloc in bg cs da de es fi fr hr hu id it ja ko nl pl pt pt_BR ru sl sk sv ; do
72                 install -d $RPM_BUILD_ROOT%{_mandir}/${mloc}/${manp}
73         done
74         for mloc in da fi fr hu it ja ko pl sk ; do
75                 install -d $RPM_BUILD_ROOT%{_xmandir}/${mloc}/${manp}
76         done
77 done
78 install -d $RPM_BUILD_ROOT%{_mandir}/man{n,l}
79
80 %clean
81 cd $RPM_BUILD_ROOT
82
83 # %{_rpmfilename} is not expanded, so use
84 # %{name}-%{version}-%{release}.%{buildarch}.rpm
85 RPMFILE=%{name}-%{version}-%{release}.%{buildarch}.rpm
86 TMPFILE=%{name}-%{version}.tmp$$
87 find . | sed -e 's|^\.||g' -e 's|^$||g' | sort | grep -v $TMPFILE > $TMPFILE
88
89 # find finds also '.', so use option -B for diff
90 if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | sort | diff -uB $TMPFILE - ; then
91         rm -rf $RPM_BUILD_ROOT
92 else
93         echo -e "\nNot so good, some directories are not included in package\n"
94         exit 1;
95 fi
96
97 %files
98 %defattr(644,root,root,755)
99 %dir /
100 /bin
101 /boot
102 /dev
103 %dir /etc
104 %dir %{_sysconfdir}/X11
105 %dir %{_sysconfdir}/opt
106 %attr(751,root,root) %dir /etc/security
107 %dir /home
108 /home/users
109 %attr(751,root,root) /home/services
110 /lib
111 /mnt
112 /opt
113 %attr(555,root,proc) %verify(not group) /proc
114 %attr(700,root,root) /root
115 %dir /sbin
116 %attr(1777,root,root) /tmp
117 %dir %{_prefix}
118 %{_prefix}/bin
119 %{_prefix}/games
120 %{_prefix}/include
121 %{_prefix}/lib
122 %{_prefix}/sbin
123 %dir %{_prefix}/share
124 %{_datadir}/dict
125 %{_datadir}/doc
126 %{_privsepdir}
127 %{_fontsdir}
128 %{_datadir}/games
129 %{_datadir}/info
130 %dir %{_mandir}
131 %dir %{_mandir}/man*
132 %lang(bg) %{_mandir}/bg
133 %lang(cs) %{_mandir}/cs
134 %lang(da) %{_mandir}/da
135 %lang(de) %{_mandir}/de
136 %lang(es) %{_mandir}/es
137 %lang(fi) %{_mandir}/fi
138 %lang(fr) %{_mandir}/fr
139 %lang(hr) %{_mandir}/hr
140 %lang(hu) %{_mandir}/hu
141 %lang(id) %{_mandir}/id
142 %lang(it) %{_mandir}/it
143 %lang(ja) %{_mandir}/ja
144 %lang(ko) %{_mandir}/ko
145 %lang(nl) %{_mandir}/nl
146 %lang(pl) %{_mandir}/pl
147 %lang(pt) %{_mandir}/pt
148 %lang(pt_BR) %{_mandir}/pt_BR
149 %lang(ru) %{_mandir}/ru
150 %lang(sl) %{_mandir}/sl
151 %lang(sk) %{_mandir}/sk
152 %lang(sv) %{_mandir}/sv
153 %{_datadir}/misc
154 %{_datadir}/tmac
155 %{_prefix}/src
156 %dir %{_prefix}/local
157 %{_prefix}/local/bin
158 %{_prefix}/local/games
159 %{_prefix}/local/lib
160 %{_prefix}/local/sbin
161 %dir %{_prefix}/local/share
162 %{_prefix}/local/share/doc
163 %{_prefix}/local/share/info
164 %{_locmandir}
165 %{_prefix}/local/src
166 %dir /usr/X11R6
167 %dir %{_xmandir}
168 %{_xmandir}/man*
169 %lang(da) %{_xmandir}/da
170 %lang(fi) %{_xmandir}/fi
171 %lang(fr) %{_xmandir}/fr
172 %lang(hu) %{_xmandir}/hu
173 %lang(it) %{_xmandir}/it
174 %lang(ja) %{_xmandir}/ja
175 %lang(ko) %{_xmandir}/ko
176 %lang(pl) %{_xmandir}/pl
177 %lang(sk) %{_xmandir}/sk
178 %dir /usr/X11R6/share
179 /usr/X11R6/share/idl
180
181 %dir /var
182 /var/cache
183 %dir /var/crash
184 %dir /var/db
185 %dir /var/games
186 %dir /var/lib
187 %dir /var/lib/misc
188 %attr(1771,root,uucp) %dir /var/lock
189 %attr(700,root,root) %dir /var/lock/subsys
190 %attr(751,root,root) /var/log
191 %attr(775,root,mail) /var/mail
192 %dir /var/opt
193 %dir /var/run
194 %dir /var/spool
195 %attr(1777,root,root) %dir /var/tmp
This page took 0.080489 seconds and 4 git commands to generate.