]> git.pld-linux.org Git - packages/kodi.git/blame - kodi.spec
BR, Mesa-libEGL-devel, libatomic-devel
[packages/kodi.git] / kodi.spec
CommitLineData
18b90c81 1# TODO:
3a71016a 2# - fix build flags - some files are compiled with -O3 and without rpm*flags
92b96980 3# - add and/or fix users/groups permissions
63ff963e 4# - split to subpackages?
928406b7 5# - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
18b90c81 6#
92b96980 7# Conditional build:
ceb94d36 8# Features:
c0d69361
ER
9%bcond_with afpclient # AFP support via libafpclient
10%bcond_without airplay # AirPlay support
11%bcond_with airtunes # AirTunes support
e148a10d
ER
12%bcond_without alsa # ALSA support
13%bcond_without avahi # Avahi support
ceb94d36
ER
14%bcond_without dbus # DBUS support
15%bcond_without dvdcss # DVDCSS support
98f23c16 16%bcond_without gl # OpenGL rendering
ceb94d36 17%bcond_with gtest # configure Google Test Framework
98f23c16 18%bcond_without joystick # SDL joystick support
c0d69361
ER
19%bcond_without libcap # libcap support
20%bcond_with libcec # libcec support
296d79de 21%bcond_without libgif # gif support via libgif
8ea15fa3 22%bcond_without libusb # libusb support
c0d69361 23%bcond_with mdnsembedded # mDNSEmbedded support
ceb94d36 24%bcond_without mysql # MySQL
8ea15fa3 25%bcond_without nfs # NFS support via libnfs
ceb94d36 26%bcond_without non_free # componentents with non-compliant licenses
c0d69361 27%bcond_with openmax # OpenMax decoding, requires OpenGLES
ceb94d36 28%bcond_without optical_drive # optical drive
98f23c16 29%bcond_without projectm # ProjectM visualisation
c0d69361 30%bcond_without pulse # PulseAudio support
c0d69361 31%bcond_without rtmp # RTMP support via librtmp
e148a10d 32%bcond_without samba # SAMBA support
c0d69361 33%bcond_without sdl # SDL
e148a10d 34%bcond_without ssh # SSH SFTP support
98f23c16 35%bcond_without texturepacker # texturepacker support
c0d69361 36%bcond_without udev # udev support
e148a10d 37%bcond_without upnp # UPnP support
c0d69361
ER
38%bcond_without vaapi # VAAPI decoding
39%bcond_without vdpau # VDPAU decoding
40%bcond_with vtbdecoder # VTBDecoder decoding (VTB Decoder not supported on this platform)
ceb94d36 41%bcond_without webserver # webserver
98f23c16
ER
42%bcond_without x11 # x11 'Linux Only'
43%bcond_without xrandr # XRandR support
e148a10d
ER
44%bcond_with asap_codec # ASAP ADPCM support
45%bcond_with gles # OpenGLES rendering
46%bcond_without libbluray # libbluray support
47%bcond_without mid # MID support
48%bcond_with profiling # gprof profiling
49%bcond_with tegra # Tegra2 arm
50%bcond_with wayland # wayland
ceb94d36 51# System libs:
6e5f6f0e 52%bcond_without system_ffmpeg # build with system ffmpeg
e25cf996 53%bcond_without system_dvdread # build with system dvdread
92b96980 54
6b5f5f8f 55%define codename Krypton
d61811e9 56Summary: Kodi is a free and open source media-player and entertainment hub
92b53b2c 57Name: kodi
6b5f5f8f 58Version: 17.6
fd935248 59Release: 1
68612b1e 60License: GPL v2+ and GPL v3+
18b90c81 61Group: Applications/Multimedia
b7bd3c34
ER
62#Source0: http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
63Source0: https://github.com/xbmc/xbmc/archive/%{version}-%{codename}.tar.gz
6b5f5f8f 64# Source0-md5: a64c2fc56ddc41b9b0dded55eaabf170
d2f0f4c7 65Patch0: jpeglib-boolean.patch
af2a7b89 66Patch1: disable-static.patch
e25cf996 67Patch2: dvdread.patch
3b89f97e
JR
68Patch3: ffmpeg3.patch
69Patch4: gcc5.patch
92b53b2c 70URL: http://kodi.tv/
a7c53f4c 71BuildRequires: Mesa-libEGL-devel
8fa5c2e4 72BuildRequires: OpenGL-GLU-devel
b85db44b 73BuildRequires: OpenGL-devel
658b3aff 74BuildRequires: SDL2-devel
18b90c81 75BuildRequires: alsa-lib-devel
8fa5c2e4 76BuildRequires: autoconf >= 2.59
18b90c81
SP
77BuildRequires: automake
78BuildRequires: avahi-devel
b85db44b 79BuildRequires: bluez-libs-devel >= 4.99
5a2f2b01 80BuildRequires: boost-devel
18b90c81
SP
81BuildRequires: bzip2-devel
82BuildRequires: cmake
c3c3c480 83BuildRequires: crossguid-devel
18b90c81
SP
84BuildRequires: curl-devel
85BuildRequires: dbus-devel
6069f65f 86BuildRequires: dcadec-devel
501e1d3e 87BuildRequires: doxygen
8fa5c2e4 88# libavcodec >= 56.26.100 libavfilter >= 5.11.102 libavformat >= 56.25.101 libavutil >= 54.20.100 libpostproc >= 53.3.100 libswscale >= 3.1.101 libswresample >= 1.1.100
64d462c0 89%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 2.4.4}
5a2f2b01 90BuildRequires: flac-devel
18b90c81
SP
91BuildRequires: fontconfig-devel
92BuildRequires: freetype-devel
93BuildRequires: fribidi-devel
94BuildRequires: gawk
63ff963e 95BuildRequires: gettext-autopoint
0747666f 96BuildRequires: gettext-tools
a1f637af 97BuildRequires: giflib-devel
3a358a3c 98%{?with_libgif:BuildRequires: giflib-devel}
18b90c81
SP
99BuildRequires: glew-devel
100BuildRequires: gperf
5a2f2b01 101BuildRequires: jasper-devel
37fbe511 102BuildRequires: jre
b85db44b 103BuildRequires: libass-devel
a7c53f4c 104BuildRequires: libatomic-devel
296d79de 105BuildRequires: libbluray-devel >= 0.7.0
37fbe511 106BuildRequires: libcap-devel
18b90c81 107BuildRequires: libcdio-devel
8fa5c2e4
JB
108%{?with_libcec:BuildRequires: libcec-devel >= 3.0.0}
109BuildRequires: libdrm-devel
e25cf996 110%{?with_system_dvdread:BuildRequires: libdvdread-devel}
1aef2bca 111%ifarch i686 pentium4 athlon %{x8664}
5f83fc0f 112BuildRequires: libcrystalhd-devel
1aef2bca 113%endif
b85db44b 114BuildRequires: libgcrypt-devel
18b90c81 115BuildRequires: libjpeg-devel
45a200ab 116BuildRequires: libltdl-devel
63ff963e 117BuildRequires: libmicrohttpd-devel
63ff963e 118BuildRequires: libmodplug-devel
c462fd57 119BuildRequires: libmpeg2-devel
18b90c81 120BuildRequires: libogg-devel
b85db44b 121BuildRequires: libplist-devel
5a2f2b01 122BuildRequires: libpng-devel
b85db44b 123BuildRequires: librtmp-devel
18b90c81
SP
124BuildRequires: libsamplerate-devel
125BuildRequires: libsmbclient-devel
b85db44b 126BuildRequires: libssh-devel
8fa5c2e4 127BuildRequires: libstdc++-devel
5a2f2b01 128BuildRequires: libtiff-devel
129BuildRequires: libtool
f99f2533 130BuildRequires: libuuid-devel
b85db44b 131BuildRequires: libva-devel
f99f2533 132BuildRequires: libva-x11-devel
5a2f2b01 133BuildRequires: libvdpau-devel
18b90c81 134BuildRequires: libvorbis-devel
8fa5c2e4 135BuildRequires: libxml2-devel >= 2.0
501e1d3e 136BuildRequires: libxslt-devel
5a2f2b01 137BuildRequires: lzo-devel
138BuildRequires: mysql-devel
c1b45330 139%ifarch %{ix86}
26cae375 140BuildRequires: nasm
c1b45330 141%endif
18b90c81 142BuildRequires: openssl-devel
63ff963e 143BuildRequires: pcre-cxx-devel
5a2f2b01 144BuildRequires: pkgconfig
8fa5c2e4
JB
145BuildRequires: pulseaudio-devel >= 1.0
146BuildRequires: python-devel >= 1:2.6
3a71016a 147BuildRequires: rpm-pythonprov
6f41c837 148BuildRequires: rpmbuild(macros) >= 1.566
c462fd57 149BuildRequires: sed >= 4.0
18b90c81 150BuildRequires: sqlite3-devel
37fbe511
KK
151BuildRequires: swig
152BuildRequires: taglib-devel >= 1.8
8fa5c2e4 153BuildRequires: tinyxml-devel >= 2.6.2
b85db44b 154BuildRequires: udev-devel
5a2f2b01 155BuildRequires: unzip
b85db44b
AF
156BuildRequires: xorg-lib-libX11-devel
157BuildRequires: xorg-lib-libXext-devel
18b90c81 158BuildRequires: xorg-lib-libXrandr-devel
8fa5c2e4 159BuildRequires: yajl-devel >= 2
18b90c81
SP
160BuildRequires: zip
161BuildRequires: zlib-devel
af2a7b89
JR
162# kodi uses it's own, modified squish
163BuildConflicts: squish-devel
b85db44b 164#https://github.com/sahlberg/libnfs
57d594cf 165BuildRequires: libnfs-devel
b85db44b
AF
166#http://sites.google.com/site/alexthepuffin/home
167#BuildRequires: afpfs-ng-devel
8fa5c2e4 168#BuildRequires: shairplay-devel
63ff963e 169Requires: /usr/bin/glxinfo
f4f8f308 170Requires: SDL >= 1.2.14-5
a58652d4
SP
171Requires: lsb-release
172Requires: xorg-app-xdpyinfo
06c1bb12 173# dlopened libraries:
d61811e9 174# grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
06c1bb12
ER
175Requires: curl-libs
176Requires: libass
177Requires: libbluray
178Requires: libmodplug
179Requires: libmpeg2-libs
180Requires: libogg
181Requires: libplist
182Requires: libvorbis
92b53b2c 183Obsoletes: xbmc < 14.0
18b90c81
SP
184BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
185
186%description
d61811e9
ER
187Kodi Entertainment Center (formerly XBMC) is a free and open-source
188media player software developed by the XBMC Foundation, a non-profit
189technology consortium. Kodi is available for multiple operating
190systems and hardware platforms, with a software 10-foot user interface
191for use with televisions and remote controls. It allows users to play
192and view most videos, music, such as podcasts from the internet, and
193all common digital media files from local and network storage media.
18b90c81
SP
194
195%prep
92b53b2c 196%setup -q -n xbmc-%{version}-%{codename}
6b5f5f8f 197#%patch0 -p1
af2a7b89 198%patch1 -p1
b2628f52 199#%{?with_system_dvdread:%patch2 -p1}
6b5f5f8f
ER
200#%patch3 -p1
201#%patch4 -p1
18b90c81 202
6b5f5f8f 203#%{__rm} -r lib/cximage-6.0/zlib
8fa5c2e4 204#%{__rm} -r lib/libhdhomerun
6b5f5f8f
ER
205#%{__rm} -r lib/libmpeg2
206#%{__rm} -r xbmc/cores/dvdplayer/DVDCodecs/Video/libmpeg2
207#%{__rm} -r lib/libbluray
b2628f52 208#%{__rm} -r lib/librtmp
8fa5c2e4 209%{__rm} -r lib/win32
b2628f52 210#%{?with_system_dvdread:%{__rm} -r lib/libdvd/libdvdread}
5d47de93 211
72cf5436 212%if %{without system_ffmpeg}
c3c3c480 213#ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
928406b7
ER
214%endif
215
18b90c81 216%build
b2628f52
ER
217#%{__make} -C tools/depends/native/libsquish-native \
218# CXX="%{__cxx}"
c3c3c480 219
18b90c81 220./bootstrap
65712ad3 221%configure \
57d594cf 222 ac_cv_type__Bool=yes \
ace9791d 223 --disable-silent-rules \
51b524ca 224 --disable-debug \
ace9791d 225 --disable-ccache \
928406b7 226 --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
c0d69361
ER
227 %{__enable_disable afpclient} \
228 %{__enable_disable airplay} \
229 %{__enable_disable airtunes} \
ceb94d36 230 %{__enable_disable alsa} \
e148a10d 231 %{__enable_disable asap_codec asap-codec} \
ceb94d36
ER
232 %{__enable_disable avahi} \
233 %{__enable_disable dbus} \
98f23c16 234 %{__enable_disable dvdcss} \
e148a10d 235 %{__enable_disable gles} \
98f23c16 236 %{__enable_disable gl} \
98f23c16 237 %{__enable_disable gtest} \
98f23c16 238 %{__enable_disable joystick} \
e148a10d 239 %{__enable_disable libbluray} \
c0d69361 240 %{__enable_disable libcap} \
98f23c16 241 %{__enable_disable libcec} \
296d79de 242 %{__enable_disable libgif} \
c0d69361
ER
243 %{__enable_disable libusb} \
244 %{__enable_disable mdnsembedded} \
e148a10d 245 %{__enable_disable mid} \
ceb94d36 246 %{__enable_disable mysql} \
c0d69361 247 %{__enable_disable nfs} \
ceb94d36 248 %{__enable_disable non_free non-free} \
c0d69361 249 %{__enable_disable openmax} \
ceb94d36 250 %{__enable_disable optical_drive optical-drive} \
e148a10d 251 %{__enable_disable profiling} \
c0d69361 252 %{__enable_disable pulse} \
c0d69361 253 %{__enable_disable rtmp} \
ceb94d36 254 %{__enable_disable samba} \
c0d69361 255 %{__enable_disable sdl} \
ceb94d36 256 %{__enable_disable ssh} \
e148a10d
ER
257 %{__enable_disable tegra} \
258 %{__enable_disable texturepacker} \
c0d69361 259 %{__enable_disable udev} \
ceb94d36 260 %{__enable_disable upnp} \
c0d69361
ER
261 %{__enable_disable vaapi} \
262 %{__enable_disable vdpau} \
263 %{__enable_disable vtbdecoder} \
e148a10d 264 %{__enable_disable wayland} \
ceb94d36 265 %{__enable_disable webserver} \
98f23c16
ER
266 %{__enable_disable x11} \
267 %{__enable_disable xrandr} \
268 %{nil}
68612b1e 269
00f4b5ab 270%{__make} V=1
18b90c81
SP
271
272%install
273rm -rf $RPM_BUILD_ROOT
18b90c81 274%{__make} install \
92b96980 275 DESTDIR=$RPM_BUILD_ROOT
18b90c81 276
25890c53
ER
277%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
278
279# no -devel package yet
280%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
281%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
282
a5bfc3a3
ER
283# no real use for symlinks to datadir, and make rpm packaging more difficult (symlink vs dir issues)
284%{__rm} $RPM_BUILD_ROOT%{_libdir}/xbmc
285%{__rm} $RPM_BUILD_ROOT%{_datadir}/xbmc
286
18b90c81
SP
287%clean
288rm -rf $RPM_BUILD_ROOT
289
290%files
291%defattr(644,root,root,755)
25890c53
ER
292%doc README.md docs/README.linux
293%attr(755,root,root) %{_bindir}/kodi
294%attr(755,root,root) %{_bindir}/kodi-standalone
18b90c81 295%{_datadir}/%{name}
92b96980 296%attr(755,root,root) %{_libdir}/%{name}
25890c53
ER
297%{_desktopdir}/kodi.desktop
298%{_iconsdir}/hicolor/*/apps/%{name}.png
299%{_datadir}/xsessions/kodi.desktop
300
301# legacy xbmc compatibility links
302%attr(755,root,root) %{_bindir}/xbmc
303%attr(755,root,root) %{_bindir}/xbmc-standalone
25890c53 304%{_datadir}/xsessions/xbmc.desktop
This page took 0.096608 seconds and 4 git commands to generate.