]> git.pld-linux.org Git - packages/kodi.git/blame - kodi.spec
bconds for rest of the options
[packages/kodi.git] / kodi.spec
CommitLineData
18b90c81 1# TODO:
3a71016a 2# - fix build flags - some files are compiled with -O3 and without rpm*flags
92b96980 3# - add and/or fix users/groups permissions
63ff963e 4# - split to subpackages?
928406b7 5# - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
18b90c81 6#
92b96980 7# Conditional build:
ceb94d36 8# Features:
c0d69361
ER
9%bcond_with afpclient # AFP support via libafpclient
10%bcond_without airplay # AirPlay support
11%bcond_with airtunes # AirTunes support
e148a10d
ER
12%bcond_without alsa # ALSA support
13%bcond_without avahi # Avahi support
ceb94d36
ER
14%bcond_without dbus # DBUS support
15%bcond_without dvdcss # DVDCSS support
98f23c16
ER
16%bcond_without fishbmc # FishBMC visualisation
17%bcond_without gl # OpenGL rendering
18%bcond_without goom # GOOM visualisation
ceb94d36 19%bcond_with gtest # configure Google Test Framework
98f23c16 20%bcond_without joystick # SDL joystick support
c0d69361
ER
21%bcond_without libcap # libcap support
22%bcond_with libcec # libcec support
23%bcond_with libusb # libusb support
24%bcond_with mdnsembedded # mDNSEmbedded support
ceb94d36 25%bcond_without mysql # MySQL
c0d69361 26%bcond_with nfs # NFS support via libnfs
ceb94d36 27%bcond_without non_free # componentents with non-compliant licenses
c0d69361 28%bcond_with openmax # OpenMax decoding, requires OpenGLES
ceb94d36 29%bcond_without optical_drive # optical drive
98f23c16 30%bcond_without projectm # ProjectM visualisation
c0d69361 31%bcond_without pulse # PulseAudio support
98f23c16 32%bcond_without rsxs # really slick X screensavers
c0d69361 33%bcond_without rtmp # RTMP support via librtmp
e148a10d 34%bcond_without samba # SAMBA support
c0d69361 35%bcond_without sdl # SDL
98f23c16 36%bcond_without spectrum # Spectrum visualisation
e148a10d 37%bcond_without ssh # SSH SFTP support
98f23c16 38%bcond_without texturepacker # texturepacker support
c0d69361 39%bcond_without udev # udev support
e148a10d 40%bcond_without upnp # UPnP support
c0d69361
ER
41%bcond_without vaapi # VAAPI decoding
42%bcond_without vdpau # VDPAU decoding
43%bcond_with vtbdecoder # VTBDecoder decoding (VTB Decoder not supported on this platform)
98f23c16 44%bcond_without waveform # Waveform visualisation
ceb94d36 45%bcond_without webserver # webserver
98f23c16
ER
46%bcond_without x11 # x11 'Linux Only'
47%bcond_without xrandr # XRandR support
e148a10d
ER
48%bcond_with asap_codec # ASAP ADPCM support
49%bcond_with gles # OpenGLES rendering
50%bcond_without libbluray # libbluray support
51%bcond_without mid # MID support
52%bcond_with profiling # gprof profiling
53%bcond_with tegra # Tegra2 arm
54%bcond_with wayland # wayland
ceb94d36 55# System libs:
6e5f6f0e 56%bcond_without system_ffmpeg # build with system ffmpeg
e25cf996 57%bcond_without system_dvdread # build with system dvdread
92b96980 58
92b53b2c 59%define codename Helix
d61811e9 60Summary: Kodi is a free and open source media-player and entertainment hub
92b53b2c
ER
61Name: kodi
62Version: 14.0
05c4c454 63Release: 0.3
68612b1e 64License: GPL v2+ and GPL v3+
18b90c81 65Group: Applications/Multimedia
92b53b2c
ER
66Source0: http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
67# Source0-md5: 9717c539789789b8aeaf1dcfdb9f2c69
72cf5436 68Source1: https://github.com/xbmc/FFmpeg/archive/2.4.4-%{codename}.tar.gz
928406b7 69# Source1-md5: 19b5d29ef6b5a6fc202c652fe3905d9b
d2f0f4c7 70Patch0: jpeglib-boolean.patch
6e5f6f0e 71Patch1: dvddemux-ffmpeg.patch
e25cf996 72Patch2: dvdread.patch
92b53b2c 73URL: http://kodi.tv/
b85db44b
AF
74BuildRequires: Mesa-libGLU-devel
75BuildRequires: OpenGL-devel
658b3aff 76BuildRequires: SDL2-devel
18b90c81
SP
77BuildRequires: SDL_image-devel
78BuildRequires: SDL_mixer-devel
79BuildRequires: alsa-lib-devel
80BuildRequires: autoconf
81BuildRequires: automake
82BuildRequires: avahi-devel
b85db44b 83BuildRequires: bluez-libs-devel >= 4.99
5a2f2b01 84BuildRequires: boost-devel
18b90c81
SP
85BuildRequires: bzip2-devel
86BuildRequires: cmake
87BuildRequires: curl-devel
88BuildRequires: dbus-devel
501e1d3e 89BuildRequires: doxygen
64d462c0 90%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 2.4.4}
5a2f2b01 91BuildRequires: flac-devel
18b90c81
SP
92BuildRequires: fontconfig-devel
93BuildRequires: freetype-devel
94BuildRequires: fribidi-devel
95BuildRequires: gawk
63ff963e 96BuildRequires: gettext-autopoint
0747666f 97BuildRequires: gettext-tools
18b90c81
SP
98BuildRequires: glew-devel
99BuildRequires: gperf
5a2f2b01 100BuildRequires: jasper-devel
37fbe511 101BuildRequires: jre
b85db44b 102BuildRequires: libass-devel
37fbe511
KK
103BuildRequires: libbluray-devel >= 0.2.1
104BuildRequires: libcap-devel
18b90c81 105BuildRequires: libcdio-devel
c0d69361 106%{?with_libcec:BuildRequires: libcec-devel}
e25cf996 107%{?with_system_dvdread:BuildRequires: libdvdread-devel}
1aef2bca 108%ifarch i686 pentium4 athlon %{x8664}
5f83fc0f 109BuildRequires: libcrystalhd-devel
1aef2bca 110%endif
b85db44b 111BuildRequires: libgcrypt-devel
18b90c81 112BuildRequires: libjpeg-devel
45a200ab 113BuildRequires: libltdl-devel
18b90c81 114BuildRequires: libmad-devel
63ff963e 115BuildRequires: libmicrohttpd-devel
63ff963e 116BuildRequires: libmodplug-devel
c462fd57 117BuildRequires: libmpeg2-devel
18b90c81 118BuildRequires: libogg-devel
b85db44b 119BuildRequires: libplist-devel
5a2f2b01 120BuildRequires: libpng-devel
b85db44b 121BuildRequires: librtmp-devel
18b90c81
SP
122BuildRequires: libsamplerate-devel
123BuildRequires: libsmbclient-devel
b85db44b 124BuildRequires: libssh-devel
5a2f2b01 125BuildRequires: libtiff-devel
126BuildRequires: libtool
b85db44b 127BuildRequires: libva-devel
5f83fc0f 128BuildRequires: libva-glx-devel
5a2f2b01 129BuildRequires: libvdpau-devel
18b90c81 130BuildRequires: libvorbis-devel
501e1d3e 131BuildRequires: libxslt-devel
5a2f2b01 132BuildRequires: lzo-devel
133BuildRequires: mysql-devel
c1b45330 134%ifarch %{ix86}
26cae375 135BuildRequires: nasm
c1b45330 136%endif
18b90c81 137BuildRequires: openssl-devel
63ff963e 138BuildRequires: pcre-cxx-devel
5a2f2b01 139BuildRequires: pkgconfig
18b90c81 140BuildRequires: pulseaudio-devel
b85db44b 141BuildRequires: python-devel >= 2.4
3a71016a 142BuildRequires: rpm-pythonprov
6f41c837 143BuildRequires: rpmbuild(macros) >= 1.566
c462fd57 144BuildRequires: sed >= 4.0
18b90c81 145BuildRequires: sqlite3-devel
37fbe511
KK
146BuildRequires: swig
147BuildRequires: taglib-devel >= 1.8
7613a43d 148BuildRequires: tinyxml-devel
b85db44b 149BuildRequires: udev-devel
5a2f2b01 150BuildRequires: unzip
b85db44b
AF
151BuildRequires: xorg-lib-libX11-devel
152BuildRequires: xorg-lib-libXext-devel
5a2f2b01 153BuildRequires: xorg-lib-libXinerama-devel
b85db44b 154BuildRequires: xorg-lib-libXmu-devel
18b90c81 155BuildRequires: xorg-lib-libXrandr-devel
b85db44b 156BuildRequires: xorg-lib-libXt-devel
5a2f2b01 157BuildRequires: xorg-lib-libXtst-devel
b85db44b 158BuildRequires: yajl-devel
501e1d3e 159BuildRequires: yasm
18b90c81
SP
160BuildRequires: zip
161BuildRequires: zlib-devel
b85db44b
AF
162#https://github.com/sahlberg/libnfs
163#BuildRequires: libnfs-devel
164#http://sites.google.com/site/alexthepuffin/home
165#BuildRequires: afpfs-ng-devel
166#http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
167#https://github.com/albertz/shairport
168#BuildRequires: libshairport
63ff963e 169Requires: /usr/bin/glxinfo
f4f8f308 170Requires: SDL >= 1.2.14-5
a58652d4
SP
171Requires: lsb-release
172Requires: xorg-app-xdpyinfo
06c1bb12 173# dlopened libraries:
d61811e9 174# grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
06c1bb12
ER
175Requires: curl-libs
176Requires: libass
177Requires: libbluray
178Requires: libmodplug
179Requires: libmpeg2-libs
180Requires: libogg
181Requires: libplist
182Requires: libvorbis
92b53b2c 183Obsoletes: xbmc < 14.0
18b90c81
SP
184BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
185
186%description
d61811e9
ER
187Kodi Entertainment Center (formerly XBMC) is a free and open-source
188media player software developed by the XBMC Foundation, a non-profit
189technology consortium. Kodi is available for multiple operating
190systems and hardware platforms, with a software 10-foot user interface
191for use with televisions and remote controls. It allows users to play
192and view most videos, music, such as podcasts from the internet, and
193all common digital media files from local and network storage media.
18b90c81
SP
194
195%prep
92b53b2c 196%setup -q -n xbmc-%{version}-%{codename}
bfa116d7 197%patch0 -p1
05c4c454
ER
198%{?with_system_ffmpeg:%patch1 -p0}
199%{?with_system_dvdread:%patch2 -p1}
18b90c81 200
5d47de93
ER
201rm -r lib/cximage-6.0/zlib
202#rm -r lib/libhdhomerun
203rm -r lib/libmpeg2
204rm -r xbmc/cores/dvdplayer/DVDCodecs/Video/libmpeg2
205rm -r lib/enca
206rm -r lib/libbluray
207rm -r lib/libmicrohttpd
208rm -r lib/libmodplug
209rm -r lib/librtmp
210rm -r lib/win32
05c4c454 211%{?with_system_dvdread:rm -r lib/libdvd/libdvdread}
5d47de93 212
72cf5436
ER
213%if %{without system_ffmpeg}
214ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
928406b7
ER
215%endif
216
18b90c81
SP
217%build
218./bootstrap
65712ad3 219%configure \
ace9791d 220 --disable-silent-rules \
51b524ca 221 --disable-debug \
ace9791d 222 --disable-ccache \
928406b7 223 --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
c0d69361
ER
224 %{__enable_disable afpclient} \
225 %{__enable_disable airplay} \
226 %{__enable_disable airtunes} \
ceb94d36 227 %{__enable_disable alsa} \
e148a10d 228 %{__enable_disable asap_codec asap-codec} \
ceb94d36
ER
229 %{__enable_disable avahi} \
230 %{__enable_disable dbus} \
98f23c16
ER
231 %{__enable_disable dvdcss} \
232 %{__enable_disable fishbmc} \
e148a10d 233 %{__enable_disable gles} \
98f23c16 234 %{__enable_disable gl} \
b85db44b 235 %{__enable_disable goom} \
98f23c16 236 %{__enable_disable gtest} \
98f23c16 237 %{__enable_disable joystick} \
e148a10d 238 %{__enable_disable libbluray} \
c0d69361 239 %{__enable_disable libcap} \
98f23c16 240 %{__enable_disable libcec} \
c0d69361
ER
241 %{__enable_disable libusb} \
242 %{__enable_disable mdnsembedded} \
e148a10d 243 %{__enable_disable mid} \
ceb94d36 244 %{__enable_disable mysql} \
c0d69361 245 %{__enable_disable nfs} \
ceb94d36 246 %{__enable_disable non_free non-free} \
c0d69361 247 %{__enable_disable openmax} \
ceb94d36 248 %{__enable_disable optical_drive optical-drive} \
e148a10d 249 %{__enable_disable profiling} \
98f23c16 250 %{__enable_disable projectm} \
c0d69361 251 %{__enable_disable pulse} \
98f23c16 252 %{__enable_disable rsxs} \
c0d69361 253 %{__enable_disable rtmp} \
ceb94d36 254 %{__enable_disable samba} \
c0d69361 255 %{__enable_disable sdl} \
98f23c16 256 %{__enable_disable spectrum} \
ceb94d36 257 %{__enable_disable ssh} \
e148a10d
ER
258 %{__enable_disable tegra} \
259 %{__enable_disable texturepacker} \
c0d69361 260 %{__enable_disable udev} \
ceb94d36 261 %{__enable_disable upnp} \
c0d69361
ER
262 %{__enable_disable vaapi} \
263 %{__enable_disable vdpau} \
264 %{__enable_disable vtbdecoder} \
98f23c16 265 %{__enable_disable waveform} \
e148a10d 266 %{__enable_disable wayland} \
ceb94d36 267 %{__enable_disable webserver} \
98f23c16
ER
268 %{__enable_disable x11} \
269 %{__enable_disable xrandr} \
270 %{nil}
68612b1e 271
00f4b5ab 272%{__make} V=1
18b90c81
SP
273
274%install
275rm -rf $RPM_BUILD_ROOT
18b90c81 276%{__make} install \
92b96980 277 DESTDIR=$RPM_BUILD_ROOT
18b90c81 278
25890c53
ER
279%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
280
281# no -devel package yet
282%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
283%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
284
a5bfc3a3
ER
285# no real use for symlinks to datadir, and make rpm packaging more difficult (symlink vs dir issues)
286%{__rm} $RPM_BUILD_ROOT%{_libdir}/xbmc
287%{__rm} $RPM_BUILD_ROOT%{_datadir}/xbmc
288
18b90c81
SP
289%clean
290rm -rf $RPM_BUILD_ROOT
291
292%files
293%defattr(644,root,root,755)
25890c53
ER
294%doc README.md docs/README.linux
295%attr(755,root,root) %{_bindir}/kodi
296%attr(755,root,root) %{_bindir}/kodi-standalone
18b90c81 297%{_datadir}/%{name}
92b96980 298%attr(755,root,root) %{_libdir}/%{name}
25890c53
ER
299%{_desktopdir}/kodi.desktop
300%{_iconsdir}/hicolor/*/apps/%{name}.png
301%{_datadir}/xsessions/kodi.desktop
302
303# legacy xbmc compatibility links
304%attr(755,root,root) %{_bindir}/xbmc
305%attr(755,root,root) %{_bindir}/xbmc-standalone
25890c53 306%{_datadir}/xsessions/xbmc.desktop
This page took 0.301145 seconds and 4 git commands to generate.