]> git.pld-linux.org Git - packages/kodi.git/blame - kodi.spec
system ffmpeg devel BR adjust
[packages/kodi.git] / kodi.spec
CommitLineData
18b90c81 1# TODO:
3a71016a 2# - fix build flags - some files are compiled with -O3 and without rpm*flags
c1b45330 3# - fix linking argument order
92b96980 4# - add and/or fix users/groups permissions
63ff963e 5# - split to subpackages?
928406b7
ER
6# - system ffmpeg (--with-ffmpeg=shared), DVDDemuxFFmpeg.cpp:542:41: error: 'av_read_frame_flush' was not declared in this scope
7# - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
18b90c81 8#
92b96980 9# Conditional build:
ceb94d36 10# Features:
c0d69361
ER
11%bcond_with afpclient # AFP support via libafpclient
12%bcond_without airplay # AirPlay support
13%bcond_with airtunes # AirTunes support
ceb94d36
ER
14%bcond_without alsa # ALSA support (only for linux/freebsd)
15%bcond_without avahi # Avahi support (default is enabled if libavahi-common and libavahi-client is found)
16%bcond_without dbus # DBUS support
17%bcond_without dvdcss # DVDCSS support
98f23c16
ER
18%bcond_without fishbmc # FishBMC visualisation
19%bcond_without gl # OpenGL rendering
20%bcond_without goom # GOOM visualisation
ceb94d36 21%bcond_with gtest # configure Google Test Framework
98f23c16 22%bcond_without joystick # SDL joystick support
c0d69361
ER
23%bcond_without libcap # libcap support
24%bcond_with libcec # libcec support
25%bcond_with libusb # libusb support
26%bcond_with mdnsembedded # mDNSEmbedded support
ceb94d36 27%bcond_without mysql # MySQL
c0d69361 28%bcond_with nfs # NFS support via libnfs
ceb94d36 29%bcond_without non_free # componentents with non-compliant licenses
c0d69361 30%bcond_with openmax # OpenMax decoding, requires OpenGLES
ceb94d36 31%bcond_without optical_drive # optical drive
98f23c16 32%bcond_without projectm # ProjectM visualisation
c0d69361 33%bcond_without pulse # PulseAudio support
98f23c16 34%bcond_without rsxs # really slick X screensavers
c0d69361 35%bcond_without rtmp # RTMP support via librtmp
ceb94d36 36%bcond_without samba # SAMBA support (default is enabled)
c0d69361 37%bcond_without sdl # SDL
98f23c16 38%bcond_without spectrum # Spectrum visualisation
ceb94d36 39%bcond_without ssh # SSH SFTP support (default is enabled)
98f23c16 40%bcond_without texturepacker # texturepacker support
c0d69361 41%bcond_without udev # udev support
ceb94d36 42%bcond_without upnp # UPnP support (default is enabled)
c0d69361
ER
43%bcond_without vaapi # VAAPI decoding
44%bcond_without vdpau # VDPAU decoding
45%bcond_with vtbdecoder # VTBDecoder decoding (VTB Decoder not supported on this platform)
98f23c16 46%bcond_without waveform # Waveform visualisation
ceb94d36 47%bcond_without webserver # webserver
98f23c16
ER
48%bcond_without x11 # x11 'Linux Only'
49%bcond_without xrandr # XRandR support
ceb94d36 50# System libs:
6e5f6f0e 51%bcond_without system_ffmpeg # build with system ffmpeg
92b96980 52
92b53b2c 53%define codename Helix
d61811e9 54Summary: Kodi is a free and open source media-player and entertainment hub
92b53b2c
ER
55Name: kodi
56Version: 14.0
57Release: 0.1
68612b1e 58License: GPL v2+ and GPL v3+
18b90c81 59Group: Applications/Multimedia
92b53b2c
ER
60Source0: http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
61# Source0-md5: 9717c539789789b8aeaf1dcfdb9f2c69
72cf5436 62Source1: https://github.com/xbmc/FFmpeg/archive/2.4.4-%{codename}.tar.gz
928406b7 63# Source1-md5: 19b5d29ef6b5a6fc202c652fe3905d9b
d2f0f4c7 64Patch0: jpeglib-boolean.patch
6e5f6f0e 65Patch1: dvddemux-ffmpeg.patch
92b53b2c 66URL: http://kodi.tv/
b85db44b
AF
67BuildRequires: Mesa-libGLU-devel
68BuildRequires: OpenGL-devel
658b3aff 69BuildRequires: SDL2-devel
18b90c81
SP
70BuildRequires: SDL_image-devel
71BuildRequires: SDL_mixer-devel
72BuildRequires: alsa-lib-devel
73BuildRequires: autoconf
74BuildRequires: automake
75BuildRequires: avahi-devel
b85db44b 76BuildRequires: bluez-libs-devel >= 4.99
5a2f2b01 77BuildRequires: boost-devel
18b90c81
SP
78BuildRequires: bzip2-devel
79BuildRequires: cmake
80BuildRequires: curl-devel
81BuildRequires: dbus-devel
501e1d3e 82BuildRequires: doxygen
64d462c0 83%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 2.4.4}
5a2f2b01 84BuildRequires: flac-devel
18b90c81
SP
85BuildRequires: fontconfig-devel
86BuildRequires: freetype-devel
87BuildRequires: fribidi-devel
88BuildRequires: gawk
63ff963e 89BuildRequires: gettext-autopoint
0747666f 90BuildRequires: gettext-tools
18b90c81
SP
91BuildRequires: glew-devel
92BuildRequires: gperf
5a2f2b01 93BuildRequires: jasper-devel
37fbe511 94BuildRequires: jre
b85db44b 95BuildRequires: libass-devel
37fbe511
KK
96BuildRequires: libbluray-devel >= 0.2.1
97BuildRequires: libcap-devel
18b90c81 98BuildRequires: libcdio-devel
c0d69361 99%{?with_libcec:BuildRequires: libcec-devel}
1aef2bca 100%ifarch i686 pentium4 athlon %{x8664}
5f83fc0f 101BuildRequires: libcrystalhd-devel
1aef2bca 102%endif
b85db44b 103BuildRequires: libgcrypt-devel
18b90c81 104BuildRequires: libjpeg-devel
45a200ab 105BuildRequires: libltdl-devel
18b90c81 106BuildRequires: libmad-devel
63ff963e 107BuildRequires: libmicrohttpd-devel
63ff963e 108BuildRequires: libmodplug-devel
c462fd57 109BuildRequires: libmpeg2-devel
18b90c81 110BuildRequires: libogg-devel
b85db44b 111BuildRequires: libplist-devel
5a2f2b01 112BuildRequires: libpng-devel
b85db44b 113BuildRequires: librtmp-devel
18b90c81
SP
114BuildRequires: libsamplerate-devel
115BuildRequires: libsmbclient-devel
b85db44b 116BuildRequires: libssh-devel
5a2f2b01 117BuildRequires: libtiff-devel
118BuildRequires: libtool
b85db44b 119BuildRequires: libva-devel
5f83fc0f 120BuildRequires: libva-glx-devel
5a2f2b01 121BuildRequires: libvdpau-devel
18b90c81 122BuildRequires: libvorbis-devel
501e1d3e 123BuildRequires: libxslt-devel
5a2f2b01 124BuildRequires: lzo-devel
125BuildRequires: mysql-devel
c1b45330 126%ifarch %{ix86}
26cae375 127BuildRequires: nasm
c1b45330 128%endif
18b90c81 129BuildRequires: openssl-devel
63ff963e 130BuildRequires: pcre-cxx-devel
5a2f2b01 131BuildRequires: pkgconfig
18b90c81 132BuildRequires: pulseaudio-devel
b85db44b 133BuildRequires: python-devel >= 2.4
3a71016a 134BuildRequires: rpm-pythonprov
6f41c837 135BuildRequires: rpmbuild(macros) >= 1.566
c462fd57 136BuildRequires: sed >= 4.0
18b90c81 137BuildRequires: sqlite3-devel
37fbe511
KK
138BuildRequires: swig
139BuildRequires: taglib-devel >= 1.8
7613a43d 140BuildRequires: tinyxml-devel
b85db44b 141BuildRequires: udev-devel
5a2f2b01 142BuildRequires: unzip
b85db44b
AF
143BuildRequires: xorg-lib-libX11-devel
144BuildRequires: xorg-lib-libXext-devel
5a2f2b01 145BuildRequires: xorg-lib-libXinerama-devel
b85db44b 146BuildRequires: xorg-lib-libXmu-devel
18b90c81 147BuildRequires: xorg-lib-libXrandr-devel
b85db44b 148BuildRequires: xorg-lib-libXt-devel
5a2f2b01 149BuildRequires: xorg-lib-libXtst-devel
b85db44b 150BuildRequires: yajl-devel
501e1d3e 151BuildRequires: yasm
18b90c81
SP
152BuildRequires: zip
153BuildRequires: zlib-devel
b85db44b
AF
154#https://github.com/sahlberg/libnfs
155#BuildRequires: libnfs-devel
156#http://sites.google.com/site/alexthepuffin/home
157#BuildRequires: afpfs-ng-devel
158#http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
159#https://github.com/albertz/shairport
160#BuildRequires: libshairport
63ff963e 161Requires: /usr/bin/glxinfo
f4f8f308 162Requires: SDL >= 1.2.14-5
a58652d4
SP
163Requires: lsb-release
164Requires: xorg-app-xdpyinfo
06c1bb12 165# dlopened libraries:
d61811e9 166# grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
06c1bb12
ER
167Requires: curl-libs
168Requires: libass
169Requires: libbluray
170Requires: libmodplug
171Requires: libmpeg2-libs
172Requires: libogg
173Requires: libplist
174Requires: libvorbis
92b53b2c 175Obsoletes: xbmc < 14.0
18b90c81
SP
176BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
177
178%description
d61811e9
ER
179Kodi Entertainment Center (formerly XBMC) is a free and open-source
180media player software developed by the XBMC Foundation, a non-profit
181technology consortium. Kodi is available for multiple operating
182systems and hardware platforms, with a software 10-foot user interface
183for use with televisions and remote controls. It allows users to play
184and view most videos, music, such as podcasts from the internet, and
185all common digital media files from local and network storage media.
18b90c81
SP
186
187%prep
92b53b2c 188%setup -q -n xbmc-%{version}-%{codename}
bfa116d7 189%patch0 -p1
6e5f6f0e 190%patch1 -p0
18b90c81 191
72cf5436
ER
192%if %{without system_ffmpeg}
193ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
928406b7
ER
194%endif
195
18b90c81
SP
196%build
197./bootstrap
65712ad3 198%configure \
ace9791d 199 --disable-silent-rules \
51b524ca 200 --disable-debug \
ace9791d 201 --disable-ccache \
928406b7 202 --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
c0d69361
ER
203 %{__enable_disable afpclient} \
204 %{__enable_disable airplay} \
205 %{__enable_disable airtunes} \
ceb94d36
ER
206 %{__enable_disable alsa} \
207 %{__enable_disable avahi} \
208 %{__enable_disable dbus} \
98f23c16
ER
209 %{__enable_disable dvdcss} \
210 %{__enable_disable fishbmc} \
211 %{__enable_disable gl} \
b85db44b 212 %{__enable_disable goom} \
98f23c16 213 %{__enable_disable gtest} \
dc0a03c5 214 %{__enable_disable texturepacker} \
98f23c16 215 %{__enable_disable joystick} \
c0d69361 216 %{__enable_disable libcap} \
98f23c16 217 %{__enable_disable libcec} \
c0d69361
ER
218 %{__enable_disable libusb} \
219 %{__enable_disable mdnsembedded} \
ceb94d36 220 %{__enable_disable mysql} \
c0d69361 221 %{__enable_disable nfs} \
ceb94d36 222 %{__enable_disable non_free non-free} \
c0d69361 223 %{__enable_disable openmax} \
ceb94d36 224 %{__enable_disable optical_drive optical-drive} \
98f23c16 225 %{__enable_disable projectm} \
c0d69361 226 %{__enable_disable pulse} \
98f23c16 227 %{__enable_disable rsxs} \
c0d69361 228 %{__enable_disable rtmp} \
ceb94d36 229 %{__enable_disable samba} \
c0d69361 230 %{__enable_disable sdl} \
98f23c16 231 %{__enable_disable spectrum} \
ceb94d36 232 %{__enable_disable ssh} \
c0d69361 233 %{__enable_disable udev} \
ceb94d36 234 %{__enable_disable upnp} \
c0d69361
ER
235 %{__enable_disable vaapi} \
236 %{__enable_disable vdpau} \
237 %{__enable_disable vtbdecoder} \
98f23c16 238 %{__enable_disable waveform} \
ceb94d36 239 %{__enable_disable webserver} \
98f23c16
ER
240 %{__enable_disable x11} \
241 %{__enable_disable xrandr} \
242 %{nil}
68612b1e 243
ace9791d 244%{__make}
18b90c81
SP
245
246%install
247rm -rf $RPM_BUILD_ROOT
18b90c81 248%{__make} install \
92b96980 249 DESTDIR=$RPM_BUILD_ROOT
18b90c81 250
25890c53
ER
251%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
252
253# no -devel package yet
254%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
255%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
256
18b90c81
SP
257%clean
258rm -rf $RPM_BUILD_ROOT
259
260%files
261%defattr(644,root,root,755)
25890c53
ER
262%doc README.md docs/README.linux
263%attr(755,root,root) %{_bindir}/kodi
264%attr(755,root,root) %{_bindir}/kodi-standalone
18b90c81 265%{_datadir}/%{name}
92b96980 266%attr(755,root,root) %{_libdir}/%{name}
25890c53
ER
267%{_desktopdir}/kodi.desktop
268%{_iconsdir}/hicolor/*/apps/%{name}.png
269%{_datadir}/xsessions/kodi.desktop
270
271# legacy xbmc compatibility links
272%attr(755,root,root) %{_bindir}/xbmc
273%attr(755,root,root) %{_bindir}/xbmc-standalone
274%{_libdir}/xbmc
275%{_datadir}/xbmc
276%{_datadir}/xsessions/xbmc.desktop
This page took 0.075897 seconds and 4 git commands to generate.