]> git.pld-linux.org Git - projects/template-specs.git/blob - lib.spec
pecl: add example how to make failed tests as XFAIL
[projects/template-specs.git] / lib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        -
7 Summary(pl.UTF-8):      -
8 Name:           ---
9 Version:        0.1
10 Release:        0.1
11 License:        - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12 Group:          Libraries
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  -
15 #Patch0:        %{name}-what.patch
16 #URL:           -
17 #BuildRequires: -
18 #BuildRequires: autoconf
19 #BuildRequires: automake
20 #BuildRequires: intltool
21 #BuildRequires: libtool
22 #Requires(postun):      -
23 #Requires(pre,post):    -
24 #Requires(preun):       -
25 #Requires:      -
26 #Provides:      -
27 #Obsoletes:     -
28 #Conflicts:     -
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 # do not keep them in newly created specs
32 # these are only here to help fixing quickly broken specs
33 %define         filterout_ld    -Wl,--no-copy-dt-needed-entries
34 %define         filterout_ld    -Wl,--as-needed
35 # do not commit spec containing this (use for local testing only):
36 %define         filterout_c     -Werror=format-security
37 %define         filterout_cpp   -D_FORTIFY_SOURCE=.
38 %define         filterout_cxx   -Werror=format-security
39
40 # Ignore file in __spec_install_post_check_so
41 BuildRequires:  rpmbuild(macros) >= 1.583
42 %define         skip_post_check_so      libunresolved.so.*
43
44 # do not commit spec containing this (use for local testing only):
45 %define         no_install_post_check_tmpfiles  1
46
47 %description
48
49 #%description -l pl.UTF-8
50
51 %package common
52 Summary:        Common files for %{name} library
53 Summary(pl.UTF-8):      Wspólne pliki biblioteki %{name}
54 Group:          Libraries
55 Requires:       %{name} = %{version}-%{release}
56
57 %description common
58 Common files for %{name} library.
59
60 %description common -l pl.UTF-8
61 Wspólne pliki biblioteki %{name}.
62
63 %package devel
64 Summary:        Header files for %{name} library
65 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68
69 %description devel
70 Header files for %{name} library.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe biblioteki %{name}.
74
75 %package static
76 Summary:        Static %{name} library
77 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Static %{name} library.
83
84 %description static -l pl.UTF-8
85 Statyczna biblioteka %{name}.
86
87 %package apidocs
88 Summary:        API documentation for %{name} library
89 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
90 Group:          Documentation
91 # if not arch-dependent
92 %if "%{_rpmversion}" >= "5"
93 BuildArch:      noarch
94 %endif
95
96 %description apidocs
97 API documentation for %{name} library.
98
99 %description apidocs -l pl.UTF-8
100 Dokumentacja API biblioteki %{name}.
101
102 %prep
103 %setup -q
104 #%patch0 -p1
105
106 %build
107 # if ac/am/lt/* rebuilding is necessary, do it in this order and add
108 # appropriate BuildRequires
109 #%{__libtoolize}
110 #%{__aclocal}
111 #%{__autoconf}
112 #%{__autoheader}
113 #%{__automake}
114 %configure \
115         %{!?with_static_libs:--disable-static}
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 # create directories if necessary
121 #install -d $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 # if library provides pkgconfig file containing proper {Requires,Libs}.private
127 # then remove .la pollution
128 #%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS CREDITS README THANKS
139 %attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/%{name}.so.N
141
142 %files common
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/%{name}*
145 %{_datadir}/%{name}
146
147 %files devel
148 %defattr(644,root,root,755)
149 %doc devel-doc/* ChangeLog NEWS TODO
150 %attr(755,root,root) %{_libdir}/%{name}.so
151 # if no pkgconfig support, or it misses .private deps, then include .la file
152 #%{_libdir}/libFOO.la
153 %{_includedir}/%{name}
154 %{_aclocaldir}/%{name}.m4
155 %{_pkgconfigdir}/%{name}.pc
156
157 %if %{with static_libs}
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/%{name}.a
161 %endif
162
163 %if %{with apidocs}
164 %files apidocs
165 %defattr(644,root,root,755)
166 %doc apidocs/*
167 %endif
This page took 0.047529 seconds and 3 git commands to generate.