]> git.pld-linux.org Git - projects/template-specs.git/blame - lib.spec
pecl: add example how to make failed tests as XFAIL
[projects/template-specs.git] / lib.spec
CommitLineData
3cb1cd3d 1#
66df3cad
ER
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
aed9d573 4%bcond_without static_libs # don't build static libraries
66df3cad 5#
f9986cd5 6Summary: -
ce39d734 7Summary(pl.UTF-8): -
3f8f5e5b
ER
8Name: ---
9Version: 0.1
10Release: 0.1
f9986cd5
JB
11License: - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12Group: Libraries
13Source0: %{name}-%{version}.tar.gz
14# Source0-md5: -
3f8f5e5b
ER
15#Patch0: %{name}-what.patch
16#URL: -
17#BuildRequires: -
c53387e8
ER
18#BuildRequires: autoconf
19#BuildRequires: automake
20#BuildRequires: intltool
21#BuildRequires: libtool
3f8f5e5b
ER
22#Requires(postun): -
23#Requires(pre,post): -
24#Requires(preun): -
25#Requires: -
26#Provides: -
27#Obsoletes: -
28#Conflicts: -
f9986cd5
JB
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
a1a32384
ER
31# do not keep them in newly created specs
32# these are only here to help fixing quickly broken specs
33%define filterout_ld -Wl,--no-copy-dt-needed-entries
34%define filterout_ld -Wl,--as-needed
31c122e0
ER
35# do not commit spec containing this (use for local testing only):
36%define filterout_c -Werror=format-security
c392e5f5 37%define filterout_cpp -D_FORTIFY_SOURCE=.
877721ed 38%define filterout_cxx -Werror=format-security
a1a32384 39
20667fb2 40# Ignore file in __spec_install_post_check_so
5346ce74 41BuildRequires: rpmbuild(macros) >= 1.583
e24df1c5 42%define skip_post_check_so libunresolved.so.*
20667fb2 43
e025831d
ER
44# do not commit spec containing this (use for local testing only):
45%define no_install_post_check_tmpfiles 1
46
f9986cd5
JB
47%description
48
3f8f5e5b 49#%description -l pl.UTF-8
f9986cd5 50
41119926 51%package common
ca8abdb7
TP
52Summary: Common files for %{name} library
53Summary(pl.UTF-8): Wspólne pliki biblioteki %{name}
41119926
TP
54Group: Libraries
55Requires: %{name} = %{version}-%{release}
56
57%description common
ca8abdb7 58Common files for %{name} library.
41119926
TP
59
60%description common -l pl.UTF-8
ca8abdb7 61Wspólne pliki biblioteki %{name}.
41119926 62
f9986cd5 63%package devel
ca8abdb7
TP
64Summary: Header files for %{name} library
65Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
f9986cd5 66Group: Development/Libraries
d7dd7729 67Requires: %{name} = %{version}-%{release}
f9986cd5
JB
68
69%description devel
ca8abdb7 70Header files for %{name} library.
f9986cd5 71
9be49f18 72%description devel -l pl.UTF-8
ca8abdb7 73Pliki nagłówkowe biblioteki %{name}.
f9986cd5
JB
74
75%package static
ca8abdb7
TP
76Summary: Static %{name} library
77Summary(pl.UTF-8): Statyczna biblioteka %{name}
f9986cd5 78Group: Development/Libraries
d7dd7729 79Requires: %{name}-devel = %{version}-%{release}
f9986cd5
JB
80
81%description static
ca8abdb7 82Static %{name} library.
f9986cd5 83
9be49f18 84%description static -l pl.UTF-8
ca8abdb7 85Statyczna biblioteka %{name}.
f9986cd5 86
66df3cad 87%package apidocs
2bd7838d 88Summary: API documentation for %{name} library
ca8abdb7 89Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
66df3cad 90Group: Documentation
2bd7838d
JB
91# if not arch-dependent
92%if "%{_rpmversion}" >= "5"
93BuildArch: noarch
94%endif
66df3cad
ER
95
96%description apidocs
e077345b 97API documentation for %{name} library.
66df3cad 98
3cb1cd3d 99%description apidocs -l pl.UTF-8
ca8abdb7 100Dokumentacja API biblioteki %{name}.
3cb1cd3d 101
f9986cd5
JB
102%prep
103%setup -q
1c854c4b 104#%patch0 -p1
f9986cd5
JB
105
106%build
c42a30cf
JB
107# if ac/am/lt/* rebuilding is necessary, do it in this order and add
108# appropriate BuildRequires
109#%{__libtoolize}
110#%{__aclocal}
111#%{__autoconf}
112#%{__autoheader}
113#%{__automake}
f6de6810
ER
114%configure \
115 %{!?with_static_libs:--disable-static}
f9986cd5
JB
116%{__make}
117
118%install
119rm -rf $RPM_BUILD_ROOT
120# create directories if necessary
121#install -d $RPM_BUILD_ROOT
122
123%{__make} install \
124 DESTDIR=$RPM_BUILD_ROOT
125
14750145
JB
126# if library provides pkgconfig file containing proper {Requires,Libs}.private
127# then remove .la pollution
4b532792
JR
128#%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
129
f9986cd5
JB
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%post -p /sbin/ldconfig
134%postun -p /sbin/ldconfig
135
136%files
137%defattr(644,root,root,755)
41119926
TP
138%doc AUTHORS CREDITS README THANKS
139%attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
140%attr(755,root,root) %ghost %{_libdir}/%{name}.so.N
141
142%files common
143%defattr(644,root,root,755)
144%attr(755,root,root) %{_bindir}/%{name}*
f9986cd5
JB
145%{_datadir}/%{name}
146
147%files devel
148%defattr(644,root,root,755)
41119926
TP
149%doc devel-doc/* ChangeLog NEWS TODO
150%attr(755,root,root) %{_libdir}/%{name}.so
14750145
JB
151# if no pkgconfig support, or it misses .private deps, then include .la file
152#%{_libdir}/libFOO.la
41119926
TP
153%{_includedir}/%{name}
154%{_aclocaldir}/%{name}.m4
155%{_pkgconfigdir}/%{name}.pc
f9986cd5 156
f6de6810 157%if %{with static_libs}
f9986cd5
JB
158%files static
159%defattr(644,root,root,755)
41119926 160%{_libdir}/%{name}.a
f6de6810 161%endif
66df3cad 162
a5f7d790 163%if %{with apidocs}
66df3cad
ER
164%files apidocs
165%defattr(644,root,root,755)
166%doc apidocs/*
a5f7d790 167%endif
This page took 0.186364 seconds and 4 git commands to generate.