]> git.pld-linux.org Git - packages/zsh.git/blob - zsh.spec
- release 3: adapterized and added using rpm new automation suit.
[packages/zsh.git] / zsh.spec
1 # $Revision: 1.20 $ $Date: 2000-10-02 23:10:51 $
2 Summary:        Enhanced bourne shell
3 Summary(de):    Enhanced Bourne Shell
4 Summary(fr):    Bourne shell amélioré
5 Summary(tr):    Geliþmiþ bir BASH sürümü
6 Summary(pl):    Ulepszona pow³oka Bourne'a
7 Name:           zsh
8 Version:        3.1.9
9 Release:        3
10 License:        GPL
11 Group:          Applications/Shells
12 Group(de):      Applikationen/Shells
13 Group(pl):      Aplikacje/Pow³oki
14 Source0:        ftp://ftp.zsh.org/pub/zsh/%{name}-%{version}.tar.gz
15 Patch0:         %{name}-info.patch
16 Patch1:         %{name}-DESTDIR.patch
17 Patch2:         %{name}-sys_capability.patch
18 Patch3:         %{name}-cap_get_proc.patch
19 Patch4:         %{name}-tinfo.patch
20 Patch5:         %{name}-addons.patch
21 Prereq:         grep
22 Prereq:         mawk
23 BuildRequires:  ncurses-devel >= 5.1
24 BuildRequires:  glibc-static
25 BuildRequires:  ncurses-static
26 BuildRequires:  texinfo
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28 Obsoletes:      zsh-doc-html, zsh-doc-ps, zsh-doc-dvi
29
30 %define         _exec_prefix            /
31
32 %description
33 zsh is an enhanced version of the Bourne shell with csh additions and
34 most features of ksh, bash, and tcsh.
35
36 %description -l pl
37 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
38 wiêkszo¶æ cech ksh, bash i tcsh.
39
40 %package static
41 Summary:        Statically linked Enhanced bourne shell
42 Summary(pl):    Zaawansowany bourne SHell - linkowany statycznie
43 Group:          Applications/Shells
44 Group(de):      Applikationen/Shells
45 Group(pl):      Aplikacje/Pow³oki
46 Requires:       %{name} = %{version}
47
48 %description static
49 zsh is an enhanced version of the Bourne shell with csh additions and
50 most features of ksh, bash, and tcsh.
51
52 %description -l pl static
53 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
54 wiêkszo¶æ cech ksh, bash i tcsh. W tym pakiecie jest statycznie
55 linkowany.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60 %patch1 -p1
61 %patch2 -p1
62 %patch3 -p1
63 %patch4 -p1
64 %patch5 -p1
65
66 %build
67 autoconf
68
69 %configure
70 %{__make}
71 mv -f Src/zsh Src/zsh.static
72
73 %configure \
74         --enable-maildir-support
75 %{__make}
76
77 (cd Doc; makeinfo zsh.texi)
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install DESTDIR=$RPM_BUILD_ROOT
83
84 install Src/zsh.static $RPM_BUILD_ROOT%{_bindir}
85
86 install -d $RPM_BUILD_ROOT%{_infodir}
87 install Doc/zsh.info* $RPM_BUILD_ROOT%{_infodir}
88
89 install -d $RPM_BUILD_ROOT%{_sysconfdir}
90 touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogout,zprofile,zshrc,zlogin,zshenv}
91
92 rm -f Etc/Makefile*
93 gzip -9nf Etc/* README ChangeLog META-FAQ
94
95 %post
96 if [ ! -f /etc/shells ]; then
97         echo "/bin/zsh" > /etc/shells
98 else
99         if ! grep '^/bin/zsh$' /etc/shells > /dev/null; then
100                 echo "/bin/zsh" >> /etc/shells
101         fi
102 fi
103
104 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
105
106 %postun
107 if [ "$1" = "0" ]; then
108         grep -v /bin/zsh /etc/shells > /etc/shells.new
109         mv -f /etc/shells.new /etc/shells
110 fi
111
112 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
113
114 %post static
115 if [ ! -f /etc/shells ]; then
116         echo "/bin/zsh.static" > /etc/shells
117 else
118         grep '^/bin/zsh.static$' /etc/shells > /dev/null || echo "/bin/zsh.static" >> /etc/shells
119 fi
120
121 %postun static
122 if [ ! -x /bin/zsh.static ]; then
123         grep -v '^/bin/zsh.static$' /etc/shells > /etc/shells.rpm
124         mv -f /etc/shells.rpm /etc/shells
125 fi
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(644,root,root,755)
132 %doc {META-FAQ,README,ChangeLog}.gz Etc/* Util Functions
133 %doc %{_infodir}/zsh.info*
134 %dir %{_libdir}/zsh/%{version}
135 %config %{_sysconfdir}/*
136
137 %attr(755,root,root) %{_bindir}/zsh
138 %attr(755,root,root) %{_libdir}/zsh/%{version}/*
139 %{_mandir}/man1/zsh*.1.gz
140
141 %files static
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_bindir}/zsh.static
This page took 0.086185 seconds and 3 git commands to generate.