]> git.pld-linux.org Git - packages/xpra.git/blob - xpra.spec
configure features to ensure stable features
[packages/xpra.git] / xpra.spec
1 # TODO
2 # - subpackages for client/server, see http://xpra.org/dev.html
3 #
4 # Conditional build:
5 %bcond_without  client
6 %bcond_without  server
7 %bcond_without  sound
8 %bcond_without  clipboard
9 %bcond_without  csc
10 %bcond_without  dec_av
11 %bcond_without  opengl
12 %bcond_without  rencode
13 %bcond_without  vpx
14 %bcond_without  webp
15 %bcond_without  x264
16
17 Summary:        Xpra gives you "persistent remote applications" for X
18 Summary(pl.UTF-8):      Xpra - "stałe zdalne aplikacje" dla X
19 Name:           xpra
20 Version:        0.10.10
21 Release:        1
22 License:        GPL v2+
23 Group:          X11/Applications/Networking
24 Source0:        http://xpra.org/src/%{name}-%{version}.tar.xz
25 # Source0-md5:  deb60252055062214f558155efc3714a
26 URL:            http://xpra.org/
27 BuildRequires:  OpenGL-devel
28 BuildRequires:  ffmpeg-devel
29 BuildRequires:  gtk+2-devel >= 2.0
30 BuildRequires:  libvpx-devel
31 BuildRequires:  libx264-devel
32 BuildRequires:  pkgconfig
33 BuildRequires:  python-Cython >= 0.14.0
34 BuildRequires:  python-distribute
35 BuildRequires:  python-pygobject-devel >= 2.0
36 BuildRequires:  python-pygtk-devel >= 2:2.0
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  tar >= 1:1.22
39 BuildRequires:  xorg-lib-libXtst-devel
40 BuildRequires:  xz
41 Requires:       libwebp
42 Requires:       python-pygtk-gtk >= 2:2.0
43 Requires:       xorg-app-setxkbmap
44 Requires:       xorg-app-xauth
45 Requires:       xorg-app-xmodmap
46 Requires:       xorg-xserver-Xvfb
47 Suggests:       python-PyOpenGL
48 Suggests:       python-pygtkglext
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Xpra gives you "persistent remote applications" for X. That is, unlike
53 normal X applications, applications run with xpra are "persistent" --
54 you can run them remotely, and they don't die if your connection does.
55 You can detach them, and reattach them later -- even from another
56 computer -- with no loss of state. And unlike VNC or RDP, xpra is for
57 remote applications, not remote desktops -- individual applications
58 show up as individual windows on your screen, managed by your window
59 manager. They're not trapped in a box.
60
61 So basically it's screen for remote X apps.
62
63 %description -l pl.UTF-8
64 Xpra daje "stałe zdalne aplikacje" dla serwera X, które w
65 przeciwieństwie do zwykłych X-owych aplikacji, uruchamiane są z xprą
66 jako niezamykające. Można je uruchomić zdalnie i one nie zostaną
67 zamknięte, gdy połączenie zostanie przerwane. Można je odłączyć i
68 podłączyć z powrotem później, również z innego komputera, bez straty
69 stanu. W odróżnieniu od VNC czy RDP, xpra jest dla zdalnych aplikacji,
70 a nie zdalnych pulpitów - pojedyncze aplikacje pokazują się jako
71 samodzielne okno na lokalnym ekranie, zarządzane przez lokalnego
72 zarządcę okien.
73
74 W uproszczeniu xpra to "screen" dla zdalnych aplikacji X-owych.
75
76 %prep
77 %setup -q
78
79 %build
80 CC="%{__cc}" \
81 CFLAGS="%{rpmcflags}" \
82 %{__python} setup.py build \
83         %{__with_without client} \
84         %{__with_without clipboard} \
85         %{__with_without csc csc_swscale} \
86         %{__with_without dec_av dec_avcodec} \
87         %{__with_without opengl} \
88         %{__with_without rencode} \
89         %{__with_without server cymaths} \
90         %{__with_without server shadow} \
91         %{__with_without server} \
92         %{__with_without sound} \
93         %{__with_without vpx} \
94         %{__with_without webp} \
95         %{__with_without x264 enc_x264} \
96         --with-Xdummy \
97         --with-argb \
98         --with-cyxor \
99         --with-gtk2 \
100         --without-gtk3 \
101         --without-qt4 \
102         --with-strict \
103         --with-warn \
104         --with-x11 \
105         --with-PIC \
106         --with%{!?debug:out}-debug \
107         %{nil}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 %{__python} setup.py install \
112         --skip-build \
113         --optimize=2 \
114         --root=$RPM_BUILD_ROOT
115
116 %{__rm} $RPM_BUILD_ROOT%{_datadir}/xpra/COPYING
117 %{__rm} $RPM_BUILD_ROOT%{_datadir}/xpra/README
118 %{__rm} $RPM_BUILD_ROOT%{_datadir}/xpra/webm/LICENSE
119
120 %py_postclean
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(644,root,root,755)
127 %doc NEWS README
128 %dir %{_sysconfdir}/%{name}
129 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/xorg.conf
130 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/xpra.conf
131 %attr(755,root,root) %{_bindir}/xpra
132 %attr(755,root,root) %{_bindir}/xpra_Xdummy
133 %attr(755,root,root) %{_bindir}/xpra_launcher
134 %dir %{_datadir}/xpra
135 %dir %{_datadir}/xpra/icons
136 %{_datadir}/xpra/icons/*.png
137 %{_desktopdir}/xpra.desktop
138 %{_desktopdir}/xpra_launcher.desktop
139 %{_iconsdir}/xpra.png
140 %{_mandir}/man1/xpra.1*
141 %{_mandir}/man1/xpra_launcher.1*
142
143 %dir %{py_sitedir}/xpra
144 %{py_sitedir}/xpra/client
145 %{py_sitedir}/xpra/clipboard
146 %dir %{py_sitedir}/xpra/codecs
147 %dir %{py_sitedir}/xpra/codecs/argb
148 %attr(755,root,root) %{py_sitedir}/xpra/codecs/argb/argb.so
149 %{py_sitedir}/xpra/codecs/argb/__init__.py[co]
150 %dir %{py_sitedir}/xpra/codecs/csc_swscale
151 %attr(755,root,root) %{py_sitedir}/xpra/codecs/csc_swscale/colorspace_converter.so
152 %{py_sitedir}/xpra/codecs/csc_swscale/__init__.py[co]
153 %dir %{py_sitedir}/xpra/codecs/dec_avcodec
154 %attr(755,root,root) %{py_sitedir}/xpra/codecs/dec_avcodec/decoder.so
155 %{py_sitedir}/xpra/codecs/dec_avcodec/__init__.py[co]
156 %dir %{py_sitedir}/xpra/codecs/enc_x264
157 %attr(755,root,root) %{py_sitedir}/xpra/codecs/enc_x264/encoder.so
158 %{py_sitedir}/xpra/codecs/enc_x264/__init__.py[co]
159 %dir %{py_sitedir}/xpra/codecs/vpx
160 %attr(755,root,root) %{py_sitedir}/xpra/codecs/vpx/decoder.so
161 %attr(755,root,root) %{py_sitedir}/xpra/codecs/vpx/encoder.so
162 %{py_sitedir}/xpra/codecs/vpx/__init__.py[co]
163 %{py_sitedir}/xpra/codecs/webm
164 %dir %{py_sitedir}/xpra/codecs/xor
165 %attr(755,root,root) %{py_sitedir}/xpra/codecs/xor/cyxor.so
166 %{py_sitedir}/xpra/codecs/xor/*.py[co]
167 %{py_sitedir}/xpra/codecs/*.py[co]
168 %dir %{py_sitedir}/xpra/gtk_common
169 %attr(755,root,root) %{py_sitedir}/xpra/gtk_common/gdk_atoms.so
170 %{py_sitedir}/xpra/gtk_common/*.py[co]
171 %{py_sitedir}/xpra/keyboard
172 %dir %{py_sitedir}/xpra/net
173 %dir %{py_sitedir}/xpra/net/rencode
174 %attr(755,root,root) %{py_sitedir}/xpra/net/rencode/_rencode.so
175 %{py_sitedir}/xpra/net/rencode/*.py[co]
176 %{py_sitedir}/xpra/net/*.py[co]
177 %{py_sitedir}/xpra/platform
178 %{py_sitedir}/xpra/scripts
179 %dir %{py_sitedir}/xpra/server
180 %dir %{py_sitedir}/xpra/server/stats
181 %attr(755,root,root) %{py_sitedir}/xpra/server/stats/cymaths.so
182 %{py_sitedir}/xpra/server/stats/*.py[co]
183 %{py_sitedir}/xpra/server/*.py[co]
184 %{py_sitedir}/xpra/sound
185 %dir %{py_sitedir}/xpra/x11
186 %dir %{py_sitedir}/xpra/x11/bindings
187 %attr(755,root,root) %{py_sitedir}/xpra/x11/bindings/*.so
188 %{py_sitedir}/xpra/x11/bindings/__init__.py[co]
189 %dir %{py_sitedir}/xpra/x11/gtk_x11
190 %attr(755,root,root) %{py_sitedir}/xpra/x11/gtk_x11/gdk_*.so
191 %{py_sitedir}/xpra/x11/gtk_x11/*.py[co]
192 %{py_sitedir}/xpra/x11/*.py[co]
193 %{py_sitedir}/xpra/*.py[co]
194 %{py_sitedir}/xpra_all-%{version}-py*.egg-info
This page took 0.088916 seconds and 4 git commands to generate.