]> git.pld-linux.org Git - packages/xpra.git/blame - xpra.spec
configure features to ensure stable features
[packages/xpra.git] / xpra.spec
CommitLineData
f1a9b771 1# TODO
29951ed6 2# - subpackages for client/server, see http://xpra.org/dev.html
4d273b65
ER
3#
4# Conditional build:
5%bcond_without client
6%bcond_without server
7%bcond_without sound
8%bcond_without clipboard
9%bcond_without csc
10%bcond_without dec_av
11%bcond_without opengl
12%bcond_without rencode
13%bcond_without vpx
14%bcond_without webp
15%bcond_without x264
16
160ef313 17Summary: Xpra gives you "persistent remote applications" for X
5a5f28f1 18Summary(pl.UTF-8): Xpra - "stałe zdalne aplikacje" dla X
160ef313 19Name: xpra
33952dff
ER
20Version: 0.10.10
21Release: 1
160ef313 22License: GPL v2+
33952dff 23Group: X11/Applications/Networking
f1a9b771 24Source0: http://xpra.org/src/%{name}-%{version}.tar.xz
33952dff 25# Source0-md5: deb60252055062214f558155efc3714a
160ef313 26URL: http://xpra.org/
5a5f28f1 27BuildRequires: OpenGL-devel
29951ed6 28BuildRequires: ffmpeg-devel
5a5f28f1
JB
29BuildRequires: gtk+2-devel >= 2.0
30BuildRequires: libvpx-devel
29951ed6
ER
31BuildRequires: libx264-devel
32BuildRequires: pkgconfig
5a5f28f1 33BuildRequires: python-Cython >= 0.14.0
160ef313 34BuildRequires: python-distribute
5a5f28f1
JB
35BuildRequires: python-pygobject-devel >= 2.0
36BuildRequires: python-pygtk-devel >= 2:2.0
160ef313 37BuildRequires: rpm-pythonprov
f1a9b771 38BuildRequires: tar >= 1:1.22
29951ed6 39BuildRequires: xorg-lib-libXtst-devel
f1a9b771 40BuildRequires: xz
282f26dd 41Requires: libwebp
5a5f28f1 42Requires: python-pygtk-gtk >= 2:2.0
33952dff
ER
43Requires: xorg-app-setxkbmap
44Requires: xorg-app-xauth
45Requires: xorg-app-xmodmap
282f26dd 46Requires: xorg-xserver-Xvfb
5c84ecfd
ER
47Suggests: python-PyOpenGL
48Suggests: python-pygtkglext
160ef313
ER
49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
52Xpra gives you "persistent remote applications" for X. That is, unlike
53normal X applications, applications run with xpra are "persistent" --
54you can run them remotely, and they don't die if your connection does.
55You can detach them, and reattach them later -- even from another
56computer -- with no loss of state. And unlike VNC or RDP, xpra is for
57remote applications, not remote desktops -- individual applications
58show up as individual windows on your screen, managed by your window
59manager. They're not trapped in a box.
60
61So basically it's screen for remote X apps.
62
134fd9a0 63%description -l pl.UTF-8
5a5f28f1
JB
64Xpra daje "stałe zdalne aplikacje" dla serwera X, które w
65przeciwieństwie do zwykłych X-owych aplikacji, uruchamiane są z xprą
66jako niezamykające. Można je uruchomić zdalnie i one nie zostaną
67zamknięte, gdy połączenie zostanie przerwane. Można je odłączyć i
134fd9a0 68podłączyć z powrotem później, również z innego komputera, bez straty
5a5f28f1
JB
69stanu. W odróżnieniu od VNC czy RDP, xpra jest dla zdalnych aplikacji,
70a nie zdalnych pulpitów - pojedyncze aplikacje pokazują się jako
71samodzielne okno na lokalnym ekranie, zarządzane przez lokalnego
72zarządcę okien.
134fd9a0 73
5a5f28f1 74W uproszczeniu xpra to "screen" dla zdalnych aplikacji X-owych.
134fd9a0 75
160ef313 76%prep
f1a9b771 77%setup -q
160ef313
ER
78
79%build
80CC="%{__cc}" \
81CFLAGS="%{rpmcflags}" \
4d273b65
ER
82%{__python} setup.py build \
83 %{__with_without client} \
84 %{__with_without clipboard} \
85 %{__with_without csc csc_swscale} \
86 %{__with_without dec_av dec_avcodec} \
87 %{__with_without opengl} \
88 %{__with_without rencode} \
89 %{__with_without server cymaths} \
90 %{__with_without server shadow} \
91 %{__with_without server} \
92 %{__with_without sound} \
93 %{__with_without vpx} \
94 %{__with_without webp} \
95 %{__with_without x264 enc_x264} \
96 --with-Xdummy \
97 --with-argb \
98 --with-cyxor \
99 --with-gtk2 \
100 --without-gtk3 \
101 --without-qt4 \
102 --with-strict \
103 --with-warn \
104 --with-x11 \
105 --with-PIC \
106 --with%{!?debug:out}-debug \
107 %{nil}
160ef313
ER
108
109%install
110rm -rf $RPM_BUILD_ROOT
111%{__python} setup.py install \
112 --skip-build \
113 --optimize=2 \
114 --root=$RPM_BUILD_ROOT
115
160ef313 116%{__rm} $RPM_BUILD_ROOT%{_datadir}/xpra/COPYING
5a5f28f1 117%{__rm} $RPM_BUILD_ROOT%{_datadir}/xpra/README
160ef313 118%{__rm} $RPM_BUILD_ROOT%{_datadir}/xpra/webm/LICENSE
160ef313
ER
119
120%py_postclean
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%files
126%defattr(644,root,root,755)
5a5f28f1 127%doc NEWS README
160ef313
ER
128%dir %{_sysconfdir}/%{name}
129%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/xorg.conf
130%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/xpra.conf
160ef313
ER
131%attr(755,root,root) %{_bindir}/xpra
132%attr(755,root,root) %{_bindir}/xpra_Xdummy
133%attr(755,root,root) %{_bindir}/xpra_launcher
134%dir %{_datadir}/xpra
135%dir %{_datadir}/xpra/icons
136%{_datadir}/xpra/icons/*.png
5a5f28f1 137%{_desktopdir}/xpra.desktop
160ef313
ER
138%{_desktopdir}/xpra_launcher.desktop
139%{_iconsdir}/xpra.png
160ef313
ER
140%{_mandir}/man1/xpra.1*
141%{_mandir}/man1/xpra_launcher.1*
142
160ef313 143%dir %{py_sitedir}/xpra
5a5f28f1
JB
144%{py_sitedir}/xpra/client
145%{py_sitedir}/xpra/clipboard
146%dir %{py_sitedir}/xpra/codecs
147%dir %{py_sitedir}/xpra/codecs/argb
148%attr(755,root,root) %{py_sitedir}/xpra/codecs/argb/argb.so
149%{py_sitedir}/xpra/codecs/argb/__init__.py[co]
150%dir %{py_sitedir}/xpra/codecs/csc_swscale
151%attr(755,root,root) %{py_sitedir}/xpra/codecs/csc_swscale/colorspace_converter.so
152%{py_sitedir}/xpra/codecs/csc_swscale/__init__.py[co]
153%dir %{py_sitedir}/xpra/codecs/dec_avcodec
154%attr(755,root,root) %{py_sitedir}/xpra/codecs/dec_avcodec/decoder.so
155%{py_sitedir}/xpra/codecs/dec_avcodec/__init__.py[co]
156%dir %{py_sitedir}/xpra/codecs/enc_x264
157%attr(755,root,root) %{py_sitedir}/xpra/codecs/enc_x264/encoder.so
158%{py_sitedir}/xpra/codecs/enc_x264/__init__.py[co]
159%dir %{py_sitedir}/xpra/codecs/vpx
160%attr(755,root,root) %{py_sitedir}/xpra/codecs/vpx/decoder.so
161%attr(755,root,root) %{py_sitedir}/xpra/codecs/vpx/encoder.so
162%{py_sitedir}/xpra/codecs/vpx/__init__.py[co]
163%{py_sitedir}/xpra/codecs/webm
164%dir %{py_sitedir}/xpra/codecs/xor
165%attr(755,root,root) %{py_sitedir}/xpra/codecs/xor/cyxor.so
166%{py_sitedir}/xpra/codecs/xor/*.py[co]
167%{py_sitedir}/xpra/codecs/*.py[co]
168%dir %{py_sitedir}/xpra/gtk_common
169%attr(755,root,root) %{py_sitedir}/xpra/gtk_common/gdk_atoms.so
170%{py_sitedir}/xpra/gtk_common/*.py[co]
171%{py_sitedir}/xpra/keyboard
172%dir %{py_sitedir}/xpra/net
173%dir %{py_sitedir}/xpra/net/rencode
174%attr(755,root,root) %{py_sitedir}/xpra/net/rencode/_rencode.so
175%{py_sitedir}/xpra/net/rencode/*.py[co]
176%{py_sitedir}/xpra/net/*.py[co]
177%{py_sitedir}/xpra/platform
178%{py_sitedir}/xpra/scripts
179%dir %{py_sitedir}/xpra/server
180%dir %{py_sitedir}/xpra/server/stats
181%attr(755,root,root) %{py_sitedir}/xpra/server/stats/cymaths.so
182%{py_sitedir}/xpra/server/stats/*.py[co]
183%{py_sitedir}/xpra/server/*.py[co]
184%{py_sitedir}/xpra/sound
185%dir %{py_sitedir}/xpra/x11
186%dir %{py_sitedir}/xpra/x11/bindings
187%attr(755,root,root) %{py_sitedir}/xpra/x11/bindings/*.so
188%{py_sitedir}/xpra/x11/bindings/__init__.py[co]
189%dir %{py_sitedir}/xpra/x11/gtk_x11
190%attr(755,root,root) %{py_sitedir}/xpra/x11/gtk_x11/gdk_*.so
191%{py_sitedir}/xpra/x11/gtk_x11/*.py[co]
192%{py_sitedir}/xpra/x11/*.py[co]
160ef313 193%{py_sitedir}/xpra/*.py[co]
5a5f28f1 194%{py_sitedir}/xpra_all-%{version}-py*.egg-info
This page took 0.096607 seconds and 4 git commands to generate.