]> git.pld-linux.org Git - packages/xpra.git/blame - xpra.spec
- release 5 (by relup.sh)
[packages/xpra.git] / xpra.spec
CommitLineData
f1a9b771 1# TODO
29951ed6 2# - subpackages for client/server, see http://xpra.org/dev.html
6fb59b95 3# - nvenc/cuda support (on bcond)
4d273b65
ER
4#
5# Conditional build:
6fb59b95
JB
6%bcond_without client # client part
7%bcond_without server # server part
8%bcond_without sound # (gstreamer) sound support
9%bcond_without clipboard # clipboard support
10%bcond_without csc # colorspace conversion support
11%bcond_without dec_av # avcodec decoding
12%bcond_without opengl # OpenGL support
6fb59b95
JB
13%bcond_without vpx # VPX/WebM support
14%bcond_without webp # WebP support
15%bcond_without x264 # x264 encoding
eeadf629
JR
16%bcond_without x265 # x265 encoding
17
c790771b 18%ifarch i386 i486 x32
eeadf629
JR
19%undefine with_x265
20%endif
4d273b65 21
160ef313 22Summary: Xpra gives you "persistent remote applications" for X
5a5f28f1 23Summary(pl.UTF-8): Xpra - "stałe zdalne aplikacje" dla X
160ef313 24Name: xpra
5b5972d7 25Version: 0.15.7
4de7c5c2 26Release: 5
160ef313 27License: GPL v2+
33952dff 28Group: X11/Applications/Networking
f1a9b771 29Source0: http://xpra.org/src/%{name}-%{version}.tar.xz
5b5972d7 30# Source0-md5: 63fa9e2cab464f53d2f37154eccf7596
ee1187c7 31Patch0: setup-cc-ccache.patch
160ef313 32URL: http://xpra.org/
62cb8620 33BuildRequires: OpenCL-devel
5a5f28f1 34BuildRequires: OpenGL-devel
62cb8620 35# libavcodec libswscale
29951ed6 36BuildRequires: ffmpeg-devel
5a5f28f1 37BuildRequires: gtk+2-devel >= 2.0
5b5972d7 38BuildRequires: libvpx-devel >= 1.4
62cb8620 39BuildRequires: libwebp-devel >= 0.3
29951ed6 40BuildRequires: libx264-devel
eeadf629 41%{?with_x265:BuildRequires: libx265-devel}
29951ed6 42BuildRequires: pkgconfig
5b5972d7 43BuildRequires: python-Cython >= 0.19.0
62cb8620 44BuildRequires: python-devel >= 1:2.6
5a5f28f1
JB
45BuildRequires: python-pygobject-devel >= 2.0
46BuildRequires: python-pygtk-devel >= 2:2.0
5b5972d7 47BuildRequires: python-setuptools
160ef313 48BuildRequires: rpm-pythonprov
5b5972d7 49BuildRequires: sed >= 4.0
f1a9b771 50BuildRequires: tar >= 1:1.22
5b5972d7
JB
51BuildRequires: xorg-lib-libXcomposite-devel
52BuildRequires: xorg-lib-libXdamage-devel
29951ed6 53BuildRequires: xorg-lib-libXtst-devel
f1a9b771 54BuildRequires: xz
5b5972d7 55Requires: libvpx >= 1.4
62cb8620 56Requires: libwebp >= 0.3
5a5f28f1 57Requires: python-pygtk-gtk >= 2:2.0
33952dff
ER
58Requires: xorg-app-setxkbmap
59Requires: xorg-app-xauth
60Requires: xorg-app-xmodmap
282f26dd 61Requires: xorg-xserver-Xvfb
5b5972d7 62Suggests: python-PIL
5c84ecfd 63Suggests: python-PyOpenGL
5b5972d7 64Suggests: python-numpy
5c84ecfd 65Suggests: python-pygtkglext
160ef313
ER
66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68%description
69Xpra gives you "persistent remote applications" for X. That is, unlike
70normal X applications, applications run with xpra are "persistent" --
71you can run them remotely, and they don't die if your connection does.
72You can detach them, and reattach them later -- even from another
73computer -- with no loss of state. And unlike VNC or RDP, xpra is for
74remote applications, not remote desktops -- individual applications
75show up as individual windows on your screen, managed by your window
76manager. They're not trapped in a box.
77
78So basically it's screen for remote X apps.
79
134fd9a0 80%description -l pl.UTF-8
5a5f28f1
JB
81Xpra daje "stałe zdalne aplikacje" dla serwera X, które w
82przeciwieństwie do zwykłych X-owych aplikacji, uruchamiane są z xprą
83jako niezamykające. Można je uruchomić zdalnie i one nie zostaną
84zamknięte, gdy połączenie zostanie przerwane. Można je odłączyć i
134fd9a0 85podłączyć z powrotem później, również z innego komputera, bez straty
5a5f28f1
JB
86stanu. W odróżnieniu od VNC czy RDP, xpra jest dla zdalnych aplikacji,
87a nie zdalnych pulpitów - pojedyncze aplikacje pokazują się jako
88samodzielne okno na lokalnym ekranie, zarządzane przez lokalnego
89zarządcę okien.
134fd9a0 90
5a5f28f1 91W uproszczeniu xpra to "screen" dla zdalnych aplikacji X-owych.
134fd9a0 92
160ef313 93%prep
f1a9b771 94%setup -q
ee1187c7 95%patch0 -p1
160ef313 96
5b5972d7
JB
97%{__sed} -e '1s,/usr/bin/env python,%{__python},' -i cups/xpraforwarder $(grep -l '/usr/bin/env python' -r xpra)
98
160ef313
ER
99%build
100CC="%{__cc}" \
101CFLAGS="%{rpmcflags}" \
4d273b65
ER
102%{__python} setup.py build \
103 %{__with_without client} \
104 %{__with_without clipboard} \
105 %{__with_without csc csc_swscale} \
5b5972d7 106 %{__with_without dec_av dec_avcodec2} \
4d273b65 107 %{__with_without opengl} \
4d273b65
ER
108 %{__with_without server shadow} \
109 %{__with_without server} \
110 %{__with_without sound} \
111 %{__with_without vpx} \
112 %{__with_without webp} \
113 %{__with_without x264 enc_x264} \
eeadf629 114 %{__with_without x265 enc_x265} \
4d273b65 115 --with-Xdummy \
4d273b65
ER
116 --with-gtk2 \
117 --without-gtk3 \
4d273b65
ER
118 --with-strict \
119 --with-warn \
120 --with-x11 \
121 --with-PIC \
122 --with%{!?debug:out}-debug \
123 %{nil}
160ef313
ER
124
125%install
126rm -rf $RPM_BUILD_ROOT
127%{__python} setup.py install \
128 --skip-build \
6a271dcc
JR
129 --prefix=%{_prefix} \
130 --install-purelib=%{py_sitescriptdir} \
131 --install-platlib=%{py_sitedir} \
160ef313
ER
132 --optimize=2 \
133 --root=$RPM_BUILD_ROOT
134
160ef313 135%{__rm} $RPM_BUILD_ROOT%{_datadir}/xpra/COPYING
5a5f28f1 136%{__rm} $RPM_BUILD_ROOT%{_datadir}/xpra/README
160ef313
ER
137
138%py_postclean
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%files
144%defattr(644,root,root,755)
5a5f28f1 145%doc NEWS README
160ef313
ER
146%dir %{_sysconfdir}/%{name}
147%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/xorg.conf
148%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/xpra.conf
160ef313
ER
149%attr(755,root,root) %{_bindir}/xpra
150%attr(755,root,root) %{_bindir}/xpra_Xdummy
151%attr(755,root,root) %{_bindir}/xpra_launcher
5b5972d7
JB
152%{_datadir}/appdata/xpra.appdata.xml
153%{_datadir}/mime/packages/application-x-xpraconfig.xml
160ef313
ER
154%dir %{_datadir}/xpra
155%dir %{_datadir}/xpra/icons
156%{_datadir}/xpra/icons/*.png
383a6766
ER
157# experimental html5 client
158%{_datadir}/%{name}/www
5a5f28f1 159%{_desktopdir}/xpra.desktop
160ef313
ER
160%{_desktopdir}/xpra_launcher.desktop
161%{_iconsdir}/xpra.png
160ef313
ER
162%{_mandir}/man1/xpra.1*
163%{_mandir}/man1/xpra_launcher.1*
164
160ef313 165%dir %{py_sitedir}/xpra
5a5f28f1
JB
166%{py_sitedir}/xpra/client
167%{py_sitedir}/xpra/clipboard
168%dir %{py_sitedir}/xpra/codecs
169%dir %{py_sitedir}/xpra/codecs/argb
170%attr(755,root,root) %{py_sitedir}/xpra/codecs/argb/argb.so
171%{py_sitedir}/xpra/codecs/argb/__init__.py[co]
172%dir %{py_sitedir}/xpra/codecs/csc_swscale
173%attr(755,root,root) %{py_sitedir}/xpra/codecs/csc_swscale/colorspace_converter.so
174%{py_sitedir}/xpra/codecs/csc_swscale/__init__.py[co]
62cb8620
JB
175%dir %{py_sitedir}/xpra/codecs/dec_avcodec2
176%attr(755,root,root) %{py_sitedir}/xpra/codecs/dec_avcodec2/decoder.so
177%{py_sitedir}/xpra/codecs/dec_avcodec2/__init__.py[co]
178%dir %{py_sitedir}/xpra/codecs/enc_proxy
179%{py_sitedir}/xpra/codecs/enc_proxy/*.py[co]
5a5f28f1
JB
180%dir %{py_sitedir}/xpra/codecs/enc_x264
181%attr(755,root,root) %{py_sitedir}/xpra/codecs/enc_x264/encoder.so
182%{py_sitedir}/xpra/codecs/enc_x264/__init__.py[co]
eeadf629 183%if %{with x265}
62cb8620
JB
184%dir %{py_sitedir}/xpra/codecs/enc_x265
185%attr(755,root,root) %{py_sitedir}/xpra/codecs/enc_x265/encoder.so
186%{py_sitedir}/xpra/codecs/enc_x265/__init__.py[co]
eeadf629 187%endif
5a5f28f1
JB
188%dir %{py_sitedir}/xpra/codecs/vpx
189%attr(755,root,root) %{py_sitedir}/xpra/codecs/vpx/decoder.so
190%attr(755,root,root) %{py_sitedir}/xpra/codecs/vpx/encoder.so
191%{py_sitedir}/xpra/codecs/vpx/__init__.py[co]
62cb8620
JB
192%dir %{py_sitedir}/xpra/codecs/webp
193%attr(755,root,root) %{py_sitedir}/xpra/codecs/webp/decode.so
194%attr(755,root,root) %{py_sitedir}/xpra/codecs/webp/encode.so
195%{py_sitedir}/xpra/codecs/webp/__init__.py[co]
5a5f28f1
JB
196%dir %{py_sitedir}/xpra/codecs/xor
197%attr(755,root,root) %{py_sitedir}/xpra/codecs/xor/cyxor.so
198%{py_sitedir}/xpra/codecs/xor/*.py[co]
199%{py_sitedir}/xpra/codecs/*.py[co]
383a6766
ER
200%dir %{py_sitedir}/xpra/codecs/csc_cython
201%{py_sitedir}/xpra/codecs/csc_cython/*.py[co]
202%attr(755,root,root) %{py_sitedir}/xpra/codecs/csc_cython/colorspace_converter.so
203%dir %{py_sitedir}/xpra/codecs/csc_opencl
204%{py_sitedir}/xpra/codecs/csc_opencl/*.py[co]
205%dir %{py_sitedir}/xpra/net/bencode
206%{py_sitedir}/xpra/net/bencode/*.py[co]
207%attr(755,root,root) %{py_sitedir}/xpra/net/bencode/cython_bencode.so
5a5f28f1
JB
208%dir %{py_sitedir}/xpra/gtk_common
209%attr(755,root,root) %{py_sitedir}/xpra/gtk_common/gdk_atoms.so
210%{py_sitedir}/xpra/gtk_common/*.py[co]
211%{py_sitedir}/xpra/keyboard
212%dir %{py_sitedir}/xpra/net
5a5f28f1
JB
213%{py_sitedir}/xpra/net/*.py[co]
214%{py_sitedir}/xpra/platform
215%{py_sitedir}/xpra/scripts
216%dir %{py_sitedir}/xpra/server
5b5972d7
JB
217%attr(755,root,root) %{py_sitedir}/xpra/server/cystats.so
218%attr(755,root,root) %{py_sitedir}/xpra/server/region.so
5a5f28f1 219%{py_sitedir}/xpra/server/*.py[co]
383a6766
ER
220%dir %{py_sitedir}/xpra/server/auth
221%{py_sitedir}/xpra/server/auth/*.py[co]
5a5f28f1
JB
222%{py_sitedir}/xpra/sound
223%dir %{py_sitedir}/xpra/x11
224%dir %{py_sitedir}/xpra/x11/bindings
225%attr(755,root,root) %{py_sitedir}/xpra/x11/bindings/*.so
226%{py_sitedir}/xpra/x11/bindings/__init__.py[co]
227%dir %{py_sitedir}/xpra/x11/gtk_x11
228%attr(755,root,root) %{py_sitedir}/xpra/x11/gtk_x11/gdk_*.so
229%{py_sitedir}/xpra/x11/gtk_x11/*.py[co]
230%{py_sitedir}/xpra/x11/*.py[co]
160ef313 231%{py_sitedir}/xpra/*.py[co]
383a6766 232%{py_sitedir}/xpra-%{version}-py*.egg-info
5b5972d7
JB
233
234#%files -n cups-backend-xpra ?
235%attr(756,root,root) %{_prefix}/lib/cups/backend/xpraforwarder
This page took 0.1154 seconds and 4 git commands to generate.