]> git.pld-linux.org Git - packages/xpra.git/blame - xpra.spec
- disable x265 support on arch < i586
[packages/xpra.git] / xpra.spec
CommitLineData
f1a9b771 1# TODO
29951ed6 2# - subpackages for client/server, see http://xpra.org/dev.html
6fb59b95 3# - nvenc/cuda support (on bcond)
4d273b65
ER
4#
5# Conditional build:
6fb59b95
JB
6%bcond_without client # client part
7%bcond_without server # server part
8%bcond_without sound # (gstreamer) sound support
9%bcond_without clipboard # clipboard support
10%bcond_without csc # colorspace conversion support
11%bcond_without dec_av # avcodec decoding
12%bcond_without opengl # OpenGL support
13%bcond_without rencode # rencode support
14%bcond_without vpx # VPX/WebM support
15%bcond_without webp # WebP support
16%bcond_without x264 # x264 encoding
eeadf629
JR
17%bcond_without x265 # x265 encoding
18
19%ifarch i386 i486
20%undefine with_x265
21%endif
4d273b65 22
160ef313 23Summary: Xpra gives you "persistent remote applications" for X
5a5f28f1 24Summary(pl.UTF-8): Xpra - "stałe zdalne aplikacje" dla X
160ef313 25Name: xpra
62cb8620 26Version: 0.13.6
eeadf629 27Release: 3
160ef313 28License: GPL v2+
33952dff 29Group: X11/Applications/Networking
f1a9b771 30Source0: http://xpra.org/src/%{name}-%{version}.tar.xz
62cb8620 31# Source0-md5: db3642eef0e0972d99f41212b3d5471c
ee1187c7 32Patch0: setup-cc-ccache.patch
160ef313 33URL: http://xpra.org/
62cb8620 34BuildRequires: OpenCL-devel
5a5f28f1 35BuildRequires: OpenGL-devel
62cb8620 36# libavcodec libswscale
29951ed6 37BuildRequires: ffmpeg-devel
5a5f28f1 38BuildRequires: gtk+2-devel >= 2.0
62cb8620
JB
39BuildRequires: libvpx-devel >= 1.0
40BuildRequires: libwebp-devel >= 0.3
29951ed6 41BuildRequires: libx264-devel
eeadf629 42%{?with_x265:BuildRequires: libx265-devel}
29951ed6 43BuildRequires: pkgconfig
5a5f28f1 44BuildRequires: python-Cython >= 0.14.0
62cb8620 45BuildRequires: python-devel >= 1:2.6
160ef313 46BuildRequires: python-distribute
5a5f28f1
JB
47BuildRequires: python-pygobject-devel >= 2.0
48BuildRequires: python-pygtk-devel >= 2:2.0
160ef313 49BuildRequires: rpm-pythonprov
f1a9b771 50BuildRequires: tar >= 1:1.22
29951ed6 51BuildRequires: xorg-lib-libXtst-devel
f1a9b771 52BuildRequires: xz
62cb8620 53Requires: libwebp >= 0.3
5a5f28f1 54Requires: python-pygtk-gtk >= 2:2.0
33952dff
ER
55Requires: xorg-app-setxkbmap
56Requires: xorg-app-xauth
57Requires: xorg-app-xmodmap
282f26dd 58Requires: xorg-xserver-Xvfb
5c84ecfd
ER
59Suggests: python-PyOpenGL
60Suggests: python-pygtkglext
160ef313
ER
61BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63%description
64Xpra gives you "persistent remote applications" for X. That is, unlike
65normal X applications, applications run with xpra are "persistent" --
66you can run them remotely, and they don't die if your connection does.
67You can detach them, and reattach them later -- even from another
68computer -- with no loss of state. And unlike VNC or RDP, xpra is for
69remote applications, not remote desktops -- individual applications
70show up as individual windows on your screen, managed by your window
71manager. They're not trapped in a box.
72
73So basically it's screen for remote X apps.
74
134fd9a0 75%description -l pl.UTF-8
5a5f28f1
JB
76Xpra daje "stałe zdalne aplikacje" dla serwera X, które w
77przeciwieństwie do zwykłych X-owych aplikacji, uruchamiane są z xprą
78jako niezamykające. Można je uruchomić zdalnie i one nie zostaną
79zamknięte, gdy połączenie zostanie przerwane. Można je odłączyć i
134fd9a0 80podłączyć z powrotem później, również z innego komputera, bez straty
5a5f28f1
JB
81stanu. W odróżnieniu od VNC czy RDP, xpra jest dla zdalnych aplikacji,
82a nie zdalnych pulpitów - pojedyncze aplikacje pokazują się jako
83samodzielne okno na lokalnym ekranie, zarządzane przez lokalnego
84zarządcę okien.
134fd9a0 85
5a5f28f1 86W uproszczeniu xpra to "screen" dla zdalnych aplikacji X-owych.
134fd9a0 87
160ef313 88%prep
f1a9b771 89%setup -q
ee1187c7 90%patch0 -p1
160ef313
ER
91
92%build
93CC="%{__cc}" \
94CFLAGS="%{rpmcflags}" \
4d273b65
ER
95%{__python} setup.py build \
96 %{__with_without client} \
97 %{__with_without clipboard} \
98 %{__with_without csc csc_swscale} \
99 %{__with_without dec_av dec_avcodec} \
100 %{__with_without opengl} \
101 %{__with_without rencode} \
102 %{__with_without server cymaths} \
103 %{__with_without server shadow} \
104 %{__with_without server} \
105 %{__with_without sound} \
106 %{__with_without vpx} \
107 %{__with_without webp} \
108 %{__with_without x264 enc_x264} \
eeadf629 109 %{__with_without x265 enc_x265} \
4d273b65
ER
110 --with-Xdummy \
111 --with-argb \
112 --with-cyxor \
113 --with-gtk2 \
114 --without-gtk3 \
115 --without-qt4 \
116 --with-strict \
117 --with-warn \
118 --with-x11 \
119 --with-PIC \
120 --with%{!?debug:out}-debug \
121 %{nil}
160ef313
ER
122
123%install
124rm -rf $RPM_BUILD_ROOT
125%{__python} setup.py install \
126 --skip-build \
127 --optimize=2 \
128 --root=$RPM_BUILD_ROOT
129
160ef313 130%{__rm} $RPM_BUILD_ROOT%{_datadir}/xpra/COPYING
5a5f28f1 131%{__rm} $RPM_BUILD_ROOT%{_datadir}/xpra/README
160ef313 132%{__rm} $RPM_BUILD_ROOT%{_datadir}/xpra/webm/LICENSE
160ef313
ER
133
134%py_postclean
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%files
140%defattr(644,root,root,755)
5a5f28f1 141%doc NEWS README
160ef313
ER
142%dir %{_sysconfdir}/%{name}
143%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/xorg.conf
144%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/xpra.conf
160ef313
ER
145%attr(755,root,root) %{_bindir}/xpra
146%attr(755,root,root) %{_bindir}/xpra_Xdummy
147%attr(755,root,root) %{_bindir}/xpra_launcher
148%dir %{_datadir}/xpra
149%dir %{_datadir}/xpra/icons
150%{_datadir}/xpra/icons/*.png
383a6766
ER
151# experimental html5 client
152%{_datadir}/%{name}/www
5a5f28f1 153%{_desktopdir}/xpra.desktop
160ef313
ER
154%{_desktopdir}/xpra_launcher.desktop
155%{_iconsdir}/xpra.png
160ef313
ER
156%{_mandir}/man1/xpra.1*
157%{_mandir}/man1/xpra_launcher.1*
158
160ef313 159%dir %{py_sitedir}/xpra
5a5f28f1
JB
160%{py_sitedir}/xpra/client
161%{py_sitedir}/xpra/clipboard
162%dir %{py_sitedir}/xpra/codecs
163%dir %{py_sitedir}/xpra/codecs/argb
164%attr(755,root,root) %{py_sitedir}/xpra/codecs/argb/argb.so
165%{py_sitedir}/xpra/codecs/argb/__init__.py[co]
166%dir %{py_sitedir}/xpra/codecs/csc_swscale
167%attr(755,root,root) %{py_sitedir}/xpra/codecs/csc_swscale/colorspace_converter.so
168%{py_sitedir}/xpra/codecs/csc_swscale/__init__.py[co]
169%dir %{py_sitedir}/xpra/codecs/dec_avcodec
170%attr(755,root,root) %{py_sitedir}/xpra/codecs/dec_avcodec/decoder.so
171%{py_sitedir}/xpra/codecs/dec_avcodec/__init__.py[co]
62cb8620
JB
172%dir %{py_sitedir}/xpra/codecs/dec_avcodec2
173%attr(755,root,root) %{py_sitedir}/xpra/codecs/dec_avcodec2/decoder.so
174%{py_sitedir}/xpra/codecs/dec_avcodec2/__init__.py[co]
175%dir %{py_sitedir}/xpra/codecs/enc_proxy
176%{py_sitedir}/xpra/codecs/enc_proxy/*.py[co]
5a5f28f1
JB
177%dir %{py_sitedir}/xpra/codecs/enc_x264
178%attr(755,root,root) %{py_sitedir}/xpra/codecs/enc_x264/encoder.so
179%{py_sitedir}/xpra/codecs/enc_x264/__init__.py[co]
eeadf629 180%if %{with x265}
62cb8620
JB
181%dir %{py_sitedir}/xpra/codecs/enc_x265
182%attr(755,root,root) %{py_sitedir}/xpra/codecs/enc_x265/encoder.so
183%{py_sitedir}/xpra/codecs/enc_x265/__init__.py[co]
eeadf629 184%endif
5a5f28f1
JB
185%dir %{py_sitedir}/xpra/codecs/vpx
186%attr(755,root,root) %{py_sitedir}/xpra/codecs/vpx/decoder.so
187%attr(755,root,root) %{py_sitedir}/xpra/codecs/vpx/encoder.so
188%{py_sitedir}/xpra/codecs/vpx/__init__.py[co]
189%{py_sitedir}/xpra/codecs/webm
62cb8620
JB
190%dir %{py_sitedir}/xpra/codecs/webp
191%attr(755,root,root) %{py_sitedir}/xpra/codecs/webp/decode.so
192%attr(755,root,root) %{py_sitedir}/xpra/codecs/webp/encode.so
193%{py_sitedir}/xpra/codecs/webp/__init__.py[co]
5a5f28f1
JB
194%dir %{py_sitedir}/xpra/codecs/xor
195%attr(755,root,root) %{py_sitedir}/xpra/codecs/xor/cyxor.so
196%{py_sitedir}/xpra/codecs/xor/*.py[co]
197%{py_sitedir}/xpra/codecs/*.py[co]
383a6766
ER
198%dir %{py_sitedir}/xpra/codecs/csc_cython
199%{py_sitedir}/xpra/codecs/csc_cython/*.py[co]
200%attr(755,root,root) %{py_sitedir}/xpra/codecs/csc_cython/colorspace_converter.so
201%dir %{py_sitedir}/xpra/codecs/csc_opencl
202%{py_sitedir}/xpra/codecs/csc_opencl/*.py[co]
203%dir %{py_sitedir}/xpra/net/bencode
204%{py_sitedir}/xpra/net/bencode/*.py[co]
205%attr(755,root,root) %{py_sitedir}/xpra/net/bencode/cython_bencode.so
5a5f28f1
JB
206%dir %{py_sitedir}/xpra/gtk_common
207%attr(755,root,root) %{py_sitedir}/xpra/gtk_common/gdk_atoms.so
208%{py_sitedir}/xpra/gtk_common/*.py[co]
209%{py_sitedir}/xpra/keyboard
210%dir %{py_sitedir}/xpra/net
211%dir %{py_sitedir}/xpra/net/rencode
62cb8620 212%attr(755,root,root) %{py_sitedir}/xpra/net/rencode/rencode.so
5a5f28f1
JB
213%{py_sitedir}/xpra/net/rencode/*.py[co]
214%{py_sitedir}/xpra/net/*.py[co]
215%{py_sitedir}/xpra/platform
216%{py_sitedir}/xpra/scripts
217%dir %{py_sitedir}/xpra/server
218%dir %{py_sitedir}/xpra/server/stats
219%attr(755,root,root) %{py_sitedir}/xpra/server/stats/cymaths.so
220%{py_sitedir}/xpra/server/stats/*.py[co]
221%{py_sitedir}/xpra/server/*.py[co]
383a6766
ER
222%dir %{py_sitedir}/xpra/server/auth
223%{py_sitedir}/xpra/server/auth/*.py[co]
5a5f28f1
JB
224%{py_sitedir}/xpra/sound
225%dir %{py_sitedir}/xpra/x11
226%dir %{py_sitedir}/xpra/x11/bindings
227%attr(755,root,root) %{py_sitedir}/xpra/x11/bindings/*.so
228%{py_sitedir}/xpra/x11/bindings/__init__.py[co]
229%dir %{py_sitedir}/xpra/x11/gtk_x11
230%attr(755,root,root) %{py_sitedir}/xpra/x11/gtk_x11/gdk_*.so
231%{py_sitedir}/xpra/x11/gtk_x11/*.py[co]
232%{py_sitedir}/xpra/x11/*.py[co]
160ef313 233%{py_sitedir}/xpra/*.py[co]
383a6766 234%{py_sitedir}/xpra-%{version}-py*.egg-info
This page took 0.081802 seconds and 4 git commands to generate.