]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- updated pl.po-update patch
[packages/xfsprogs.git] / xfsprogs.spec
1 #
2 # Conditional build:
3 %bcond_without  debug_asserts
4 #
5 Summary:        Tools for the XFS filesystem
6 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
7 Name:           xfsprogs
8 Version:        4.19.0
9 Release:        1
10 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
11 Group:          Applications/System
12 Source0:        https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/%{name}-%{version}.tar.gz
13 # Source0-md5:  955b3dad9cbe01d6b21a562cc0100e04
14 Source1:        xfs_lsprojid
15 Patch0:         %{name}-miscfix-v2.patch
16 Patch1:         %{name}-pl.po-update.patch
17 # Patch1-md5:   28832d2c0aefb92ec17ebfe924c156e3
18 URL:            http://www.xfs.org/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  bash
22 BuildRequires:  gettext-tools
23 BuildRequires:  glibc-static
24 BuildRequires:  libblkid-devel
25 BuildRequires:  libtool
26 BuildRequires:  libuuid-devel
27 BuildRequires:  libuuid-static
28 BuildRequires:  readline-devel
29 BuildRequires:  rpm >= 4.4.9-56
30 BuildRequires:  rpmbuild(macros) >= 1.402
31 BuildRequires:  sed >= 4.0
32 Obsoletes:      xfsprogs-initrd
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %if "%{pld_release}" == "ac"
36 # libtool in ac doesn't do the reordering of args properly
37 %define         filterout_ld -Wl,--as-needed
38 %endif
39
40 %description
41 A set of commands to use the XFS filesystem, including mkfs.xfs.
42
43 XFS is a high performance journaling filesystem which originated on
44 the SGI IRIX platform. It is completely multi-threaded, can support
45 large files and large filesystems, extended attributes, variable block
46 sizes, is extent based, and makes extensive use of Btrees
47 (directories, extents, free space) to aid both performance and
48 scalability.
49
50 This implementation is on-disk compatible with the IRIX version of
51 XFS.
52
53 %description -l pl.UTF-8
54 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
55
56 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
57 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
58 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
59 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
60 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
61
62 %package scrub
63 Summary:        xfs_scrub - XFS online check and repair feature (EXPERIMENTAL!)
64 Summary(pl.UTF-8):      xfs_scrub - sprawdzanie i naprawianie zamontowanego systemu plików XFS (EKSPERYMENTALNE!)
65 Group:          Applications/System
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       systemd-units >= 38
68
69 %description scrub
70 xfs_scrub is an XFS online check and repair feature.
71
72 WARNING: EXPERIMENTAL, use at your own risk!
73
74 %description scrub -l pl.UTF-8
75 xfs_scrub służy do sprawdzania i naprawiania zamontowanego systmeu
76 plików XFS w locie.
77
78 UWAGA: EXPERIMENTALNE, użycie na własne ryzyko!
79
80 %package devel
81 Summary:        Header files and libraries to develop XFS software
82 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
83 Group:          Development/Libraries
84 Requires:       %{name} = %{version}-%{release}
85 Requires:       libuuid-devel
86
87 %description devel
88 Header files and libraries to develop software which operates on XFS
89 filesystems.
90
91 %description devel -l pl.UTF-8
92 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
93 operującego na systemie plików XFS.
94
95 %package static
96 Summary:        Static XFS software libraries
97 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
98 Group:          Development/Libraries
99 Requires:       %{name}-devel = %{version}-%{release}
100
101 %description static
102 Static XFS software libraries.
103
104 %description static -l pl.UTF-8
105 Biblioteki statyczne do XFS.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110 %patch1 -p1
111
112 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' scrub/xfs_scrub_all.in tools/xfsbuflock.py
113
114 %build
115 %{__aclocal} -I m4
116 %{__autoconf}
117 %configure \
118         DEBUG="%{?with_debug_asserts:-DDEBUG}%{!?with_debug_asserts:-DNDEBUG}" \
119         OPTIMIZER="%{rpmcflags}" \
120         --enable-lto=no \
121         --enable-blkid \
122         --enable-gettext \
123         --enable-readline
124
125 %{__make} -j1 \
126         V=1
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 install -d $RPM_BUILD_ROOT/etc/cron.d
131
132 DIST_ROOT=$RPM_BUILD_ROOT
133 DIST_INSTALL=$(pwd)/install.manifest
134 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
135 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
136
137 %{__make} install \
138         DIST_MANIFEST="$DIST_INSTALL"
139 %{__make} install-dev \
140         DIST_MANIFEST="$DIST_INSTALL_DEV"
141
142 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/xfs_lsprojid
143
144 # adjust symlink to point to actual library, not libhandle.so symlink, which we remove afterwards
145 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libhandle.so.*.*.*) \
146          $RPM_BUILD_ROOT%{_libdir}/libhandle.so
147 # adjust library path used at link time
148 %{__sed} -i -e "s|libdir='/%{_lib}'|libdir='%{_libdir}'|" \
149         $RPM_BUILD_ROOT%{_libdir}/libhandle.la
150 # already in /usr
151 %{__rm} $RPM_BUILD_ROOT/%{_lib}/libhandle.{so,la,a}
152
153 # install cron file
154 %{__mv} $RPM_BUILD_ROOT{%{_libdir}/%{name}/xfs_scrub_all.cron,/etc/cron.d/xfs_scrub_all}
155
156 # (config file paths are specified in libfrog/projects.c)
157 echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
158 echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
159
160 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
161
162 %find_lang %{name}
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post   -p /sbin/ldconfig
168 %postun -p /sbin/ldconfig
169
170 %post scrub
171 %systemd_reload
172
173 %files -f %{name}.lang
174 %defattr(644,root,root,755)
175 %doc README doc/{CHANGES,CREDITS}
176 %config(noreplace) %verify(not md5 mtime size) /etc/projects
177 %config(noreplace) %verify(not md5 mtime size) /etc/projid
178 %attr(755,root,root) /sbin/fsck.xfs
179 %attr(755,root,root) /sbin/mkfs.xfs
180 %attr(755,root,root) /sbin/xfs_repair
181 %attr(755,root,root) %{_sbindir}/xfs_*
182 %attr(755,root,root) /%{_lib}/libhandle.so.*.*
183 %attr(755,root,root) %ghost /%{_lib}/libhandle.so.1
184 %dir %{_libdir}/%{name}
185 %attr(755,root,root) %{_libdir}/%{name}/xfs_scrub_fail
186 %{_mandir}/man5/projects.5*
187 %{_mandir}/man5/projid.5*
188 %{_mandir}/man5/xfs.5*
189 %{_mandir}/man8/fsck.xfs.8*
190 %{_mandir}/man8/mkfs.xfs.8*
191 %{_mandir}/man8/xfs_*.8*
192 %exclude %{_mandir}/man8/xfs_scrub*.8*
193
194 %files scrub
195 %defattr(644,root,root,755)
196 %attr(755,root,root) /sbin/xfs_scrub
197 %attr(755,root,root) /sbin/xfs_scrub_all
198 %{systemdunitdir}/xfs_scrub@.service
199 %{systemdunitdir}/xfs_scrub_all.service
200 %{systemdunitdir}/xfs_scrub_all.timer
201 %{systemdunitdir}/xfs_scrub_fail@.service
202 %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/xfs_scrub_all
203 %{_mandir}/man8/xfs_scrub.8*
204 %{_mandir}/man8/xfs_scrub_all.8*
205
206 %files devel
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_libdir}/libhandle.so
209 %{_libdir}/libhandle.la
210 %{_includedir}/xfs
211 %{_mandir}/man2/ioctl_xfs_scrub_metadata.2*
212 %{_mandir}/man3/*handle.3*
213 %{_mandir}/man3/xfsctl.3*
214
215 %files static
216 %defattr(644,root,root,755)
217 %{_libdir}/libhandle.a
This page took 0.150542 seconds and 4 git commands to generate.