]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- up to 3.2.3; back to glibc memory alloc functions (we don't want to diverge from...
[packages/xfsprogs.git] / xfsprogs.spec
1 #
2 # Conditional build:
3 %bcond_without  tcmalloc        # don't use tcmalloc
4
5 %ifarch x32
6 %undefine       with_tcmalloc
7 %endif
8
9 Summary:        Tools for the XFS filesystem
10 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
11 Name:           xfsprogs
12 Version:        3.2.3
13 Release:        1
14 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
15 Group:          Applications/System
16 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/cmd_tars/%{name}-%{version}.tar.gz
17 # Source0-md5:  9f383e36682709e62b12c125e5d8b895
18 Source1:        xfs_lsprojid
19 Patch0:         %{name}-miscfix-v2.patch
20 Patch1:         %{name}-pl.po-update.patch
21 Patch2:         %{name}-noquotasync.patch
22 URL:            http://www.xfs.org/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  bash
26 BuildRequires:  gettext-tools
27 BuildRequires:  libblkid-devel
28 %{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
29 BuildRequires:  libtool
30 BuildRequires:  libuuid-devel
31 BuildRequires:  readline-devel
32 BuildRequires:  rpm >= 4.4.9-56
33 BuildRequires:  rpmbuild(macros) >= 1.402
34 %{?with_tcmalloc:Requires:      libtcmalloc >= 1.8.3-3}
35 Obsoletes:      xfsprogs-initrd
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %if "%{pld_release}" == "ac"
39 # libtool in ac doesn't do the reordering of args properly
40 %define         filterout_ld -Wl,--as-needed
41 %endif
42
43 %define         _sbindir        /sbin
44 %define         _bindir         /usr/sbin
45 %define         _libdir         /%{_lib}
46 %define         _libexecdir     /usr/%{_lib}
47
48 %description
49 A set of commands to use the XFS filesystem, including mkfs.xfs.
50
51 XFS is a high performance journaling filesystem which originated on
52 the SGI IRIX platform. It is completely multi-threaded, can support
53 large files and large filesystems, extended attributes, variable block
54 sizes, is extent based, and makes extensive use of Btrees
55 (directories, extents, free space) to aid both performance and
56 scalability.
57
58 This implementation is on-disk compatible with the IRIX version of
59 XFS.
60
61 %description -l pl.UTF-8
62 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
63
64 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
65 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
66 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
67 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
68 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
69
70 %package devel
71 Summary:        Header files and libraries to develop XFS software
72 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       libuuid-devel
76
77 %description devel
78 Header files and libraries to develop software which operates on XFS
79 filesystems.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
83 operującego na systemie plików XFS.
84
85 %package static
86 Summary:        Static XFS software libraries
87 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static XFS software libraries.
93
94 %description static -l pl.UTF-8
95 Biblioteki statyczne do XFS.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 #%patch1 -p1
101 %patch2 -p1
102
103 %build
104 %{__aclocal} -I m4
105 %{__autoconf}
106 %configure \
107         --sbindir=%{_bindir}\
108         --enable-gettext \
109         --enable-readline \
110         --enable-blkid \
111         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
112         OPTIMIZER="%{rpmcflags}"
113
114 %{__make} -j1 \
115         V=1
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT{%{_libexecdir},/etc}
120
121 DIST_ROOT=$RPM_BUILD_ROOT
122 DIST_INSTALL=$(pwd)/install.manifest
123 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
124 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
125
126 %{__make} install \
127         DIST_MANIFEST="$DIST_INSTALL"
128 %{__make} install-dev \
129         DIST_MANIFEST="$DIST_INSTALL_DEV"
130
131 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/xfs_lsprojid
132
133 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libhandle.so.*.*.*) \
134          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
135
136 mv $RPM_BUILD_ROOT%{_libdir}/lib*.la $RPM_BUILD_ROOT%{_libexecdir}
137 mv $RPM_BUILD_ROOT%{_libdir}/lib*.a $RPM_BUILD_ROOT%{_libexecdir}
138
139 %{__sed} -i -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
140         $RPM_BUILD_ROOT%{_libexecdir}/libhandle.la
141
142 echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
143 echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
144
145 %find_lang %{name}
146
147 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
148
149 # already in /usr
150 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libhandle.so
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post   -p /sbin/ldconfig
156 %postun -p /sbin/ldconfig
157
158 %files -f %{name}.lang
159 %defattr(644,root,root,755)
160 %doc README doc/{CHANGES,CREDITS}
161 %config(noreplace) %verify(not md5 mtime size) /etc/projects
162 %config(noreplace) %verify(not md5 mtime size) /etc/projid
163 %attr(755,root,root) %{_sbindir}/fsck.xfs
164 %attr(755,root,root) %{_sbindir}/mkfs.xfs
165 %attr(755,root,root) %{_sbindir}/xfs_repair
166 %attr(755,root,root) %{_bindir}/xfs_*
167 %attr(755,root,root) %{_libdir}/libhandle.so.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libhandle.so.1
169 %{_mandir}/man5/projects.5*
170 %{_mandir}/man5/projid.5*
171 %{_mandir}/man5/xfs.5*
172 %{_mandir}/man8/fsck.xfs.8*
173 %{_mandir}/man8/mkfs.xfs.8*
174 %{_mandir}/man8/xfs_*.8*
175
176 %files devel
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libexecdir}/libhandle.so
179 %{_libexecdir}/libhandle.la
180 %{_includedir}/xfs
181 %{_mandir}/man3/*handle.3*
182 %{_mandir}/man3/xfsctl.3*
183
184 %files static
185 %defattr(644,root,root,755)
186 %{_libexecdir}/libhandle.a
This page took 0.074581 seconds and 4 git commands to generate.