]> git.pld-linux.org Git - packages/xfsprogs.git/blame - xfsprogs.spec
- up to 3.2.3; back to glibc memory alloc functions (we don't want to diverge from...
[packages/xfsprogs.git] / xfsprogs.spec
CommitLineData
00d1530a
JR
1#
2# Conditional build:
4a867e5e 3%bcond_without tcmalloc # don't use tcmalloc
d9432d77
JR
4
5%ifarch x32
6%undefine with_tcmalloc
7%endif
8
80ded214 9Summary: Tools for the XFS filesystem
809af116 10Summary(pl.UTF-8): Narzędzia do systemu plików XFS
80ded214 11Name: xfsprogs
661ed87b
AM
12Version: 3.2.3
13Release: 1
636af8bd 14License: LGPL v2.1 (libhandle), GPL v2 (the rest)
80ded214 15Group: Applications/System
4ede93fd 16Source0: ftp://linux-xfs.sgi.com/projects/xfs/cmd_tars/%{name}-%{version}.tar.gz
661ed87b 17# Source0-md5: 9f383e36682709e62b12c125e5d8b895
a32e9a39 18Source1: xfs_lsprojid
bc92c0b0 19Patch0: %{name}-miscfix-v2.patch
8e06f9de 20Patch1: %{name}-pl.po-update.patch
661ed87b 21Patch2: %{name}-noquotasync.patch
51a52578 22URL: http://www.xfs.org/
80ded214 23BuildRequires: autoconf
1c0f6863 24BuildRequires: automake
cb58e4a3 25BuildRequires: bash
7fb2d2e7 26BuildRequires: gettext-tools
51a52578 27BuildRequires: libblkid-devel
4a867e5e 28%{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
92a53cbb 29BuildRequires: libtool
a5769371 30BuildRequires: libuuid-devel
99229502 31BuildRequires: readline-devel
dec839eb 32BuildRequires: rpm >= 4.4.9-56
9656c3b9 33BuildRequires: rpmbuild(macros) >= 1.402
727e5a6d 34%{?with_tcmalloc:Requires: libtcmalloc >= 1.8.3-3}
7c029ef7 35Obsoletes: xfsprogs-initrd
c826f244 36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80ded214 37
dec839eb
ER
38%if "%{pld_release}" == "ac"
39# libtool in ac doesn't do the reordering of args properly
40%define filterout_ld -Wl,--as-needed
41%endif
42
b087bbdd
JR
43%define _sbindir /sbin
44%define _bindir /usr/sbin
a19d7677
JK
45%define _libdir /%{_lib}
46%define _libexecdir /usr/%{_lib}
b087bbdd 47
80ded214
AM
48%description
49A set of commands to use the XFS filesystem, including mkfs.xfs.
50
51XFS is a high performance journaling filesystem which originated on
52the SGI IRIX platform. It is completely multi-threaded, can support
53large files and large filesystems, extended attributes, variable block
54sizes, is extent based, and makes extensive use of Btrees
55(directories, extents, free space) to aid both performance and
56scalability.
57
58This implementation is on-disk compatible with the IRIX version of
59XFS.
60
ddc220a9
JR
61%description -l pl.UTF-8
62Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
80ded214 63
ddc220a9
JR
64XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
65był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
66obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
67atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
68B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
80ded214
AM
69
70%package devel
71Summary: Header files and libraries to develop XFS software
809af116 72Summary(pl.UTF-8): Pliki nagłówkowe i biblioteki
80ded214 73Group: Development/Libraries
8b4647b2 74Requires: %{name} = %{version}-%{release}
2528905a 75Requires: libuuid-devel
80ded214
AM
76
77%description devel
78Header files and libraries to develop software which operates on XFS
79filesystems.
80
ddc220a9
JR
81%description devel -l pl.UTF-8
82Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
83operującego na systemie plików XFS.
80ded214 84
1c0f6863 85%package static
86Summary: Static XFS software libraries
809af116 87Summary(pl.UTF-8): Biblioteki statyczne do XFS
1c0f6863 88Group: Development/Libraries
8b4647b2 89Requires: %{name}-devel = %{version}-%{release}
1c0f6863 90
91%description static
92Static XFS software libraries.
93
ddc220a9 94%description static -l pl.UTF-8
1c0f6863 95Biblioteki statyczne do XFS.
96
80ded214 97%prep
600886d5 98%setup -q
80ded214 99%patch0 -p1
3d585810 100#%patch1 -p1
661ed87b 101%patch2 -p1
4ede93fd 102
80ded214 103%build
ff9c0a4e 104%{__aclocal} -I m4
551b0d1f 105%{__autoconf}
1c0f6863 106%configure \
a084b099 107 --sbindir=%{_bindir}\
4ede93fd
AM
108 --enable-gettext \
109 --enable-readline \
528ce8b7 110 --enable-blkid \
0c1d4bf9 111 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
4ede93fd 112 OPTIMIZER="%{rpmcflags}"
00d1530a 113
03dcab3f
JB
114%{__make} -j1 \
115 V=1
80ded214
AM
116
117%install
118rm -rf $RPM_BUILD_ROOT
0efa133e 119install -d $RPM_BUILD_ROOT{%{_libexecdir},/etc}
df004a70 120
9656c3b9
ER
121DIST_ROOT=$RPM_BUILD_ROOT
122DIST_INSTALL=$(pwd)/install.manifest
123DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
59aa30e8 124export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
ff9c0a4e
JB
125
126%{__make} install \
127 DIST_MANIFEST="$DIST_INSTALL"
128%{__make} install-dev \
129 DIST_MANIFEST="$DIST_INSTALL_DEV"
80ded214 130
a32e9a39
AM
131install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/xfs_lsprojid
132
9656c3b9 133ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libhandle.so.*.*.*) \
ff9c0a4e 134 $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
cb190f67 135
51a52578
AM
136mv $RPM_BUILD_ROOT%{_libdir}/lib*.la $RPM_BUILD_ROOT%{_libexecdir}
137mv $RPM_BUILD_ROOT%{_libdir}/lib*.a $RPM_BUILD_ROOT%{_libexecdir}
138
4ede93fd 139%{__sed} -i -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
8e06f9de 140 $RPM_BUILD_ROOT%{_libexecdir}/libhandle.la
b756248b 141
6e781c10
PG
142echo "#10:/mnt/ftp/roman" >> $RPM_BUILD_ROOT/etc/projects
143echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
144
01483858
JB
145%find_lang %{name}
146
03dcab3f 147%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
5e040522 148
9656c3b9 149# already in /usr
8e06f9de 150%{__rm} $RPM_BUILD_ROOT%{_libdir}/libhandle.so
9656c3b9 151
80ded214
AM
152%clean
153rm -rf $RPM_BUILD_ROOT
154
c5b3782d 155%post -p /sbin/ldconfig
c7083593
JR
156%postun -p /sbin/ldconfig
157
01483858 158%files -f %{name}.lang
80ded214 159%defattr(644,root,root,755)
636af8bd 160%doc README doc/{CHANGES,CREDITS}
6e781c10
PG
161%config(noreplace) %verify(not md5 mtime size) /etc/projects
162%config(noreplace) %verify(not md5 mtime size) /etc/projid
0c1d4bf9
JB
163%attr(755,root,root) %{_sbindir}/fsck.xfs
164%attr(755,root,root) %{_sbindir}/mkfs.xfs
165%attr(755,root,root) %{_sbindir}/xfs_repair
166%attr(755,root,root) %{_bindir}/xfs_*
9656c3b9 167%attr(755,root,root) %{_libdir}/libhandle.so.*.*
9656c3b9 168%attr(755,root,root) %ghost %{_libdir}/libhandle.so.1
275db5b4
AM
169%{_mandir}/man5/projects.5*
170%{_mandir}/man5/projid.5*
0c1d4bf9
JB
171%{_mandir}/man5/xfs.5*
172%{_mandir}/man8/fsck.xfs.8*
173%{_mandir}/man8/mkfs.xfs.8*
174%{_mandir}/man8/xfs_*.8*
80ded214
AM
175
176%files devel
177%defattr(644,root,root,755)
0c1d4bf9 178%attr(755,root,root) %{_libexecdir}/libhandle.so
0c1d4bf9 179%{_libexecdir}/libhandle.la
353bc53d 180%{_includedir}/xfs
0c1d4bf9
JB
181%{_mandir}/man3/*handle.3*
182%{_mandir}/man3/xfsctl.3*
1c0f6863 183
184%files static
185%defattr(644,root,root,755)
0c1d4bf9 186%{_libexecdir}/libhandle.a
This page took 0.102338 seconds and 4 git commands to generate.