]> git.pld-linux.org Git - packages/xen.git/commitdiff
- updated to 4.16.1 (new sonames) auto/th/xen-4.16.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 18 Sep 2022 16:13:18 +0000 (18:13 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 2 Oct 2022 19:02:31 +0000 (21:02 +0200)
ocaml-4.12.patch
xen-doc.patch
xen-golang-32bit.patch
xen-systemd.patch
xen.spec

index f82f446269fcccb327f9e9885b567102306562c8..845de1047900b5338c400eb79c2ce7bf3bca1e79 100644 (file)
@@ -1,36 +1,3 @@
---- xen-4.14.1/tools/ocaml/libs/xentoollog/xentoollog_stubs.c.orig     2020-12-17 16:47:25.000000000 +0000
-+++ xen-4.14.1/tools/ocaml/libs/xentoollog/xentoollog_stubs.c  2021-03-01 22:53:23.106205483 +0000
-@@ -53,8 +53,6 @@
- #include "_xtl_levels.inc"
- /* Option type support as per http://www.linux-nantes.org/~fmonnier/ocaml/ocaml-wrapping-c.php */
--#define Val_none Val_int(0)
--#define Some_val(v) Field(v,0)
- static value Val_some(value v)
- {
---- xen-4.14.1/tools/ocaml/libs/xl/xenlight_stubs.c.orig       2020-12-17 16:47:25.000000000 +0000
-+++ xen-4.14.1/tools/ocaml/libs/xl/xenlight_stubs.c    2021-03-01 23:01:24.229859714 +0000
-@@ -227,8 +227,6 @@
- }
- /* Option type support as per http://www.linux-nantes.org/~fmonnier/ocaml/ocaml-wrapping-c.php */
--#define Val_none Val_int(0)
--#define Some_val(v) Field(v,0)
- static value Val_some(value v)
- {
---- xen-4.14.1/tools/ocaml/libs/xc/xenctrl_stubs.c.orig        2020-12-17 16:47:25.000000000 +0000
-+++ xen-4.14.1/tools/ocaml/libs/xc/xenctrl_stubs.c     2021-03-01 23:24:45.477290290 +0000
-@@ -43,8 +43,6 @@
- #define _H(__h) ((xc_interface *)(__h))
- #define _D(__d) ((uint32_t)Int_val(__d))
--#define Val_none (Val_int(0))
--
- #define string_of_option_array(array, index) \
-       ((Field(array, index) == Val_none) ? NULL : String_val(Field(Field(array, index), 0)))
 --- xen-4.13.1/tools/ocaml/common.make~        2020-05-14 14:19:32.000000000 +0200
 +++ xen-4.13.1/tools/ocaml/common.make 2021-03-26 11:08:01.558827358 +0100
 @@ -9,7 +9,7 @@
index 44e80c28eb49dabf94e61b871b6e8490a60ec5f5..cb31f8910b99f3b4025285f48f3219b796274973 100644 (file)
@@ -1,15 +1,3 @@
-diff -urNp -x '*.orig' xen-4.13.1.org/tools/qemu-xen/scripts/texi2pod.pl xen-4.13.1/tools/qemu-xen/scripts/texi2pod.pl
---- xen-4.13.1.org/tools/qemu-xen/scripts/texi2pod.pl  2020-04-14 19:38:05.000000000 +0200
-+++ xen-4.13.1/tools/qemu-xen/scripts/texi2pod.pl      2021-03-25 22:42:21.257653071 +0100
-@@ -397,6 +397,8 @@ print "=encoding $encoding\n\n" if defin
- $sects{NAME} = "$fn \- $tl\n";
- $sects{FOOTNOTES} .= "=back\n" if exists $sects{FOOTNOTES};
-+print "=encoding utf8\n";
-+
- for $sect (qw(NAME SYNOPSIS DESCRIPTION OPTIONS ENVIRONMENT FILES
-             BUGS NOTES FOOTNOTES EXAMPLES SEEALSO AUTHOR COPYRIGHT)) {
-     if(exists $sects{$sect}) {
 diff -urNp -x '*.orig' xen-4.13.1.org/tools/qemu-xen-traditional/Makefile xen-4.13.1/tools/qemu-xen-traditional/Makefile
 --- xen-4.13.1.org/tools/qemu-xen-traditional/Makefile 2018-10-24 17:18:11.000000000 +0200
 +++ xen-4.13.1/tools/qemu-xen-traditional/Makefile     2021-03-25 22:42:21.257653071 +0100
index 957191a93cf5cc190540bf0e7b776bf597c52a5b..e6160dc9dcd2113da9d549825e1a212c90e4e367 100644 (file)
@@ -32,8 +32,8 @@ Adjust types and sizes for 32-bit pointers
                                                                           ctypename,cname,
                                                                           golenvar,golenvar)
      s += 'for i,v := range x.{0} {{\n'.format(goname)
---- xen-4.14.3/tools/golang/xenlight/xenlight.go.orig  2021-09-10 14:30:40.000000000 +0200
-+++ xen-4.14.3/tools/golang/xenlight/xenlight.go       2021-11-07 17:46:36.600731277 +0100
+--- xen-4.16.1/tools/golang/xenlight/xenlight.go.orig  2022-04-12 14:21:23.000000000 +0200
++++ xen-4.16.1/tools/golang/xenlight/xenlight.go       2022-09-18 15:39:56.819306319 +0200
 @@ -478,7 +478,7 @@ type StringList []string
  
  func (sl *StringList) fromC(csl *C.libxl_string_list) error {
@@ -46,15 +46,15 @@ Adjust types and sizes for 32-bit pointers
 @@ -492,8 +492,8 @@ func (sl *StringList) fromC(csl *C.libxl
  func (sl StringList) toC(csl *C.libxl_string_list) error {
        var char *C.char
-       size := len(sl)
+       size := len(sl) + 1
 -      *csl = (C.libxl_string_list)(C.malloc(C.ulong(size) * C.ulong(unsafe.Sizeof(char))))
--      clist := (*[1 << 30]*C.char)(unsafe.Pointer(csl))[:size:size]
+-      clist := (*[1 << 30]*C.char)(unsafe.Pointer(*csl))[:size:size]
 +      *csl = (C.libxl_string_list)(C.malloc(C.size_t(size) * C.size_t(unsafe.Sizeof(char))))
-+      clist := (*[1 << 28]*C.char)(unsafe.Pointer(csl))[:size:size]
++      clist := (*[1 << 28]*C.char)(unsafe.Pointer(*csl))[:size:size]
  
        for i, v := range sl {
                clist[i] = C.CString(v)
-@@ -537,8 +537,8 @@ func (bm *Bitmap) toC(cbm *C.libxl_bitma
+@@ -538,8 +538,8 @@ func (bm *Bitmap) toC(cbm *C.libxl_bitma
        size := len(bm.bitmap)
        cbm.size = C.uint32_t(size)
        if cbm.size > 0 {
@@ -65,7 +65,7 @@ Adjust types and sizes for 32-bit pointers
  
                copy(cs, bm.bitmap)
        }
-@@ -605,7 +605,7 @@ func (Ctx *Context) ListCpupool() (list
+@@ -606,7 +606,7 @@ func (ctx *Context) ListCpupool() (list
        }
  
        // Magic
@@ -74,7 +74,7 @@ Adjust types and sizes for 32-bit pointers
        for i := range cpupoolListSlice {
                var info Cpupoolinfo
                _ = info.fromC(&cpupoolListSlice[i])
-@@ -1081,7 +1081,7 @@ func (Ctx *Context) ListDomain() (glist
+@@ -1082,7 +1082,7 @@ func (ctx *Context) ListDomain() (glist
                return
        }
  
@@ -83,7 +83,7 @@ Adjust types and sizes for 32-bit pointers
        for i := range gslice {
                var info Dominfo
                _ = info.fromC(&gslice[i])
-@@ -1105,7 +1105,7 @@ func (Ctx *Context) ListVcpu(id Domid) (
+@@ -1106,7 +1106,7 @@ func (ctx *Context) ListVcpu(id Domid) (
                return
        }
  
index 6353db121f4d950a02aab3069bd21589ca11f347..0ce34da1d5d84ad9336e0e09cfc36d726dcc7051 100644 (file)
@@ -1,13 +1,13 @@
---- xen-4.9.0/tools/hotplug/Linux/systemd/xenconsoled.service.in.orig  2017-07-30 21:05:26.089563010 +0200
-+++ xen-4.9.0/tools/hotplug/Linux/systemd/xenconsoled.service.in       2017-07-30 21:12:17.189558321 +0200
-@@ -7,12 +7,12 @@
+--- xen-4.16.1/tools/hotplug/Linux/systemd/xenconsoled.service.in.orig 2022-09-18 15:05:07.257293114 +0200
++++ xen-4.16.1/tools/hotplug/Linux/systemd/xenconsoled.service.in      2022-09-18 15:07:08.493302989 +0200
+@@ -7,12 +7,12 @@ ConditionPathExists=/proc/xen/capabiliti
  [Service]
  Type=simple
  Environment=XENCONSOLED_ARGS=
 -Environment=XENCONSOLED_TRACE=none
 +Environment=XENCONSOLED_LOG=none
  Environment=XENCONSOLED_LOG_DIR=@XEN_LOG_DIR@/console
--EnvironmentFile=@CONFIG_DIR@/@CONFIG_LEAF_DIR@/xencommons
+-EnvironmentFile=-@CONFIG_DIR@/@CONFIG_LEAF_DIR@/xencommons
 +EnvironmentFile=-@CONFIG_DIR@/@CONFIG_LEAF_DIR@/xenconsoled
  ExecStartPre=/bin/grep -q control_d /proc/xen/capabilities
  ExecStartPre=/bin/mkdir -p ${XENCONSOLED_LOG_DIR}
index 382ffd78437195e562bd269188d25e1ad9b96781..76b9586433736d0d25140e03599972810af8b923 100644 (file)
--- a/xen.spec
+++ b/xen.spec
@@ -17,6 +17,7 @@
 %bcond_without brlapi                  # brlapi support in Xen qemu
 %bcond_with    golang                  # Go library
 %bcond_without ocaml                   # Ocaml libraries for Xen tools
+%bcond_without pv_grub                 # pv-grub (deprecated)
 %bcond_with    python2                 # CPython 2.x module instead of 3.x
 %bcond_without efi                     # EFI hypervisor
 %bcond_without hypervisor              # Xen hypervisor build
 Summary:       Xen - a virtual machine monitor
 Summary(pl.UTF-8):     Xen - monitor maszyny wirtualnej
 Name:          xen
-Version:       4.15.3
+Version:       4.16.1
 Release:       1
 License:       GPL v2, interface parts on BSD-like
 Group:         Applications/System
-# for available versions see https://www.xenproject.org/developers/teams/hypervisor.html
+# for available versions see https://xenproject.org/xen-project-archives/
 Source0:       https://downloads.xenproject.org/release/xen/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: ad68aa30e6dd0ca34cadd0a3d23f9244
+# Source0-md5: 1c2cd4f7f966c1d455aab630953e5fad
 # used by stubdoms
 Source10:      %{xen_extfiles_url}/lwip-1.3.0.tar.gz
 # Source10-md5:        36cc57650cffda9a0269493be2a169bb
@@ -60,8 +61,8 @@ Source13:     %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
 # Source13-md5:        cec05e7785497c5e19da2f114b934ffd
 Source14:      %{xen_extfiles_url}/grub-0.97.tar.gz
 # Source14-md5:        cd3f3eb54446be6003156158d51f4884
-Source15:      %{xen_extfiles_url}/ipxe-git-988d2c13cdf0f0b4140685af35ced70ac5b3283c.tar.gz
-# Source15-md5:        1c3f5c0d6d824697361481aa7004fc5b
+Source15:      %{xen_extfiles_url}/ipxe-git-3c040ad387099483102708bb1839110bc788cefb.tar.gz
+# Source15-md5:        23ba00d5e2c5b4343d12665af73e1cb5
 Source17:      %{xen_extfiles_url}/polarssl-%{polarssl_version}-gpl.tgz
 # Source17-md5:        7b72caf22b01464ee7d6165f2fd85f44
 Source18:      %{xen_extfiles_url}/tpm_emulator-%{tpm_emulator_version}.tar.gz
@@ -444,7 +445,6 @@ ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
 ln -s %{SOURCE17} %{SOURCE18} %{SOURCE19} stubdom
 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
 
-
 %if %{with python2}
 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' \
 %else
@@ -485,6 +485,7 @@ export PATH=$(pwd)/our-ld:$PATH
        ac_cv_lib_iconv_libiconv_open=no \
        --disable-debug \
        %{!?with_golang:--disable-golang} \
+       %{?with_pv_grub:--enable-pv-grub} \
        %{__enable_disable qemu_traditional qemu-traditional} \
        --with-system-seabios=/usr/share/seabios/bios.bin \
 %ifarch %{x8664}
@@ -596,7 +597,7 @@ cp -p tools/pygrub/README _doc/README.pygrub
 # remove unneeded files
 %if %{with hypervisor}
 %{__mv} xen/xen-syms $RPM_BUILD_ROOT/boot/%{name}-syms-%{version}
-%{__rm} $RPM_BUILD_ROOT/boot/xen-4.15.gz
+%{__rm} $RPM_BUILD_ROOT/boot/xen-4.16.gz
 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
 %endif
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
@@ -725,12 +726,14 @@ fi
 %if %{with qemu_traditional}
 %{_libexecdir}/%{name}/boot/ioemu-stubdom.gz
 %endif
+%if %{with pv_grub}
 %ifarch %{ix86} %{x8664}
 %{_libexecdir}/%{name}/boot/pv-grub-x86_32.gz
 %endif
 %ifarch %{x8664}
 %{_libexecdir}/%{name}/boot/pv-grub-x86_64.gz
 %endif
+%endif
 %{_libexecdir}/%{name}/boot/vtpm-stubdom.gz
 %{_libexecdir}/%{name}/boot/vtpmmgr-stubdom.gz
 %{_libexecdir}/%{name}/boot/xenstore-stubdom.gz
@@ -792,11 +795,11 @@ fi
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libxenfsimage.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenfsimage.so.4.15
+%attr(755,root,root) %ghost %{_libdir}/libxenfsimage.so.4.16
 %attr(755,root,root) %{_libdir}/libxencall.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libxencall.so.1
 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.15
+%attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.16
 %attr(755,root,root) %{_libdir}/libxendevicemodel.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libxendevicemodel.so.1
 %attr(755,root,root) %{_libdir}/libxenevtchn.so.*.*
@@ -806,21 +809,21 @@ fi
 %attr(755,root,root) %{_libdir}/libxengnttab.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libxengnttab.so.1
 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.15
+%attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.16
 %attr(755,root,root) %{_libdir}/libxenhypfs.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libxenhypfs.so.1
 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenlight.so.4.15
+%attr(755,root,root) %ghost %{_libdir}/libxenlight.so.4.16
 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenstat.so.4.15
+%attr(755,root,root) %ghost %{_libdir}/libxenstat.so.4.16
 %attr(755,root,root) %{_libdir}/libxentoolcore.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libxentoolcore.so.1
 %attr(755,root,root) %{_libdir}/libxentoollog.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libxentoollog.so.1
 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.4.15
+%attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.4.16
 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxlutil.so.4.15
+%attr(755,root,root) %ghost %{_libdir}/libxlutil.so.4.16
 %dir %{_libdir}/xenfsimage
 %dir %{_libdir}/xenfsimage/ext2fs-lib
 %dir %{_libdir}/xenfsimage/fat
@@ -833,8 +836,8 @@ fi
 
 %files libs-guest
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
+%attr(755,root,root) %{_libdir}/libxenstore.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libxenstore.so.4
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.160241 seconds and 4 git commands to generate.