]> git.pld-linux.org Git - packages/xen.git/commitdiff
- updated ipxe patch, added gcc10+ fixes auto/th/xen-4.15.3-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 19 Sep 2022 17:00:51 +0000 (19:00 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 19 Sep 2022 17:00:51 +0000 (19:00 +0200)
gcc10.patch
xen-gcc12.patch [new file with mode: 0644]
xen.spec

index c07a48239864efac01566fa01aa4f7b666c82b3d..9b487b7e6688b2c6d34fba073029636b688bcb46 100644 (file)
@@ -5,4 +5,4 @@
  CFLAGS += -UCONSOLE_SERIAL
  CFLAGS += -DCONSOLE_SERIAL=1
 +
-+CFLAGS += -Wno-error=enum-conversion -Wno-error=maybe-uninitialized
++CFLAGS += -Wno-error=enum-conversion -Wno-error=maybe-uninitialized -Wno-error=array-bounds -Wno-error=dangling-pointer
diff --git a/xen-gcc12.patch b/xen-gcc12.patch
new file mode 100644 (file)
index 0000000..dc4957f
--- /dev/null
@@ -0,0 +1,11 @@
+--- xen-4.15.3/Config.mk.orig  2022-09-18 21:17:34.143899962 +0200
++++ xen-4.15.3/Config.mk       2022-09-18 21:34:45.351065045 +0200
+@@ -192,6 +192,8 @@ $(call cc-option-add,HOSTCFLAGS,HOSTCC,-
+ $(call cc-option-add,CFLAGS,CC,-Wdeclaration-after-statement)
+ $(call cc-option-add,CFLAGS,CC,-Wno-unused-but-set-variable)
+ $(call cc-option-add,CFLAGS,CC,-Wno-unused-local-typedefs)
++$(call cc-option-add,CFLAGS,CC,-Wno-error=array-bounds)
++$(call cc-option-add,CFLAGS,CC,-Wno-error=address)
+ LDFLAGS += $(foreach i, $(EXTRA_LIB), -L$(i)) 
+ CFLAGS += $(foreach i, $(EXTRA_INCLUDES), -I$(i))
index ef3a277b3c4c20b0f9b4b511c255d81ee3bf4864..382ffd78437195e562bd269188d25e1ad9b96781 100644 (file)
--- a/xen.spec
+++ b/xen.spec
@@ -60,8 +60,8 @@ Source13:     %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
 # Source13-md5:        cec05e7785497c5e19da2f114b934ffd
 Source14:      %{xen_extfiles_url}/grub-0.97.tar.gz
 # Source14-md5:        cd3f3eb54446be6003156158d51f4884
-Source15:      %{xen_extfiles_url}/ipxe-git-1dd56dbd11082fb622c2ed21cfaced4f47d798a6.tar.gz
-# Source15-md5:        b3ab0488a989a089207302111d12e1a0
+Source15:      %{xen_extfiles_url}/ipxe-git-988d2c13cdf0f0b4140685af35ced70ac5b3283c.tar.gz
+# Source15-md5:        1c3f5c0d6d824697361481aa7004fc5b
 Source17:      %{xen_extfiles_url}/polarssl-%{polarssl_version}-gpl.tgz
 # Source17-md5:        7b72caf22b01464ee7d6165f2fd85f44
 Source18:      %{xen_extfiles_url}/tpm_emulator-%{tpm_emulator_version}.tar.gz
@@ -102,6 +102,7 @@ Patch14:    gcc9.patch
 Patch15:       gcc10.patch
 Patch16:       ocaml-4.12.patch
 Patch17:       %{name}-golang-32bit.patch
+Patch18:       %{name}-gcc12.patch
 URL:           http://www.xen.org/products/xenhyp.html
 BuildRequires: autoconf >= 2.67
 %ifarch %{ix86} %{x8664}
@@ -436,6 +437,7 @@ Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
 %ifarch %{ix86} %{arm}
 %patch17 -p1
 %endif
+%patch18 -p1
 
 # stubdom sources
 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
This page took 0.22484 seconds and 4 git commands to generate.